17:00:36 <sayan> #startmeeting fedora_cloud_wg
17:00:36 <zodbot> Meeting started Wed Sep 21 17:00:36 2016 UTC.  The chair is sayan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:36 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
17:00:48 <sayan> #topic Roll Call
17:00:54 <trishnag> .hello trishnag
17:00:55 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:00:56 <sayan> .hello sayanchowdhury
17:00:58 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:01:03 <jberkus> .hello jberkus
17:01:04 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:01:07 <bowlofeggs> .hello bowlofeggs
17:01:08 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
17:01:10 <nzwulfin> .hello mmicene
17:01:10 <zodbot> nzwulfin: mmicene 'Matt Micene' <nzwulfin@gmail.com>
17:02:16 <sayan> #chair trishnag bowlofeggs nzwulfin jberkus
17:02:16 <zodbot> Current chairs: bowlofeggs jberkus nzwulfin sayan trishnag
17:02:27 <scollier> .hello scollier
17:02:28 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:02:33 <sayan> #chair scollier
17:02:33 <zodbot> Current chairs: bowlofeggs jberkus nzwulfin sayan scollier trishnag
17:02:45 * dustymabe sneaks in
17:03:00 <dustymabe> .hellomynameis dustymabe
17:03:02 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:03:03 <sayan> #chair dustymabe
17:03:03 <zodbot> Current chairs: bowlofeggs dustymabe jberkus nzwulfin sayan scollier trishnag
17:03:12 <dustymabe> bowlofeggs: \o/
17:03:16 <kushal> .hellomynameis kushal
17:03:17 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:03:18 <subho> .hello subho
17:03:21 <zodbot> subho: subho 'None' <subho.prp@gmail.com>
17:03:31 <sayan> #chair kushal
17:03:31 <zodbot> Current chairs: bowlofeggs dustymabe jberkus kushal nzwulfin sayan scollier trishnag
17:03:35 <sayan> #chair subho
17:03:35 <zodbot> Current chairs: bowlofeggs dustymabe jberkus kushal nzwulfin sayan scollier subho trishnag
17:03:47 <jbrooks> .fas jasonbrooks
17:03:48 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:04:03 <sayan> #chair jbrooks
17:04:03 <zodbot> Current chairs: bowlofeggs dustymabe jberkus jbrooks kushal nzwulfin sayan scollier subho trishnag
17:04:12 <sayan> #topic Action items from last meeting
17:04:21 <sayan> * Kushal will work on moving to Pagure from Trac
17:04:23 <sayan> * kushal will create the vote ticket, and update the list :)
17:05:03 <sayan> kushal: any updates?
17:05:17 <sayan> I know you deployed the non-gating test one
17:05:44 <rtnpro> .fas rtnpro
17:05:45 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:05:49 <kushal> sayan, the first item I will do next week.
17:05:52 <kushal> could not finish
17:05:52 <sayan> #chair rtnpro
17:05:52 <zodbot> Current chairs: bowlofeggs dustymabe jberkus jbrooks kushal nzwulfin rtnpro sayan scollier subho trishnag
17:06:01 <kushal> sayan, readd that action
17:06:06 <sayan> ok, re-actioning it
17:06:19 <sayan> #action Kushal will work on moving to Pagure from Trac
17:06:34 <sayan> Moving onto tickets
17:06:51 <sayan> #topic vagrant boxes fixups https://fedorahosted.org/cloud/ticket/136
17:07:40 <maxamillion> .hello maxamillion
17:07:40 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:07:55 <sayan> imcleod isn't here, so moving to next ticket
17:08:02 <sayan> #chair maxamillion
17:08:02 <zodbot> Current chairs: bowlofeggs dustymabe jberkus jbrooks kushal maxamillion nzwulfin rtnpro sayan scollier subho trishnag
17:08:24 <sayan> #topic design, deploy and document Fedora OpenShift Playground (FOSP) https://fedorahosted.org/cloud/ticket/153
17:08:50 <sayan> Next work session is Sept 23 so skipping this one too
17:09:32 <sayan> jberkus: anything you would like to add?
17:09:52 <jberkus> sayan: no, except that the work session has been postponed
17:09:58 <jberkus> scollier: ^^^ ?
17:10:17 <scollier> jberkus, looking
17:10:34 <scollier> sayan, i pushed the meeting out one week.
17:10:43 <scollier> i'll update the ticket.
17:10:55 <sayan> scollier: sure
17:11:28 <sayan> #topic make Fedora Atomic download page clearer https://fedorahosted.org/cloud/ticket/154
17:12:01 <sayan> jberkus: update on this one? ^^
17:12:25 <jberkus> sayan: see the whole long discussion about the new getfedora pages
17:12:29 <jberkus> and the wiki page
17:13:15 <jberkus> are we ready to discuss getfedora?
17:13:38 <jberkus> so, here: https://fedoraproject.org/wiki/Cloud/getfedora_update
17:14:04 <sayan> jberkus: what about the aws picker for cloud base?
17:14:15 <jberkus> here's  a draft from the designer: https://raw.githubusercontent.com/fedoradesign/nextweb-assets/master/Mockups/Brochure%20Site/brochure-mock-atomic_WIP.png
17:14:23 <jberkus> sayan: I can't answer that.  someone else has to
17:15:37 <sayan> the mockup looks good to me
17:16:06 <jbrooks> jberkus, looks nice
17:16:12 <jberkus> just so everyone's up to date, the problem is that this redesign orphans the AWS picker for Cloud base images (as opposed to Atomic)
17:16:21 <maxamillion> I like it
17:16:22 <maxamillion> +1
17:16:29 <jberkus> presumably that now needs to live somewhere on Server
17:16:42 <jberkus> but someone more central to Fedora than me needs to take it to them
17:16:48 <jbrooks> So, is cloud base going to server for 25? Or is that 26?
17:17:03 <jberkus> 25
17:17:42 <dustymabe> i guess a question about that
17:18:05 <dustymabe> so does the server WG now own it? are we no longer going to talk about "cloud" issues in this channel and in this meeting?
17:18:27 <sayan> dustymabe: +1
17:18:54 <dustymabe> would seem kind of odd
17:18:54 <jberkus> that's presumably the idea, yeah.  the problem is that while the council members talked about cloud --> atomic, there wasn't any serious talk about how that changes server
17:19:11 <sayan> does the server WG know about the issue and the plan they would be taking over?
17:19:20 <jberkus> I don't know that they do
17:19:32 <jbrooks> Well, that's an important bit
17:19:45 <jberkus> yes, which is why I keep trying to raise it
17:20:39 <dustymabe> yeah I don't know what the best situation is
17:20:51 <dustymabe> seems almost like server should be broken out into two targets
17:21:06 <dustymabe> server(hardware + cloud)
17:21:14 <jbrooks> Whatever happens w/ it, they need to be in on it
17:21:42 <jbrooks> I'd expect to use server bits on metal and cloud
17:21:48 <jbrooks> Just like I expect that from atomic
17:22:02 <dustymabe> or would it make more sense to get a fair # of people from the server WG to join CLOUD meetings and then have a new WG for Atomic
17:22:27 <maxamillion> jbrooks: +1
17:22:32 <jbrooks> The weird thing is that we chose to switch our focus to atomic a long time back
17:23:20 <dustymabe> ok so basically what we need to do is have server WG own the thing, but a fair number of us probably need to put down some roots there as well
17:23:32 <sayan> dustymabe: I think it would be better for people from server WG to join Cloud meetings
17:23:37 <jbrooks> I don't get how a minimal install of fedora that'll run on a cloud even counts as a separate WG
17:23:38 <sayan> or the vice-versa?
17:23:46 <trishnag> sayan: +1
17:24:01 <jbrooks> Whichever, but I'm on team atomic, wherever that is
17:24:16 <dustymabe> jbrooks: well I think "Fedora Server" has meant something in the past. i.e. not a minimal install
17:24:31 <maxamillion> jbrooks: yeah, the choice was made but then nothing ever happened ... I think the fear of leaving people behind lead to maintaining things as they were
17:24:38 <jbrooks> Yeah
17:25:05 <jbrooks> Well, maybe we need to do a new atomic wg
17:25:09 <dustymabe> so that is why I said that
17:25:13 <jbrooks> And we need to do the prd and all that
17:25:25 <dustymabe> i think a new wg would make sense
17:25:27 <jbrooks> And we haven't done it yet, so we're still the old cloud wg
17:25:38 <dustymabe> right that would be a more official switch
17:25:43 <jberkus> jbrooks: we started during Flock, but it didn't get finished
17:26:01 <dustymabe> and the people who are just interested in the 'old' cloud can still come to the same places they have in the past
17:26:04 <maxamillion> I think the problem with creating a new group is getting people to show up and actually do work
17:26:13 <jbrooks> jberkus, are there any notes from that?
17:26:15 <maxamillion> we have enough trouble with that now
17:26:23 <jbrooks> I will show up for atomic
17:26:29 <jbrooks> That's why I've been here
17:26:33 <jberkus> me too
17:26:35 <dustymabe> jbrooks: thank you for being here
17:26:39 <maxamillion> I will as well, but I'll stop showing up for cloud
17:26:42 <jbrooks> Heh, thank you
17:26:51 <jbrooks> Me too, probably
17:26:56 <maxamillion> I think what would happen is there'd be an exodus of people doing work for cloud
17:26:59 <jberkus> so the idea from the PRD meeting was not to create a 4th group
17:27:07 <jbrooks> I mean, I want there to be a vagrant image of fedora base
17:27:09 <maxamillion> so we would effectively abandon the users just as we would have otherwise
17:27:12 <jberkus> but to replace Cloud with Atomic and merge Cloud Base into Server
17:27:19 <jbrooks> I think it's crazy that fedora wouldn't just have that
17:27:48 <dustymabe> right. so we'd at least have to have some minimal team of people who make sure that happen. part of the server WG or not
17:27:51 <dustymabe> which I'm ok with
17:27:57 <dustymabe> just want to make sure it has a place
17:28:05 <kushal> dustymabe, correct.
17:28:12 <kushal> But sadly we will not have time for it.
17:28:12 <sayan> dustymabe: rightly said
17:28:14 <kushal> :(
17:28:22 <maxamillion> the Server WG needs to accept the responsibility for the Cloud Base
17:28:32 <jbrooks> OK, who's the server WG point person?
17:28:36 <maxamillion> we can't just be like "here, you deal with it" and then they will magically take on the extra work :)
17:28:54 <jbrooks> Or maybe we ping the FPL
17:28:56 <jbrooks> :)
17:29:14 <jbrooks> Fix everything, FPL!
17:29:21 <dustymabe> well. does it really make sense though? a lot of the "workflows" for building/testing cloud base are so similar to Atomic
17:29:39 <jbrooks> In centos, the base stuff is core
17:29:40 * dustymabe head explodes
17:30:08 <smooge> hello I am from the server WG
17:30:14 <dustymabe> smooge: hi
17:30:24 <bowlofeggs> hello I am from the bowlofeggs WG
17:30:29 <bowlofeggs> (hehe)
17:30:30 <jbrooks> heh
17:30:33 <sayan> bowlofeggs: hehe
17:30:41 <trishnag> hehe
17:30:42 <jbrooks> bowlofeggs, where's your dang prd
17:30:51 <jberkus> bowlofeggs hey, your WG release is late.  I'm hungry.
17:31:08 <bowlofeggs> hahaha
17:31:31 <jbrooks> So, smooge, does the server WG want to / plan to adopt fedora cloud base?
17:31:39 <bowlofeggs> my prd is deployed all across the world in various diners and restaurants
17:31:40 <sayan> smooge: so the plan is that the Server WG take over cloud base
17:31:49 <smooge> yes I have heard of this plan
17:32:18 <smooge> I think we are looking for a more formal request and statement of what it means
17:32:47 <jbrooks> smooge, OK, and that'd be the cloud WG that would be doing the requesting?
17:33:14 <smooge> well it is your base
17:33:24 <dustymabe> smooge: how do you think the integration could go?
17:33:27 <smooge> and I don't believe all your base belong to us
17:33:33 <jbrooks> heh
17:34:45 <smooge> so I am not sure what the "cloud" base means. How does it overlap with the Server base? Are we talking about images that run in cloud or images that create a cloud infrastructure
17:35:06 <dustymabe> smooge: it's just a "minimal" fedora image
17:35:14 <dustymabe> for running in the cloud
17:35:14 <jbrooks> yep
17:35:17 <dustymabe> or as local VM
17:35:47 <jbrooks> And, btw, the sort of thing I'd start w/ on metal, too, if that was an option
17:36:17 <maxamillion> well the on-metal is what the Server WG already does
17:36:23 <smooge> dustymabe, ok and it needs to be built into various "forms": vbox, libvirt, ??
17:36:23 <dustymabe> jbrooks: can't you just select what groups you want installed in anaconda
17:36:24 <maxamillion> they'd basically just add cloud images
17:36:33 <dustymabe> smooge: right
17:37:20 <jbrooks> dustymabe, yeah, I guess I'd use the netinstall
17:37:38 <jbrooks> dustymabe, I just can't get over the 1.7GB iso
17:37:49 <jbrooks> I guess I'm being old and cranky or something
17:38:40 <sayan> so should someone from the Cloud WG file a request with the Server WG more info?
17:39:24 <maxamillion> "with the Server WG more info" ?
17:39:48 <dustymabe> this might sound crazy but it almost seems like more work to "move" cloud to the server WG than it is to just keep it in this WG and have a few people maintain it
17:39:58 <maxamillion> let's make a wiki page or gobby doc or something that we can collectively as a group edit and review it before shipping the request to the server WG
17:39:58 <smooge> sayan, maxamillion could someone file a ticket or a request on the mailing list for what is wanted
17:40:10 <sayan> maxamillion: I meant ticket with more information
17:40:11 <dustymabe> i get that the "focus" would change
17:40:12 <sayan> a detailed one
17:40:18 <maxamillion> dustymabe: ehhhhh
17:40:32 <sayan> dustymabe: I thing OK with helping to maintain it
17:40:46 <sayan> s/thing/am
17:40:52 <maxamillion> dustymabe: there are some people who spend a respectable amount of time on it during various periods of the release cycle
17:41:31 <tflink> if the cloud base image moves to the server WG, what happens to the current suite of automated tests?
17:41:36 <dustymabe> maxamillion: do you think if it moved to server WG the people that work onit would be different people>
17:41:36 <smooge> by the way, don't take my questions as "we don't want it." it is more of "what do you want us to take over" so that we don't end up saying "here is server.img" and you wanted something else
17:43:08 <maxamillion> dustymabe: I don't know, I just don't want to shift focus and then people who are doing work to work on the new thing and the old things just fall on the floor .... or lets do that, make a hard line in the sand and just say "we're not doing $thing anymore" and be done with it, I don't really have a preference but we need to have a well defined objective of what we're trying to accomplish and
17:43:14 <maxamillion> how we would like to accomplish it
17:44:03 <jbrooks> maxamillion, One thing I keep thinking, is how can the cloud wg decide when most of the official membership isn't here / invovled
17:44:34 <jbrooks> Most of us couldn't even vote, officially, to drop this
17:44:44 <jberkus> do we have people who are doing work on cloud images who aren't in the meetigns?
17:44:45 <dustymabe> jbrooks: that is when we vote to update the WG members
17:45:05 <maxamillion> dustymabe: can we do that though? I think that'd need to go to the Council
17:45:20 <dustymabe> ehh. I think we've done it in the past
17:45:29 <dustymabe> adimania hasn't been here in like a year
17:45:40 <dustymabe> roshi will keep his spot, as he will be back
17:46:26 <dustymabe> TBH delivering the cloud image could be done by like 1 person if that was their focus
17:46:54 <dustymabe> maybe we'll break off a small group from this one - still part of the same WG
17:46:58 <dustymabe> but with a focus on cloud base
17:47:08 <dustymabe> so we can have two separate meetings during the week
17:48:02 <kushal> dustymabe, but most of us will go to the container/atomic meeting.
17:48:23 <kushal> maxamillion, We can update our membership as required iirc.
17:48:23 <dustymabe> kushal that is fine
17:48:51 <dustymabe> that is no different than having a server WG with like 2 people that care about cloud base image
17:49:11 <dustymabe> same difference in my opinion
17:49:27 <jbrooks> To me, a server product that doesn't run in clouds... it's much less compelling
17:49:41 <jbrooks> I expect to be able to run a server distro in the cloud or on metal
17:49:56 <dustymabe> jbrooks: I guess I need to understand server a bit mor
17:49:59 <dustymabe> more
17:50:19 <jbrooks> Like, understand that WG or product?
17:50:26 <dustymabe> WG
17:50:29 <jbrooks> It seems like it was trying to be more like Windows Server
17:50:35 <jbrooks> with the roles and such
17:50:37 <maxamillion> I'll say this, I have no real interest in the base cloud image so I don't really pay it much attention, and as someone who doesn't really have a "dog in the fight" I'm going to duck out of the discussion around the base image's fate
17:50:38 <dustymabe> yeah
17:50:44 <jbrooks> And then it seems like that was sort of dropped
17:51:03 <dustymabe> for my cloud image I don't want anything extra
17:51:17 <dustymabe> just a minimal base and then i can use cloud-init to get to where I want to be
17:51:29 <scollier> ^ that
17:51:36 <dustymabe> scollier++
17:51:37 <zodbot> dustymabe: Karma for scollier changed to 2 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:52:04 <dustymabe> so jbrooks I agree with you. having a server product that runs in the cloud is beneficial too
17:52:07 <jbrooks> dustymabe, but on metal you want more?
17:52:09 * tflink is very interested in the base image (or at least the tooling that makes it) as that is a critical bit of taskotron
17:52:22 <dustymabe> but I would suggest starting with cloud base image and then easily configured that using the roles to get to a desired state
17:52:35 <dustymabe> jbrooks: not necessarily
17:52:38 <jbrooks> Yeah, so, just call it server and be done
17:52:48 <dustymabe> I personally always want to start minimal and then add the things I want
17:52:52 <jbrooks> Me too
17:53:08 <dustymabe> but I think the server WG had a different idea on that
17:53:10 <dustymabe> smooge: ^^
17:53:41 * dustymabe just looked at the time - sorry for derailment
17:53:52 <dustymabe> let's take this to #fedora-cloud after the meeting
17:53:55 <dustymabe> sayan please continue
17:54:00 <sayan> sure
17:54:19 <sayan> should I move to open floor?
17:54:29 <dustymabe> probably unless there was something else big
17:54:30 <sayan> or quickly go through other tickets?
17:55:09 <sayan> #topic Decide on post-GA update cadence for various deliverables https://fedorahosted.org/cloud/ticket/155
17:55:14 <sayan> maxamillion: jbrooks ^^
17:55:18 <smooge> dustymabe, I don't know what the server WG has in mind exactly.. beyond we want to be able to deploy stuff on an image somehow the way people want it
17:55:42 <dustymabe> smooge: i'll be in fedora-cloud
17:55:44 <maxamillion> I'll update that ticket and close it
17:55:47 <maxamillion> sayan: ^
17:55:47 <smooge> dustymabe, which why I want to make sure a formal idea is put forth so no one feels like they got bum-shafted
17:55:51 <sayan> maxamillion: thanks
17:55:58 <maxamillion> sayan: we have that sorted out, I'm hoping to start work on it by the end of the week
17:56:20 <sayan> #topic Need complete Kickstart docs for Atomic Host https://fedorahosted.org/cloud/ticket/156
17:56:39 <sayan> jberkus: any update on this one? ^^
17:57:24 <jberkus> been busy with other stuff, new kickstarts are awaiting testing
17:57:57 <sayan> Ok
17:58:06 <sayan> moving onto next then
17:58:18 <sayan> #topic Put OpenShift Origin in Container with Fedora Base https://fedorahosted.org/cloud/ticket/168
17:58:31 <sayan> scollier: ^^
17:58:51 <scollier> yup, far as i know, we are not going to block the FOSP work on the FAO work.
17:58:59 <scollier> sayan, i'm happy to close that ticket.
17:59:14 <scollier> sounds like maxamillion has that part covered.
17:59:14 <sayan> scollier: thanks
17:59:19 <sayan> yep
17:59:22 <maxamillion> scollier: I do?
17:59:33 <scollier> maxamillion, yup, origin in system containers as part of FAO
17:59:49 <maxamillion> scollier: oh ... ehhhh, if I ever find time I'll get back to it :)
17:59:54 <sayan> since we are less on time moving to open floor :)
18:00:00 <sayan> #topic Open Floor
18:00:17 <sayan> Anybody have anything to share in Open Floor?
18:00:49 <jbrooks> I want to schedule a test day
18:00:57 <dustymabe> jbrooks++
18:00:58 <jbrooks> I can send a msg to the list about that
18:01:04 <sayan> jbrooks: +!
18:01:06 <sayan> +1
18:01:15 <maxamillion> jbrooks: +1
18:01:40 <kushal> we need regular mails to explain all of these sort forms :(
18:01:43 <jbrooks> But I only want to test the server product
18:01:46 <jbrooks> heh j/k
18:01:56 <sayan> #action jbrooks to send out an email to the list regarding Test Day
18:02:25 <dustymabe> :)
18:02:35 * maxamillion has to run to get food before next meeting
18:02:40 <maxamillion> sayan: thanks for hosting!
18:02:47 <sayan> Anything else?
18:02:59 <sayan> maxamillion: thanks for coming
18:03:07 <sayan> ending in
18:03:08 <sayan> 3.
18:03:10 <sayan> 2.
18:03:13 <sayan> 1.
18:03:17 <sayan> #endmeeting