14:00:35 <tflink> #startmeeting fedora-qadevel
14:00:35 <zodbot> Meeting started Mon Sep 26 14:00:35 2016 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:35 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:00:37 <tflink> #meetingname fedora-qadevel
14:00:37 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:00:39 <tflink> #topic roll call
14:00:47 * kparal is here
14:00:51 <tflink> who's around for the qa-devel meeting?
14:00:55 * mkrizek is here
14:01:21 * garretraziel is here
14:04:20 <tflink> no josef, though?
14:05:48 <tflink> alrighty, let's get started
14:05:49 <kparal> no one knows where he is, he might be on a PTO
14:05:57 <kparal> I already tried to find out, no success
14:06:28 <garretraziel> I bet that he put his PTO into his private calendar, not public
14:06:34 <tflink> someone updated the list of announcements with things attributed to him so I figure he's kinda around
14:07:01 <tflink> #topic Announcements and Information
14:07:11 <kparal> he did not edit that page
14:07:20 <tflink> i was looking at the wrong page
14:07:29 <kparal> k
14:07:38 <tflink> #info got CI to generate docs and releases in stg - tflink
14:07:39 <tflink> #link https://qa.stg.fedoraproject.org/docs/
14:07:39 <tflink> #link https://qa.stg.fedoraproject.org/releases/
14:07:39 <tflink> #info created task-rpmdeplint to replace task-depcheck - mkrizek
14:07:39 <tflink> #link https://phab.qadevel.cloud.fedoraproject.org/D1008
14:07:40 <tflink> #info resultsdb_frontend and execdb packages approved - mkrizek
14:07:53 <tflink> anything to add or comments/questions on what's there?
14:08:06 <garretraziel> not here
14:08:10 <mkrizek> the one thing I wanted to ask is naming of execdb package
14:08:12 <kparal> four digit diff numbers, say wow
14:08:40 <mkrizek> whether we want to name it python-execdb (as the reviewer suggests) or just execdb
14:08:50 <kparal> or taskotron-execdb?
14:09:06 <garretraziel> is execdb really taskotron specific?
14:09:17 <kparal> I thought so, but don't really know
14:09:21 <tflink> in its current form, yes
14:09:59 * tflink doesn't care much either way
14:10:04 <kparal> it seems weird to name a server with python-, like a set of libraries
14:10:26 <tflink> but it does seem odd to name just one of our apps that way
14:10:26 <kparal> but python-execdb_api, sure
14:11:08 <mkrizek> the rest don't have python-* as well except for resulstdb_api, right?
14:11:27 <tflink> the reviewer does have a point with python3 but I don't really see us maintaining both at the same time
14:11:38 <mkrizek> yeah that's what I thought
14:13:14 <kparal> +1
14:13:17 <tflink> it doesn't look like the other python webapps that are packaged for fedora use python-*
14:13:28 <mkrizek> so it seems like "execdb" it is?
14:13:32 <tflink> yep
14:13:39 <tflink> unless someone has an objection
14:13:50 <tflink> which it doesn't sound like
14:14:04 <garretraziel> +1 for simply execdb
14:14:22 <mkrizek> cool
14:15:32 <tflink> proposed #agreed while the reviewer for execdb does have a point about any future python3 migration, we don't think maintaining both python2 and python3 versions of execdb are likely and the risk of having problems with that is something we're willing to deal with
14:15:51 <mkrizek> ack
14:15:56 <tflink> ack/nak/patch?
14:16:10 <kparal> ack
14:16:50 <garretraziel> ack
14:16:53 <tflink> #agreed while the reviewer for execdb does have a point about any future python3 migration, we don't think maintaining both python2 and python3 versions of execdb are likely and the risk of having problems with that is something we're willing to deal with
14:17:19 <tflink> any other comments, questions, issues with the other announcements/information?
14:17:46 <mkrizek> none here
14:18:06 <tflink> #chair kparal mkrizek garretraziel
14:18:06 <zodbot> Current chairs: garretraziel kparal mkrizek tflink
14:18:24 <tflink> ok, let's move on. there are plenty of topics to cover
14:18:33 <tflink> #topic Docker Testing Status
14:19:09 <tflink> with no Josef, I'm not sure this is going to be terribly productive but it's still something that we're on the hook for
14:19:47 <garretraziel> what's the status of trigger modifications for handling docker builds?
14:19:57 <tflink> I'd like to see the new trigger in dev this week so we can start testing it and aren't putting new code into production with little/no testing
14:20:09 <tflink> AFAIK, they work
14:20:28 * tflink had problems setting it up but it sounds like it was an isolated issue
14:20:58 <garretraziel> cool
14:22:14 <tflink> the example checks that are in the docs for docker testing work well enough to be used for testing
14:23:24 <tflink> until the task storage question is answered, that'll probably need to go into some side git repo, though
14:24:31 <tflink> the remainder of this topic needs lbrabec and/or jskladan so I'll follow up with them later this week
14:24:53 <tflink> moving on to the next topic
14:25:10 <tflink> which is also not likely to go many places while missing the folks we're missing
14:25:19 <tflink> #topic Trigger Re-Write Status
14:25:55 <tflink> #link https://phab.qadevel.cloud.fedoraproject.org/D963
14:26:27 <tflink> pretty much the same status as the last topic - would like to see it in dev this week so that we can shake out issues before deploying it to production
14:27:15 <tflink> #topic Dist-Git Task Storage Proposal
14:27:32 <tflink> #link https://phab.qadevel.cloud.fedoraproject.org/w/taskotron/new_distgit_task_storage_proposal/
14:27:57 <tflink> I'd like to send this out to devel@ for comments
14:28:25 <tflink> any last comments, issues or suggestions before I start that process?
14:29:51 <mkrizek> not here, looked good to me
14:29:56 <garretraziel> nope
14:30:29 <tflink> if there are, let me know soon :)
14:30:42 <tflink> as in today
14:30:50 * kparal just wondering if we need to have event types in uppercase
14:30:57 <kparal> but that's just bikeshedding
14:31:09 <tflink> we don't
14:31:30 <tflink> they're case insensitive as far as I'm concerned
14:31:39 <kparal> ok
14:33:25 <kparal> looks ok
14:33:27 * tflink can change it before sending out the proposal
14:33:45 <tflink> #topic CI Generated Document URLs
14:34:03 <tflink> just wanted to mention the thread on qadevel@
14:34:41 <tflink> at this point, those changes won't make it to production until after beta freeze, at the earliest so the conversation doesn't need to happen right now
14:34:53 <tflink> but other suggestions soon-ish would be appreciated
14:35:20 <tflink> #topic Packaging Status
14:35:33 <tflink> It sounds like all the taskotron packages are through review now?
14:36:29 <mkrizek> yep
14:36:31 <mkrizek> \o/
14:38:08 <tflink> yay!
14:38:30 * kparal inserts fireworks
14:39:03 <tflink> the phabricator packages are progressing ... slowly
14:39:19 <tflink> but that's less directly related
14:39:54 <tflink> mkrizek: does getting builds done and into dev this week sound reasonable?
14:40:46 <mkrizek> I think so, most of them at least
14:41:07 <tflink> do you think that there will be issues/complications with one of the packages?
14:41:53 <mkrizek> taskotron-trigger and resultsdb are not built, because it doesn't make sense to build old versions with new ones coming
14:42:02 <tflink> good point
14:42:10 * tflink wasn't thinking about that bit
14:42:42 <tflink> which leads into the last topic I have but it's another that's kinda silly to talk about without josef
14:42:51 <tflink> #topic Resultsdb 2.0
14:42:52 <tflink> #link https://phab.qadevel.cloud.fedoraproject.org/D999
14:43:27 <tflink> more reviews would be appreciated if folks have the time
14:44:00 <tflink> but not much else to say on this one
14:44:07 <tflink> which brings us to
14:44:12 <tflink> #topic Open Floor
14:44:25 <tflink> any additional topics?
14:45:34 <kparal> matthew miller posted a user experience from bodhi+taskotron into test list, I replied, more clarifications welcome, if you have some
14:46:18 * tflink started a reply on friday, didn't quite finish it
14:46:47 <tflink> there's also adamw's topic about results and validation systems but that'll come up during the qa meeting
14:47:05 <kparal> I hoped jskladan would be present, but seems not
14:47:58 <kparal> also, anyone knows why our production is generating so many errors?
14:48:02 <tflink> we could always propose a jskladan-locating device
14:48:26 <tflink> i have a suspicion but hadn't noticed that yet
14:48:45 <kparal> I have a 1000 errors in my mailbox for the last 3 days
14:49:01 <kparal> hmm, it's all dev stg and prod
14:49:36 <tflink> we can start looking into it after the meeting :-/
14:49:42 <tflink> assuming there are no more topics
14:49:47 <kparal> nope
14:50:49 <tflink> hrm, we used almost the whole hour today
14:50:56 * tflink will send out minutes shortly
14:51:00 <tflink> thanks for coming, everyone
14:51:04 <tflink> #endmeeting