17:01:59 <kushal> #startmeeting Fedora Atomic Working Group
17:01:59 <zodbot> Meeting started Wed Nov  9 17:01:59 2016 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:59 <zodbot> The meeting name has been set to 'fedora_atomic_working_group'
17:02:02 <jbrooks> .fas jasonbrooks
17:02:03 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:02:11 <kushal> #topic Roll call
17:02:17 <sayan> .fas sayanchowdhury
17:02:18 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:02:30 <kushal> .hellomynameis kushal
17:02:34 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:02:40 <walters> .fas walters
17:02:41 <zodbot> walters: jvwsaw 'James Walters' <jvwsaw@live.com> - jwalters 'Jake Walters' <jwalters@redhat.com> - jwalters1 '' <admin@frozennorth.biz> - nawalters 'Nathan Walters' <waltersnh@adelphia.net> - walters228 'clinton walters' <walters228@hotmail.com> - whodaimen 'Brian Michael Walters' <whodaimen@gmail.com> - goldwingers 'David Walters' <goldwingers@usa.com> - jjjwalters '' <jjjwalters@hotmail.com> - walters 'Colin (1 more message)
17:02:48 <walters> .hellomynameis walters
17:02:49 <zodbot> walters: walters 'Colin Walters' <walters@redhat.com>
17:02:53 <sayan> .hello sayanchowdhury
17:02:54 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:04:40 <dustymabe> .hello dustymabe
17:04:41 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:04:50 <maxamillion> .hello maxamillion
17:04:51 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:05:00 <trishnag> .hello trishnag
17:05:01 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:05:39 <walters> do we have an agenda for today?
17:05:55 <kushal> #chair walters trishnag maxamillion dustymabe sayan jbrooks
17:05:55 <zodbot> Current chairs: dustymabe jbrooks kushal maxamillion sayan trishnag walters
17:06:18 <kushal> Good news is all F25 images are passing.
17:06:24 <jbrooks> sweet
17:06:32 <kushal> walters, if people are are okay we can move to open floor.
17:06:46 <dustymabe> walters: we usually go through "meeting" ticket items, but we should start doing a formal agenda like the server wg does
17:07:49 <kushal> One major point, website change for F25
17:08:30 <kushal> #topic https://pagure.io/atomic-wg/issue/158 website change for atomic
17:09:58 <dustymabe> kushal: is this for f25?
17:10:00 <dustymabe> or f26?
17:10:09 <kushal> There are changes for F25
17:10:12 * kushal is trying to find link
17:10:56 <kushal> dustymabe, https://stg.getfedora.org/en/cloud/
17:10:59 <kushal> https://stg.getfedora.org/en/cloud/
17:11:06 <kushal> Everyone please have a look
17:11:48 <dustymabe> kushal: that stg site looks good
17:11:57 <dustymabe> some weirdness around "atomic CLI" part
17:12:00 <dustymabe> do you notice that?
17:12:23 <kushal> dustymabe, Yup, was thinking about that background X
17:12:26 <sayan> the background?
17:12:27 <kushal> X-Men?
17:12:48 <jbrooks> the dark text on purple is a little tough to read
17:13:31 <kushal> Yup.
17:13:43 <dustymabe> how do we get this feedback to the right person?
17:13:57 <kushal> Robyduck is the person in charge iirc.
17:14:10 <kushal> dustymabe, jbrooks Meanwhile feel free to comment in the ticket.
17:14:13 <kushal> with the details.
17:14:20 <dustymabe> kushal: 10-4
17:14:35 <kushal> dustymabe, what is that?
17:14:50 <dustymabe> kushal: haha - it means ok - i hear you
17:14:50 <kushal> sorry if I am missing most obvious things :(
17:15:10 <kushal> Moving to open floor then?
17:15:20 <kushal> I have few proposals etc.
17:15:45 <maxamillion> I say go for it
17:16:11 <kushal> #topic Open Floor
17:16:44 <kushal> In the last test day we found no surprises. Autocloud is kind of working hard on the images.
17:16:49 <walters> just a note that we're still trying to debug https://bugzilla.redhat.com/show_bug.cgi?id=1392698
17:17:08 <kushal> But we are still testing the .qcow2 locally, I would love to move that image testing on our Fedora Infra Cloud.
17:17:31 <kushal> So, only the vagrant images will be tested locally, qcow2s in the real cloud environment.
17:18:10 <kushal> 2. Is about the real tests, till now we are mostly reactive to bugs, we convert those into tests.
17:18:48 <bowlofeggs> .hello bowlofeggs
17:18:50 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
17:18:58 <dustymabe> walters: I was going to ask you about that - would be nice to get an executive summary
17:19:02 <kushal> After F25 release, we can have an online write new test cases (at least file the issues with the ideas) day? We should have enough volunteers to add in those new tests.
17:19:09 <kushal> #chair bowlofeggs
17:19:09 <zodbot> Current chairs: bowlofeggs dustymabe jbrooks kushal maxamillion sayan trishnag walters
17:19:23 <dustymabe> kushal: so what is the problem with testing the qcow locally
17:19:39 <dustymabe> I think we should do that, as well as test in openstack ec2 etc..
17:20:02 <kushal> dustymabe, Okay, so you are suggesting just add Openstack testing along with local tests?
17:20:10 <kushal> * are you
17:21:22 <dustymabe> sure - that is what I'm suggesting
17:21:35 <kushal> Okay, we can do that too :)
17:21:43 <dustymabe> it already works for local, so might as well keep doing that
17:21:48 <kushal> Okay.
17:21:50 <maxamillion> +1
17:22:26 <kushal> Next target point is documentation, can we please get our focus back to our users in that area?
17:22:47 <kushal> In the cloud FAD we had long discussion on that, but not much work was done other than trishnag's writings.
17:22:58 <kushal> We really need to work more on that area for our users.
17:23:03 <dustymabe> bowlofeggs: did make some docs
17:23:09 <trishnag> +1
17:23:17 <bowlofeggs> i did!
17:23:19 <kushal> dustymabe, Oh yes, about vagrant
17:23:19 <bowlofeggs> it was fun too
17:23:25 <jbrooks> One important doc matter -- for f25 atomic, kubernetes is no longer in the image, so we'll need to adjust docs for container-based kube
17:23:33 <bowlofeggs> those same docs are also on the wiki
17:23:51 <maxamillion> bowlofeggs: making docs and fun rarely go together ... skeptical face is skeptical
17:23:55 <jbrooks> And I think this is a new development, but as of the last rhel atomic, the basic docs are cc licensed
17:24:04 <jbrooks> I don't think they were before?
17:24:11 <dustymabe> jbrooks: did we make a blog post letting people know about that change?
17:24:14 <bowlofeggs> maxamillion: hahah well i actually kind of like doing that from time to time
17:24:23 <kushal> dustymabe, I don't think so.
17:24:23 <jbrooks> dustymabe, I don't think so
17:24:24 <maxamillion> bowlofeggs: fair enough
17:24:25 <dustymabe> jbrooks: what are the implications of that
17:24:53 <jbrooks> Well, there are a few ways to run kube in containers
17:25:02 <dustymabe> jbrooks: no the cc license
17:25:08 <jbrooks> Oh, we can resue
17:25:10 <jbrooks> reuse
17:25:21 <dustymabe> ok, good to know
17:25:26 <jbrooks> I think they were behind the paywall before
17:25:43 <jbrooks> We don't have fedora-based kube containers
17:25:51 <jbrooks> There's an old PR about that
17:26:10 <jbrooks> And our kube packages are crazy old
17:26:16 <kushal> Oh, means we are in kind of broken state :(
17:27:00 <kushal> I will open up an issue, we have to find out the current state, what all needs to done etc.
17:27:01 <jbrooks> I can sum up the situation in a msg to the list
17:27:10 <jbrooks> I've been doing some work on possibilities
17:27:17 <kushal> jbrooks, Can you please open up an issue?
17:27:23 <jbrooks> kushal, yes
17:27:41 <jbrooks> #action jbrooks to file issue on kube situation w/ f25 atomic
17:27:43 <kushal> jbrooks, Thanks.
17:28:02 <kushal> Anything else?
17:28:38 <dustymabe> jbrooks: so you're saying the kube in f25 won't work?
17:29:27 <jbrooks> dustymabe, It will work, but it's 1.2, and current is 1.4
17:29:30 <jbrooks> and 1.5 is in beta
17:29:48 <jbrooks> There are up to date kube pkgs in koji for f26
17:30:12 <dustymabe> jbrooks: so we just need to karma?
17:30:16 <dustymabe> oh wait, f25
17:30:23 <dustymabe> f25 != f26
17:30:24 <jbrooks> I rebuilt them for f25 and el7: https://copr.fedorainfracloud.org/coprs/jasonbrooks/kubernetes/
17:30:34 <jbrooks> yeah, nothing beyond 1.2 in bodhi
17:30:53 <dustymabe> jbrooks: is this because of openshift pinning again?
17:31:00 <jbrooks> Just today, Jan switched the pkg back to being based on straight upstream kube, raather than on origin
17:31:05 <jbrooks> So that's a nice advance
17:31:19 <dustymabe> jbrooks: which means we should be able to move freely again?
17:31:30 <jbrooks> Yes
17:31:31 <kushal> jbrooks, what is stopping us to have it in F25?
17:31:43 <jbrooks> I don't know
17:31:51 <jbrooks> Here's another option: https://copr.fedorainfracloud.org/coprs/jasonbrooks/kube-release/
17:32:05 <dustymabe> jbrooks: thanks, let's send an email to Jan and copy our list and find out if we can get the latest into f25
17:32:07 <jbrooks> for running kube w/ kubeadm, which is slick
17:32:23 <jbrooks> I've been in touch w/ him today, I'll ask
17:32:43 <dustymabe> jbrooks: wouldn't be bad to have the convo on the list so others can follow
17:32:52 <dustymabe> we need to start doing a better job of communicating there
17:32:54 <dustymabe> i think
17:32:55 <jbrooks> I'll link to the issue on the list
17:33:15 <jbrooks> This legit upstream pkg deal is a new development -- I didn't expect it
17:36:05 <kushal> Okay
17:36:21 <jbrooks> I sent Jan a msg
17:36:53 <dustymabe> ok one other item for today:
17:36:55 <dustymabe> https://lists.fedoraproject.org/archives/list/cloud@lists.fedoraproject.org/thread/2VY5QFBU5KXXBEGCNIYQDSZXEHDILPEG/
17:36:59 <kushal> if no other things on plate, we can end the meeting.
17:37:05 <dustymabe> please test nightlies as the RC process goes through
17:37:19 <dustymabe> we need to make sure we don't forget about atomic host
17:38:10 <jbrooks> +1
17:38:26 <kushal> yup
17:40:00 <kushal> We will be keeping our eyes open for any new issue.
17:40:14 <kushal> Ending the meeting then?
17:40:16 <kushal> 5
17:40:19 <kushal> 4.5?
17:40:29 <kushal> 3
17:40:31 <kushal> 2
17:40:35 <kushal> 1
17:40:38 <kushal> 0.7
17:40:40 <kushal> 0.1
17:40:45 <kushal> #endmeeting