17:00:56 <tibbs> #startmeeting fpc
17:00:56 <zodbot> Meeting started Thu Nov 10 17:00:56 2016 UTC.  The chair is tibbs. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:56 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:56 <zodbot> The meeting name has been set to 'fpc'
17:01:00 <tibbs> #meetingname fpc
17:01:00 <zodbot> The meeting name has been set to 'fpc'
17:01:01 <orionp> hello
17:01:05 <tibbs> #topic Roll Call
17:01:11 <racor> hi
17:01:23 <tibbs> #chair orionp
17:01:23 <zodbot> Current chairs: orionp tibbs
17:01:26 <tibbs> #chair racor
17:01:26 <zodbot> Current chairs: orionp racor tibbs
17:01:46 <tibbs> limburgher mbooth Rathann SmootherFr0gZ tomspur: FPC ping
17:01:57 <tibbs> I know geppetto is away.
17:02:09 <tibbs> So I'll try to muddle through this, assuming we can get quorum.
17:02:43 <tibbs> And if not, well, there's no new tickets this week and only one thing that needs a vote.
17:02:51 <mbooth> hi
17:02:59 <tibbs> #chair mbooth
17:02:59 <zodbot> Current chairs: mbooth orionp racor tibbs
17:03:09 <tibbs> One to go...
17:04:05 <Rathann> hi
17:04:09 <Rathann> I'm here today
17:04:11 <tibbs> #chair Rathann
17:04:11 <zodbot> Current chairs: Rathann mbooth orionp racor tibbs
17:04:24 <tibbs> Cool, that's five.  I'll wait a couple more minutes.
17:04:57 <Rathann> so... meeting time is moved one hour later now?
17:05:47 * Rathann was here 1 hour ago
17:05:52 <tibbs> That's the way it was scheduled in the calendar.
17:06:09 <tibbs> And reflected in the agenda I sent yesterday.
17:06:13 <Rathann> right
17:06:26 * Rathann was away the whole day yesterday
17:06:28 * limburgher here
17:06:41 <tibbs> #chair limburgher
17:06:41 <zodbot> Current chairs: Rathann limburgher mbooth orionp racor tibbs
17:07:06 <tibbs> I guess we can get started.
17:07:31 <tibbs> No new tickets this week besides the request to add the ppc64le excludearch tracker, which I took care of.
17:07:42 <tibbs> #topic #650        Suggested Change for Python Guidelines about Alternate Python Interpreters
17:07:48 <tibbs> .fpc 650
17:07:53 <zodbot> tibbs: #650 (Suggested Change for Python Guidelines about Alternate Python Interpreters) – fpc - https://fedorahosted.org/fpc/ticket/650
17:08:08 <Rathann> looks like I'll have to drop off in about 20 minutes
17:08:26 <tibbs> If we're lucky everyone can drop off in about 10....
17:08:30 <Rathann> :D
17:08:36 <tibbs> Anyway, we still have one thing to do with 650.
17:08:43 <limburgher> That might dovetail nicely with my lunch. :)
17:08:54 <tibbs> We banned all dependencies on "leaf-only" packages.
17:09:05 <tibbs> Which are those that add Provides: leaf-only*
17:09:25 <tibbs> But they actually want to have the python-tox have a soft dependency on those packages.
17:09:40 <tibbs> Well, specifically the leaf-only python2.* and python3.* packages.
17:09:56 <Rathann> yes
17:10:06 <Rathann> that's fine IMHO
17:10:09 <tibbs> I guess python-tox is a tool for testing compatibility of your code against various python interpreters.  Which makes sense.
17:10:15 <Rathann> yes
17:10:20 <tibbs> But since the guideline is a MUST NOT, we must approve exceptions.  So....
17:10:34 <Rathann> I'm +1 to the exception
17:11:04 <tibbs> +1 to allowing python-tox to have some dependency on the python2.* and python3.* leaf-only packages.
17:11:10 <orionp> I'm +1
17:11:13 <limburgher> +1
17:11:33 <mbooth> Sure +1
17:12:06 <tibbs> Hmm, crap, geppetto's summary document doesn't tell me how to tell the bot about a vote.
17:13:15 <tibbs> OK, got it from my logs.
17:13:40 <tibbs> Will wait another minute or so to see if racor wants to vote.
17:14:17 <racor> sorry,  i was reading #650
17:14:33 <racor> +1
17:14:35 <tibbs> It's fine.  I'm still reading bot docs.
17:15:54 <tibbs> #action #650 Approve leaf-only dependency exception for python-tox (+1:6, 0:0, -1:0)
17:16:07 <tibbs> ...
17:16:42 <tibbs> #action Approve leaf-only dependency exception for python-tox (+1:6, 0:0, -1:0)
17:17:21 <tibbs> Well that should work.
17:17:23 <tibbs> .ping
17:17:23 <zodbot> pong
17:17:31 <tibbs> OK, well, whatever.
17:17:59 <tibbs> In any case, I'm not inclined to be picky about what dependencies we're allowing.
17:18:32 <tibbs> #agreed Approve leaf-only dependency exception for python-tox (+1:6, 0:0, -1:0)
17:18:42 <tibbs> Well I just don't know.
17:19:41 <tibbs> Anyway, someone wanted to be picky and say that they were requesting _only_ the ability to use a weak dependency here (Suggests:)  I'm not inclined to make the distinction as to which flavor of dependency we're allowing.
17:20:00 <tibbs> Does anyone have another opinion on that?
17:20:14 <tibbs> #halp
17:20:32 <Rathann> tibbs: let me check
17:20:36 <tibbs> #chair tibbs
17:20:36 <zodbot> Current chairs: Rathann limburgher mbooth orionp racor tibbs
17:20:47 <limburgher> Yeah, it's whitelisted anyway. . .
17:20:48 <tibbs> #action Approve leaf-only dependency exception for python-tox (+1:6, 0:0, -1:0)
17:21:56 <Rathann> I think it's #agreed
17:22:03 <tibbs> Tried that, too.
17:22:21 <Rathann> at least that's what I have in my logs
17:22:24 <tibbs> The minutes will look funny, but it will be in the raw logs so we should be good.
17:22:56 <tibbs> I did just notice that the names for the alternate python packages in the original comment on #650 are actually wrong.
17:23:11 <tibbs> They use "python26" but the guidelines specify "python2.6".
17:23:24 <tibbs> I sure hope those didn't all get imported with the wrong names.
17:23:33 <orionp> Yeah, that's been a hard habit to break
17:23:44 <orionp> The packages are all in place now
17:23:45 <tibbs> One day they'll release python26.
17:23:57 <tibbs> RIght, but with the right names or the wrong ones?
17:24:06 <sgallagh> tibbs: But most of the world will still be on Python 2 -_-
17:24:16 <orionp> wrong - python34 etc
17:24:49 <tibbs> Yep.  What the hell.
17:24:56 <tibbs> I'll get to blocking them.
17:25:26 <tibbs> limburgher: We'll need to double check that when approving the new package requests.
17:25:43 * limburgher groans
17:25:47 <limburgher> tibbs: Yep.
17:25:56 <tibbs> Anyway, that's another topic, but we should fix it before these things start getting used.
17:26:55 <Rathann> ok guys
17:26:57 <Rathann> I have to run
17:27:00 <Rathann> sorry
17:27:03 <tibbs> Yeah, we're done anyway.
17:27:04 <Rathann> bye
17:27:07 <tibbs> Take care.
17:27:42 <tibbs> Now, the only real other thing was that I did actually finish the first draft of https://fedoraproject.org/wiki/User:Tibbs/VersioningCleanup
17:28:11 <tibbs> #topic #656    pre/post-release version guidelines need major simplification for the git era
17:28:22 <tibbs> Why does it listen to me now?
17:28:27 <tibbs> .fpc 656
17:28:28 <zodbot> tibbs: #656 (pre/post-release version guidelines need major simplification for the git era) – fpc - https://fedorahosted.org/fpc/ticket/656
17:29:06 <tibbs> Really, I just would like some suggestions for making it easier to follow.
17:30:05 <tibbs> Still need to rework the "Minor release bumps" and "Rawhide is allowed to lag" sections; I haven't managed to mess with them yet.
17:30:22 <tibbs> And, of course, examples.
17:30:44 <tibbs> If anyone wants to provide some examples, we could certainly use them.  Having them in a separate document means we can basically include as many as we want.
17:31:09 <tibbs> But, really, it would be good to know if anyone thinks this is actually simpler.
17:31:34 <tibbs> But we don't have to do that in this meeting; I just wanted to make sure folks were aware of it.
17:31:40 <limburgher> Cool.
17:31:58 * orionp reading, seems good so far
17:32:01 <limburgher> i'll give it a read and comment on anything that bugs me. :)
17:33:45 <tibbs> I'm just stuck on how to use something like YYYYMMDD%{scm}%{revision} without giving people the impression that those are real macros.
17:34:21 <tibbs> ${date}${scm}${revision}, maybe, but then someone might think they're shell variables.
17:34:34 <orionp> I think we've generally used all caps - SCM ,  REVISION
17:34:35 <tibbs> And if you put in spaces or something, people will think that you need the spaces to be there.
17:34:43 <tibbs> DATESCMREVISION
17:34:47 <orionp> but all run together...
17:34:48 <orionp> yeah
17:34:55 <tibbs> DateScmRevision
17:35:09 <limburgher> <scm><revision>
17:36:12 <tibbs> It would be easier to just write code.
17:36:38 <tibbs> But basically, there are three (or four, or five) things you _might_ put into a Release:.
17:37:06 <tibbs> I figured it was easier to just say "if you have this situation, use this bit" and then tell them how to put the ones they have all together.
17:37:40 <tibbs> Actually trying to follow our current document has shown me exactly why people keep getting it wrong.  It basically only makes sense if you already know what you're supposed to do.
17:38:26 <tibbs> Anyway, I'm sure we all have work to do, and there's really nothing else.
17:38:47 <tibbs> I "took control" of rpmlint and played around with writing some extra tests.
17:39:03 <tibbs> I need to see if we can easily override rpmlint warnings to link directly to our guidelines.
17:40:05 <tibbs> #topic Open Floor
17:40:08 <tibbs> Guess I should do that.
17:40:09 <limburgher> That would be gold.
17:40:16 <orionp> nice
17:40:17 <tibbs> Yeah, it's a lot of work.
17:40:28 <limburgher> Indeed.
17:40:32 <tibbs> But I think doable.  Christmas holidays are coming up, after all.
17:40:38 <limburgher> tibbs++
17:42:04 <tibbs> I should mention that in a package review I submitted, the reviewer told me that I needed to add a build dep on coreutils and fileutils, because I called "mv", "touch" and "find" in the spec.
17:42:15 <tibbs> Which indicates a failure somewhere.
17:42:20 <limburgher> eek
17:43:11 <tibbs> Turns out the Perl guidelines try to restate the statement on build deps from the main guidelines, but end up saying "add buildrequires for absolutely everything".
17:43:54 <tibbs> I went ahead and changed that statement to just restate the main guidelines, but I realize that this is what we get when we try to restate things instead of using links.
17:45:02 <limburgher> No Bundled Guidelines
17:45:08 <tibbs> Yeah, pretty much.
17:46:03 <tibbs> Other random things:
17:46:07 <tibbs> https://stg.pagure.io/packaging-committee
17:46:23 <tibbs> I ran a test conversion of our trac tickets.
17:46:29 <tibbs> https://stg.pagure.io/packaging-committee/issues is the unfortunate result.
17:47:15 <tibbs> I'm either going to do the conversion again without trying to incorporate keywords (because some people just fill them in and I don't think we actually ever cared).
17:47:28 <limburgher> I forgot we had them.
17:47:33 <tibbs> We can add useful keywords back in for the tickets that are still open.
17:48:02 <limburgher> Like "perl", "special_case" or "godnotthisagain"
17:48:04 <tibbs> It's just a field in trac.  There's obviously an impedance mismatch because pagure doesn't have the kind of workflow tracking that trac had.
17:48:26 <tibbs> The other issue is the lack of proper resolutions.
17:48:39 <tibbs> The closed tickets are mostly "Fixed" which... isn't what we want.
17:50:11 <tibbs> I think I can fix all of that, maybe by mogrifying the json in the pagure ticket repo.
17:50:16 <tibbs> But that's what it's going to look like.
17:50:55 <tibbs> Well, that combined with https://pagure.io/docs/packaging-guidelines/
17:51:08 <tibbs> And obviously a whole lot of formatting and cleanup.
17:51:42 <tibbs> But the end result is that we use pagure for both committee business tickets _and_ a repository for the packaging guidelines.  Probably in RST format, though the test import above is in markdown.
17:52:53 <limburgher> I think overall it should be a lot more useful for us.
17:53:04 <tibbs> Obviously it needs a whole lot of CSS and such to be useful.  But in the end we'd get a proper, non-wiki document that we can present as individual pages, a big single HTML document, or a PDF you could print (right before your long vacation in the asylum).
17:53:33 <tibbs> The fact that someone could just send us a pull request is a big thing.
17:54:09 <tibbs> Note that this incorporates full history.
17:54:35 <tibbs> At least back to the import from Moin nearly 9 years ago, which lost history.
17:55:44 <tibbs> Anyway, fale is still working on it.  We know the formatting is crap and that there's junk in the existing wiki which we really _don't_ want to try to convert.
17:57:01 <tomspur> Hi
17:57:03 <tibbs> But if you have any recommendations, he'd love to hear them.
17:57:10 <tibbs> tomspur: Hey.  We're basically trailing off.
17:57:18 * limburgher waves
17:57:27 <tomspur> I see, already @Open Floor
17:57:39 <tibbs> Which basically means I'm typing random things and everyone besides limburgher is already off to lunch or dinner.
17:57:49 <tibbs> There was only one vote, on 650.
17:57:53 <tibbs> .fpc 650
17:57:55 <zodbot> tibbs: #650 (Suggested Change for Python Guidelines about Alternate Python Interpreters) – fpc - https://fedorahosted.org/fpc/ticket/650
17:57:59 <tibbs> Nothing contentious.
17:58:23 <tibbs> Right now I'm pointing people at https://stg.pagure.io/packaging-committee which has a trial trac ticket import.
17:58:48 <tibbs> And https://pagure.io/docs/packaging-guidelines/ which has a trial conversion of the wiki pages.
17:59:09 <tibbs> (and which really should be in staging or hidden, but he'll delete that repo at some point).
18:00:17 <tomspur> Nice
18:01:56 <tomspur> Why are there so many tags: https://stg.pagure.io/packaging-committee/issues ?
18:02:06 <tibbs> Because it converted keywords to tags.
18:03:02 <tibbs> I'll reconvert without tags at all, and then we can just add the few we need (meeting, needinfo, writeup, announce).
18:03:18 <tibbs> And I'll see if we can't properly convert the closed statuses.
18:03:26 <tibbs> But basically, that's what it's going to look like.
18:03:34 <tomspur> Hmm, I like some of those tags
18:04:24 <tomspur> bundling, security... could make sense too besides meeting, needinfo...
18:05:07 <tibbs> It would be nice if we could keep the ones related to process separate from the ones related to content, but... I don't think we can.
18:05:20 <tibbs> And if we had to pick, I'd pick the ones relating to process every time.
18:05:41 <tibbs> Fortunately "bundling" doesn't have any relevance these days, and I'm not sure what "security" would mean for us.
18:05:58 <tibbs> But we can start with the process ones and see if there's a reason to do the others.
18:06:24 <tomspur> The assignee cannot be tricked to do the process tags?
18:06:49 <tomspur> But then we cannot properly assign tickets anymore
18:07:23 <tomspur> Wait... isn't meeting, needinfo etc a "status"?
18:07:39 <tibbs> pagure only has status for closed tickets.
18:07:50 <tomspur> ok
18:07:51 <tibbs> Ther are custom fields.
18:08:40 <tibbs> Anyway, pagure is still evolving so it may gain what we need eventually.
18:08:55 <tibbs> We have until the end of february to switch, but I'd prefer not to wait that long.
18:10:21 * tomspur nods
18:10:59 <tibbs> But you're right that it would be nice to see "python" related tickets quickly.
18:11:23 <tibbs> But the tag list can grow without bounds.  I think there will be a better way eventually.
18:13:07 <tibbs> Anyway, that's basically the current status of things.
18:13:25 <tibbs> I don't have anything else to add right now.  But I do have about 70 writeups to do.
18:13:56 <tibbs> tomspur: Do have a glance at https://fedoraproject.org/wiki/User:Tibbs/VersioningCleanup if you get a chance and let me know if you think I'm at least moving things in the right direction.
18:17:05 <tomspur> It is very easy readable +1
18:17:21 <tibbs> Anyone know racor's FAS ID off hand?
18:17:55 <racor> tibbs: I am still around ;)
18:18:11 <tibbs> Well, you were included in Anyone?
18:18:29 <tibbs> I was just making sure I had the proper user list for adding everyone to pagure.
18:18:46 <tibbs> But you're not "racor", as far as I can tell.
18:18:58 <racor> It's "corsepiu"
18:19:38 <tibbs> Thanks.  fas queries weren't showing me anything for some reason.
18:20:10 <tibbs> OK, I added everyone, at least.
18:21:26 <tibbs> Anyway, I'm about spent and we should probably end this.
18:21:29 <tibbs> Anyone have anything else?
18:22:52 <limburgher> not here.
18:23:07 <tomspur> same here
18:24:17 <tomspur> What are "priorities" in pagure?
18:24:38 <tomspur> Maybe that can be used for the process tags too
18:25:18 <tibbs> I think they're just for sort order.
18:26:06 <limburgher> can't we just use <date><scm><hash>
18:26:09 * limburgher ducks
18:28:17 <tibbs> You can add a boolean like "meeting" but there's no real way to search for it currently.
18:28:45 <tibbs> Anyway, I'll end the misery and then figure out how to send the email.
18:28:51 <tibbs> But... one more try.
18:29:02 <tibbs> #halp
18:29:07 <limburgher> Push the button, Frank.
18:29:07 <tibbs> .help
18:29:07 <zodbot> Please see https://fedoraproject.org/wiki/Zodbot for general help and information about this Supybot - If you want information about a specific command, type .misc help <command>
18:29:36 <tibbs> #agreed Approve leaf-only dependency exception for python-tox (+1:6, 0:0, -1:0)
18:29:50 <tibbs> #link https://stg.pagure.io/packaging-committee/issues
18:30:04 <tibbs> #topic zodbot, you confuse me.
18:30:14 <tibbs> #topic I give up.
18:30:19 <tibbs> #endmeeting