15:01:21 <tflink> #startmeeting fedora-qadevel
15:01:21 <zodbot> Meeting started Mon Jan  9 15:01:21 2017 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:21 <zodbot> The meeting name has been set to 'fedora-qadevel'
15:01:22 <tflink> #meetingname fedora-qadevel
15:01:22 <zodbot> The meeting name has been set to 'fedora-qadevel'
15:01:22 <tflink> #topic Roll Call
15:02:00 * mkrizek is here
15:02:03 * lbrabec is here
15:02:11 * garretraziel is here
15:03:21 * kparal is here
15:04:00 <tflink> any idea if josef was planning to be around?
15:04:46 * kparal doesn't know
15:05:15 <tflink> let's get started
15:05:36 <tflink> #topic Announcements and Information
15:05:45 <tflink> #info taskotron stg rebuild to f24/f25 process started, many snags are being hit - tflink, mkrizek
15:05:46 <tflink> #info new qa.fp.o instance with phabricator FINALLY deployed with working auth - tflink
15:05:47 * roshi is here
15:05:53 <tflink> roshi: welcome back
15:05:58 <roshi> thanks :)
15:06:03 <kparal> #info roshi is back
15:06:05 <kparal> :P
15:06:11 <roshi> got my cup of coffee and an ready to go
15:06:50 <tflink> any other things to add to the list?
15:07:05 * kparal has nothing important
15:07:25 <kparal> tflink: great job on getting the phab working with fas
15:07:40 <mkrizek> #info discussion started on qa-devel ML about running tasks on koji scratch builds - mkrizek
15:08:06 <tflink> kparal: thanks, puiterwijk gets a bunch of the credit for getting the backend stuff working
15:08:26 <kparal> puiterwijk gets cookies all the time
15:08:28 <mkrizek> tflink++ puiterwijk++
15:08:28 <zodbot> mkrizek: Karma for tflink changed to 3 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:08:28 <kparal> tflink++
15:08:30 <kparal> puiterwijk++
15:08:31 <zodbot> kparal: Karma for tflink changed to 4 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:08:58 <puiterwijk> And I'm always happy to accept :-)
15:09:04 <tflink> which segues into one of our topics well
15:09:15 <tflink> #topic Phabricator Maintenance
15:10:22 <tflink> So, this process took a lot longer than I had hoped and I'd really like some help with the packages etc. if we're going to continue using phab
15:11:09 <tflink> any volunteers?
15:11:36 <kparal> just to clarify, is this more about packaging or system administration?
15:11:41 <tflink> both
15:12:00 <roshi> o/ - I'll help with either
15:12:13 <mkrizek> I can help too
15:12:22 <roshi> though, I've got a bunch of backlog at the moment, so going to be a slow starter
15:12:25 <roshi> lol
15:12:35 <tflink> also, testing and maintaining the auth extension I wrote to make fas work
15:12:46 <kparal> roshi: reading a year of emails? :-)
15:12:59 <tflink> https://pagure.io/phabricator-extension-ipsilonoauth/
15:13:19 <roshi> pretty much
15:13:26 <roshi> getting my local infra set up again...
15:13:41 <tflink> https://pagure.io/phabphourphedora
15:14:01 <kparal> ouch, the name!
15:14:04 <roshi> lol
15:14:57 <tflink> glad to see you like it :)
15:15:10 <tflink> the reviews are still underway, hopefully they'll be done before too much longer
15:16:19 <tflink> also, I think of this as generally lower priority than a lot of other taskotron work for the most part
15:17:17 <tflink> familiarizing yourself with the packages and learning how to deploy an instance for dev/test would be a good place to start
15:17:51 <tflink> the auth extension needs to be packaged at some point
15:18:22 <tflink> anyhow, I'll be poking folks later (but maybe not too much later) about this
15:18:32 <roshi> sgtm
15:18:37 * tflink really hopes that phab and qa.fp.o can go into maintance mode for a while
15:18:48 <tflink> anyhow, any other comments, questions?
15:19:04 <kparal> roshi++
15:19:04 <zodbot> kparal: Karma for roshi changed to 1 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:19:37 <tflink> ok, moving on
15:19:46 <tflink> #topic Rebuilding Taskotron instances
15:20:07 <tflink> The update and redeployment of our Taskotron instances is ongoing
15:21:23 <tflink> we tried moving the persistent files to nfs so that they didn't need to be moved on every migration but it turns out that the buildmaster really doesn't like having its files on nfs
15:21:43 <tflink> but it sounds like moving the buildmaster back to local disk got things working again
15:21:57 <tflink> mkrizek: did I miss something?
15:23:41 <mkrizek> nope
15:24:33 <tflink> stg should be fixed today, prod will hopefully be redeployed this week sometime
15:24:44 <tflink> any other comments, questions?
15:25:48 * tflink takes that as a no
15:25:57 <tflink> #topic Documentation
15:26:26 <tflink> This is mostly a heads up. with the new phab comes some other stuff behind the scenes like better support for building and hosting documentation
15:26:55 * tflink is going to be posting a review for libtaskotron so that docs are built automatically on every push to develop and master
15:27:09 <tflink> it'd be nice to get something similar set up for all of our projects
15:27:19 <kparal> sounds great
15:27:41 <tflink> but not all of them have sphinx projects, IIRC
15:27:59 <kparal> or documentation at all :)
15:28:06 <tflink> that too
15:29:11 <kparal> I can help out with setting up other projects once I see how to do it, if needed
15:29:20 <tflink> that would be appreciated
15:29:42 <kparal> ok
15:29:47 <tflink> I'm hoping that the dodo.py file will be easy to transfer between projects so that we can minimize the duplication and maintenance
15:30:02 <tflink> anything else on this?
15:30:17 <tflink> #topic Dist-Git Task Storage Proposal (and test case docs)
15:30:31 <tflink> https://phab.qa.fedoraproject.org/w/taskotron/new_distgit_task_storage_proposal/
15:30:51 <tflink> This needs to be finalized before we can say that we support tasks in dist-git
15:31:52 * tflink is wondering where it should live - thoughts?
15:32:25 <tflink> the obvious answers would be phab and the fp wiki
15:32:25 <kparal> what is "it", the documentation?
15:32:29 <tflink> yeah, the docs
15:32:47 <tflink> or in the sphinx docs for one of our projects
15:33:03 <kparal> put it in one place and link from the other?
15:33:21 <tflink> that makes sense
15:33:35 * tflink doesn't care a whole lot about where it ends up so long as it's readable and folks can find it
15:33:48 <kparal> it depends if we want to allow easy editing for fedora community (wiki)
15:34:04 <tflink> what are the odds that someone is going to edit it?
15:34:14 <kparal> I have no idea, some examples perhaps?
15:34:22 <tflink> possible
15:34:40 <tflink> another thought would be to start a taskotron documentation project and let that get autobuilt and hosted on qa.fp.o
15:34:55 <roshi> that'd be easy enough to vet those patches though, I'd think
15:36:40 <tflink> it sounds like there aren't many strong feelings on the matter, though?
15:37:07 * kparal shrugs
15:37:22 <tflink> :)
15:37:51 <tflink> ok, I'll find somewhere to put it
15:38:03 <tflink> probably fp.o wiki or a sphinx project
15:38:13 <tflink> moving on to
15:38:22 <tflink> #topic git hosting
15:39:00 <tflink> I didn't send this one out in the meeting ahead of time but this is something that we're going to have ot deal with before much longer
15:39:17 <tflink> blockerbugs is still on fedorahosted which is being shut down soon
15:39:33 <tflink> I propose that we move everything to pagure.io
15:39:48 <kparal> time for github? :)
15:39:51 <kparal> just trolling...
15:40:13 <kparal> do we still have plans to host gits inside phab?
15:40:29 <tflink> I'm not sure it'd be worth the effort
15:40:37 <roshi> fedorahosted is getting shut down?
15:40:43 <kparal> sounds reasonable. move to pagure
15:40:47 <tflink> yep, by the end of february AFAIK
15:40:57 <roshi> for good?
15:41:03 <kparal> but I'd like all our projects to have in a single place. so perhaps it's good time to move _everything_ to pagure?
15:41:04 <tflink> yep
15:41:15 <tflink> kparal: that's what I was proposing
15:41:28 <tflink> sorry if I wasn't clear
15:41:42 * kparal is in favor
15:41:47 <roshi> wfm
15:42:07 <garretraziel> +1 for moving to pagure
15:42:24 <kparal> I thought you're talking just about blockerbugs, not that I read it again, you weren't
15:42:43 <tflink> proposed #agreed move all of our projects over to pagure so that things are all on pagure
15:42:51 <kparal> garretraziel: including those funky openqa projects!
15:43:02 <roshi> +1
15:43:08 <roshi> ack
15:43:22 <tflink> +1
15:43:36 <kparal> ack
15:43:45 <tflink> #agreed move all of our projects over to pagure so that things are all on pagure
15:44:22 <tflink> any questions, concerns, comments before moving on to the next topic?
15:44:31 <roshi> none here
15:45:16 <kparal> nope
15:45:24 <tflink> ok, moving on
15:45:30 <tflink> #topic tasking
15:46:17 <tflink> does anyone have the bandwidth for an additional project
15:46:19 <tflink> ?
15:46:40 <tflink> https://phab.qa.fedoraproject.org/T725
15:46:40 <roshi> unsure atm :p
15:46:55 <tflink> I really want to have that at least demo-able before devconf
15:46:59 <tflink> if not sooner
15:47:10 <roshi> when is that?
15:47:14 <tflink> end of Jan
15:47:15 <kparal> oof
15:47:53 <tflink> I'm hoping that it wouldn't take more than a few full days
15:48:06 <tflink> note that I said "demo-able" not completely done
15:49:06 <lbrabec> i can look at that
15:49:29 <kparal> lbrabec++
15:49:29 <zodbot> kparal: Karma for lbrabec changed to 1 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:49:32 <tflink> lbrabec: thanks, let me know if you have questions
15:49:48 <tflink> i'll be pestering you later this week for an update :)
15:49:54 <lbrabec> ok :)
15:50:10 <tflink> anyone else need/want tasks?
15:50:52 <tflink> if so, ping me but I think that folks are pretty occupied right now
15:51:00 <tflink> with 10 minutes left, moving on to
15:51:03 <tflink> #topic Open Floor
15:51:11 <tflink> anything that folks wanted to bring up?
15:52:02 <roshi> nothing here
15:52:07 <roshi> just getting situated
15:56:00 <tflink> ok, thanks for coming everyone
15:56:05 * tflink will send out minutes shortly
15:56:10 <tflink> #endmeeting