17:01:30 <geppetto> #startmeeting fpc
17:01:30 <zodbot> Meeting started Thu Jan 12 17:01:30 2017 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:30 <zodbot> The meeting name has been set to 'fpc'
17:01:30 <geppetto> #meetingname fpc
17:01:30 <zodbot> The meeting name has been set to 'fpc'
17:01:30 <geppetto> #topic Roll Call
17:02:11 * limburgher here
17:02:55 <geppetto> #chair limburgher
17:02:55 <zodbot> Current chairs: geppetto limburgher
17:05:57 <tibbs> Hey, folks.
17:06:04 <tibbs> I'm still swamped here at work.
17:06:11 <geppetto> #chair tibbs
17:06:11 <zodbot> Current chairs: geppetto limburgher tibbs
17:06:27 <geppetto> No problem, doesn't look like we'll make it today anyway, and we have no new stuff
17:07:38 <limburgher> Fine here.  I brain is mostly static today anyway.
17:07:40 <limburgher> My.
17:07:42 <limburgher> See?
17:07:45 * geppetto nods
17:07:52 <geppetto> you are not alone :)
17:08:06 * limburgher takes some minor comfort in that
17:08:17 <mbooth> Hi
17:08:26 <limburgher> Yo
17:08:37 <geppetto> #chair mboddu
17:08:37 <zodbot> Current chairs: geppetto limburgher mboddu tibbs
17:08:45 <geppetto> #unchair mboddu
17:08:45 <zodbot> Current chairs: geppetto limburgher tibbs
17:08:53 <geppetto> #chair mbooth
17:08:53 <zodbot> Current chairs: geppetto limburgher mbooth tibbs
17:08:56 <geppetto> #chair racor
17:08:56 <zodbot> Current chairs: geppetto limburgher mbooth racor tibbs
17:09:15 <limburgher> Holy quorum, Batman!
17:09:22 <tibbs> The python folks did update their draft.
17:09:35 <geppetto> ok
17:09:55 <geppetto> #topic Schedule
17:09:58 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/5PDMVGYZQKNIZP5QD7O3TVRJFVLPZNMT/
17:10:03 <tibbs> Personally I am replacing all of my server racks with new server racks, and that is taking absolutely forever.
17:10:23 <limburgher> Oh my.
17:10:35 <geppetto> You mean 650?
17:11:58 <tibbs> Not 650.
17:12:08 <tibbs> 635
17:12:15 <tibbs> https://fedorahosted.org/fpc/ticket/635
17:12:28 <tibbs> trac doesn't set things back from needinfo automatically, so it's easy to miss them.
17:12:36 <tibbs> They updated just over a day ago.
17:12:40 <geppetto> ahh, yeh, it's not on the schedule :(
17:13:14 <geppetto> #topic #635  FC Automatic Provides for Python RPM Packages
17:13:17 <geppetto> .fpc 635
17:13:18 <zodbot> geppetto: #635 (FC Automatic Provides for Python RPM Packages: Accompanying change of Python packaging guidelines) – fpc - https://fedorahosted.org/fpc/ticket/635
17:13:43 <geppetto> New diff: https://fedoraproject.org/w/index.php?title=User%3ATorsava%2FPackagingDrafts%2FPythonProvides&diff=483708&oldid=483696
17:16:13 <tibbs> As is usual for the python guidelines, it's a lot of stuff for something that Perl has done mostly painlessly forever.
17:17:21 <tibbs> I'm not 100% sure we need the full explanation of how RPM generates those automatic Provides:, but I guess it doesn't hurt.
17:17:44 <limburgher> This looks good.  Speaking as someone who hand-writes makefiles, I'm somewhat skeptical but willing to have it work. :)
17:17:51 <geppetto> It looks fine to me
17:18:28 <tibbs> I would prefer that we be able to say "this release has what you need" instead of having to say "was introduced in F25 but only packages which were rebuilt will have this".
17:19:16 <tibbs> It's too much complexity for something which only matters for some packages in one release.  Are we safe saying "F26"?
17:19:23 <geppetto> Doesn't it just say "starting with F26"?
17:19:41 <tibbs> It says "starting with F25, plus caveats"
17:19:53 <limburgher> Maybe packages with release tag >=fc25, so if it's not rebuilt people know.
17:19:56 <geppetto> I'm looking at "requires and build requires"
17:20:17 <limburgher> So if you're running f26 but the RPM says f22 you know.
17:20:28 <tibbs> Look at the admin/note
17:20:33 <tibbs> admon/note
17:20:38 <tibbs> And all of the other mentions of F25.
17:20:51 <tibbs> I would suggest to say "F26 and newer only".
17:21:22 <tibbs> If people want to try them in F25 and it actually works for them, then great but I don't think we need to have the guideline page go into the details.
17:21:58 <limburgher> How about F25ish?
17:22:38 <geppetto> I'm happy to s/25/26/ throughout
17:22:57 <geppetto> Maybe better would be 25+ for provides and 26+ for usage.
17:23:07 <limburgher> That's probably safest.  And it will give us more time to work out the kinks.
17:24:06 <tibbs> In two years I can just remove all mention of versions completely.
17:25:10 <geppetto> haha
17:25:26 <tibbs> What do folks think of the explanation of how the Provides: are generated.
17:25:28 <tibbs> ?
17:26:22 <limburgher> Seems straightforward enough.
17:26:23 <tibbs> I think it's well written; I'm just not convinced it needs to actually be there.
17:26:26 <geppetto> you mean about all the py2/py3 stuff?
17:26:39 <mbooth> Does the packager need to know about the nuts and bolts? If not, maybe there could simply be a link to a non-guideline page.
17:26:42 <limburgher> tibbs: I think it does.
17:26:50 <limburgher> mbooth: Ooh, or that.
17:28:02 <tibbs> Looking at Perl, it only mentions any details about how auto-dep-generation works in a section about working around it when it doesn't work.
17:29:27 * geppetto nods, that seems fine
17:29:40 <tibbs> I don't think we document how autodeps for .so files works, either.  Though sometimes I have thought that maybe some mention of at least the basics.
17:29:53 <tibbs> But that's probably because there isn't any documentation about that anywhere.
17:30:14 <limburgher> I suppose the need for detail is proportional to the likelihood of breakage.
17:30:33 <tibbs> In any case, I don't object to it.  If it turns out that it makes things too long or difficult to read then we can come back to it.
17:31:09 <geppetto> Yeh, I'm +1
17:31:21 <limburgher> Ideally it will be useful to those who need it and ignored by those who don't.
17:31:44 <mbooth> Indeed, TBH I'd be happy to +1 this as is
17:32:02 <limburgher> MmmHmm.
17:32:04 <limburgher> +1
17:32:41 <geppetto> racor: I believe it's just you to vote
17:35:03 <racor> +1 - Though I do not feel sufficiently familiar with python, my feel is the python specialists seem to be satisfied, I do not want to hold things up ;)
17:35:17 * geppetto nods
17:35:34 <geppetto> tibbs: I assumed you are +1, but you didn't actually say that :)
17:35:49 <tibbs> I thought I did, but might have backspaced over it.
17:35:51 <tibbs> +1
17:35:54 <geppetto> #action  FC Automatic Provides for Python RPM Packages (+1:5, 0:0, -1:0)
17:36:05 <geppetto> ok, we did something :)
17:36:20 <mbooth> \o/
17:36:49 <geppetto> Any of the other tickets we want to talk about, because AFAIK there is nothing new happened on them officially
17:39:34 <geppetto> #topic Open Floor
17:39:45 <geppetto> Ok, anything else to talk about?
17:40:27 <tibbs> I'm about out of time I can spend today anyway.
17:40:32 <geppetto> I might be going to devconf this year
17:40:35 * geppetto nods
17:40:55 <geppetto> Ok, I'll close the meeting in the next minute or so
17:41:17 <mbooth> Right-o, see you next time
17:41:22 <tibbs> Thanks.
17:41:31 <tibbs> Forgive me, but exactly what is devconf?
17:41:46 <tibbs> I see people going to it but I've never bothered to figure out what it actually is.
17:42:30 <geppetto> tibbs: https://devconf.cz/
17:43:05 <tibbs> Ah, it's sort of a Red Hat thing.
17:43:10 <geppetto> yeh
17:43:35 <tibbs> I should try to get funding to go, but certainly not this year.
17:43:40 <geppetto> it's open, but there is a large contingent of RH people there/speaking
17:44:27 <geppetto> #endmeeting