21:00:27 <sgallagh> #startmeeting Server Working Group Weekly Meeting (2017-01-17)
21:00:27 <zodbot> Meeting started Tue Jan 17 21:00:27 2017 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:27 <zodbot> The meeting name has been set to 'server_working_group_weekly_meeting_(2017-01-17)'
21:00:27 <sgallagh> #chair nirik sgallagh mhayden dperpeet smooge jds2001 vvaldez adamw mjwolf
21:00:27 <zodbot> Current chairs: adamw dperpeet jds2001 mhayden mjwolf nirik sgallagh smooge vvaldez
21:00:27 <sgallagh> #topic roll call
21:00:27 <sgallagh> .hello sgallagh
21:00:29 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
21:00:34 <mhayden> .hello mhayden
21:00:35 <zodbot> mhayden: mhayden 'Major Hayden' <major@mhtx.net>
21:00:44 <dperpeet> .hello dperpeet
21:00:45 <nirik> .hello kevin
21:00:45 <zodbot> dperpeet: dperpeet 'None' <dperpeet@redhat.com>
21:00:48 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
21:00:49 <mjwolf> .hello mjwolf
21:00:51 <zodbot> mjwolf: mjwolf 'Michael Wolf' <mjwolf@us.ibm.com>
21:01:01 <smooge> hello
21:01:15 <smooge> .hello smooge
21:01:16 <zodbot> smooge: smooge 'Stephen J Smoogen' <smooge@gmail.com>
21:02:02 * langdon lurks
21:02:13 <sgallagh> /me drags langdon out into the open
21:02:19 <langdon> lol
21:02:22 <langdon> .hello langdon
21:02:23 <zodbot> langdon: langdon 'Langdon White' <langdon@fishjump.com>
21:02:53 * langdon needs a 3rd monitor
21:03:08 <sgallagh> OK, we have quorum, but I'd like to wait for adamw before we start (since the release-blocking media affects his team strongly)
21:05:11 <sgallagh> That being said, I guess he's not turning up today.
21:05:47 <sgallagh> #topic agenda
21:05:53 <sgallagh> #info Agenda Item: Release-blocking Media
21:05:53 <sgallagh> #info Agenda Item: Bikeshed on a marketing-friendly name for the modular Server
21:06:08 <sgallagh> Does anyone else have a pressing agenda item for this week?
21:07:04 <sgallagh> #topic Release-blocking Media
21:07:04 <sgallagh> #link https://fedoraproject.org/wiki/Fedora_Program_Management/ReleaseBlocking/Fedora26#Server
21:07:41 <sgallagh> Currently, Server Edition produces all of the media described at that link, but only considers issues that affect the x86_64 DVD and netinstall media to be blockers.
21:08:22 <sgallagh> Would anyone like to revise this list?
21:09:11 <nirik> kinda would like the cloud image too... but perhaps not if there's not a lot of support for it
21:09:42 <sgallagh> /me nods
21:09:48 <sgallagh> dustymabe: You around?
21:10:11 <sgallagh> I'd like to hear the general confidence level around it before we go ahead and add it
21:10:57 <dperpeet> I agree - if the confidence level is high enough, that image would be valuable to have as well
21:11:37 <nirik> well, right now we are just keeping it the way it is right? so we just need to watch for breakage...
21:11:43 <nirik> or were we going to adjust it any?
21:12:04 <sgallagh> Let's pause for a moment: which image?
21:12:24 <sgallagh> The qcow2 image for OpenStack/KVM? The AMI? Something else?
21:12:38 <nirik> excellent point. ;)
21:12:38 <sgallagh> (all of the above...?)
21:13:31 <nirik> I was just thinking of the Fedora_cloud_base qcow2.
21:13:37 <nirik> (x86_64)
21:14:02 <sgallagh> I think we probably need to revisit that conversation
21:14:36 <nirik> yeah. Also, it might be wise to have a release without it blocking and see how we do with it... since we are new to maintaining it.
21:15:04 <sgallagh> Yeah, I think I'd fall on that side of things as well: don't block this time around while we work out the kinks
21:15:21 <sgallagh> But we should start producing them
21:15:45 <nirik> yes
21:15:52 <sgallagh> Proposal: Add Fedora Server qcow2 and AMI images as produced media, but treat them as non-blocking for Fedora 26.
21:16:52 <nirik> sure.
21:17:16 <mjwolf> +1
21:17:21 <dperpeet> +1
21:17:34 <sgallagh> +1
21:17:41 <sgallagh> smooge: ?
21:17:45 <dperpeet> no fancy architectures though :)
21:17:54 <sgallagh> dperpeet: Valid point.
21:17:56 <sgallagh> /me revises
21:18:12 <langdon> does vagrant not "count"
21:18:13 <langdon> ?
21:18:13 <sgallagh> Proposal: Add Fedora Server qcow2 x86_64 and AMI x86_64 images as produced media, but treat them as non-blocking for Fedora 26.
21:18:44 <sgallagh> langdon: If you want Server SIG to produce an official vagrant image, that's an additional option.
21:18:51 <sgallagh> But someone will need to own it
21:18:58 <langdon> ohh.. right.. cloud owned the old one
21:19:01 <langdon> sorry..
21:19:08 <sgallagh> (I'm not willing to volunteer dustymabe for that without him being present)
21:19:14 <langdon> i do .. but i am not sure who/how to own it
21:19:47 <smooge> sorry kid came in
21:20:01 <langdon> maybe we cna take it up with dusty offline
21:20:01 <smooge> +1
21:20:09 <sgallagh> langdon: And/or on the mailing list
21:20:26 <sgallagh> #agreed Add Fedora Server qcow2 x86_64 and AMI x86_64 images as produced media, but treat them as non-blocking for Fedora 26.
21:20:39 <sgallagh> #action sgallagh to update the release-blocking media page
21:20:57 <sgallagh> #topic Bikeshed on a marketing-friendly name for the modular Server
21:21:11 <sgallagh> Before we start, let's identify the purpose of the activity.
21:21:50 <sgallagh> We plan to start offering an alternative medium (likely produced outside the normal process for this release, so I'm not going to add it to the media link above).
21:22:31 <sgallagh> The reason for it is to build an operating system out of individually well-tested components, rather than the build-it-yourself approach of Fedora today.
21:22:48 <sgallagh> * build an operating system suited for your specific needs
21:23:29 <sgallagh> For an indeterminate amount of time, this will be delivered as an alternative to the present-day Server Edition.
21:23:48 <sgallagh> As such, we need to call it something, and I'm morally opposed to langdon's placeholder "Crazy Server"
21:24:07 <langdon> i did the sys wide change "Modular Server Preview"
21:24:10 <sgallagh> OK, level-set complete
21:24:12 <dperpeet> although it does have a certain ring to it
21:24:14 <langdon> was that not "cool" enough?
21:24:21 <smooge> urBikeShed
21:24:22 <nirik> Fedora Autobot!
21:24:34 <sgallagh> nirik: If that wouldn't get us sued, I rather like that one...
21:24:43 <langdon> Fedora Voltron would be more accurate!
21:24:50 <nirik> and as long as it's not a decepticon. ;)
21:24:51 <smooge> Fedora Boltron
21:25:07 <smooge> Bolting together parts to make the system of your needs
21:25:08 <sgallagh> langdon: Modular is neither descriptive enough nor "active" enough, IMHO
21:25:11 <nirik> Fedorastiens monster? no, thats a bit negative
21:25:17 * langdon mutters "i am sure some people will see it as decepticon" ;(
21:25:36 <dperpeet> "Fedora Served", heh
21:25:40 <langdon> lol
21:25:59 <nirik> Fedora Unit Block (https://en.wikipedia.org/wiki/Unit_block)
21:26:00 <sgallagh> The Island of Dr. Fedora?
21:26:08 <smooge> Fedorad -- replacing all your spins
21:26:18 <dperpeet> but it's too tied to English
21:26:31 <sgallagh> Right, that's another thing: we need something that we can translate
21:26:47 <dperpeet> or something clearly not meant to be translated
21:27:13 <sgallagh> langdon: What I'm looking for is something that catches the attention enough that people want to learn more. "Modular" to me just sounds like buzzword-generator.
21:27:41 <langdon> sgallagh, ack.. that makes sense to me
21:27:53 <langdon> i guess there wasnt enough level setting for me ;)
21:28:07 <sgallagh> (Side-note: I wonder if we could replace "Module Build Service" with "Fedora Haberdashery" ;-) )
21:28:17 <smooge> just to be clear.. I have been serious about urBikeShed, Fedora Boltron and Fedorad
21:28:32 <sgallagh> smooge: Duly noted
21:28:36 <langdon> do we want something like Boltron? or something more "technical" a la "Server"
21:28:57 * langdon really doesn't have a clue and stinks at naming.. see "Modularity" as example 1
21:29:27 <sgallagh> Boltron actually does have an interesting sound to it (and it's a nonsense word, so it would be carried directly rather than translated)
21:29:53 <smooge> Instead of Crazy Server: MadHatter?
21:29:56 <langdon> smooge, why "B"? popped in to your head? or something i am missing?
21:30:10 <langdon> smooge, ooo.. i like that .. but see example 1 ;)
21:30:34 <sgallagh> langdon: "(04:25:07 PM) smooge: Bolting together parts to make the system of your needs"
21:30:38 <smooge> Well the idea of bolts tieing parts together gave a solidity
21:30:47 <langdon> sorry.. missed that
21:30:50 <smooge> np
21:31:26 <langdon> i like the "voltron" being the sum greater than the parts.. so the combo is pretty good
21:31:27 <sgallagh> (Frankly, this one is really growing on me; even if we don't go with it ultimately, I'm using it as a codename)
21:31:36 <langdon> sgallagh, boltron?
21:31:39 <sgallagh> Yes
21:32:34 <smooge> It also tied into the Fedora-stein in that instead of having a lion or vehicle combo robot you could have something with bolts coming out the neck
21:32:43 <sgallagh> /me snickers
21:32:59 <langdon> as long as it isn't langdon-stein ;)
21:33:18 <sgallagh> smooge: Yeah, there's a lot of logo possibility here as well.
21:33:23 * nirik likes Boltron too
21:33:29 <sgallagh> /me keeps waiting for others to disagree...
21:33:36 <dperpeet> I could live with Boltron
21:33:44 <smooge> langdon, I was actually going to base the image off of you
21:33:48 <dperpeet> not everything needs to be well thought-out and sane
21:33:59 <langdon> my only problem with "boltron" is it kind sounds like "bolt on" .. but meh
21:34:10 <sgallagh> langdon: So it's also accurate?
21:34:14 <smooge> well isn't what this is? bolt on
21:34:18 <langdon> sgallagh, lol harsh
21:34:43 <langdon> "bolt on" for me has a negative connotation .. like "not really a part just tagged on the side" .. but maybe that is just me?
21:35:17 <sgallagh> Proposal: Entrusted by the alliance with the ancient secret of how to assemble, Boltron: Defender of Fedora is born.
21:35:27 <langdon> NICE
21:36:56 <smooge> 2
21:36:57 <smooge> +1
21:37:07 <sgallagh> +1 from me as well
21:37:19 <dperpeet> +1
21:37:21 <misc> that's a US specific pop culture reference ?
21:37:30 * langdon doesn't know if he has a vote
21:37:36 <sgallagh> misc: Well, that sentence is.
21:37:45 <sgallagh> misc: https://en.wikiquote.org/wiki/Voltron:_Defender_of_the_Universe
21:38:05 <mjwolf> +1
21:38:20 <nirik> sure, +1. we should avoid getting sued, but otherwise fine.
21:38:31 <mjwolf> though me wonders if there would be an acronym that would work.  I just cant come up with one right now
21:38:32 <sgallagh> nirik: If the lawyers flag it down, we'll address it at that time
21:38:42 <dperpeet> no acronym please
21:38:45 <smooge> langdon, I understand the idea you have but I bolt on is also used in reference to how you attach a water holder on a bike or other tools
21:39:14 <langdon> smooge, ahh ok.. so mostly just me then ;)
21:39:33 <sgallagh> #agreed Entrusted by the alliance with the ancient secret of how to assemble, Boltron: Defender of Fedora is born.
21:39:48 <langdon> ha
21:39:58 <sgallagh> #topic Open Floor
21:39:59 <langdon> i would like to see someone reading the minutes..
21:40:15 <sgallagh> langdon: That's partly why I stuck that in there. To see if anyone ever reads them :)
21:40:50 <langdon> :)
21:41:28 <sgallagh> Next week I will be traveling for DevConf.cz and will not be available to run the meeting.
21:41:37 <sgallagh> Does anyone want to volunteer to do so, or shall we skip?
21:41:37 <mjwolf> same here
21:42:30 <dperpeet> I will be away in two weeks
21:44:17 <sgallagh> nirik, smooge: What does your schedule look like?
21:44:25 * nirik should be around
21:44:33 <nirik> but if everyone else is gone, perhaps we should punt..
21:46:57 <sgallagh> OK, I'm not hearing anyone excited to run it next week
21:47:15 <sgallagh> #info No meeting on 2017-01-24
21:47:41 <sgallagh> I'll aim to run one on the 31st and see who shows up
21:47:44 <smooge> I would be here next week
21:48:16 <smooge> however I believe it would just be me and nirik while the cool kids are partying in Prague
21:48:26 <smooge> boogying in brno
21:48:41 <langdon> a bit of a side bar on boltron ... where should we "publish" that? promote it?
21:48:54 <dperpeet> run it by the designers first?
21:48:55 <smooge> first person would be Mo
21:49:20 <smooge> we need to get a graphic and then we tell the bosses
21:49:34 <langdon> i thought mo was the boss?
21:49:42 <smooge> the Boss
21:49:49 <smooge> versus bosses
21:49:59 <smooge> the capitalization is important
21:50:16 <langdon> gotcha!
21:50:49 <sgallagh> Probably we should take it to the Council first
21:51:15 <langdon> sgallagh, good point..
21:51:29 <langdon> i could file a ticket on behalf of server?
21:51:32 <sgallagh> They may just decide to shatter our hopes and dreams
21:51:35 <sgallagh> langdon: Much appreciated
21:51:37 <langdon> or on behalf of modularity?
21:51:40 <langdon> or both?
21:51:52 <sgallagh> #action langdon To bring up the Boltron name with Fedora Council.
21:52:00 <sgallagh> langdon: Both, I would think
21:52:09 <langdon> ack..
21:53:41 <sgallagh> Anything else here, or shall I close the meeting out?
21:54:20 <sgallagh> Going once
21:54:44 <sgallagh> Going twice
21:55:00 <sgallagh> #endmeeting