#fedora-meeting-1: Rust SIG (2017-02-01)

Meeting started by ignatenkobrain at 21:00:01 UTC (full logs).

Meeting summary

  1. Agenda (ignatenkobrain, 21:00:11)
    1. (1) Roll Call (ignatenkobrain, 21:00:14)
    2. (2) Current State of Packaging (ignatenkobrain, 21:00:18)
    3. (3) Wildcard Versions (ignatenkobrain, 21:00:22)
    4. (4) Normalize versions for RPM (ignatenkobrain, 21:00:25)
    5. (5) Boilerplate in %install (ignatenkobrain, 21:00:29)
    6. (6) Packaging binaries (and libraries together) (ignatenkobrain, 21:00:32)
    7. (7) Optional dependencies which do not exist (ignatenkobrain, 21:00:35)
    8. (8) Open Floor (ignatenkobrain, 21:00:38)

  2. Roll Call (ignatenkobrain, 21:00:41)
  3. Current State of Packaging (ignatenkobrain, 21:02:04)
    1. We have RPM macro for build/install procedures, dependency generator and even generator of spec files! (ignatenkobrain, 21:02:09)
    2. https://pagure.io/fedora-rust/rust2rpm (ignatenkobrain, 21:02:12)
    3. https://crates.io/crates/ripgrep (ignatenkobrain, 21:06:02)
    4. initial target is to package ripgrep and its dependencies (definitely should be build-able in koji which means w/o network as well) (ignatenkobrain, 21:08:04)

  4. Normalize version for RPM (ignatenkobrain, 21:18:10)
    1. https://pagure.io/fedora-rust/rust2rpm/issue/3 (ignatenkobrain, 21:18:39)
    2. ACTION: jistone to implement normalizing pre-release versions for RPM (ignatenkobrain, 21:21:26)

  5. Wildcard Versions (ignatenkobrain, 21:21:36)
    1. https://pagure.io/fedora-rust/rust2rpm/issue/6 (ignatenkobrain, 21:21:41)
    2. https://github.com/rbarrois/python-semanticversion/issues/51 (ignatenkobrain, 21:24:22)
    3. ACTION: ignatenkobrain to implement support for wildcard versions (ignatenkobrain, 21:27:44)

  6. Boilerplate in %install (ignatenkobrain, 21:27:46)
    1. https://pagure.io/fedora-rust/rust2rpm/issue/7 (ignatenkobrain, 21:27:50)
    2. http://lists.rpm.org/pipermail/rpm-ecosystem/2017-January/000448.html (ignatenkobrain, 21:41:18)
    3. http://lists.rpm.org/pipermail/rpm-ecosystem/2017-January/000447.html (ignatenkobrain, 21:41:25)
    4. ACTION: jistone to investigate differences between cargo dependency-resolving in `cargo install foo` and `cargo install .` (at least minimal analysis) (ignatenkobrain, 21:46:02)

  7. Packaging binaries (and libraries together) (ignatenkobrain, 21:46:08)
    1. https://pagure.io/fedora-rust/rust2rpm/issue/11 (ignatenkobrain, 21:46:12)
    2. AGREED: bin + lib naming scheme is Name: foo and subpackage rust-bar-devel (ignatenkobrain, 21:52:07)

  8. Optional dependencies which do not exist (ignatenkobrain, 21:52:21)
    1. https://pagure.io/fedora-rust/rust2rpm/issue/12 (ignatenkobrain, 21:52:26)
    2. AGREED: we will package even winapi stuff (since it would probably make sense for cross-compilation and will not give any problems) (ignatenkobrain, 22:15:13)

  9. Open Floor (ignatenkobrain, 22:15:33)
    1. Rust 1.15 / Cargo 0.16 releases tomorrow (ignatenkobrain, 22:17:10)
    2. ACTION: Pharaoh_Atem to provide presentation slides from his local LUG afterwards (ignatenkobrain, 22:21:00)
    3. ACTION: Akien Pharaoh_Atem to write introduction to SIG, its goals and such (ignatenkobrain, 22:36:23)
    4. ACTION: ignatenkobrain to write about how to get involved (ignatenkobrain, 22:37:02)
    5. ACTION: jistone to write about features in new version of rust/cargo (ignatenkobrain, 22:39:37)
    6. jflory7 approves plan (ignatenkobrain, 22:41:33)


Meeting ended at 22:42:31 UTC (full logs).

Action items

  1. jistone to implement normalizing pre-release versions for RPM
  2. ignatenkobrain to implement support for wildcard versions
  3. jistone to investigate differences between cargo dependency-resolving in `cargo install foo` and `cargo install .` (at least minimal analysis)
  4. Pharaoh_Atem to provide presentation slides from his local LUG afterwards
  5. Akien Pharaoh_Atem to write introduction to SIG, its goals and such
  6. ignatenkobrain to write about how to get involved
  7. jistone to write about features in new version of rust/cargo


Action items, by person

  1. Akien
    1. Akien Pharaoh_Atem to write introduction to SIG, its goals and such
  2. ignatenkobrain
    1. ignatenkobrain to implement support for wildcard versions
    2. ignatenkobrain to write about how to get involved
  3. jistone
    1. jistone to implement normalizing pre-release versions for RPM
    2. jistone to investigate differences between cargo dependency-resolving in `cargo install foo` and `cargo install .` (at least minimal analysis)
    3. jistone to write about features in new version of rust/cargo
  4. Pharaoh_Atem
    1. Pharaoh_Atem to provide presentation slides from his local LUG afterwards
    2. Akien Pharaoh_Atem to write introduction to SIG, its goals and such


People present (lines said)

  1. ignatenkobrain (268)
  2. Pharaoh_Atem (122)
  3. jistone (120)
  4. Akien (31)
  5. jflory7 (26)
  6. zodbot (12)
  7. msehnout (4)
  8. lupinix (2)


Generated by MeetBot 0.1.4.