#fedora-meeting-1: Rust SIG (2017-02-08)

Meeting started by ignatenkobrain at 21:00:34 UTC (full logs).

Meeting summary

  1. Agenda (ignatenkobrain, 21:00:49)
    1. (1) Roll Call (ignatenkobrain, 21:00:54)
    2. (2) Cargo metadata vs [workspace] paths (ignatenkobrain, 21:00:59)
    3. (3) Tool for checking crates (with dependencies) in upstream vs Fedora ones (ignatenkobrain, 21:01:04)
    4. (4) Open Floor (ignatenkobrain, 21:01:09)

  2. Roll Call (ignatenkobrain, 21:01:13)
  3. Cargo metadata vs [workspace] paths (ignatenkobrain, 21:03:17)
    1. libc uses [workspace] which doesn't exist in archive on crates.io (ignatenkobrain, 21:03:22)
    2. https://pagure.io/fedora-rust/rust2rpm/issue/10 (ignatenkobrain, 21:03:27)
    3. https://github.com/rust-lang/cargo/issues/3642 (ignatenkobrain, 21:03:32)
    4. ACTION: jistone to followup on cargo's handling of unpacked *.crate packages (jistone, 21:11:05)
    5. AGREED: just drop [workspace] thing for now in libc crate (ignatenkobrain, 21:12:03)

  4. Tool for checking crates (with dependencies) in upstream vs Fedora ones (ignatenkobrain, 21:12:07)
    1. ACTION: ignatenkobrain to write some simple script to show tree of dependencies and their packaged version in Fedora (ignatenkobrain, 21:24:05)

  5. Open Floor (ignatenkobrain, 21:24:59)
    1. Rust 1.15.1 is tagged, should be announced today, jistone is ready to build it in Fedora (ignatenkobrain, 21:25:47)
    2. https://pagure.io/fedora-rust/rust2rpm/c/c946648932a7aaa4e59154b7a3e5fda06f75cb50?branch=master (ignatenkobrain, 21:36:29)
    3. https://github.com/rust-lang/rust/tree/master/src/vendor (jistone, 21:51:55)


Meeting ended at 22:00:24 UTC (full logs).

Action items

  1. jistone to followup on cargo's handling of unpacked *.crate packages
  2. ignatenkobrain to write some simple script to show tree of dependencies and their packaged version in Fedora


Action items, by person

  1. ignatenkobrain
    1. ignatenkobrain to write some simple script to show tree of dependencies and their packaged version in Fedora
  2. jistone
    1. jistone to followup on cargo's handling of unpacked *.crate packages


People present (lines said)

  1. ignatenkobrain (106)
  2. jistone (49)
  3. Pharaoh_Atem (31)
  4. zodbot (8)
  5. walters (7)
  6. msehnout (4)
  7. dgilmore (4)


Generated by MeetBot 0.1.4.