17:05:08 <dustymabe> #startmeeting atomic-wg
17:05:08 <zodbot> Meeting started Wed Feb 22 17:05:08 2017 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:05:08 <zodbot> The meeting name has been set to 'atomic-wg'
17:05:12 <dustymabe> #topic roll call
17:05:17 <dustymabe> .hellomynameis dustymabe
17:05:17 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:05:20 <marc84> hi everyone
17:05:24 <dustymabe> marc84: hi
17:05:50 <sayan> .hello sayanchowdhury
17:05:51 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:06:13 <dustymabe> hi jberkus
17:06:18 <bowlofeggs> .hello bowlofeggs
17:06:19 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
17:06:22 <jbrooks> .fas jasonbrooks
17:06:22 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:06:28 <sayan> dustymabe: I can volunteer for the meeting if you want
17:06:30 <jberkus> .hello jberkus
17:06:31 <dustymabe> yay we are graced with presences of eggs
17:06:31 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:06:38 <bowlofeggs> so many eggs
17:06:43 <dustymabe> sayan, thanks
17:06:56 <jberkus> sayan: go for it
17:06:57 <dustymabe> sayan: i'll let you pick up when if I "disappear" or have to leave
17:07:09 <sayan> dustymabe: sure
17:07:18 <dustymabe> #chair bowlofeggs sayan jbrooks walters bowlofeggs marc84
17:07:18 <zodbot> Current chairs: bowlofeggs dustymabe jbrooks marc84 sayan walters
17:07:25 <dustymabe> who am I missing?
17:08:26 <dustymabe> ok I'll get started
17:08:33 <dustymabe> #topic action items from last meeting
17:08:57 <dustymabe> * maxamillion to close pagure issue 202 and complete the sync
17:08:58 <dustymabe> * maxamillion to comment and close this ticket as it had already been
17:09:00 <dustymabe> agreed on
17:09:02 <dustymabe> * dustymabe to create a ticket with this discussion in it
17:09:04 <dustymabe> * jberkus to open issues around each proposed dockerfile requirements
17:09:06 <dustymabe> change
17:09:18 <jberkus> feh, didn't get that done, keep it on for next meeting
17:09:31 <dustymabe> #action jberkus to open issues around each proposed dockerfile requirements change
17:09:38 <dustymabe> I opened a ticket for the discussion
17:09:41 <dustymabe> https://pagure.io/atomic-wg/issue/228
17:10:13 <dustymabe> #202 is closed
17:10:20 <dustymabe> so maxy did that
17:10:26 <dustymabe> so we look to be good
17:10:33 <dustymabe> ok items for today
17:10:54 <dustymabe> #topic  decide on version scheme and image naming scheme for f26
17:10:58 <dustymabe> #link https://pagure.io/atomic-wg/issue/229
17:11:11 <dustymabe> would be nice if we could get some more comments in the ticket on this one
17:11:21 <dustymabe> and/or discussion here
17:11:30 <dustymabe> i'll give you all a moment to read
17:12:29 <jberkus> commented
17:12:57 <dustymabe> ok, will give it another minute, if we are good with comments in the ticket and no discussion here then we'll move on
17:14:10 <dustymabe> ok cool, will carry on discussion in the ticket
17:14:12 <dustymabe> thanks
17:14:38 <dustymabe> #topic  clarify policy on atomic host support for older Fedora "number" releases
17:14:43 <dustymabe> #link https://pagure.io/atomic-wg/issue/228
17:14:51 <dustymabe> sigh
17:14:55 <dustymabe> wait a sec
17:15:06 <dustymabe> #topic clarify policy on atomic host support for older Fedora "number" releases
17:15:18 <dustymabe> #link https://pagure.io/atomic-wg/issue/228
17:15:38 <dustymabe> i've got a couple of +1 a couple of -1
17:15:44 <dustymabe> err. one -1
17:16:06 <dustymabe> should we talk more about this here or leave discussion in the ticket?
17:16:20 <dustymabe> if we talk here I'll try to summarize what we decide and put it in the ticket too
17:17:18 <dustymabe> either way I think we need more people to weigh in on the ticket and give their opinion/vote
17:17:42 <sayan> I'll comment on the ticket after the meeting
17:17:48 <dustymabe> sayan: thanks
17:18:10 <dustymabe> anyone else? have anything on this? orrr NEXT?
17:19:24 <dustymabe> i feel like I'm talking to myself a lot today
17:19:31 <sayan> move to next ticket
17:19:47 <rtnpro> .fas rtnpro
17:19:48 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:19:49 <rtnpro> .fas rtnpro
17:19:51 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:19:57 <dustymabe> #topic move ostree ref to be "container-host"
17:20:08 <dustymabe> #link https://pagure.io/atomic-wg/issue/198
17:20:22 <dustymabe> so really this is just an FYI and a last opportunity for anyone to object
17:20:41 <dustymabe> we are moving to something like fedora/rawhide/x86_64/atomic-host for f26
17:20:52 <dustymabe> from fedora-atomic/rawhide/x86_64/docker-host
17:21:20 <dustymabe> I'll be merging that change on thursday night (don't want to do it right before I become unavailable)
17:21:50 <dustymabe> one minute for comments and then I'll move on to the next issue
17:22:24 <jberkus> added comment
17:23:20 <dustymabe> #topic Future of Fedora Dockerfiles
17:23:23 <dustymabe> https://pagure.io/atomic-wg/issue/180
17:23:31 <dustymabe> i'm pretty sure this one can be closed
17:23:48 <dustymabe> #action dusty to close Future of Fedora Dockerfiles #180
17:24:11 <dustymabe> #topic Ship fedora-motd in F24 atomic image
17:24:24 <dustymabe> #link https://pagure.io/atomic-wg/issue/160
17:24:27 <rtnpro> yes, let me update
17:25:06 <rtnpro> I have fixed the 2 blocker issues: 1) don't cache update info from pam module 2) move from cron to system.d timer
17:25:29 <rtnpro> I'd reckon folk in this group to review the code
17:25:56 <rtnpro> once I get up votes for it, I can re package it and push it to the repos
17:26:11 <dustymabe> walters: any comments about fedora-motd and potential issues with adding it ?
17:26:21 <walters> haven't had a chance to look
17:26:24 <dustymabe> i.e. any other stuff that needs to be done (other than proper integration and testing)
17:26:36 <dustymabe> yeah I agree. I really need to look at it myself
17:26:40 <walters> big picture i want to go to automatic updates
17:26:50 <walters> which somewhat (but not entirely) obviates this
17:26:53 <rtnpro> walters, what do you mean?
17:26:58 <dustymabe> walters: agree, but if a user opts out this would be nice
17:27:37 <dustymabe> rtnpro: he means the system automatically updates when there is an update available
17:27:43 <rtnpro> dustymabe, aha!
17:27:52 <dustymabe> now that we only release ostree content every two weeks
17:27:56 <dustymabe> rather than every day
17:27:56 * roshi is here
17:27:59 <dustymabe> this makes much more sense
17:28:02 <roshi> sorry, was distracted :)
17:28:02 <dustymabe> roshi: :)
17:28:08 <dustymabe> #chair roshi
17:28:08 <zodbot> Current chairs: bowlofeggs dustymabe jbrooks marc84 roshi sayan walters
17:28:13 <dustymabe> #chair rtnpro
17:28:14 <zodbot> Current chairs: bowlofeggs dustymabe jbrooks marc84 roshi rtnpro sayan walters
17:28:15 <walters> there's levels of sophistication we can apply, for example download but not apply by default, but *do* automatically apply for critical CVE if not applied after a week
17:28:23 <rtnpro> dustymabe, walters, in the future, we can let motdgen enable/disable plugins on the fly'
17:28:31 <jberkus> how's that going to work given that a reboot is required?
17:28:50 <dustymabe> jberkus: I think he is saying that it would implement a reboot as well
17:29:03 <rtnpro> walters, that will be great, but it's out of scope of motdgen
17:29:10 <dustymabe> users would chhose to be ok with this, or opt out
17:29:12 <jberkus> dustymabe: that sounds like a solution for a tiny minority of users
17:29:12 <rtnpro> jberkus, +1
17:29:21 <jberkus> and we could never have it on by default
17:29:29 <dustymabe> rtnpro: agreed, outside the scope of motdgen
17:29:36 <jberkus> even for IoT devices, automated unscheduled reboots would not be OK
17:29:40 <dustymabe> so we need to take a look at motdgen and get back to you
17:29:52 <rtnpro> dustymabe, cool
17:30:02 <dustymabe> jberkus: let's move this to fedora-cloud or we may open a ticket on it
17:30:07 <jberkus> ok
17:30:09 <dustymabe> and have discussion there
17:30:12 <dustymabe> next topic
17:30:29 <dustymabe> #topic  Spec for IRC bot to notify about blockers
17:30:44 <dustymabe> #link https://pagure.io/atomic-wg/issue/169
17:30:52 <dustymabe> roshi: i'm going to remove the meeting label from this one
17:31:00 <roshi> sounds good
17:31:02 <dustymabe> you said you wanted to look at it, maybe in some downtime
17:31:08 <dustymabe> will update it
17:31:10 <dustymabe> thanks
17:31:18 <dustymabe> #topic design, deploy and document Fedora OpenShift Playground (FOSP)
17:31:19 <roshi> yeah, I thought I took the meeting label off of it :-/
17:31:26 <dustymabe> #link https://pagure.io/atomic-wg/issue/153
17:31:30 <jberkus> wait, I thought we closed that one?
17:31:43 <jberkus> I'm going to close the IRC one
17:31:52 <dustymabe> jberkus: roshi wanted to "look at it"
17:32:07 <dustymabe> so we left it open
17:32:09 <sayan> IRC one is needed?
17:32:09 <jberkus> ok, but let's take the meeting tag off it
17:32:17 <dustymabe> yes, we just agreed to do that
17:32:22 <sayan> we can remove that or close that ticket?
17:32:24 <jberkus> sayan: that would be a "nice to have but extremely low priority"
17:32:44 <jberkus> dustymabe: I have no idea what's going on with the HW for the FOSP
17:32:49 <jberkus> I'll bug misc
17:32:53 <misc> we are still waiting for it
17:32:53 <dustymabe> ok to current topic
17:33:05 <jberkus> misc: how long does it take to order hardware?
17:33:21 <misc> jberkus: too much...
17:33:22 <dustymabe> no wonder this "cloud" thing has taken off
17:33:43 <jberkus> if we haven't spent the money, what about just having a slush fund for AWS/GCE?
17:33:48 <jberkus> seems like the better route
17:34:10 <dustymabe> jberkus: this is probably the wrong place to have that discussion
17:34:13 <misc> jberkus: quaid can give you are more detailed reports on the status regarding the order
17:34:23 <dustymabe> do you mind taking it up with misc individually?
17:35:21 <dustymabe> ok moving to open floor
17:35:25 <dustymabe> #topic open floor
17:35:31 <dustymabe> anyone have any items?
17:35:42 <dustymabe> actually I do -
17:35:49 <dustymabe> we have a few VFADs we want to have
17:35:53 <sayan> yes, I have one
17:36:03 <dustymabe> 1. discussion on fedora atomic and "rolling release" and what all that could look like
17:36:29 <dustymabe> 2. kushal is going to give us a deep dive on gotun and how it works and we'll write a new test for it
17:36:44 <dustymabe> i need to create a page with future VFAD topics
17:36:55 <dustymabe> #action dusty to create atomic-wg page for future VFAD topics
17:36:56 <roshi> why are we getting a deep dive on gotun?
17:37:14 <dustymabe> roshi: would be nice for more of us to understand it
17:37:27 <roshi> tunir/autocloud/gotun will all be going away when we move to taskotron, would make more sense to have the cycles spent there
17:37:43 <roshi> since we're actively trying to move to taskotron
17:37:49 <dustymabe> roshi: if that's the case then why the hell did kushal just do a rewrite of tunir in Go?
17:38:07 <roshi> I have no idea
17:38:09 <sayan> roshi: when are we planning the move?
17:38:12 <jberkus> roshi: what's the status of taskotron, anyway?
17:38:31 <roshi> I've got a task to run the upstream atomic-host-tests in taskotron already
17:38:42 <roshi> working with tflink and company to get it into production
17:38:56 <sayan> roshi: does taskotron handle testing of AMIs?
17:39:21 <roshi> I've ported the tunirtests (except non-gating) to ansible, to run in the same manner
17:39:23 <jberkus> #action jberkus to follow-up with misc and quaid about location of HW
17:39:41 <roshi> it can, we just have to give it the bits to talk to aws
17:39:42 <dustymabe> sigh. in the very least we need more communication around this topic
17:39:54 <dustymabe> so we can VFAD on what the hell we should be doing with regard to tests
17:40:00 <roshi> fwiw, I've been saying this for ages now
17:40:04 <roshi> years even
17:40:07 <dustymabe> moving to next open floor topic
17:40:11 <dustymabe> sayan: you're up
17:40:35 <sayan> dustymabe: should I be talking about the fedimg issue here?
17:40:48 <dustymabe> sayan: sure
17:41:18 <sayan> I saw the BZ issue after returning from PyCon
17:41:26 <dustymabe> no worries
17:41:55 <sayan> libcloud does not support making the snapshot public :(
17:42:12 <sayan> I have submitted a PR today: https://github.com/apache/libcloud/pull/990
17:42:33 <jberkus> dustymabe, roshi do we have an action item for the group around taskotron?
17:42:40 <dustymabe> sayan: that's nice -
17:42:50 <sayan> I don't know how much time will it take to merge
17:42:56 <roshi> jberkus: what do you mean?
17:43:04 <dustymabe> sayan: do we keep running into limitations of "libcloud" when it comes to the full API coverage that we need?
17:43:17 <dustymabe> seems like we keep wanting to do things, but "libcloud doesn't support it"
17:43:23 <sayan> dustymabe: yes, quite often
17:43:24 <jberkus> "we need more communicaiton around this topic" (taskotron/testing)
17:43:31 <jberkus> what does "more communication" translate into
17:43:40 <sayan> I was thinking of re-writing using boto
17:43:44 <dustymabe> jberkus: VFAD would be one
17:43:51 <roshi> jberkus: VFAD would work
17:43:54 <dustymabe> sayan: I think that would be smart
17:43:55 <jberkus> ok
17:44:16 <dustymabe> maybe open a ticket for that
17:44:22 <dustymabe> shit they just called me to the desk
17:44:22 <sayan> dustymabe: in that case for the time being let me fix the issue using boto for now
17:44:25 <dustymabe> i have to go
17:44:33 <sayan> dustymabe: have a safe flight
17:44:35 <dustymabe> can someone please send the meeting minutes out
17:44:37 <dustymabe> thanks
17:44:40 <dustymabe> bye all
17:44:41 <sayan> dustymabe: I will do
17:44:45 <roshi> later dustymabe
17:46:39 <sayan> anything else for the open floor?
17:46:57 <jberkus> where's the list of potential vfads?
17:47:18 <jberkus> we should have one on the wiki somewhere ...
17:47:21 * roshi has nothing for open floor
17:47:34 <roshi> I don't know that we have a good list of them
17:47:46 <jbrooks> dustymabe was saying we needed to create a vfad topic list
17:47:51 <roshi> jberkus: want to set up a spot on the wiki
17:47:55 <roshi> ?
17:48:02 <jberkus> ok
17:48:12 <jberkus> new page, or just add it to /Cloud ?
17:48:19 <jberkus> eh, new page
17:48:21 <jberkus> will do
17:48:23 <sayan> new page +1
17:48:34 <jberkus> #action jberkus to create vfad idea list page
17:49:09 <sayan> #action sayan to create ticket on moving fedimg from libcloud to boto
17:50:06 <sayan> can I go ahead and close the meeting?
17:50:27 <jberkus> yes
17:50:36 <sayan> #endmeeting