#fedora-meeting-1: Rust SIG (2017-02-22)

Meeting started by ignatenkobrain at 21:00:05 UTC (full logs).

Meeting summary

  1. Agenda (ignatenkobrain, 21:00:15)
    1. https://docs.pagure.org/fedora-rust.sig/meetings/2017-02-22.html (ignatenkobrain, 21:00:20)
    2. (1) Roll Call (ignatenkobrain, 21:00:25)
    3. (2) Current status of packaging (ignatenkobrain, 21:00:28)
    4. (3) Open Floor (ignatenkobrain, 21:00:31)

  2. Roll Call (ignatenkobrain, 21:00:36)
  3. Current status of packaging (ignatenkobrain, 21:03:01)
    1. 30+ crates in COPR repo, but there’s blocker – DNF doesn’t support rich builddeps (ignatenkobrain, 21:03:06)
    2. https://pagure.io/fedora-rust/rust2rpm/pull-request/23 (ignatenkobrain, 21:03:10)
    3. http://doc.crates.io/specifying-dependencies.html (jistone, 21:20:01)
    4. We have 3 ways of "solving" issue: 1) Some dirty workaround/solution in DNF 2) Patch crates for latest versions 3) Patch (Build)Requires to have compat-rust-fooXY-devel dep and remove Provides: crate() from such packages (ignatenkobrain, 21:22:16)
    5. ACTION: ignatenkobrain to get back with more info on workaround/solution in DNF (ignatenkobrain, 21:22:49)

  4. Open Floor (ignatenkobrain, 21:34:46)
    1. Many crates now contain license text in crates.io archive (ignatenkobrain, 21:35:11)
    2. https://pagure.io/fedora-rust/rust2rpm/c/d4334a2ee7e30f8a50f425393af188320a94c1d3?branch=master (ignatenkobrain, 21:38:37)
    3. AGREED: remove all useless files (like appveyor.yml or CI scripts) in %prep (ignatenkobrain, 21:50:18)


Meeting ended at 22:02:17 UTC (full logs).

Action items

  1. ignatenkobrain to get back with more info on workaround/solution in DNF


Action items, by person

  1. ignatenkobrain
    1. ignatenkobrain to get back with more info on workaround/solution in DNF


People present (lines said)

  1. ignatenkobrain (141)
  2. jistone (46)
  3. Pharaoh_Atem (43)
  4. ljones (15)
  5. zodbot (10)
  6. f2u (6)
  7. Akien (1)


Generated by MeetBot 0.1.4.