17:00:32 <dustymabe> #startmeeting atomic_wg
17:00:32 <zodbot> Meeting started Wed Mar 15 17:00:32 2017 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:32 <zodbot> The meeting name has been set to 'atomic_wg'
17:01:09 <jbrooks> .fas jasonbrooks
17:01:10 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:02:05 <trishnag> hi
17:02:10 <trishnag> dustymabe: roll call? :)
17:02:16 <bowlofeggs> .hello brodhi
17:02:17 <zodbot> bowlofeggs: Sorry, but you don't exist
17:02:25 <bowlofeggs> i should change my fas account again to brodhi
17:02:31 <bowlofeggs> .hello bowlofeggs
17:02:32 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
17:02:38 <dustymabe> .hellomynameis dustymabe
17:02:39 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:02:43 <jberkus> .hello jberkus
17:02:44 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:02:47 <trishnag> .hello trishnag
17:02:48 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:03:23 <maxamillion> .hello maxamillion
17:03:27 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:03:33 <jdoss> .hello jdoss
17:03:34 <zodbot> jdoss: jdoss 'None' <joe@solidadmin.com>
17:05:04 <yzhang> .hello yzhang
17:05:05 <zodbot> yzhang: yzhang 'Yu Qi Zhang' <jzehrarnyg@gmail.com>
17:05:08 <yzhang> hey it works
17:05:14 <dustymabe> yzhang: \o/
17:05:18 <yzhang> \o/
17:06:03 <dustymabe> #chair jbrooks jberkus bowlofeggs maxamillion yzhang jdoss trishnag
17:06:03 <zodbot> Current chairs: bowlofeggs dustymabe jberkus jbrooks jdoss maxamillion trishnag yzhang
17:06:07 <dustymabe> who did I miss?
17:06:32 <dustymabe> ok
17:06:41 <dustymabe> #topic action items from last meeting
17:06:48 <dustymabe> * maxamillion to follow-up on fixing ami permissions, links with
17:06:49 <dustymabe> dgilmore
17:06:51 <dustymabe> * jberkus to schedule a meeting about support policy, rolling upgrades
17:06:53 <dustymabe> * jberkus to set up github repo for atomichost ASCIIDoc source
17:06:55 <dustymabe> * jberkus, trishnag to kick off documentation re-org project
17:07:24 <jberkus> feh, forgot about the rolling update meeting
17:07:27 <jberkus> too many things
17:07:47 <jberkus> at this point, any meeting after this week, for me, is going to be after April 5th
17:08:30 <dustymabe> jberkus: really?
17:08:39 <trishnag> dustymabe: Asciibinder primary setup done for atomic-host-doc https://github.com/projectatomic/atomic-host-docs/pull/1
17:08:39 <dustymabe> was hoping to have that rolling update meeting next week
17:08:53 <dustymabe> or this week I guess
17:08:53 <trishnag> I and jberkus have been discussing what docs to have and what not.
17:09:04 <jberkus> dustymabe: yeah, OSAS in-person followed by NCECA followed by KubeCon followed by PTO with family
17:09:14 <jberkus> dustymabe: well, better be tommorrow then
17:09:20 <jberkus> I'll try to calendar something
17:09:24 <walters> hm, i had been thinking we merge docs into Fedora - like a "Containers" equivalent of https://docs.fedoraproject.org/en-US/Fedora/25/html/Virtualization_Getting_Started_Guide/index.html
17:09:30 <jlebon> .hello jlebon
17:09:31 <zodbot> jlebon: jlebon 'None' <jlebon@redhat.com>
17:09:41 <walters> and having the installation guide understand Atomic Host
17:09:53 <jberkus> anyway, docs are set up, but that's an agenda item
17:10:02 <trishnag> dustymabe: walters We are using etherpad for the same https://public.etherpad-mozilla.org/p/atomic-host-docs .
17:10:10 <trishnag> #link https://public.etherpad-mozilla.org/p/atomic-host-docs
17:10:10 <roshi> .hello
17:10:10 <zodbot> roshi: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:10:14 <roshi> .hello roshi
17:10:15 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:10:38 <walters> .hello walters
17:10:39 <zodbot> walters: walters 'Colin Walters' <walters@redhat.com>
17:10:47 <dustymabe> jberkus: what do we need to re-action ?
17:10:56 <dustymabe> also maxamillion, any update?
17:11:12 <jberkus> dustymabe: better we need to schedule a meeting.  you, me, jbrooks, walters are critical
17:11:23 <jberkus> I'll try to schedule something in the next 2 days that all of us can be at
17:11:31 <jbrooks> +1
17:11:34 <dustymabe> ok
17:11:51 <dustymabe> #action jberkus to schedule a meeting about support policy, rolling upgrades
17:12:13 <dustymabe> we will come back to maxamillion
17:12:25 <dustymabe> #action maxamillion to follow-up on fixing ami permissions, links with dgilmore
17:12:39 <dustymabe> moving to meeting topics
17:12:44 <roshi> just as an FYI, tomorrow is readiness and go/no-go meetings, so people might be busy
17:13:22 <dustymabe> #topic Label/comment for primary RPM?
17:13:30 <dustymabe> #link https://pagure.io/atomic-wg/issue/254
17:13:48 <dustymabe> i've put my thoughts in the ticket
17:13:53 <maxamillion> dustymabe: sorry, on a call
17:14:11 <maxamillion> dustymabe: I was giving an update on something, come back to me whenever you're ready ... I'm here now
17:14:12 <jberkus> dustymabe, walters, jbrooks: everyone's calendar seems to be clear at ... oh, wait, timezones
17:14:14 <jberkus> re-doing
17:14:29 <dustymabe> maxamillion: would be interested in your htoughts on $topic
17:15:10 <jberkus> dustymabe, walters, jbrooks: calendars were clear at 4pm EDT today, so i scheduled it
17:15:14 <jberkus> lemme invite the rest
17:15:20 <maxamillion> dustymabe: yeah, just a sec
17:15:28 <maxamillion> dustymabe: getting a link
17:15:56 <dustymabe> jberkus: would rather not have that discussion in this meeting
17:15:58 <maxamillion> dustymabe: https://pagure.io/atomic-wg/issue/249
17:16:38 <dustymabe> maxamillion: what about that issue?
17:16:43 <maxamillion> dustymabe: as soon as I find time, I'm going to come up with a way to accomplish that (after digging into some code in OSBS to make sure it would work), then make a proposal.
17:16:52 <maxamillion> dustymabe: it's directly related to the one you asked me about
17:17:37 <dustymabe> maxamillion: right, but I think the question is, how do we tell what the primary rpm is for the container?
17:17:47 <dustymabe> jberkus: can you confirm?
17:17:53 <trishnag> I wonder what primary rpm is.
17:17:53 <maxamillion> dustymabe: we'll need a way to notate that in the Dockerfile
17:18:04 <jberkus> confirm what?
17:18:09 <maxamillion> dustymabe: which is part of the plan, I'm almost positive we talked about this at the VFAD
17:18:27 <dustymabe> maxamillion: right, but this ticket is open and has the Meeting tag
17:18:36 <maxamillion> dustymabe: I'm updating it now
17:19:31 <jberkus> there's a separate issue for primary RPM
17:19:56 <dustymabe> jberkus: you opened issue #254
17:20:01 <dustymabe> which is what we are discussing right now
17:20:16 <dustymabe> that is the current topic
17:20:42 <jberkus> yah
17:20:49 <jberkus> so that's directly related to 249
17:21:02 <jberkus> in either case, we can't count on the name of the package and container being the same
17:21:16 <dustymabe> sure - so we want to have some other identifier
17:21:18 <dustymabe> which is fine
17:21:27 <jberkus> in some cases, the maintainer will want to truncate it; in other cases, extend it
17:21:37 <dustymabe> jberkus: this ticket has the meeting tag, so you lead the discussion on it
17:21:44 <dustymabe> let me know when you have everything you want
17:22:11 <jberkus> ah ok
17:22:36 <jberkus> maxamillion: we talked about doing something at the VFAD, but we didn't add an actual requirement for a label or structured comment
17:22:54 <jberkus> and without that requirement, container submissions won't have it
17:22:57 <maxamillion> I'm adding context to the ticket now
17:23:13 <dustymabe> maxamillion: which ticket specifically? #254?
17:23:25 <maxamillion> dustymabe: yes
17:23:31 <maxamillion> https://pagure.io/atomic-wg/issue/254#comment-431590
17:24:01 <jberkus> aha
17:24:10 <jberkus> so we need one, but we don't know what it should look like yet?
17:24:56 <maxamillion> correct
17:25:17 <dustymabe> maxamillion: you think that you can automatically do that without having a label that identifies the primary rpm?
17:25:50 <jberkus> dustymabe: it's more that there's no point in us drafting a requirement if we can't tell people how to populate it
17:26:00 <dustymabe> maxamillion: or you are saying the macro will define the primary rpm
17:26:02 <jberkus> I think
17:26:10 <maxamillion> dustymabe: it will have to be provided somehow, either as a label or as an argument to the macro
17:26:20 <dustymabe> ok, so summary
17:26:33 <dustymabe> if we need to require a label then we need to draft guidance now
17:26:49 <dustymabe> if we can provide the primary rpm via an arg to the macro, then we don't need to draft guidance
17:27:08 <dustymabe> ^^ is that accurate?
17:28:03 <maxamillion> we'll still need something in the guidelines either way
17:28:12 <roshi> yeah
17:28:22 <dustymabe> right, but what matters is "when" we need to have it in the guidelines
17:28:28 <roshi> somehow the maintainer needs to have a way to let us know what the macro is, right?
17:28:40 <dustymabe> if we know we want to use a label, then we can go ahead and tell people to put the label in their files
17:28:47 <dustymabe> if not, then we can just wait
17:29:20 <maxamillion> we don't know
17:29:24 <maxamillion> I need to look at the code
17:29:34 <dustymabe> ok - so put this on wait then jberkus
17:29:48 <jberkus> yah, that's all we can do for discussion
17:29:54 <dustymabe> k
17:29:58 <dustymabe> moving on
17:30:01 <jbrooks> I think we'll need a label
17:30:07 <jbrooks> I'll comment on the issue
17:30:40 <maxamillion> it might make sense to have a label either way if we want that metadata with the image
17:31:12 <dustymabe> #topic  lower case vs Initial Cap in Labels
17:31:20 <dustymabe> #link https://pagure.io/atomic-wg/issue/253
17:31:28 <dustymabe> jberkus: please lead discussion
17:31:35 <jberkus> yeah, that's a major "do yesterday" quesiton
17:31:56 <jberkus> yzhang pointed out that we've created a 3rd class of capitalization with FLIBS, which I don't think was intentional
17:32:02 <jberkus> and is confusing to users and maintainers
17:32:16 <jberkus> docker/openshift/kubernetes wants lowercase
17:32:21 <jberkus> atomic cli wants uppercase
17:32:27 <jberkus> and we're using proper case
17:32:50 <jberkus> maxamillion thought that we could switch to lower case without breaking koji etc.
17:33:05 <yzhang> I personally think the lowercase makes more sense, and we can adapt the atomic CLI to that
17:33:06 <jberkus> but it would mean a search-and-replace across all existing images
17:33:19 <dustymabe> i've commented in the ticket
17:33:23 <roshi> should atomic CLI care about the case?
17:33:31 <jberkus> roshi: not, sure, I'm going off the docs
17:33:35 <jberkus> haven't had a chance to test
17:33:35 <dustymabe> for atomic CLI labels shouldn't we leave them as uppercase?
17:33:45 <maxamillion> jberkus: yeah, I still need to test ... stage is all messed up
17:33:56 <roshi> then we would need to duplicate labels, aiui
17:34:27 <jberkus> maxamillion: ah, so we don't know yet that we can change the case?
17:34:56 <jberkus> maxamillion: if we can't, how hard would that be to fix, at a guesstimate?
17:35:55 <maxamillion> jberkus: I don't think it would be that hard, the label validation code is pretty clean
17:36:19 <yzhang> I'm not sure why the atomic CLI wants everything as upper case
17:36:22 <jberkus> ok
17:36:30 <yzhang> And by everything I mean RUN INSTALL UNINSTALL HELP
17:36:42 <dustymabe> yzhang: we probably shouldn't care
17:36:48 <dustymabe> RUN == run == Run
17:36:50 <jberkus> yzhang: I thought we verified that "Help" works
17:37:34 <jberkus> so, three action items:
17:37:37 <maxamillion> :/
17:37:55 <jdoss> As a user that lives in the CLI -- anything that that is not lowercase and forces me to do caps of any kind is a bummer for me personally.
17:37:58 <maxamillion> the inconsistency in label "best practices" out in the ether is going to be painful before long
17:38:03 <miabbott> i think the uppercase requirement for 'atomic cli' is just historical.  there was no label guidelines at the outset, so they chose uppercase
17:38:18 <miabbott> strong emphasis on 'i think
17:38:21 <jbrooks> Send PR to atomic cli to address this, if needed
17:38:22 <jberkus> #action maxamillion to verify if we can change case in koji etc., or fix it if we can't
17:38:24 <jbrooks> I say
17:38:27 <yzhang> jberkus: "Help" doesn't work
17:38:33 <yzhang> It has to be "HELP"
17:38:52 <jberkus> but wait ...
17:39:02 <yzhang> let me double check
17:39:09 <jberkus> are we all up for the global search-and-replace if we can get all the tools to behave?
17:39:38 <jberkus> btw, according to the rest of the industry, our labels should all be org.fedoraproject.xxx
17:39:48 <jberkus> but I'm not even going to go there
17:40:09 <dustymabe> fudge
17:40:19 <dustymabe> was hoping that labels were case insensitive
17:40:28 <dustymabe> [root@vanilla-f25atomic ~]# atomic info img
17:40:30 <dustymabe> Image Name: img
17:40:32 <dustymabe> Foo: baz
17:40:34 <dustymabe> foo: bar
17:40:44 <jberkus> dustymabe: no, they're not
17:40:52 <dustymabe> that sucks
17:41:01 <yzhang> its literally a hard coded check for 'INSTALL'
17:41:02 <yzhang> for example
17:41:21 <jberkus> so, I'm less concerned about Atomic CLI
17:41:28 <dustymabe> jberkus: so how about this. can we not just require that all labels but the atomic CLI labels be lowercase?
17:41:34 <dustymabe> that's what I thought we were doing
17:41:37 <jberkus> because we can fix it, and we can fix it in a backwards-compatible way
17:41:51 <jberkus> dustymabe: yes, that was what I was trying to get to
17:41:54 <yzhang> Actually you're right jberkus, "Help" works, my bad
17:42:17 <yzhang> please continue
17:42:17 <jberkus> so, any objections to the idea that we're going to lower-case everything?
17:42:25 <yzhang> None here
17:42:35 <jberkus> maxamillion: 2nd question ... could we backwards-compatible this?  how painful would that be?
17:42:39 <dustymabe> that's fine with me, but we'll have to fix atomic CLI right?
17:42:52 <dustymabe> to accept INSTALL or install
17:42:55 <miabbott> +1 for lower-case and having 'atomic cli' fixed to support that
17:42:56 <jberkus> dustymabe: yes, but the atomic CLI fix could be done on a more relaxed schedule
17:43:08 <jberkus> again, it's less important
17:43:16 <dustymabe> jberkus: unless you want someone to be able to use it now
17:43:21 <jberkus> right now I'm worried about name/bzcomponent/etc
17:43:55 <jberkus> the build fields
17:43:56 <dustymabe> also we need buy in from atomic CLI team
17:44:12 <jberkus> dustymabe: can we please drop atomic CLI from this discussion for now?
17:44:23 <dustymabe> jberkus: ok please put forth a proposal and we can agree to it
17:44:51 <jberkus> I propose that we make all fedora build labels ... all the onese FLIBS requires ... all-lowercase
17:45:08 <jberkus> including, if necessary, a search-and-replace on existing images
17:45:21 <dustymabe> jberkus: and atomic CLI vars - we give no guidance
17:45:29 <maxamillion> jberkus: there's already a lot of weird backwards compat logic in there
17:45:31 <dustymabe> what about other labels that aren't for FLIBS?
17:45:35 <maxamillion> jberkus: should be fine to add more if we must
17:45:42 <jberkus> maxamillion: ah, ok
17:45:58 <maxamillion> jberkus: OSBS has been around for a long time, used to be a project called "dock" ... there's plenty of backwards compat weirdness already in there
17:46:01 <maxamillion> :)
17:46:07 <jberkus> ok
17:46:32 <jberkus> maxamillion: as long as we're messing around in that code, would adding support for org.fedoraproject.label make sense?
17:46:59 <jberkus> or should we put that off?
17:47:42 <jberkus> meh, let's put it off, I shoudl verify that there aren't *other* standards
17:48:12 <jberkus> so, query to WG:  if maxamillion can make the build backwards-compatible, do we want to do search-and-replace?
17:49:01 <dustymabe> jberkus: would have to make some sort of announcement
17:49:06 <jberkus> anyone?
17:49:17 <dustymabe> i guess if we can make the changes without breaking things
17:49:24 <dustymabe> and with an appropriate commit message
17:49:28 <dustymabe> then i would be ok with it
17:50:00 <yzhang> Isn't it better then to have individual maintainers do so, so they're aware of the changes?
17:50:02 <roshi> jberkus: I'm a lazy +1 to that, as I'm not sure how much work that is for maxamillion and what the returns would be
17:50:03 <jbrooks> I'm fine w/ it
17:50:11 <yzhang> I'm fine either way
17:50:45 <dustymabe> jberkus: can you summarize this discussion in the ticket
17:50:56 <jberkus> sure
17:50:59 <dustymabe> please include policy on FLIBS labels, ATOMIC CLI labels, and "other labels"
17:51:06 <maxamillion> jberkus: we can do that, but I don't want to just have a mess of labels that we change all the time ... can we hammer this down before I go throwing code into the mix? at some point it's going to get unweildy
17:51:37 <dustymabe> we ar erunning out of time
17:51:43 <dustymabe> #topic  Container Guidelines: Layered Images used as a base for other Layered Builds
17:51:48 <jberkus> maxamillion: for right now: lowercase labels for what we have now, with backwards copat to Proper Case
17:51:50 <dustymabe> #link https://pagure.io/atomic-wg/issue/248
17:53:01 <dustymabe> anyone with any information on this one ?
17:53:05 <dustymabe> hhorak opened the issue
17:53:17 <maxamillion> jberkus: rgr
17:53:17 <jbrooks> hmm, this page isn't loading for me
17:53:34 <jberkus> me either
17:53:36 <trishnag> jbrooks: same here.
17:53:37 <jberkus> pagure down?
17:53:41 <maxamillion> jberkus: looks like it
17:53:59 <dustymabe> basically there is a new section that hhorak proposed to be added to the guidelines
17:54:50 <dustymabe> i guess we'll skip this for now since no one can load the page
17:55:07 <dustymabe> #topic clarify policy on atomic host support for older Fedora "number" releases
17:55:13 <dustymabe> #link https://pagure.io/atomic-wg/issue/228
17:55:35 <dustymabe> we are going to talk about this - along with "rolling releases" in the meeting that jberkus has scheduled
17:55:53 <dustymabe> jberkus: in the very least can you send the meeting details to the cloud/atomic lists
17:56:12 * dustymabe would prefer that we gave more notice than "today"
17:56:22 <dustymabe> so that people from the community could take part
17:56:25 <dustymabe> if they wanted to
17:56:26 <jberkus> yah
17:56:48 <roshi> when it's back up we should file an issue against pagure to update the admin email
17:56:49 <jberkus> dustymabe: well, the other possibility is that you can schedule something for next week when I'll be gone
17:57:00 <dustymabe> jberkus: what about friday?
17:57:19 <maxamillion> if this is something I need to be at, note that I'm on PTO this friday
17:57:49 <dustymabe> jberkus: there is no way you could make something on Monday?
17:58:16 <jberkus> aha, theres one timeslot open
17:58:18 <jberkus> on friday
17:58:21 <jberkus> dustymabe: nope
17:58:24 <jberkus> all-day meeting
17:58:33 <dustymabe> jberkus: what timeslot is that?
17:58:38 <jberkus> 10am PDT
17:58:57 <jberkus> btw, we still have Documentation on the agenda today
17:59:30 <dustymabe> #topic documentation
17:59:33 <dustymabe> jberkus: go
17:59:57 <jberkus> so trishnag and I set up an ASCIIBinder repo for the Atomic Host documentation
17:59:57 * dustymabe joins another meeting
18:00:17 <jberkus> https://github.com/projectatomic/atomic-host-docs
18:00:36 <jberkus> this is where the new Fedora (and CentOS) Atomic Host Docs will live
18:01:00 <jberkus> we could use contributors to help merge existing content into the new docs structure
18:01:30 <dustymabe> jberkus: indeed
18:01:39 <trishnag> I am going to write contributing guide for the Doc, that would help new contributors join in.
18:02:24 <maxamillion> jberkus++ trishnag++
18:02:24 <zodbot> maxamillion: Karma for trishnag changed to 6 (for the f25 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:02:25 <jberkus> trishnag: we should also create a series of issues for each content item
18:02:28 <dustymabe> sigh.. I don't even think I have time to "review docs" much less create them
18:02:34 <trishnag> jberkus: +1
18:02:35 <dustymabe> :(
18:02:44 <jberkus> dustymabe: docs are a good place for new contribs
18:02:44 <trishnag> jberkus: in my todo list :)
18:02:57 <jberkus> heck, we have non-RH folk contributing docs already
18:03:06 <dustymabe> jberkus: thats good!
18:03:44 * jbrooks sees pagure is back
18:05:31 <maxamillion> I'll try to see what I can come up with as contributions to the docs
18:06:34 <trishnag> maxamillion: we currently have the agenda https://public.etherpad-mozilla.org/p/atomic-host-docs . Please review :).
18:06:47 <dustymabe> trishnag: please finish the meeting
18:06:50 <dustymabe> i'm out
18:06:54 <trishnag> ok
18:07:03 <trishnag> #endmeeting