#fedora-meeting-1: Rust SIG (2017-03-15)

Meeting started by ignatenkobrain at 21:00:01 UTC (full logs).

Meeting summary

  1. Agenda (ignatenkobrain, 21:00:15)
    1. https://docs.pagure.org/fedora-rust.sig/meetings/2017-03-15.html (ignatenkobrain, 21:00:19)
    2. (1) Roll Call (ignatenkobrain, 21:00:22)
    3. (2) Packaging Guidelines (ignatenkobrain, 21:00:25)
    4. (3) State of affairs and future plans (ignatenkobrain, 21:00:28)
    5. (4) Open Floor (ignatenkobrain, 21:00:30)

  2. Roll Call (ignatenkobrain, 21:00:33)
  3. Packaging Guidelines (ignatenkobrain, 21:01:31)
    1. https://pagure.io/fedora-rust/sig/pull-request/9 (ignatenkobrain, 21:01:36)
    2. ACTION: ignatenkobrain to make BuildRequires as sub-section and add example (ignatenkobrain, 21:08:25)

  4. State of affairs and future plans (ignatenkobrain, 21:10:43)
    1. ripgrep has been updated to 0.5.0 🕺 (ignatenkobrain, 21:11:08)
    2. "Target RPM" feature has been tested on COPR dev instance, a bit more work is needed to get in prod (ignatenkobrain, 21:11:14)
    3. libdnf and dnf-plugins-core patches were merged upstream (ignatenkobrain, 21:11:20)
    4. https://github.com/rpm-software-management/rpm/pull/164/commits/45777d2ebf98ff2d3831c33fbfbfe900b1c2dc92 (ignatenkobrain, 21:14:30)
    5. we need to start working on integration into distros (ignatenkobrain, 21:19:56)
    6. ACTION: jistone to file issue about "legacy" mode with examples (ignatenkobrain, 21:37:23)
    7. ACTION: ignatenkobrain to package remaining cargo deps and try re-bootstrap using system libraries (ignatenkobrain, 21:51:33)
    8. https://github.com/mmstick/systemd-manager (Pharaoh_Atem, 21:55:05)

  5. Open Floor (ignatenkobrain, 21:57:39)
    1. rust 1.16 comes out tomorrow (jistone, 21:58:22)


Meeting ended at 22:00:12 UTC (full logs).

Action items

  1. ignatenkobrain to make BuildRequires as sub-section and add example
  2. jistone to file issue about "legacy" mode with examples
  3. ignatenkobrain to package remaining cargo deps and try re-bootstrap using system libraries


Action items, by person

  1. ignatenkobrain
    1. ignatenkobrain to make BuildRequires as sub-section and add example
    2. ignatenkobrain to package remaining cargo deps and try re-bootstrap using system libraries
  2. jistone
    1. jistone to file issue about "legacy" mode with examples


People present (lines said)

  1. ignatenkobrain (123)
  2. jistone (66)
  3. Pharaoh_Atem (46)
  4. luke_nukem (12)
  5. zodbot (11)
  6. mich181189 (11)
  7. Akien (3)


Generated by MeetBot 0.1.4.