14:03:02 <tflink> #startmeeting fedora-qadevel
14:03:02 <zodbot> Meeting started Mon Apr 24 14:03:02 2017 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:02 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:03:02 <tflink> #meetingname fedora-qadevel
14:03:02 <zodbot> The meeting name has been set to 'fedora-qadevel'
14:03:02 <tflink> #topic roll call
14:03:08 <tflink> Let's try this again
14:03:52 * garretraziel is here
14:04:01 * mkrizek is here
14:04:05 * lbrabec is here
14:05:10 <tflink> let's get this party started
14:05:16 <tflink> #topic Announcements and Information
14:05:22 <tflink> #info i386 repo issues should be fixed now (related to i386 being an alternate arch since F26) -- kparal
14:05:22 <tflink> #link https://phab.qa.fedoraproject.org/T876
14:05:22 <tflink> #info task-modularity-testing-framework should be now working fine on dev -- kparal, tflink, mkrizek, puiterwijk
14:06:19 <tflink> has anyone followed up with the modularity folks to make sure everything is working on their end?
14:06:24 * roshi is here
14:07:20 <mkrizek> kparal has been following up with them
14:08:07 <tflink> ok, he added that to the meeting page so I assume that things are working well enough on that end
14:08:52 <tflink> any other questions/comments?
14:08:58 <mkrizek> none here
14:09:24 <tflink> ok, moving on
14:09:32 <tflink> #topic Test Invocation
14:10:35 <tflink> #link https://fedoraproject.org/wiki/Changes/InvokingTestsAnsible
14:10:40 <mkrizek> I started cleaning up the libtaskotron codebase for that today
14:10:42 <tflink> #link https://phab.qa.fedoraproject.org/T939
14:10:49 <tflink> cool
14:11:05 * tflink is looking forward to getting this done, it'll allow us to get rid of some bits that really need to go away :)
14:11:11 <tflink> not that it'll be a trivial transition
14:11:31 <tflink> but no more imagefactory, no more nested runner are all good things
14:11:47 <mkrizek> what images are we going to use?
14:11:54 <tflink> the ones produced by releng
14:11:59 <mkrizek> cool
14:12:49 <tflink> I really don't want to be building images and since we won't need libtaskotron on the images anymore, I think we can use the releng produced images now that all production releases should be getting new cloud base images nightly
14:13:05 <tflink> mkrizek: which part? or just in general?
14:14:04 <roshi> so we'd just boot guests on a bare metal host and ssh into those?
14:14:16 <roshi> is that how we'd be getting rid of nested virt?
14:14:28 <tflink> we'd still have nested virt
14:14:48 <mkrizek> in general, looks like a lot of code will go away
14:14:51 <tflink> but we'd be getting rid of the "libtaskotron spins up a vm and calls libtaskotron in that vm" part
14:15:05 <roshi> ah
14:15:17 <tflink> mkrizek: are you looking at getting rid of the minion code, then?
14:15:32 <tflink> instead, we'd be calling ansible which would connect to that VM via ssh
14:15:42 <mkrizek> yep
14:16:01 <mkrizek> tflink: regarding that ^^^, I found this in the proposal "MUST execute the playbook locally with ansible_connection=local and host localhost"
14:16:21 <tflink> huh, I missed that part
14:16:23 <mkrizek> and there is "hosts: localhost" in the task examples
14:16:48 <mkrizek> which is... strange requirement for "the testing system"
14:16:57 <tflink> it's not a testing system, though
14:17:16 <tflink> it's just a standard way to invoke tests with as little nailed down as we can get away with
14:17:56 * tflink is not sure why that's in there as a requirement
14:18:19 <tflink> an important use-case, I understand. required, not so much
14:19:34 <mkrizek> yeah, with that requirement we wouldn't get rid of the "libtaskotron spins up a vm and calls libtaskotron in that vm" part
14:19:56 <tflink> :(
14:20:02 <tflink> that part needs to DIAF
14:20:32 <tflink> at the very least, move forward with the proposal to separate the executor from the minions
14:21:16 <mkrizek> or we can hack inventory and do "[localhost] $ip_of_vm" :P
14:21:36 <tflink> it seems silly to me to require an inventory file in that case
14:21:57 * tflink will follow up on that part
14:21:59 <mkrizek> doesn't ansible-playbook need a inventory file?
14:22:13 <mkrizek> thanks
14:22:15 <tflink> yeah, but if it's always localhost, why not generate it?
14:23:03 <tflink> #action tflink to follow up with ci folks on why localhost-only is a requirement for ansible-based tests
14:23:43 <tflink> we need to have this ready by the end of may
14:24:04 <tflink> I don't think it needs to be perfect by then but at least working
14:24:27 <tflink> I also think that for the sake of our sanity, we should make this a hard switch and deprecate the task formulas at the same time
14:24:50 <tflink> I'm only aware of a few people other than us who have written tasks
14:24:52 <roshi> makes sense
14:25:03 <mkrizek> +1
14:25:12 <roshi> +1
14:25:22 <tflink> and the translation should be relatively easy
14:26:13 * tflink realizes that he just used a bad word
14:26:31 <roshi> wash your mouth out with soap
14:26:39 <tflink> soap is worse
14:26:46 <roshi> and then rinse with bleach to make sure you got it all :p
14:27:07 <tflink> https://en.wikipedia.org/wiki/SOAP
14:27:11 * roshi almost typed soup, which doesn't really serve as a cleaner (depending on where you get it)
14:27:17 <tflink> is bleach enough to kill soap?
14:27:42 <roshi> in the wild, I think soap will always roam free somewhere
14:27:47 <tflink> are there any questions, concerns or comments on all of this?
14:28:00 <roshi> who's going to do what?
14:28:25 <tflink> roshi: you're signed up to do it all
14:28:31 <tflink> on top of what you're already doing
14:28:36 <tflink> and I expect it by the end of the week
14:28:45 <tflink> in reality ...
14:28:56 <roshi> lol
14:28:59 <tflink> I suspect that I'll continue porting the directives to work with ansible
14:28:59 * roshi shrugs
14:29:18 <tflink> it sounds like mkrizek has started working on the other libtaskotron tweaks
14:29:45 <tflink> we still need to rework our documentation, port the existing tasks and test everything
14:30:03 <roshi> that's it?
14:30:05 <roshi> :p
14:30:07 * roshi ducks
14:30:15 * tflink hears a volunteer
14:30:22 <tflink> for ALL THE THINGS!
14:32:04 <tflink> I also want to add a new entry point either in addition to or to replace runtask
14:32:18 <tflink> but that's a ticket already and I think that's been discussed
14:32:52 <tflink> any corrections or other concerns?
14:33:18 <roshi> is 'tron' taken as a binary name?
14:33:25 <tflink> no idea
14:35:31 <mkrizek> deploying it all will be fun as well :)
14:36:06 <tflink> yeah
14:36:18 <tflink> roshi: any idea how close you are to the docker-from-git stuff?
14:36:42 <tflink> I know the answer: docker! lots of docker!
14:36:52 <tflink> that'll solve all the problems :)
14:36:54 <roshi> still sussing out all the details
14:37:15 <tflink> so no idea how close you are?
14:37:19 <roshi> since what's in taskotron-docker doesn't match prod, I'm trying to understand all the bits
14:37:27 <roshi> I hope by the end of the week
14:38:03 <tflink> to make sure I've been clear: what's in taskotron-docker isn't what I'm looking for
14:38:12 <roshi> right
14:38:15 <mkrizek> is docker-from-git stuff for taskotron self-testing?
14:38:23 <roshi> and local runs
14:38:25 <tflink> basically, yeah
14:38:42 <tflink> well, will be used for self-testing but also for local dev environments
14:38:50 <mkrizek> are we going to get rid of taskotron-ansible-local then?
14:38:54 * mkrizek hopes so
14:39:00 <tflink> not sure, it would make sense
14:39:11 * tflink hadn't gotten that far, though
14:39:13 <mkrizek> I don't think it works anymore
14:39:26 <tflink> probably doesn't, it's been a while since it was updated
14:40:15 <tflink> anything else on this?
14:40:32 <mkrizek> nothing here
14:41:17 <tflink> ok, moving on, then
14:41:36 <tflink> #topic ResultsDB performance/usage
14:42:07 <tflink> it occurs to me that this was supposed to get started last week but some jerk forgot about the plans ...
14:42:11 * tflink glares at tflink
14:42:36 <tflink> mkrizek: any thoughts on when a decent time to do it this week will be?
14:43:16 <mkrizek> tflink: does tomorrow work for you?
14:43:43 <tflink> depends on what time - I have meetings from 6-10 tomorrow
14:44:19 <tflink> so, afternoon my time will work well enough
14:44:40 <tflink> but that starts getting a bit late for you
14:45:33 <mkrizek> let's sort it out after the meeting
14:45:52 <tflink> sounds like a good plan
14:46:10 <tflink> anything else on this topic?
14:47:45 * tflink assumes not
14:47:49 <tflink> which brings us to:
14:47:52 <tflink> #topic Open Floor
14:48:03 <tflink> any other topics that folks want to bring up?
14:49:34 * roshi has nothing
14:51:12 * tflink sets the fuse
14:51:41 <tflink> thanks for coming, everyone
14:51:45 * tflink will send out minutes shortly
14:51:49 <tflink> #endmeeting