20:02:45 <sgallagh> #startmeeting Server SIG Weekly Meeting (2017-05-16)
20:02:45 <zodbot> Meeting started Tue May 16 20:02:45 2017 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:02:45 <zodbot> The meeting name has been set to 'server_sig_weekly_meeting_(2017-05-16)'
20:02:53 <sgallagh> #meetingname serversig
20:02:53 <zodbot> The meeting name has been set to 'serversig'
20:03:04 <sgallagh> #chair sgallagh nirik
20:03:04 <zodbot> Current chairs: nirik sgallagh
20:03:12 <sgallagh> #topic Init Process
20:03:59 <jds2001> .hello jstanley
20:03:59 <zodbot> jds2001: jstanley 'Jon Stanley' <jonstanley@gmail.com>
20:04:04 <dperpeet> .hello dperpeet
20:04:05 <zodbot> dperpeet: dperpeet 'None' <dperpeet@redhat.com>
20:04:18 <nirik> morning
20:04:22 <nirik> .hello kevin
20:04:24 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
20:04:27 <sgallagh> #chair jds2001 dperpeet
20:04:27 <zodbot> Current chairs: dperpeet jds2001 nirik sgallagh
20:04:29 <mjwolf> .hello mjwolf
20:04:31 <zodbot> mjwolf: mjwolf 'Michael Wolf' <mjwolf@us.ibm.com>
20:04:34 <sgallagh> #chair mjwolf
20:04:34 <zodbot> Current chairs: dperpeet jds2001 mjwolf nirik sgallagh
20:04:37 <jds2001> morning? It's quitting time after this! :D
20:04:44 <sgallagh> jds2001: If only...
20:04:59 <nirik> server working group: we make you quit. ;)
20:05:01 <sgallagh> pbrobinson: Are you around?
20:05:49 <sgallagh> I'm going to try to make this meeting short today, because I have a hard stop in 25 minutes due to other obligations.
20:06:07 <sgallagh> #topic WiFI hardware support in Fedora Server, Revisited
20:06:33 <sgallagh> I was talking with pbrobinson this morning and he pointed out that Server is the base platform used by most of the armv7hl disk images that Fedora builds.
20:06:58 * nirik nods
20:07:08 <sgallagh> It turns out that some (many?) of them are boards with WiFI for networking.
20:07:14 <nirik> I think it might be reasonable to include firmware and such for wireless.
20:07:31 <sgallagh> nirik: Well, we actually already ship that firmware, I think.
20:07:40 <sgallagh> It's bundled in with the rest of the firmware
20:07:42 <mhayden> .hello mhayden
20:07:43 <zodbot> mhayden: mhayden 'Major Hayden' <major@mhtx.net>
20:07:47 <nirik> ok. whats missing then?
20:07:55 <sgallagh> But we don't ship the userspace bits like NetworkManager-wifi
20:08:02 <nirik> ah.
20:08:04 <sgallagh> #chair mhayden smooge
20:08:04 <zodbot> Current chairs: dperpeet jds2001 mhayden mjwolf nirik sgallagh smooge
20:08:18 <nirik> yeah, those should be easy to include... do we include the vpn ones?
20:08:35 <jds2001> none of that pulls in gnome UI bits, right?
20:08:49 <sgallagh> jds2001: No, NetworkManager divested itself from those deps a long time ago
20:08:49 <jds2001> or any other weird deps?
20:09:10 <jds2001> NetworkManager++ :D
20:09:12 <sgallagh> According to pbrobinson this morning, it adds about 250kiB worth of stuff.
20:09:13 <nirik> the vpn ones pull in their vpn, but otherwise I think it's all fine
20:09:28 <nirik> the wifi one is pretty self contained.
20:09:46 <nirik> requires wpa_supplicant.
20:10:10 <mhayden> 250kiB isn't terrible
20:10:19 <mhayden> even for a small device running off a SD card ;)
20:10:52 <jds2001> well, hopefully our SD card has that much space left :D
20:11:06 <jds2001> if not, then 1KiB is a real problem :D
20:11:08 <sgallagh> heh
20:11:22 <sgallagh> The DVD already includes these, they're just not part of the default install
20:11:24 <mhayden> 250kiB should be enough for everyone
20:11:30 * mhayden utters the famous last words
20:11:37 <sgallagh> And (today) the images contain only the default package sets.
20:11:52 <sgallagh> The alternative approach is changing the kickstarts for the specific models that are affected.
20:11:59 * jds2001 is fine with adding to the default since there's a real use case.
20:12:02 <sgallagh> Which is more maintenance effort, but more targeted.
20:12:48 * jds2001 assumes that the firmware is already included in the default for other things.
20:12:52 <jds2001> broadcom nics, etc.
20:13:48 <sgallagh> Actually, I'm looking at comps and I'm not sure the earlier assessment about firmware was correct.
20:13:59 <sgallagh> I think we'd need to shuffle comps around a bit for this.
20:14:12 <jds2001> so we're not really bloating for the firmware that includes firmware for every esoteric piece of hardware out there.
20:14:52 <jds2001> been awhile since i was involved at this low a level, but i thought bnx2x for example required firmware.
20:14:57 <sgallagh> OK, I just double-checked.
20:15:11 <jds2001> which is common in enterprise-y servers.
20:15:20 <sgallagh> At some point in the past, we split the @hardware-support comps group into @server-hardware-support and @hardware-support
20:15:33 <sgallagh> We ship the former by default and make the latter available on the DVD
20:15:50 <sgallagh> So we may want to amend that
20:15:53 <jds2001> ahh, and @server-hardware-support doesnt include wifi?
20:16:42 <sgallagh> Correct
20:16:58 <sgallagh> Actually, I take even *that* back
20:17:06 <sgallagh> (Sorry, comps is hard to parse)
20:17:44 <sgallagh> Looks like @server-hardware-support is not enabled by default either... and is only special hardware components for things like Dell firmware
20:18:25 <sgallagh> So I think we only carry whatever @standard and @base provide
20:21:04 * mhayden must depart for a company meeting, unfortunately ;/
20:21:41 <sgallagh> OK, I'm going to stop chasing the details and just ask the question:
20:21:42 * nirik is fine with adding wireless support, whatever is needed there, unless it's very large
20:21:53 <sgallagh> do we want to ship this by default or go for the targeted approach?
20:22:44 <nirik> targeted would be... only arm images? or ?
20:22:58 <sgallagh> nirik: Individually add it to kickstarts where appropriate
20:23:10 <nirik> ah. I'd prefer default.
20:23:32 <sgallagh> Anyone in opposition?
20:24:08 <sgallagh> jds2001: Yeah, it does and we'd have to figure out which ones to pull in.
20:24:22 <sgallagh> If we go this route, I'll work with pbrobinson to figure out which ones are applicable and which are not
20:24:34 <sgallagh> I'd prefer not to bring in the whole world here
20:24:34 <jds2001> makes sense to me.
20:25:21 <sgallagh> OK, then if no one who's here is dissenting:
20:25:39 <sgallagh> #agreed We will ship WiFI support for common hardware in the default package set.
20:25:40 <dperpeet> no objection
20:25:57 <mjwolf> no objection
20:26:00 <sgallagh> nirik: Would you mind opening a ticket at https://pagure.io/fedora-server/issues on this?
20:26:13 <sgallagh> I need to run off to my other appointment.
20:26:17 <sgallagh> I'll look into it tomorrow
20:26:26 <nirik> sure
20:26:52 <sgallagh> Thank you
20:26:59 <sgallagh> #action nirik to file a ticket to track that effort
20:27:17 <sgallagh> OK and with that, I need to run.
20:27:20 <sgallagh> Thanks for coming, folks.
20:27:25 <dperpeet> thanks!
20:27:26 <sgallagh> #endmeeting