16:00:22 <geppetto> #startmeeting fpc
16:00:22 <zodbot> Meeting started Thu Jun  1 16:00:22 2017 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:22 <zodbot> The meeting name has been set to 'fpc'
16:00:22 <geppetto> #meetingname fpc
16:00:22 <zodbot> The meeting name has been set to 'fpc'
16:00:22 <geppetto> #topic Roll Call
16:00:28 <tibbs> Howdy.
16:00:29 * limburgher here
16:00:31 <mbooth> Hi
16:00:36 <geppetto> #chair tibbs
16:00:36 <zodbot> Current chairs: geppetto tibbs
16:00:39 <geppetto> #chair limburgher
16:00:39 <zodbot> Current chairs: geppetto limburgher tibbs
16:00:44 <geppetto> #chair mbooth
16:00:44 <zodbot> Current chairs: geppetto limburgher mbooth tibbs
16:00:48 <geppetto> Hey
16:04:23 <geppetto> #chair racor
16:04:23 <zodbot> Current chairs: geppetto limburgher mbooth racor tibbs
16:04:37 <geppetto> Hey racor
16:04:44 <racor> hi
16:05:07 <geppetto> Give orionp a minute or so then we'll start anyway
16:06:33 <geppetto> ok
16:06:37 <geppetto> #topic Schedule
16:06:40 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/TT6KQ3IRSEJACK4VI6KDX3GPXLUXR4IH/
16:06:48 <geppetto> #topic #686 Avoid using names with `python-` prefix in requires
16:06:52 <geppetto> .fpc 686
16:06:53 <zodbot> geppetto: Issue #686: Avoid using names with `python-` prefix in requires for Python packages - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/686
16:09:55 <tibbs> My +1 is in the ticket.
16:10:03 <geppetto> Seems fine to me, although I thought /usr/bin/python would always be python2?
16:10:24 <limburgher> Me likely.
16:10:26 <limburgher> +1
16:10:31 <geppetto> +1
16:10:39 <limburgher> Me likey.  I already exist, I am VERY likely.
16:10:41 <tibbs> Fedora will change when upstream python requests that distros change, I think.
16:11:12 <tibbs> But basically nothing in Fedora should ever assume anything about what /usr/bin/python, or a "python-foo" package, will get you.
16:11:26 <limburgher> Smart.
16:11:40 * geppetto sighs
16:11:40 <tibbs> Which for the guidelines basically means that nothing in Fedora should ever depend on python-* or ever reference /usr/bin/python.
16:12:28 <tibbs> Mishandling this whole transition is the worst thing Python upstream could possibly have one, but that's life.
16:12:49 <tibbs> It's been nine years now and it's still a mess.
16:12:55 <limburgher> We seem to be adapting well, though.
16:13:02 * limburgher toots collective horn
16:13:20 <mbooth> +1 then
16:13:33 <geppetto> racor: vote?
16:13:39 <racor> +1
16:14:06 <geppetto> #action Avoid using names with `python-` prefix in requires for Python packages (+1:5, 0:0, -1:0)
16:14:08 <tibbs> Anyway, this is just a little piece of the puzzle.  Stop using dependencies on python-X when python2-X is available.
16:14:24 <geppetto> #topic #687 Repository config/COPr policy conflicts with FESCo policy
16:14:26 <tibbs> Another one on my queue to write up.
16:14:34 <geppetto> .fpc 687
16:14:36 <zodbot> geppetto: Issue #687: Repository config guideline conflicts with FESCo-approved policy regarding COPR repos - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/687
16:15:05 <tibbs> So while trying to answer a question on the packaging list I ran into this small mess.
16:15:22 <tibbs> Basically we have guidelines saying that packages can't configure repositories that aren't "official".
16:15:41 <geppetto> Pretty sure that was written before copr
16:15:50 <tibbs> Because a long time ago someone pushed a package into Fedora which set up his personal repository.
16:16:10 <tibbs> And, yeah, it predates a lot of things.
16:16:58 <tibbs> I think I would prefer to just replace https://fedoraproject.org/wiki/Packaging:Guidelines#Configuration_of_Package_Managers with something like:
16:17:30 <mbooth> I think it would be sensible to have this section delegate to the Fesco policy page
16:17:37 <tibbs> "Packages may not install configuration files for package managers which violate the Third Party Repository Policy" and link to https://fedoraproject.org/wiki/Third_Party_Repository_Policy
16:18:07 <mbooth> Quite
16:18:19 <geppetto> +1
16:18:38 <limburgher> +1
16:19:01 <tibbs> Only real problem with that is that it should still be OK to ship such configuration files as documentation.
16:20:06 <tibbs> I'd say "Packages may not install (except as documentation)...." except that then someone may think they can pyut afile in /etc/yum.repos.d and mark it as %doc.
16:20:18 <limburgher> Eeew!
16:20:26 <geppetto> tibbs: lol
16:20:45 <tibbs> "Packages may not install (except as documentation stored below %{_docdir}) ...."
16:20:56 <mbooth> Is there anything to say you can't ship examples as documentation? Probably there are hundreds of packages that ship code and config examples in their documentation...
16:21:27 <limburgher> I hope not.  Some of my packages do that.
16:21:49 <tibbs> You can generally ship whatever you like as documentation as long as it doesn't introduce dependencies.
16:22:11 <mbooth> So I don't there's any explicit need to mention it here, it's business as usual
16:22:15 <limburgher> Like, iso files?
16:22:18 * limburgher ducks
16:22:21 <tibbs> Unless of course it violates legal restrictions or our restrictions on types of content.
16:22:51 <racor> like coprs which introduce package conflicts`and incompatibilities?
16:23:05 <mbooth> Yes, well, legality of RPM content is discussed elsewhere
16:23:11 <tibbs> racor: Well, the policy page says you can ship those in a default disabled state.
16:23:26 <racor> that said, i do not agree with FESCO's decision
16:23:29 <tibbs> Our guidelines say you can't ship them at all.  Thus, the conflict and this ticket.
16:23:47 <tibbs> I don't agree with it either, but it's not our decision.
16:24:06 <racor> tibbs: Irrelevant. These coprs may blow up everything when they are enabled
16:24:08 <limburgher> Yeah, we're How, not What.
16:24:14 <tibbs> I didn't even know it happened.  In fact, I don't think it was FESCo that did this.
16:24:43 <tibbs> I think it came directly from the Council, and then FESCo implemented their policy page and nobody thought to tell us to implement it in the guidelines.
16:24:56 <racor> libburgher: my answer to "how" - Impossible to do. This task is inresolvable
16:25:17 <tibbs> The task at hand is trivial to resolve.  That's what my proposal does.
16:25:27 <racor> tibbs: Council? ... no comment
16:25:39 <tibbs> The general task of "don't install something which will screw up people's machines" isn't ours to solve.
16:27:11 <racor> tibbs; No. It's our job to tell people how to package. In this case this is not possible
16:27:38 <tibbs> It is our job to tell people how to package repository configuration files, yes.
16:28:04 <tibbs> Since a higher power has basically decided to dictate that, we can refer to them.
16:28:59 <limburgher> Were the conflict truly unresolvable, we'd have to kill the crew and complete the mission ourselves.  Fortunately we have tibbs.
16:29:12 <geppetto> racor: I'm not sure what you want to do … leave conflicting wrong information in our wiki?
16:29:20 <tibbs> Updated https://pagure.io/packaging-committee/issue/687 with a proposal, since it's not likely we can get a result today.
16:29:39 <geppetto> racor: Do you have another proposal?
16:30:05 <tibbs> We could also just remove the section entirely, I guess, but it doesn't seem fair to packagers to not simply point them at the policy.
16:30:59 <geppetto> Yeh, not sure what we'd gain by not linking to the FESCo policy
16:31:10 <geppetto> And anyone searching for info would lose a lot
16:31:13 <racor> geppetto: I want us to do nothing.
16:31:18 <tibbs> If we really want to be explicit, we'd have to start getting really complicated because "package managers" can now include dnf and graphical things and anything that can get flatpacks and whatever that other bundled application thing is, plus anything else.
16:31:21 <tibbs> Doing nothing is not an option.
16:31:31 <racor> I do not see any sense in packaging coprs in Fedora
16:31:33 <tibbs> Our guidelines are simply wrong.
16:31:55 <geppetto> racor: Again, nothing means keeping info. on our wiki that is wrong
16:31:58 <tibbs> The task isn't for you to see sense in it.  It's to resolve the conflict between our guidelines and policy.
16:32:04 <limburgher> Right, but that's above our pay grade.
16:32:20 <racor> geppetto: Can we agree to disagree.
16:32:26 <limburgher> It's like SCLs.  Not a personal fan, but I see the wisdom in doing it well.
16:32:47 <tibbs> FPC as a whole can't simply agree to disagree with FESCo.
16:32:57 <racor> If people want to set up coprs their can do so
16:32:58 <tibbs> (and the Council).
16:33:18 <geppetto> racor: Not really … why do you want to lie to people? What does anyone gain from people saying "Oh, you can't trust the FPC wiki information"??
16:33:50 <racor> geppetto: Explain to me why Fedora should ship COPR configs.
16:34:02 <tibbs> That's not a fair question.
16:34:03 <geppetto> racor: If you want to speak to FESCo about why shipping copr repos. is bad … that's fine, I have no problem with that.
16:34:14 <tibbs> You can't ask him to defend a decision someone else made.
16:34:26 <geppetto> But reality is that people can do so now, and our information says they can't … which is a lie.
16:34:32 <racor> they are personal repos, so users will have to pick these repos configs from these repos.
16:34:56 <tibbs> Yes, that's an excellent argument to make to someone else.
16:35:05 <tibbs> Take it up with FESCo if you disagree.
16:35:20 <racor> geppetto: No. We are talking about Fedora not about some arbitrary groups private repos,
16:35:35 <tibbs> I would if I cared enough, but I'm OK with shipping these things disabled.  Which is what the policy required.
16:35:48 <racor> geppetto: That why I asked you to explain. To me this all is rubbish
16:36:10 <geppetto> racor: again, I'm not saying this is good or bad … it's just reality that fesco let you ship them disabled
16:36:11 <limburgher> Perhaps, but not our rubbish.
16:36:34 <tibbs> One thing I don't want to do is explicitly state in our guidelines that this kind of thing is OK.
16:36:41 <geppetto> racor: If you want to change fesco … that's fine. But atm. we need to deal with the fact that what we say on the wiki is false
16:36:45 <tibbs> See, that's my productive protest.
16:36:56 <racor> geppetto: Is the reason the Council's onions?
16:37:14 <tibbs> racor: Just read the ticket: https://pagure.io/fesco/issue/1421
16:37:48 <racor> geppetto: No, the group worrying me is the Council -
16:38:05 <tibbs> I mean, it's 2+ years old.  The time for throwing a fit over it has kind of passed, but feel free to bring it up again.
16:38:49 <tibbs> Just bring it up.... somewhere besides this meeting, where we can't do anything about it.
16:39:13 <mbooth> fwiw, if we're finished griping about something we can't change today, I'm +1 for the simple proposal tibbs added to the ticket
16:39:23 <tibbs> Yes, I'm +1 to that as well.
16:39:28 <racor> -1
16:39:41 * geppetto sighs
16:39:52 <racor> this proposal is not helpful
16:39:56 <limburgher> +1
16:39:59 <geppetto> #action Repository config/COPR policy conflicts with FESCo policy (+1:4, 0:0, -1:1)
16:40:18 <limburgher> racor: It's ok to put on a plaster while driving to the hospital.
16:40:46 <geppetto> It's even better not to lie to the EMT while they are driving you to the hospital
16:40:47 <tibbs> Also, really, racor, you seem to be unclear on what this committee can actually do.
16:41:23 <racor> I hope having been explicit enough and keep my face shut now,
16:41:30 <tibbs> "Override FESCo decisions" isn't one of the things we're tasked with doing.
16:41:54 <geppetto> racor: you haven't been explicit at all on what you think we can do, apart from lying to fedora packagers
16:42:44 <racor> geppetto: Is this meant do be an offense?
16:42:58 <tibbs> No, it's meant to get you to actually make a constructive proposal.
16:43:35 <geppetto> racor: Again, the state we are in now is lying to fedora packagers
16:43:49 <geppetto> racor: You are voting down the proposal to stop lying to them
16:43:52 <limburgher> We are a subcommittee of FESCO.
16:44:03 <limburgher> We are subordinate by design.
16:44:05 <geppetto> racor: What do you want to do instead? … just keep lying?
16:46:02 * geppetto sighs
16:46:04 <geppetto> #topic #688 Council banned weak fwd deps to third party repos
16:46:04 <racor> limburgher: But we are not supposed to FESCO monkeys.
16:46:08 <geppetto> .fpc 688
16:46:22 <racor> geppetto: Ban COPRs
16:46:48 <geppetto> racor: Again, that's not an option … we can't overrule FESCO
16:47:15 <tibbs> Basically, our guidelines are unclear on whether you can have a weak dep on something that's in an external repository.
16:47:15 <geppetto> racor: If you want that, you need to bring it up a change with FESCo
16:47:16 <zodbot> geppetto: Issue #688: The Council banned weak forward dependencies to third party repositories - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/688
16:47:17 <racor> geppetto: But we can tell them they are wrong
16:47:55 <limburgher> racor: We can, but in the interim we need to fix what we have the authority to fix.
16:47:56 <racor> geppetto: We can reject deciding and redelegate to FESCO
16:47:58 <tibbs> racor: So if you want FPC as a whole to tell them they are wrong, then please.  Spend five minutes writing a proposal.
16:48:01 <tibbs> We can vote on it.
16:48:24 <racor> tibbs: I can't do now.
16:48:45 <tibbs> Let's finish the agenda.
16:48:59 <geppetto> racor: You certainly can … as a group it would be hard, you'd need a proposal and then get a vote on it … and "reject deciding and delegate to FESCo is the proposal you voted no on"
16:49:15 <racor> tibbs: ... and I will not be able to do so for the next 2 weeks (I'll be missing next 2 meetings)
16:50:10 <geppetto> tibbs: I assume this is mostly a legal thing?
16:50:11 <racor> ... holidays in Germany
16:50:25 <geppetto> tibbs: Where we basically have to reject them?
16:51:38 <geppetto> I think most of them would be useless anyway … Eg. weak dep. from firefox to rando plugin would mean the repo. rando. plugin is in would need to be abled when you first installed firefox
16:51:54 <geppetto> enabled, too
16:52:09 <tibbs> geppetto: I don't think it's a legal thing, really.
16:52:12 <limburgher> Not Cained, for sure.
16:52:30 <tibbs> Basically, what if you had a weak dep on "flash-plugin".  What would that mean?
16:52:36 <limburgher> tibbs: I think the legal thing is valid. $_DEITY knows what's in someone's repo.
16:52:41 <geppetto> tibbs: Ok, I thought it would come under the same stuff as linking directly to external repos. from the wiki etc.
16:53:07 <limburgher> I guess they want it more explicitly.  Not a problem.
16:53:19 <geppetto> tibbs: As I said, that would only work if the repo. flash is in was enabled before you installed firefox
16:53:20 <racor> tibbs: A forward dep to a COPR?
16:53:29 <tibbs> Well, it's not mentioning any specific repo.  Just a package.  Nothing wrong with that in theory, and the package itself could be completely legal in any jurisdiction.  Just not in Fedora.
16:53:34 <geppetto> tibbs: So, basically useless
16:53:37 <tibbs> Well, it would just not be in Fedora.
16:53:54 <tibbs> And yeah, it would be useless unless you had something else set up, and would probably be confusing in the extreme.
16:54:20 <tibbs> It's just that we have this weird paragraph down at the end of https://fedoraproject.org/wiki/Packaging:WeakDependencies
16:54:30 <tibbs> "Reverse dependencies are mainly designed for 3rd party vendors who can attach their plug-ins/add-ons/extensions to distribution or other 3rd party packages. Within Fedora the control over which packages a package requires should stay with the package maintainer. There are, however, cases when it is easier for the requiring package not needing to care about all add-ons. In this cases reverse dependencies may be used with the agreement of the package
16:54:31 <geppetto> So, anyway, I'm happy to +1 banning weak deps. on packages not in fedora
16:54:32 <tibbs> maintainer of the targeted package."
16:55:03 <limburgher> +1 as well.
16:55:14 <racor> +1
16:55:18 <limburgher> To a draft-to-be-written.
16:55:22 <tibbs> That "There are, however, cases..." bit makes it sound like it's OK for Fedora packages to suggest things in rpmfusion or whatever, and the council said "no" to that.
16:56:38 <tibbs> So, I would propose removing that "There are, however" sentence entirely, and then adding to the "Weak Dependencies" section that weak deps must include only packages which exist in the official Fedora repositories".
16:56:42 <limburgher> So I think if we just whack that sentence, we're good.
16:56:47 <limburgher> Same.
16:56:50 <limburgher> Yes.
16:56:56 <geppetto> tibbs: I thought that was saying the other thing … meaning you should use fwd weak deps. within fedora, and reverse deps. for 3rd party repos. … but there are cases you want to use reverse deps. within fedora
16:57:23 <tibbs> geppetto: Maybe that's what it meant, but it's not really what it says.
16:57:52 <geppetto> Ok, that's how I still read it … but I'm happy to  +1 any change you want to make it easier
16:57:53 <tibbs> If you're looking for an answer to the simple question "Can I have Suggests: flash-plugin", well, it seems like maybe.
16:58:19 <geppetto> Yeh, no problem being more explicit and adding a "you can't weak dep. on things not in fedora"
16:58:21 <tibbs> And anyway, we do need to state it clearly somewhere.
16:58:51 <racor> How about: All package deps must be resolvable within Fedora?
16:58:53 <tibbs> flash-plugin isn't a great example anyway, since if you actually have that repo configured you're certain to actually have the package installed.
16:59:04 <tibbs> racor: Yes, that's basically the same thing.
16:59:29 <tibbs> We might even state that elsewhere, but in a section that was certainly written before weak deps existed.
16:59:40 <geppetto> resolvable is bad because dnf will "resolve" if they are missing
16:59:49 <geppetto> reachable, maybe
16:59:55 <geppetto> ¯\_(ツ)_/¯
17:00:01 <limburgher> installable?
17:00:04 <geppetto> sure
17:00:11 <limburgher> thesaurizable?
17:00:14 <tibbs> Though reading https://fedoraproject.org/wiki/Packaging:Guidelines#Package_dependencies doesn't say anything about it.
17:00:29 <geppetto> limburgher: At this point I'm at least 50/50 on +1 that
17:00:32 <tibbs> That section is very old and written in the old conversational style.
17:00:47 <limburgher> geppetto: Vocabulence FTW
17:01:05 <geppetto> words; we have the best words
17:01:20 <limburgher> Remember when you had to put gcc in BuildRequires?  Pepperidge Farm remembers.
17:02:21 <tibbs> I think I would just like to rewrite the "Package dependencies" section of the main guidelines to be a bit clearer.
17:02:30 * limburgher nods
17:02:39 <tibbs> limburgher: You mean, "remember when you didn't have to put gcc in BuildRequires"....
17:02:42 <tibbs> It's mandatory now.
17:03:01 <limburgher> tibbs: MATLOCK!!!!!
17:03:14 <geppetto> Can we vote on just adding racor's one line change: "All package deps, even weak ones, must be installable from within Fedora"
17:03:20 <limburgher> +1
17:03:20 <geppetto> Then vote on a re-write?
17:03:24 <racor> +1
17:03:34 <tibbs> +1
17:03:36 <geppetto> +1
17:03:44 <geppetto> mbooth: It's all on you now
17:03:46 <tibbs> I can add that to the "Package dependencies" section.
17:03:52 <mbooth> The pressure!
17:03:54 <mbooth> +1
17:04:00 <geppetto> 👍
17:04:08 <geppetto> Ok
17:04:24 <geppetto> tibbs: Did you want to propose a re-write today, or wait until next week?
17:04:53 <limburgher> doon doon doon do do doon doon SNAP
17:05:06 <tibbs> Not now, certainly.
17:05:09 * geppetto nods
17:05:14 <geppetto> #topic Open Floor
17:05:31 <geppetto> Ok, anyone have anything to talk about?
17:06:14 <tibbs> Typing....
17:06:29 <tibbs> Would anyone support something like the following:
17:07:18 <tibbs> "FPC believes that allowing disabled COPR repositories to be installed by Fedora packages is not a particularly good idea"
17:07:38 <racor> tibbs: I would
17:07:41 <tibbs> I think that is relatively close to racor's position.
17:08:19 <tibbs> I would +1 it, but would probably want something more than a bare majority before actually sending it on to FESCo.
17:08:25 <limburgher> Installed in /etc/yum.repos.d or at all?
17:08:33 <limburgher> even in doc?
17:08:38 <geppetto> I think it will depend a lot on the copr repo. … I can imagine repos. where it's fine, and I can certainly imagine ones where it'd be a disaster
17:09:04 <tibbs> limburgher: Maybe "configured" instead of "installed"?
17:09:11 <racor> tibbs, I appreciate you want to continue the discussion, unfortunately I'll have to leave any moment.
17:09:24 <tibbs> OK, well, that was my attempt at making progress on the issue.
17:09:33 <geppetto> I guess I don't mind adding that, if we can actually pass the change for 687
17:09:34 <limburgher> tibbs: p'raps.
17:09:41 <racor> geppetto: That's why I asked you why COPRs should be in Fedora
17:09:48 <tibbs> geppetto: I wouldn't add it to the guidelines.
17:09:57 <geppetto> tibbs: where would you add it then?
17:10:06 <tibbs> I would simply send it to FESCo.
17:10:27 <limburgher> Like, with an Edible Arrangement?  Or in a ticket?
17:10:33 <racor> I really can't imagine any reason, except for "testing" or a means to implement the "onion rings"
17:10:42 <tibbs> Well a ticket would be the official way.
17:10:49 * limburgher nods
17:10:51 <geppetto> limburgher: lols
17:11:13 <tibbs> I'm just seeing if there would be support for FPC "officially" telling FESCo something.
17:11:17 <geppetto> I think change request by edible arrangement is for sure the way forward
17:11:59 <tibbs> For the guidelines, I guess we could conceivably add a "Please be careful" note but, really, it would be better if the guidelines just told you want was OK and what wasn't.
17:12:03 <geppetto> It seems pointless and annoying without someone going to a fesco meeting and speaking with people
17:12:18 <racor> anyway, I'll have to leave now. As mentioned before, I'll likely not be available for meetings for the next 2 weeks.
17:12:29 <geppetto> If racor wants to do that I'm mostly happy to say I have reservations about shipping random coprs
17:12:45 <tibbs> Well, besides seeing them at Flock, of course I would be available for their meetings.  I'm always online anyway.
17:12:54 <geppetto> But if we are just opening a ticket to shout into the internet, meh.
17:13:22 <tibbs> Of course, what we should really object to is the fact that nobody bothered to mention this to us so that I just noticed it two+ years later.  But that was certainly just an oversight.
17:13:26 <limburgher> geppetto: Does anyone on FESCO have any food allergies?
17:13:46 <geppetto> limburgher: only one way to find out
17:13:58 <tibbs> Am I a bad person if I say I can't even remember who is on FESCo at this point?
17:14:10 <limburgher> tibbs: I just know I haven't been in years.
17:14:21 <geppetto> I know a couple of them, but lol at naming the entire group
17:14:22 <limburgher> Which is fine.
17:15:15 <mbooth> Why remember info you can look up?
17:15:17 <tibbs> Yeah, I did that once.  Since I'm not down with all of the "new direction" stuff with modules and containers and whatever, I will almost certainly not try to serve again.
17:16:02 <tibbs> Anyway, I'm alone here in the office today so I should probably do some work.  And I have some writeups to do....
17:16:09 * geppetto nods
17:16:19 <geppetto> racor gone so we don't have quorum anyway
17:16:30 <geppetto> So I'll close in a minute unless anyone shouts
17:16:31 <limburgher> tibbs: That's what YOU think. . .
17:18:16 <geppetto> #endmeeting