15:00:06 <bowlofeggs> #startmeeting Bodhi stakeholders (2017-06-19)
15:00:06 <zodbot> Meeting started Tue Jun 20 15:00:06 2017 UTC.  The chair is bowlofeggs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:06 <zodbot> The meeting name has been set to 'bodhi_stakeholders_(2017-06-19)'
15:00:07 <bowlofeggs> #meetingname bodhi_stakeholders
15:00:07 <zodbot> The meeting name has been set to 'bodhi_stakeholders'
15:00:09 <bowlofeggs> #topic salutations
15:00:10 <bowlofeggs> #chair acarter bowlofeggs dgilmore masta mboddu nirik pbrobinson puiterwijk trishnag Kellin
15:00:10 <zodbot> Current chairs: Kellin acarter bowlofeggs dgilmore masta mboddu nirik pbrobinson puiterwijk trishnag
15:01:40 * jcline holds his bodhi stake
15:01:58 <bowlofeggs> hold it high!
15:02:04 <bowlofeggs> the stakes are high!
15:02:16 * mboddu is kinda here
15:04:04 <nirik> morning
15:05:12 <bowlofeggs> so maybe just the four of us
15:05:21 <bowlofeggs> ok, let's dive it head first without looking
15:05:39 <bowlofeggs> #topic announcements and information
15:05:40 <bowlofeggs> #info Bodhi 2.7.0 was deployed to production on Thursday and it seems like smooth sailing so far
15:05:41 <bowlofeggs> #info A Bodhi 2.8.0 beta is deployed to stg: https://bodhi.stg.fedoraproject.org/
15:05:43 <bowlofeggs> #info Release notes available at https://bodhi.stg.fedoraproject.org/docs/release_notes.html
15:05:44 <bowlofeggs> #info 2.8.0 is the "largest" update so far in bowlofeggs' Bodhi tenure
15:05:54 <bowlofeggs> srsly, take a look at those release notes
15:06:01 <bowlofeggs> there's a lot going on there
15:06:07 <bowlofeggs> that was done in ~4 weeks
15:06:08 <jcline> whoa
15:06:25 <nirik> dev dev dev. ;)
15:06:27 <bowlofeggs> (i usually make a release about every 4 weeks, usually around teh time of this meeting which is also every 4 weeks)
15:06:57 <bowlofeggs> we even got a patch from mattdm
15:07:18 <bowlofeggs> any thoughts on that?
15:07:31 <bowlofeggs> "tjhat
15:07:37 <nirik> nice. :)
15:07:41 <bowlofeggs> " being the announcements, not matt's patch ☺
15:08:07 <jcline> It'll be an exciting release
15:08:24 <bowlofeggs> haha yeah that's one way to say it
15:08:38 <bowlofeggs> i will say that i would suggest expecting 2.8.0 to be bumpier than usual
15:08:44 <nirik> so is 2.8.0 going to go to prod before final freeze? or after?
15:08:53 <bowlofeggs> only because there were some pretty large patches in there that change bodhi in pretty big ways
15:09:17 <bowlofeggs> nirik: the plan is before, early next week. i'm amenable to not doing that if you don't want it
15:09:41 <bowlofeggs> oh, looks like freeze is next week
15:09:43 <bowlofeggs> i didn't realize that
15:09:45 <bowlofeggs> on tuesday
15:09:53 <nirik> ok, well, freeze is tuesday. Might be good if you could land it later this week to allow a few days of shake out?
15:10:00 <bowlofeggs> would a deployment of 2.8.0 on monday be a Bad Idea™?
15:10:21 <bowlofeggs> i can do it any time
15:10:32 <bowlofeggs> i usually like to give betas ~1 week in stg in case people want to test it
15:10:39 <bowlofeggs> but honestly, i rarely get feedback based on beta
15:10:42 <bowlofeggs> i mean, stage
15:11:02 <nirik> yeah. It seems to me it would be nice to have a few days of pushes where we can fix things without freeze bothering us...
15:11:05 <jcline> Today _is_ Tuesday, which is a good release day.
15:11:05 <bowlofeggs> so, i could deploy it today, tomorrow, or thursday. monday seems ill advised (?). or we could just wait until after freeze
15:11:06 <nirik> but we can work with whatever.
15:11:36 <nirik> today is a good day to die!^Wrelease software!
15:11:49 <bowlofeggs> i'm fine with any time. since i expect 2.8.0 to be rough, let's not do monday (or friday obvs)
15:11:58 <bowlofeggs> nirik: i suppose we do have that outage today
15:12:03 <nirik> so, today we are doing update/reboots... yeah...
15:12:13 <nirik> so Ive asked for no pushes until we finish that.
15:12:15 <bowlofeggs> and jcline sounds like a +1
15:12:25 <nirik> so today might be good later after the updates/reboots...
15:12:47 <bowlofeggs> i might have a few PRs taht need review first
15:12:54 <bowlofeggs> there are patches in the beta that are currently open PRs
15:12:58 <jcline> I can help with that
15:13:10 <bowlofeggs> jcline: fantastic - i'll send you a list after this meeting
15:13:13 <nirik> yeah, 2.8.1 might be good.
15:13:16 <bowlofeggs> hahah
15:13:32 <bowlofeggs> well it'll still be 2.8.0 - these patches were in the rpm as %patch
15:13:34 <bowlofeggs> 's
15:14:02 <bowlofeggs> so they were tested in the beta (and they were necessary to get it working, so they're not features or anything like that)
15:14:12 <bowlofeggs> they just haven't been reviewed and merged upstream yet
15:14:52 <nirik> ok
15:14:59 <bowlofeggs> i make betas in kind of a weird way - i just pick a commit and hack the spec file to do a scratch build off that commit, and then i patch whatever is inevitably broken until it seems good. then i make a branch off that commit named x.y and cherry pick the patches
15:15:08 <bowlofeggs> once they're all there, i tag it for a release and open champagne
15:15:21 <bowlofeggs> ok agreed
15:15:29 <bowlofeggs> #action jcline will review 2.8.0 PRs today
15:15:31 <nirik> we have champagne? niiiice
15:15:40 <bowlofeggs> #action bowlofeggs will make a 2.8.0 release today and deploy during the infra outage
15:15:46 <bowlofeggs> nirik: yeah, e-champagne
15:15:51 <kushal> bowlofeggs, :)
15:16:29 <bowlofeggs> looks like the outage starts in ~5.75 hours, so that'll work for me
15:16:36 <bowlofeggs> ok, i have more topics
15:16:43 <bowlofeggs> the next one is really anotehr announcement in disguise
15:16:58 <bowlofeggs> (btw, there is a gobby for this called bodhi-stakeholder…)
15:17:10 <bowlofeggs> #topic multi-type support in Bodhi
15:17:11 <bowlofeggs> #info There is a milestone tracking adding multi-type support to Bodhi: https://github.com/fedora-infra/bodhi/milestone/4
15:17:13 <bowlofeggs> #info Bodhi is now ready for multiple types with 2.8.0. It still can't mash modules, but the code is type-flexible now.
15:17:25 <bowlofeggs> so basically bodhi's code is flexible enough to handle non-rpms now
15:17:35 <bowlofeggs> and adding new types is much easier than adding modules was
15:17:53 <bowlofeggs> because the bulk of that work was making bodhi not assume that everything was rpms
15:18:14 <bowlofeggs> i think the next target will probably be containers, which might actualyl also include flatpaks
15:18:39 <bowlofeggs> i've been talking with the flatpak devs and they think there's a chance that flatpaks might be able to be shoved into our container registry
15:18:46 <bowlofeggs> there's some uncertainty around that
15:18:56 <jcline> I can hardly contain my excitement
15:18:57 <bowlofeggs> but if it turns out to work that'll be nice for us because it's less work ☺
15:19:00 <bowlofeggs> hahaha
15:19:01 <bowlofeggs> oh my
15:19:17 <bowlofeggs> if that doesn't work out, i'm sure we can deal with it anyway
15:19:20 <bowlofeggs> but i hope it does
15:19:46 <bowlofeggs> anyways, i am planning container support for the f28 deadline, but i *might* be able to get it in for f27 depending on how things go this summer
15:19:48 <nirik> cool
15:20:04 <nirik> modules had a sooner deadline?
15:20:06 <bowlofeggs> i just don't want to commit to that yet
15:20:19 <bowlofeggs> nirik: yeah, supposedly f27 will be entirely modular
15:20:36 <bowlofeggs> nirik: as in, no more "old school" rpm installs, afaiui
15:21:03 <bowlofeggs> as for modules, we are currently blocked and waiting on pungi to be able to "mash" module updates
15:21:11 <nirik> ok
15:21:17 <bowlofeggs> it can actually make module repos as-is, but it needs a few more features to know how to do update repos
15:21:36 <bowlofeggs> and we plan to have bodhi call pungi to "mash" (i don't nkow a better word than mash, but it won't use mash)
15:21:46 <nirik> compose/
15:21:46 <nirik> ?
15:22:03 <bowlofeggs> mcurlej is working on pungi to add support for that, perhaps even as we type ☺
15:22:07 <bowlofeggs> nirik: works for me
15:22:38 <bowlofeggs> once pungi can do that, we just need some code in bodhi's masher.py to build a pungi config for module updates and call it
15:22:50 <bowlofeggs> so probably not too bad on teh bodhi side. i have no idea how much work is needed on the pungi side
15:23:07 <bowlofeggs> i'm thrilled that bodhi doesn't have to do it itself though ☺
15:23:49 <bowlofeggs> any other thoughts on this topic?
15:23:50 <nirik> so after f27 bodhi won't have rpm updates? just modules of rpms? well, I guess thats all in the air
15:24:07 <kushal> That is good news.
15:24:11 <bowlofeggs> nirik: you know, i really don't know or understand how rpms fit into this
15:24:19 <kushal> bowlofeggs, We will have to take out total masher.py anyway
15:24:20 <bowlofeggs> it sort of seems like modules are still made out of rpms?
15:24:32 <nirik> yes, they are.
15:24:38 <bowlofeggs> kushal: yeah eventually we want to use pungi for everything
15:24:50 <bowlofeggs> kushal: for now, he's just going to use it for modules
15:25:06 <kushal> bowlofeggs, Okay.
15:25:08 <bowlofeggs> so i guess rpms are in the picture somewhere
15:25:19 <kushal> bowlofeggs, Okay
15:25:19 <bowlofeggs> i really don't know how they will play into bodhi
15:25:25 <bowlofeggs> it's possible nobody knows
15:25:34 <bowlofeggs> or, nobodhi, as the case may be
15:25:40 <bowlofeggs> that was for jcline's benefit
15:26:06 <kushal> :)
15:26:28 <jcline> That was good
15:26:41 <bowlofeggs>15:26:43 <kushal> bowlofeggs, Also I would love to start adding type annotations to bodhi, please have a look at my RFC to the infra list today.
15:27:22 <bowlofeggs> kushal: i'm on board - that requires python 3 to actually be enforced, right?
15:27:33 <kushal> bowlofeggs, Nope, we can do in Python2 also
15:27:33 <bowlofeggs> kushal: bodhi will be python 3 one day
15:27:41 * bowlofeggs sings somewhere over the rainbow
15:27:44 <kushal> and will also help to move to Python3 without breaking things.
15:27:46 <bowlofeggs> oh cool, i didn't know that
15:28:12 <bowlofeggs> i've been working to pep-257 bodhi a bit here and there
15:28:20 <bowlofeggs> and when i do that i've been documenting argument types
15:28:29 <bowlofeggs> so that will help
15:28:35 <bowlofeggs> ok, next topic
15:28:44 <bowlofeggs> #topic Bodhi Outreachy intern
15:28:50 <kushal> Going offline to the shops before they get closed.
15:28:54 <bowlofeggs> Bodhi has an outreachy intern, Caleigh!
15:29:02 <bowlofeggs> she's actually off for the day and not here
15:29:23 <bowlofeggs> but if you see her on IRC (caleigh) say hi!
15:29:34 <bowlofeggs> c u kushal!
15:29:55 <bowlofeggs> ok, last topic:
15:29:57 <bowlofeggs> #topic Looking forward
15:29:59 <bowlofeggs> #info Bodhi's high priority issue list https://github.com/fedora-infra/bodhi/issues?q=is%3Aopen+is%3Aissue+label%3A%22High+priority%22
15:30:00 <bowlofeggs> #info High priority means it's important, but not a show stopper
15:30:02 <bowlofeggs> Any filed issues that aren't on these lists that should be?
15:35:26 <bowlofeggs> sounds like… no
15:35:33 <bowlofeggs> ok, well i don't have anything else
15:35:36 <bowlofeggs> #topic open floor
15:38:40 * nirik has nothing off hand
15:40:16 <bowlofeggs> alright
15:40:20 <bowlofeggs> thanks for coming everyone!
15:40:22 <bowlofeggs> #endmeeting