17:01:17 <dustymabe> #startmeeting fedora_atomic_wg
17:01:17 <zodbot> Meeting started Wed Jun 28 17:01:17 2017 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:17 <zodbot> The meeting name has been set to 'fedora_atomic_wg'
17:01:23 <dustymabe> #topic roll call
17:01:27 <yzhang> .hello yzhang
17:01:28 <zodbot> yzhang: yzhang 'Yu Qi Zhang' <jzehrarnyg@gmail.com>
17:01:40 <kushal> .hellomynameis kushal
17:01:41 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:01:51 <maxamillion> .hello maxamillion
17:01:52 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:02:18 <jberkus> .hello jberkus
17:02:19 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:03:25 <dustymabe> .hello dustymabe
17:03:26 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:03:52 <rubao> .hello rubao
17:03:53 <zodbot> rubao: rubao 'rubao' <rubao.net@hotmail.com>
17:04:07 <dustymabe> welcome everyone
17:04:14 <nzwulfin> .hello mmicene
17:04:15 <zodbot> nzwulfin: mmicene 'Matt Micene' <nzwulfin@gmail.com>
17:04:33 <sayan> .hello sayanchowdhury
17:04:36 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:04:41 <dustymabe> #chair sayan nzwulfin rubao jberkus maxamillion kushal yzhang
17:04:41 <zodbot> Current chairs: dustymabe jberkus kushal maxamillion nzwulfin rubao sayan yzhang
17:05:02 <suiwenfeng> .hello suiwenfeng
17:05:03 <zodbot> suiwenfeng: suiwenfeng 'suiwenfeng' <suiwenfeng@live.cn>
17:05:10 <dustymabe> hi suiwenfeng, welcome
17:05:59 <suiwenfeng> It`s my first meeting at atomic wg.|-_-\
17:06:22 <jzb> .hellomynameis jzb
17:06:22 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:06:27 <roshi> .hello roshi
17:06:28 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:07:04 <dustymabe> #topic list of people to ping for meetings
17:07:13 <dustymabe> #link https://pagure.io/atomic-wg/pull-request/288#
17:07:33 <dustymabe> I created a list of people that I'll ping before the meetings start - this is more of a friendly reminder
17:07:46 <dustymabe> if you want your name added to the list just add a comment in that PR and I'll get you added
17:08:05 <dustymabe> make sure to let me know what your IRC nick is (in case it is different from your FAS account username)
17:08:56 <yzhang> do we change meeting time often?
17:09:13 <roshi> nope
17:09:17 <roshi> at least we haven't
17:09:41 <kushal> This is a good time for most of us I think.
17:09:43 <dustymabe> yzhang: no we haven't change the meeting time in a while
17:09:53 <dustymabe> do note that we don't change for daylight savings, though
17:09:57 <yzhang> ok, was just curious, thanks
17:10:03 <dustymabe> so we stay at the same UTC time year round
17:10:18 <suiwenfeng> roshi, I will contact you after finish reading some documents.
17:10:19 <dustymabe> if you live in a country/tz that changes with daylight savings then the meeting will "move"
17:10:21 <dustymabe> for ou
17:10:30 <roshi> sounds good suiwenfeng
17:10:30 <miabbott> .hello miabbott
17:10:31 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
17:10:45 <dustymabe> ok i'll move on to previous meeting action items
17:10:51 <dustymabe> #topic previous meeting action items
17:10:53 <dustymabe> * maxamillion to add summary to ticket
17:10:55 <dustymabe> https://pagure.io/atomic-wg/issue/284
17:10:57 <dustymabe> * dustymabe to propose a VFAD for wiki and docs discussion
17:10:59 <dustymabe> * jberkus to update wg on final approval of PRD
17:11:01 <dustymabe> * jberkus to create new issues, specs for docs.projectatomic.io
17:11:03 <dustymabe> publication
17:11:39 <dustymabe> #action dustymabe to propose a VFAD for wiki and docs discussion
17:11:44 <dustymabe> ^^ i promise to do that today
17:11:56 * sayan is having flaky internet, goes to find the issue
17:12:27 <dustymabe> sayan: issue? related to action items?
17:13:04 <dustymabe> welcom gbraad_ gholms :)
17:13:13 <gholms> Heya
17:13:20 <dustymabe> #chair suiwenfeng jzb roshi miabbott gbraad_ gholms
17:13:20 <zodbot> Current chairs: dustymabe gbraad_ gholms jberkus jzb kushal maxamillion miabbott nzwulfin roshi rubao sayan suiwenfeng yzhang
17:13:33 <maxamillion> dustymabe: I'm looking at this ticket and I don't remember what needs a summary update :(
17:13:41 <maxamillion> dustymabe: I'll ping some folks and try to get that sorted
17:13:45 <gholms> Sorry; I'm normally double-booked now.
17:13:47 * maxamillion adds it to his TODO list for the day
17:13:59 <maxamillion> gholms: same :/
17:14:02 <dustymabe> maxamillion: basically you were going to add a summary of the discussion we had last meeting
17:14:05 <dustymabe> to the ticket
17:14:08 <maxamillion> dustymabe: ah +1
17:14:21 <dustymabe> maxamillion: logs from that meeting are here
17:14:22 <dustymabe> https://meetbot.fedoraproject.org/teams/fedora_atomic_wg/fedora_atomic_wg.2017-06-21-17.03.log.html
17:14:47 <jberkus> ooops, lemme check on PRD
17:14:52 <dustymabe> #action maxamillion to look at logs from last meeting and add summary of our discussion to ticket https://pagure.io/atomic-wg/issue/284
17:14:58 <maxamillion> dustymabe: you're the best
17:15:04 <maxamillion> dustymabe++
17:15:05 * dustymabe blushes
17:15:18 <dustymabe> maxamillion: save that cookie until after f26 release :)
17:15:18 <maxamillion> :D
17:15:23 <maxamillion> dustymabe: lol
17:15:25 <gholms> Heh
17:15:31 <jberkus> Our PRD has been approved
17:15:32 <maxamillion> dustymabe: I'm sure you'll get another one
17:15:35 <maxamillion> jberkus: \o/
17:15:40 <dustymabe> jberkus: woot!
17:15:49 <dustymabe> jberkus: roshi thanks for running that to term
17:15:55 <dustymabe> and jbrooks as well
17:16:04 <gholms> #info PRD has been approved
17:16:10 <jberkus> we were thanked for making the structure of our PRD match Server so that it's easy to comapre them
17:16:19 <roshi> what'd I do?
17:16:21 <jberkus> so thanks for that roshi
17:16:23 <jberkus> roshi++
17:16:24 <dustymabe> roshi: wiki magic
17:16:31 <suiwenfeng> dustymabe, what will be discussed in this meeting?
17:16:32 <roshi> I can explain!
17:16:34 <roshi> I tripped
17:16:37 <roshi> there were wires
17:16:39 <gholms> #info Matching Fedora Server's PRD format was helpful
17:16:39 <roshi> I didn't mean to!
17:16:45 <roshi> have mercy!
17:16:55 <dustymabe> suiwenfeng: we typically go over some announcements, then previous meeting action items, then we go over tickets
17:17:09 <dustymabe> tickets with the meeting keyword in our issue tracker
17:17:12 <dustymabe> https://pagure.io/atomic-wg/issues?status=Open&tags=meeting
17:17:22 <dustymabe> and then open floor, for anyone with anything new
17:17:44 <dustymabe> suiwenfeng: any questions about that structure?
17:18:05 <dustymabe> jberkus: any update on jberkus to create new issues, specs for docs.projectatomic.io
17:18:20 <suiwenfeng> dustymabe, no, please assign me one of them if possible after the meeting...
17:18:52 <jberkus> dustymabe: not at this point, please re-action
17:18:55 <dustymabe> #action jberkus to create new issues, specs for docs.projectatomic.io publication
17:19:01 <roshi> suiwenfeng: the QA is much the same
17:19:03 <dustymabe> suiwenfeng: ok we'll chat
17:19:41 <suiwenfeng> dustymabe, Thanks.
17:20:07 <dustymabe> #topic clarify policy on atomic host support for older Fedora "number" releases
17:20:11 <dustymabe> #info https://pagure.io/atomic-wg/issue/228
17:20:27 * roshi saw a blog post about that the other day
17:20:29 <gholms> Looks like the fedoramagazine post is up.
17:20:31 <dustymabe> #info the fedora magazine post has landed https://fedoramagazine.org/upcoming-fedora-atomic-lifecycle-changes/
17:20:47 <dustymabe> the ticket can now be closed. anyone opposed?
17:21:06 <kushal> dustymabe, nope.
17:21:08 <gholms> Keep in mind that without support for N-1 releases working N+1 builds are more important than ever.
17:21:18 <roshi> nope, close it
17:21:27 <dustymabe> gholms: indeed and we are hoping to test more and more
17:21:34 <dustymabe> in more automated ways
17:22:21 <dustymabe> ok moving on to next ticket
17:22:43 <gholms> Builds are just as important as tests.  ;)
17:22:54 <dustymabe> #topic fedimg: don't use 'builder' instance for uploading AMIs
17:23:00 <dustymabe> #link https://pagure.io/atomic-wg/issue/269
17:23:22 <dustymabe> this will most likely wait until after fedora 26 release because we are now in freeze
17:23:29 <dustymabe> #info this will most likely wait until after fedora 26 release because we are now in freeze
17:23:34 <dustymabe> sayan: any other update?
17:23:44 * kushal is wondering if sayan's network is working
17:23:53 <kushal> dustymabe, network problem this side.
17:24:13 <dustymabe> kushal: k. I think i had enough information
17:24:14 <gholms> Yeah, so, import-volume involves writing to S3, FWIW.
17:24:33 <kushal> dustymabe, He was working on it, I think he will ask for a FBR
17:24:54 <dustymabe> kushal: hmm - i would actually prefer no FBR for this issue in particular
17:25:11 <dustymabe> there was another thing that needs fixing with fedimg that we can FBR
17:25:21 <dustymabe> for those interested FBR == Freeze Break Request
17:25:23 <gholms> We also can't use the ec2-* tools thanks to their license, but I can stuff whatever functionality we need into euca2ools.
17:25:43 <dustymabe> it's basically what you have to do to get things merged for changes to fedora infrastructure during "Freeze"
17:25:55 <kushal> dustymabe, Okay.
17:26:09 <dustymabe> gholms: cool. maybe we can get with sayan when he gets back to talk about it
17:26:13 <dustymabe> moving on
17:26:16 <kushal> dustymabe, I thought both of them will get into the same release.
17:26:17 <gholms> Sounds good
17:26:28 <dustymabe> #topic Set architecture label in the base container image
17:26:35 <dustymabe> #link https://pagure.io/atomic-wg/issue/276
17:27:02 <dustymabe> we discussed this last meeting, probably should have removed the meeting tag
17:27:06 <dustymabe> removing it now
17:27:25 <dustymabe> for anyone interested here was the comment from last meeting:
17:27:31 <dustymabe> Discussed in the atomic working group meeting today. The proposal in the description sounds reasonable. Assuming we need to set an architecture label, then making layered images inherit from the base image makes sense. This assumes that there is not some technical reason why this can't be achieved.
17:27:31 <DimGR> hi
17:27:32 <dustymabe> +1
17:27:34 <dustymabe> DimGR: welcome
17:27:37 <dustymabe> #chair DimGR
17:27:37 <zodbot> Current chairs: DimGR dustymabe gbraad_ gholms jberkus jzb kushal maxamillion miabbott nzwulfin roshi rubao sayan suiwenfeng yzhang
17:27:48 <yzhang> pagure seems to be having some troubles here
17:27:57 <dustymabe> yzhang: yeah, that happens :(
17:28:07 <dustymabe> it is improving, though
17:28:08 * sayan is back
17:28:11 <dustymabe> sayan: yay
17:28:29 <dustymabe> sayan: we moved past your ticket, but gholms wants to talk to you after the meeting
17:28:32 <sayan> dustymabe: I will discuss the progress in open floor
17:28:39 <dustymabe> ok
17:28:45 <dustymabe> #topic Figure out comprehensive strategy for atomic host container storage
17:29:07 <dustymabe> #link https://pagure.io/atomic-wg/issue/281
17:29:33 <yzhang> still dead for me
17:29:45 <gholms> RIP pagure
17:29:53 <dustymabe> so this ticket is mostly about moving atomic host to a larger root partition in the future
17:30:03 <DimGR> pagure was giving me 404 errors last night
17:30:09 <dustymabe> and having the container-storage-setup match other platforms in fedora
17:30:21 <dustymabe> using overlay2 by default on the root partition
17:30:33 <dustymabe> you can easily configure it to put the storage somewhere else, but that will be the default
17:30:41 <gholms> Other platforms?
17:30:55 <dustymabe> other platforms == fedora sever fedora workstation etc..
17:31:02 <dustymabe> sorry, should have clarified
17:31:02 <gholms> Ah
17:31:46 <dustymabe> anyone have any input on this change?
17:31:47 <jberkus> dustymabe: that seems like a fine solution to me, and its what we talked about for F27
17:31:52 <jberkus> are we looking to move the schedule up?
17:32:20 <gholms> It's awfully late to move it up.
17:32:57 <dustymabe> no - just for f27
17:33:03 <kushal> dustymabe, That sounds good.
17:33:18 <dustymabe> so this hinges on overlayfs proving stable in f26
17:33:28 <gholms> Mhm
17:33:28 <dustymabe> i've been using it for quite a while and all has gone well
17:33:34 <dustymabe> in f25 and f26
17:34:04 <dustymabe> ok is anyone opposed to this change?
17:34:17 <roshi> haven't followed this close
17:34:30 <roshi> so the proposal is to have all of Fedora on overlayfs?
17:34:50 <dustymabe> roshi: well - all of fedora will default to overlayfs for docker in fedora 26 already
17:34:59 <dustymabe> this change is more for how storage is set up
17:35:05 <roshi> ok, so for docker
17:35:12 <roshi> docker on any Fedora host would be overlay
17:35:25 <roshi> +1 to that then :)
17:35:30 <dustymabe> right now in f26atomic host /var/lib/docker will be mounted on another filesystem on another logicial volume
17:35:40 <roshi> just wanted to make sure I grokked what was going on :)
17:35:49 <dustymabe> we would change the default to not do that
17:36:02 <walters> we already have done for f27
17:36:11 <dustymabe> which basically means our storage setup is more simple for the default
17:36:12 <walters> (and i'd vote to port this to f26 at some point too)
17:36:51 <dustymabe> yeah not sure about changing f26 mid release - but that is a separate discussion
17:36:59 <kushal> We will have to add test for no regression on that part.
17:37:20 <dustymabe> ok - anyone opposed?
17:37:36 <yzhang> nope
17:38:11 <kushal> dustymabe, Nope.
17:38:14 <dustymabe> #proposed changing fedora 27 and beyond to default to overlayfs on the root partition will help us simplify our storage setup and align better with other fedora variants. This seems like a reasonable change to make assuming that overlayfs proves stable for the f26 cycle.
17:38:20 <dustymabe> acks?
17:39:06 <kushal> dustymabe, Aye to that.
17:39:20 <jberkus> +1
17:39:53 <maxamillion> +1
17:40:02 <dustymabe> anyone else?
17:40:10 <maxamillion> sorry, multi-tasking badly
17:40:16 <dustymabe> maxamillion: happens
17:40:18 <maxamillion> I always have this hour double-booked :/
17:40:23 <yzhang> +1
17:40:33 <dustymabe> ok will update the ticket
17:41:27 <dustymabe> #agreed changing fedora 27 and beyond to default to overlayfs on the root partition will help us simplify our storage setup and align better with other fedora variants. This seems like a reasonable change to make assuming that overlayfs proves stable for the f26 cycle.
17:41:38 <dustymabe> #topic Atomic Host images omit many common locales that all other flavors include
17:41:45 <dustymabe> #link https://pagure.io/atomic-wg/issue/282
17:41:46 <maxamillion> at some point we might want to establish a "minimum number of attendees for a meeting to continue with the meeting" so that we can define what's quorum for voting on things
17:41:51 <maxamillion> just a thought
17:42:15 <dustymabe> maxamillion: yeah - so far we've been pretty unstructured
17:42:27 <dustymabe> which has its pros and cons
17:42:43 <roshi> yeah
17:42:51 <roshi> for QA, or blocker, we need 3
17:42:59 <dustymabe> seems like we have some technical discussion going on in this ticket - anyone have anything to add for now ?
17:42:59 <maxamillion> dustymabe: agreed
17:43:08 <roshi> we generally have more than that for this meeting though
17:43:27 <maxamillion> roshi: right, I'd just like to come up with some baseline and add it to the meetings wiki page
17:43:36 <roshi> +1 to that
17:43:39 <DimGR> im catching up , hence being silent now
17:43:43 <dustymabe> roshi: maxamillion want to take that action?
17:44:14 <dustymabe> #action maxamillion roshi to come up with guidelines for meeting quorum for the atomic working group
17:44:17 <dustymabe> too late
17:44:39 <dustymabe> ok we can move past this  ticket
17:44:40 <maxamillion> dustymabe: +1
17:44:56 <dustymabe> #topic Identify group of people interested in maintaining kubernetes
17:45:03 <dustymabe> #link https://pagure.io/atomic-wg/issue/282
17:45:08 <dustymabe> #undo
17:45:08 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x2c347f90>
17:45:14 <dustymabe> #link https://pagure.io/atomic-wg/issue/287
17:45:43 <maxamillion> not I
17:45:46 <dustymabe> so I created this ticket to try to find a group of people who use and want to help maintain kubernetes in Fedora
17:45:54 <roshi> I don't know enough about it to help maintain it
17:45:57 <jberkus> seems like there's more than a few
17:46:10 <dustymabe> yeah we've had a few people step up already (woot!)
17:46:29 <suiwenfeng> dustymabe, I am in?
17:46:34 <dustymabe> glad to reach out to the community and get new contributors
17:46:40 <sayan> I've recently started to tinker around with kubernetes
17:46:44 <dustymabe> suiwenfeng: :) i don't know if it is exclusive
17:46:54 <sayan> but not much of a knowledge yet.
17:46:56 <dustymabe> basically anyone is in - if they want to help
17:47:21 <dustymabe> so what we are doing is finding a list of names and then we'll decide what to do with it
17:47:25 * gholms guarantees one will have more interest from outside of the red hat universe, provided someone manages to maintain it
17:47:33 <dustymabe> we may make a new specialized group where kuberetes issues can be discussed
17:47:41 <dustymabe> or that group may just piggy back off of this group
17:48:06 <dustymabe> gholms: one == ?
17:48:23 <gholms> kubernetes
17:48:43 <dustymabe> gholms: rightr
17:48:45 <gholms> Just how it appears from over here, at least
17:48:58 <dustymabe> yep, that is very understood
17:48:58 <maxamillion> I think that's a fair statement
17:48:59 <kushal> gholms, Same everywhere.
17:49:39 <dustymabe> so summary: add your name if you're interested :)
17:49:46 <dustymabe> next topic
17:49:50 <dustymabe> #topic open floor
17:49:54 <dustymabe> who all has something for open floor?
17:50:14 * gholms pokes sayan
17:50:52 <sayan> Yes, so over the last few days, I have been fixing the AMI public/private issues
17:51:02 <gbraad_> eh, I would appreciate help with realizing: https://github.com/gbraad/minishift-atomic-iso
17:51:11 <gbraad_> that's all
17:51:18 <gbraad_> :-D
17:51:25 <maxamillion> I need to step afk to grab some food before my next meeting, apologies all
17:51:28 <maxamillion> dustymabe: thanks for hosting!
17:51:35 <dustymabe> gbraad_: can you open an issue under https://pagure.io/atomic-wg ?
17:51:50 <sayan> I deployed the fix on Monday. But, found an issue where the snapshot copied to other regions are still private
17:51:54 <jberkus> gbraad_: what is it?
17:51:54 <dustymabe> gbraad_: might be nice to have the rest of the group updated on progress for that
17:52:08 <dustymabe> jberkus: basically we want minishift to run on atomic host
17:52:13 <jberkus> ah, ok
17:52:20 <dustymabe> i.e. the little minishift OS is atomic host
17:52:29 <jberkus> ok
17:52:30 <dustymabe> which openshift running as a container
17:52:34 <dustymabe> s/which/with/
17:52:57 <jberkus> it would also be nice to have a minishift which runs on atomic host without a VM ...
17:53:06 <gholms> #info Work continues on fixing EC2 image visibility, as copied images need their permissions changed
17:53:21 <gbraad_> targeting a non-VM environment is on the roadmap, but not for now
17:53:31 <dustymabe> sayan: any luck with the snapshot permissions ?
17:53:51 <dustymabe> #info if you haven't yet tried out minishift, you should check it out
17:54:08 <sayan> dustymabe: sadly, libcloud does not have ways to query the snapshot. But, I have a written a work-around
17:54:11 <dustymabe> #undo
17:54:11 <zodbot> Removing item from minutes: INFO by dustymabe at 17:53:51 : if you haven't yet tried out minishift, you should check it out
17:54:15 <dustymabe> #info if you haven't yet tried out minishift, you should check it out https://www.openshift.org/minishift/
17:54:19 <gbraad_> any docker/container host is our goal, but for predictability we run a VM at the moment
17:54:46 <sayan> dustymabe: right now, I am testing that in the dev instance I have
17:55:01 <dustymabe> gbraad_: glad to have you at this meeting. looking forward to seeing you more in the future
17:55:11 <dustymabe> sayan++
17:55:15 <gbraad_> you will
17:55:21 <sayan> After the fix is deployed, I'll make some patches to the libcloud to have method to query the snapshots
17:55:45 <dustymabe> ok - anyone have anything else for open floor ?
17:55:57 <gbraad_> have mostly been doing things for atomic in the bacground
17:56:18 <DimGR> is there i could test on openstack and fed atomic ?
17:56:23 <DimGR> *something
17:57:05 <jberkus> gbraad_: btw, thanks so much for helping with Atomic at LinuxCon China.  did you get your shirt?
17:57:24 <dustymabe> DimGR: basically running fedora or centos atomic host on openstack and reporting issues
17:57:35 <dustymabe> or any difference in behavior you see vs non openstack
17:57:36 <gbraad_> eh... no?
17:57:38 <yzhang> jberkus: was that shirt for gbraad?
17:57:39 <yzhang> oops
17:57:57 <dustymabe> DimGR: have you tried out fedora 26 atomic host on openstack yet?
17:58:00 <gbraad_> LOL
17:58:02 <jberkus> yzhang: there should have been multiple shirts, two for you and one for gbraad_
17:58:10 <yzhang> jberkus: I got the 2 for me
17:58:14 <jberkus> dammit
17:58:21 <dustymabe> language
17:58:24 <yzhang> I was under the impression the other one was for Gordon
17:58:27 <gholms> Oh, right.  Libcloud.
17:58:32 <yzhang> Well, there was only 2 but
17:58:33 <DimGR> dustymabe only downloaded the image today  but didnt have time to fire up instances , will do tomorrow
17:58:33 <dustymabe> ok i think we are done with meeting DimGR hit me up in #fedora-cloud
17:58:36 <dustymabe> or #atomic
17:58:42 <DimGR> ok
17:58:46 <dustymabe> #endmeeting