20:00:39 <sgallagh> #startmeeting Fedora Server SIG (2017-09-05)
20:00:39 <zodbot> Meeting started Tue Sep  5 20:00:39 2017 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:39 <zodbot> The meeting name has been set to 'fedora_server_sig_(2017-09-05)'
20:00:39 <sgallagh> #meetingname serversig
20:00:39 <zodbot> The meeting name has been set to 'serversig'
20:00:50 <sgallagh> #topic Roll Call
20:00:55 <dperpeet> .hello dperpeet
20:00:55 <sgallagh> .hello2
20:00:58 * nirik is sort of here, but also sort of busy
20:00:58 <mhayden> .hello mhayden
20:01:14 <zodbot> dperpeet: dperpeet 'None' <dperpeet@redhat.com>
20:01:17 <zodbot> sgallagh: Something blew up, please try again
20:01:20 <zodbot> mhayden: Something blew up, please try again
20:01:42 <sgallagh> I anticipate this to be a fairly short meeting, as many folks are still post-processing Flock
20:01:45 <sgallagh> .hello2
20:01:47 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
20:01:51 <sgallagh> better
20:01:57 <imcleod> .hello2
20:01:58 <mjwolf> .hello mjwolf
20:01:59 <zodbot> imcleod: imcleod 'Ian McLeod' <imcleod@redhat.com>
20:02:02 <zodbot> mjwolf: mjwolf 'Michael Wolf' <mjw@linux.vnet.ibm.com>
20:03:31 <sgallagh> #topic Post-Flock discussion
20:03:45 <sgallagh> First off, thanks everyone who participated in Flock this year!
20:04:36 <sgallagh> I'm sure it will come as a complete surprise to everyone here that the main theme of Flock this year focused around efforts to get Modularity out the door for F27
20:05:20 <sgallagh> #info The Module Build Service has been activated and is now available for use by anyone in the 'packager' group.
20:05:39 <sgallagh> So if you've got a favorite service you'd like to see modularized, now's your chance!
20:06:26 <sgallagh> Progress is also moving along quite well in terms of the modules necessary to meet the Fedora Server requirements for F27
20:06:49 <dperpeet> That's great
20:06:54 <sgallagh> I need to double-check, but I *think* as of last week we had at least a testable module for all of the official (blocking) Server components
20:07:30 <sgallagh> (I don't promise that they *work*, but they should at least exist)
20:08:28 <sgallagh> During the State of Fedora Server talk, I made it clear that we have decided to abandon 'rolekit' (and the concept of Server Roles in general) from Fedora Server in favor of Modules and Server Applications.
20:09:03 <nirik> did we decide a hard eol date for rolekit?
20:09:03 <sgallagh> The latter of which I heard from Marius Vollmer and Alexander Bokovoy were moving ahead well. I'll ask dperpeet to give us a status update from the Cockpit side.
20:09:08 <dperpeet> was there feedback regarding that?
20:09:20 <sgallagh> dperpeet: "When can we have it?"
20:09:35 <sgallagh> and "Can you do it sooner than that?" ;-)
20:09:51 <dperpeet> mvollmer is working on packaging it properly
20:09:51 <sgallagh> nirik: We haven't, and I was going to bring that up today.
20:10:09 <dperpeet> that coincides with ongoing work on the cockpit starter kit
20:10:37 <dperpeet> I believe the current status is at https://github.com/mvollmer/cockpit-app-freeipa
20:11:17 <sgallagh> Yes. I'm also glad to see that the Cockpit team isn't developing this in a vacuum.
20:11:40 <dperpeet> I think progress is steady at this point
20:11:45 <sgallagh> As previously mentioned, Alexander Bokovoy of the FreeIPA team is collaborating (and I've volunteered to do package reviews when needed to move it along)
20:12:25 <dperpeet> oh, one thing: the spec addition mvollmer was waiting on has been approved
20:12:27 <sgallagh> dperpeet: So the $1,000,000 question: Is F28 a reasonable target and if so, will you get a Change Proposal ready soon?
20:12:30 <dperpeet> cockpit PR for this work is https://github.com/cockpit-project/cockpit/pull/7076
20:12:36 <sgallagh> Spec addition?
20:12:43 <dperpeet> appstream
20:12:49 <dperpeet> to make everything a bit more user friendly
20:12:55 <dperpeet> and discoverable
20:12:55 <sgallagh> ah
20:13:00 <sgallagh> Sounds good
20:13:08 <dperpeet> in that pr you can see a huge checklist with todo items
20:13:19 <dperpeet> and all of them checked :)
20:13:38 <dperpeet> this will go through some review, but land soon-ish
20:13:58 <dperpeet> sgallagh, what has to change in F28?
20:14:29 <sgallagh> dperpeet: A "Change Proposal" is a formal request to FESCo to allow a major new feature into Fedora.
20:14:45 <sgallagh> In this case, it'll be a formality, but the Change Proposals are also culled for use in marketing materials
20:14:51 <sgallagh> So it's a good way to get publicity
20:15:09 <dperpeet> I will forward that question to mvollmer
20:15:14 <sgallagh> dperpeet: https://fedoraproject.org/wiki/Changes/Policy
20:15:32 <sgallagh> (It also helps FESCo plan the release)
20:15:52 <dperpeet> right, I'll forward that question to the Cockpit team
20:16:16 <dperpeet> the change in question is the capability to install apps?
20:16:25 <dperpeet> or to automatically pick up apps that expose this?
20:16:34 <sgallagh> dperpeet: Yes, with the Acceptance Criteria being FreeIPA for this pass.
20:16:41 <dperpeet> ok
20:16:53 <sgallagh> Automatically picking up arbitrary apps could be a separate proposal (possibly for a future Fedora)
20:17:46 <sgallagh> #action dperpeet to discuss the Server Apps plan with Cockpit upstream and plan a Change Proposal for the appropriate Fedora release.
20:17:53 <sgallagh> (Hopefully F28...)
20:17:57 <dperpeet> :)
20:18:23 <sgallagh> #topic Rolekit gallops off into the sunset
20:18:42 <sgallagh> We announced our intentions to retire rolekit, but haven't firmed up the plan for it.
20:18:53 <sgallagh> I want this dead and gone by F28
20:19:22 <sgallagh> However, as it's being consumed by Fedora QA testing at the moment, this is a non-trivial task.
20:19:58 <sgallagh> (I mean, I *could* just retire the package and make adamw angry at me for breaking the tests, but I try not to antagonize my friends... too much)
20:20:19 * adamw sharpens knives
20:20:21 * nirik nods
20:21:07 <sgallagh> I spoke with adamw about this briefly at Flock. Our current plan (correct me if I'm wrong) is to just swap out the places where `rolectl` is called with the `ipa-server-install` command that rolekit would be calling under the hood
20:21:39 <sgallagh> This is probably not a huge job, but it's one I've managed to fail to find time to accomplish
20:21:44 <adamw> ...and somehow adjust all of the PRD, release criteria, and test case bits that involve rolekit. you forgot that bit.
20:21:59 <sgallagh> Well, strictly speaking they never mention rolekit.
20:22:06 <adamw> the automated tests are based on the manual test cases, which cover the release criteria, which are based on the PRD.
20:22:08 <adamw> sure they do.
20:22:10 <sgallagh> They refer to a *concept* of server roles :)
20:22:17 <adamw> *fry eyes*
20:22:36 <sgallagh> What I mean is that the criteria define an end-state, not an implementation
20:22:45 <sgallagh> (There may be small exceptions to this)
20:23:04 <sgallagh> The end-state should remain the same, but yes we'll need to fix the manual test cases
20:23:05 <adamw> well, yes, but the end state the server criteria describe was pretty specifically written around the rolekit design
20:23:15 <adamw> and not just some abstract idea of a 'server role'
20:23:17 * adamw goes to read 'em again
20:23:47 <sgallagh> OK, we don't need to solve it here. Suffice to say there is a documentation component to this as well.
20:24:00 <adamw> yeah.
20:24:06 <adamw> i just want to make sure you're not underestimating it.
20:24:23 <adamw> i mean, large chunks of https://fedoraproject.org/wiki/Server/Product_Requirements_Document#Featured_Server_Roles can't plausibly be held to be implemented by 'oh just run ipa-server-install'.
20:24:28 <sgallagh> I'll help where I can, but is there anyone who is itching for something to do (or has an unaccompanied intern lying around in a corner) that would like to help with this?
20:24:46 * adamw is not really dying for more todo list items, no.
20:24:53 <adamw> currently too busy trying to make freeipa actually work.
20:25:03 <sgallagh> Yes, understood
20:27:51 <sgallagh> OK, we will figure something out, but I'll state for the record that the worst-case scenario here is that I retire it from F29 the moment that F28 branches off, so we WILL have a hard break.
20:27:55 * linuxmodder super late
20:28:03 <sgallagh> (Assuming that we don't sort it out before that)
20:28:10 <linuxmodder> reading scrollback
20:29:16 <adamw> sure. i just like to keep the process in mind; we did do this whole 'build it out from the PRD' thing for fedora.next for good reasons.
20:29:26 <sgallagh> Yes
20:29:50 <sgallagh> It's probably worth updating that document with the new Server App ideas
20:30:11 <sgallagh> In any case, this is mostly informational at the moment; I'm not in a position to make changes right now.
20:30:25 <adamw> sure
20:30:27 <linuxmodder> sgallagh, need help with the docs update/rewrite?
20:30:43 <sgallagh> linuxmodder: I certainly will
20:31:06 <linuxmodder> sgallagh,  feel free to ping me via irc/email etc when that happens to come to life
20:31:31 <sgallagh> #action linuxmodder to rewrite all of Server SIGs documentation
20:31:32 <sgallagh> ;-)
20:31:49 <linuxmodder> that escalated quick :=)
20:32:18 <linuxmodder> more like help not solely rewrite :)
20:32:39 <sgallagh> #topic Open Floor
20:32:43 <adamw> #action linuxmodder to rewrite the entire wiki
20:32:45 <sgallagh> That's all I had for today. Anyone else?
20:32:59 <adamw> linuxmodder: start with /wiki/Aardvark, we'll see you back here next week
20:33:02 <linuxmodder> adamw,  that is totally  not cool that is a self torture
20:33:19 <linuxmodder> i have other projects too you know
20:33:26 <adamw> not any more you don't
20:33:26 <adamw> :P
20:33:54 <adamw> we'll be monitoring your from your webcam to make sure you never leave your desk
20:33:59 <linuxmodder> where are the present set of 26  server builder kickstarts?  been having requests of late for server based kickstarts installs
20:34:08 * sgallagh wonders if we should just assign him to rewrite readthedocs.org too
20:34:32 <linuxmodder> why did this become linuxmodder becomes  docs dude ?
20:35:15 <adamw> you should know never to volunteer by now
20:35:15 <adamw> :P
20:35:29 <linuxmodder> to help not be point man
20:35:43 <adamw> oh, we stop reading at 'i volunteer'
20:35:44 <sgallagh> nirik: Where are the new server definitions again? I can never remember where they went when we stopped using fedora-kickstarts
20:35:52 <adamw> pungi-fedora, isn't it?
20:35:56 <sgallagh> AH, thanks
20:36:14 <sgallagh> https://pagure.io/pungi-fedora/tree/master
20:36:14 <adamw> https://pagure.io/pungi-fedora/blob/master/f/variants-fedora.xml#_52
20:36:19 <linuxmodder> the kickstarts there too sgallagh ?
20:36:20 <adamw> (for the non-modular server)
20:36:21 <nirik> definitions? you mean whats on the server dvd?
20:36:24 <sgallagh> also variante-modular
20:36:27 <adamw> linuxmodder: it doesn't use kickstarts exactly any more.
20:38:02 <linuxmodder> I leave for a few weeks and lost all track so all server builds are modularity based now?
20:39:08 <sgallagh> linuxmodder: The DVD is no longer constructed by kickstart
20:39:16 <sgallagh> It's built from pungi configs like those linked above
20:39:45 <sgallagh> The default install is what is included in the "Fedora Server Edition" comps group
20:39:58 <sgallagh> Anyway, this is getting a bit off-topic.
20:40:08 <sgallagh> Anything else for the meeting or shall I close it out?
20:42:30 <sgallagh> #endmeeting