17:01:57 <jberkus> #startmeeting fedora_atomic_wg
17:01:57 <zodbot> Meeting started Wed Oct 11 17:01:57 2017 UTC.  The chair is jberkus. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:57 <zodbot> The meeting name has been set to 'fedora_atomic_wg'
17:02:07 <jberkus> #topic Roll Call
17:02:12 <jberkus> .hello jberkus
17:02:13 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:02:31 <dustymabe> .hello dustymabe
17:02:32 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:02:36 <jbrooks> .hello jasonbrooks
17:02:37 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:03:25 <ksinny> .hello sinnykumari
17:03:26 <zodbot> ksinny: sinnykumari 'Sinny Kumari' <ksinny@gmail.com>
17:04:18 <maxamillion> .hello maxamillion
17:04:22 <walters> .hello walters
17:04:24 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:04:27 <zodbot> walters: walters 'Colin Walters' <walters@redhat.com>
17:04:54 <miabbott> .hello miabbott
17:04:55 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
17:06:05 <jberkus> #chair jberkus dustymabe jbrooks ksinny maxamillion miabbott walters
17:06:05 <zodbot> Current chairs: dustymabe jberkus jbrooks ksinny maxamillion miabbott walters
17:06:33 <jberkus> OK, before we get to action items, we have a different important matter.
17:06:41 <jberkus> #topic Atomic WG Composition
17:06:55 <jberkus> We've had some folks move on to other things, and other folks join the WG
17:07:09 <jberkus> It seems to me that we need to update the list of membership in the WG
17:07:24 <jberkus> Does anyone know how we do that?  Send a resolution to the Council?
17:07:28 <dustymabe> jberkus: that's been something i've been wanting to do for a while
17:07:40 <dustymabe> i don't think we need the council at all
17:07:54 <jberkus> dustymabe: yeah, well, I was looking at the wiki and realized that I don't think we can actually take a valid vote in this meeting
17:08:23 <dustymabe> which wiki? and you mean a valid vote according to how Fedora defines it?
17:08:36 <davdunc> .hello davdunc
17:08:37 <zodbot> davdunc: davdunc 'David Duncan' <davdunc@amazon.com>
17:09:24 <jberkus> At minimum 51% of the voting members of the Atomic WG must be in attendance in order to make decisions on meeting items.
17:09:36 <jberkus> https://fedoraproject.org/wiki/Cloud#Meetings
17:09:48 <jberkus> #chair jberkus dustymabe jbrooks ksinny maxamillion miabbott walters davdunc
17:09:48 <zodbot> Current chairs: davdunc dustymabe jberkus jbrooks ksinny maxamillion miabbott walters
17:10:12 <dustymabe> jberkus: sure. basically we've been doing lazy consensus
17:10:36 <dustymabe> fortunately we haven't had any extremely controversial topics, but we should probably follow process better
17:10:48 <dustymabe> if you'd like to champion that effort, that would be great!
17:10:55 <jberkus> ksinny miabbott walters please add your names to the wiki here: https://fedoraproject.org/wiki/Cloud#Working_Group_Members_and_Points_of_Contact
17:11:48 <jberkus> davdunc: you too if you're planning on hanging around for the medium term
17:12:10 <davdunc> I am jberkus thanks.
17:12:39 <jberkus> #action jberkus to follow-up on adding/removing Atomic WG members via atomic-devel
17:12:49 <ksinny> jberkus: sure, thanks
17:13:12 <jberkus> #topic Action Items from Last Meeting
17:13:56 <jberkus> dustymabe: you have two action items
17:13:58 <walters> ok done
17:14:09 <jberkus> * dustymabe to update the rolling release plan with info about f27ah
17:14:09 <jberkus> * dustymabe to open ticket to consider changing meeting time of atomic
17:14:09 <jberkus> wg meeting
17:14:48 <dustymabe> #info ticket for new meeting time: https://pagure.io/atomic-wg/issue/346
17:15:03 <dustymabe> #action dustymabe to update the rolling release plan with info about f27ah
17:15:07 <dustymabe> ^^ re-action
17:15:53 <jberkus> dustymabe: so where are we with meeting times?
17:16:24 <dustymabe> jberkus: we should probably make that a topic
17:16:32 <dustymabe> let's get other action items done firt
17:16:34 <dustymabe> first
17:16:35 <jberkus> ok, that'll be last topic
17:16:48 <jberkus> neither of my two action items are done, so I'm going to re-action
17:17:14 <jberkus> #action jberkus to identify and create issue with list of blog posts we want for f27 release
17:17:25 <kushal> I found some errors in the autocloud run, I will send in a mail to the list later.
17:17:28 <jberkus> #action jberkus to follow up on images from Flock container workshop
17:17:33 <jberkus> hey, kushal!
17:17:44 <jberkus> #chair jberkus dustymabe jbrooks ksinny maxamillion miabbott walters davdunc kushal
17:17:45 <zodbot> Current chairs: davdunc dustymabe jberkus jbrooks ksinny kushal maxamillion miabbott walters
17:18:41 <jberkus> #action jberkus to follow up on docs from Flock workshop
17:18:50 <jberkus> jbrooks items
17:18:59 <jberkus> * jbrooks to go through remove-kube items and update
17:18:59 <jberkus> * jbrooks to email fedora-devel with issue of needed deps for
17:19:00 <jberkus> asciibinder container in fedora proper
17:19:18 <jberkus> strigazi: here?
17:19:33 <jbrooks> I didn't email fedora-devel about asciibinder, we can re-action that
17:19:51 <jbrooks> #action  jbrooks to email fedora-devel with issue of needed deps for asciibinder container
17:20:41 <jbrooks> I did go through the remove-kube issues, there are basically two outstanding -- document the installation/migration, and that's basically done, in pieces, I'm going to put it in a wiki page. And the other outstanding one is an end-to-end kube test
17:20:50 <jbrooks> Which I haven't looked into so far
17:21:23 <dustymabe> should the document the installation/migration go in the atomic host docs repo?
17:21:34 <jbrooks> Yeah, I can put it there instead
17:21:39 <jbrooks> Or in addition
17:22:26 <dustymabe> jbrooks: want to give us an #info and then we can move on?
17:22:32 <jberkus> jbrooks: for end-to-end test, we kinda need todecide on a blessed installation method
17:22:37 <jberkus> which is an ongoing problem
17:22:55 <jberkus> #action jberkus to raise kube installation issues with openshift installer team
17:23:43 <jbrooks> #info remove-kube issues outstanding are documentation and end-to-end tests
17:23:52 <jbrooks> dustymabe, does that work
17:24:42 <jberkus> ok, strigazi isn't here, so I'll just re-up his action
17:25:04 <jberkus> #action strigazi to do some testing around upgrades from f26 to f27 with kubernetes
17:25:32 <maxamillion> jberkus: I think the most popular one in community space that could be easily augmented to work on Atomic Host would be kubespray (it's also based on ansible)
17:25:38 <dustymabe> +1
17:25:47 <jbrooks> I've tried that
17:25:48 <jberkus> #topic Open Tickets
17:25:51 <maxamillion> jberkus: it's a k8s incubator project
17:26:08 <jberkus> maxamillion: current obstacle is that it requires selinux=0
17:26:16 <maxamillion> jberkus: ohhhhh, that's not great
17:26:17 <jbrooks> I'm sure I can fix thatr
17:26:18 <jberkus> but potentially solvable
17:26:30 <maxamillion> jberkus: yeah
17:26:34 <jberkus> maxamillion: we could also use a canonical Ansible container (hint, hint)
17:26:41 <jbrooks> But I also really like the idea of latching onto openshift-ansible
17:27:00 <jbrooks> Just swap out the master and node roles, basically
17:27:04 <jberkus> jbrooks: more I want to know what their long-term plans are so that we can aim at convergence
17:27:28 <dustymabe> ok what topic are we on?
17:27:30 <jbrooks> Kubespray might be good, though, as a really upstream-focused thing
17:27:39 <jbrooks> We're talking about kube installation atm
17:27:40 <dustymabe> can we set the topic based on the 'meeting' label and go through those tickets?
17:27:48 <jberkus> ok, let's hash this out after the meeting?
17:27:56 <maxamillion> jberkus: yeah, the upstream focus is what I like about it especially since we're targeting vanilla k8s as a WG
17:27:57 <jbrooks> fine
17:28:01 <maxamillion> errr
17:28:03 <maxamillion> jbrooks: ^
17:28:15 <jberkus> lemme add a new meeting ticket
17:28:27 <maxamillion> jberkus: yeah, I know ... I might ask if we can bring such a thing back into existence
17:28:51 <jberkus> ok, open tickets
17:29:16 * gholms appears
17:29:20 <jberkus> first: https://pagure.io/atomic-wg/issue/349
17:29:26 <jberkus> evaluate atomic-ci repo
17:30:14 <dustymabe> so releng builds a rawhide ostree like once an hour
17:30:17 <jberkus> dustymabe, maxamillion I'll admit that I don't really understand this one
17:30:29 <dustymabe> it's a little known thing that they do
17:30:40 <jberkus> does anyone consume it?
17:30:45 <dustymabe> it has been broken for a while and they are asking who is using it and if it's really needed
17:31:06 <dustymabe> the question is: who asked for this to be set up initially? is anyone using it now ?
17:31:10 <dustymabe> should we be using it for testing?
17:31:39 <jbrooks> seems like something walters would like
17:31:42 <maxamillion> I don't know who asked for it
17:31:45 <jberkus> dustymabe: can we raise this with stefw?
17:31:53 <walters> for a development stream I find FAHC *much* more useful
17:32:21 <walters> i guess if we have this tree it raises the issue of sync with the daily composes
17:32:23 <maxamillion> FAHC?
17:32:29 <walters> maxamillion, https://pagure.io/fedora-atomic-host-continuous
17:32:33 <maxamillion> walters: ah
17:32:47 <dustymabe> walters: question of sync with the daily composes?
17:33:01 <walters> does the daily rawhide compose generate an ostree commit too?
17:33:07 <walters> with the same ref?
17:33:13 <dustymabe> walters: yeah, but in a different ostree repo I think
17:33:17 <walters> oh
17:33:24 <dustymabe> i don't think they overwrite each other but I could be wrong
17:33:25 <walters> another one of those =(
17:33:42 <dustymabe> so.. should we set up atomic-host-tests against this stream as well?
17:33:52 <dustymabe> or should we just drop it ?
17:34:13 <gholms> Is anyone going to fix them when they break?
17:34:25 <dustymabe> gholms: good question
17:34:32 <gholms> If it's perpetually going to get dropped on the floor then we may as well drop them.
17:34:38 <walters> of course if we *reverted* things that caused to break, i.e. made the tests meaningful, that's a totally different thing
17:35:03 <dustymabe> so the Fedora CI work probably encroaches on this question too
17:35:22 <dustymabe> we should probably drop this effort from releng in favor of the Fedora CI work
17:35:34 <walters> anyways i don't have a really strong opinion
17:35:58 <dustymabe> neither do I
17:36:03 <dustymabe> anyone else?
17:36:07 <dustymabe> maxamillion??
17:36:21 <maxamillion> yeah, I think that makes sense
17:36:28 <maxamillion> Fedora CI should really supercede this
17:36:41 <jlebon> i'd say if we're already busy with a-h-t on regular rawhide, then let's drop it for now?
17:36:43 <jberkus> ok, somebody want ot update the ticket?
17:36:51 <dustymabe> jberkus: i will
17:37:08 <jberkus> #chair jberkus dustymabe jbrooks ksinny maxamillion miabbott walters davdunc kushal gholms jlebon
17:37:08 <zodbot> Current chairs: davdunc dustymabe gholms jberkus jbrooks jlebon ksinny kushal maxamillion miabbott walters
17:37:18 <dustymabe> #action dustymabe to update the ticket regarding rawhide atomic-ci stream
17:37:18 <jberkus> ok, next ticket, Meeting Times
17:37:25 <jberkus> dustymabe: so what does the doodle say?
17:37:36 <dustymabe> jberkus: so i figured I'd give people another week to respond
17:37:43 <dustymabe> but I do want to discuss a few things
17:37:58 <dustymabe> 1. there was a question about whether we should move with daylight savings or not
17:38:24 <dustymabe> 2. I think we shouldn't implement the new meeting time until after daylight savings has changed (i.e. mid november)
17:38:47 <dustymabe> thoughts?
17:39:25 <jberkus> 2. yes
17:39:33 <gholms> Seems reasonable
17:39:40 <jberkus> 1. so non-DST makes things easier for Indians, but not for anyone else
17:40:11 <davdunc> 2. I think it’s good to wait. It’s not that far away.
17:40:12 <jberkus> I don't know about the rest of y'all, but most of my meetings for my employer are DST
17:40:22 <dustymabe> is India the only country of our contributors that don't observe DST ? I thought it was more
17:40:35 <jberkus> dustymabe: it's the only one where I know we have contributors
17:40:39 <jbrooks> Have we been moving already?
17:40:42 <dustymabe> ok
17:40:43 <jbrooks> I don't recall
17:40:46 <jberkus> we might have someone in Arizona we don't know about
17:40:52 <jbrooks> I know CentOS just sticks w/ UTC
17:41:06 <dustymabe> jbrooks: we have traditionally stuck with UTC
17:41:10 <gholms> So have we
17:41:12 <dustymabe> and not moved based on DST
17:41:28 <jbrooks> I'm fine w/ that -- I'm just wondering about time and how sleepy I'll be
17:41:36 <dustymabe> jberkus: is claiming this is actually more hurtful for the majority of our meeting attendees
17:41:40 <jbrooks> But the doodle looked all right
17:42:11 <jberkus> dustymabe: yes, because most of us in DST countries have other meetings, which are DST, and we can't steer them clear of conflicts if the meeting time "changes" twice a year.
17:42:31 <dustymabe> ksinny: sayan: i'd be interested in your input
17:42:38 <jberkus> counter-argument: DST doesn't change at the same time for all countries.  And maybe changing times twice a year spreads the conflict pain around
17:43:06 <jberkus> also kushal ^^^
17:43:08 * ksinny has got comfortable with current meeting time (17:00 UTC)
17:43:26 <ksinny> It works for me since it is after my dinner time
17:43:50 <dustymabe> ksinny: how do you feel about moving the meeting with DST vs sticking with UTC year round?
17:44:01 <gholms> Which DST transition?
17:44:06 <gholms> The US's?
17:44:20 <jberkus> gholms: yah, that's the other counter-argument
17:45:04 <ksinny> dustymabe: with current time, it will be a bit late with DST
17:45:09 <jberkus> ok, 2 more minutes on this?  just because we have some topics for open floor
17:45:44 <dustymabe> can we get some resolution on DST vs UTC?
17:46:01 * ksinny votes for UTC
17:46:07 <miabbott> +1 UTC
17:46:19 <kushal> UTC is the best.
17:46:23 <jbrooks> +1 UTC
17:46:29 <davdunc> +1 UTC
17:46:30 <jberkus> that seems determinative
17:46:32 <jberkus> UTC it is
17:46:33 <gholms> Heh
17:46:38 <dustymabe> ok
17:46:41 <dustymabe> i'll update the ticket
17:46:47 <dustymabe> jberkus: feel free to move on
17:46:52 <jberkus> ok
17:46:58 <jberkus> #topic Open Floor
17:47:00 <gholms> Re-selecting the meeting time semi-annually makes sense to me anyway, as people come and go.
17:47:06 <jberkus> davdunc: you had an update?
17:47:19 <davdunc> sure.
17:47:55 <davdunc> I have artwork for the publication of the cloud server and fah for AWS Marketplace lined up.
17:48:02 <kushal> Yay :)
17:48:42 <davdunc> I am working on scheduling availability in AWS MP for the end of Oct. release of F27.
17:49:03 <davdunc> should have more details for next week's meeting.
17:49:14 <dustymabe> davdunc: cool cool
17:49:18 <dustymabe> davdunc: so we release every two weeks
17:49:44 <dustymabe> is there a way to automated the process and have some status page that shows which marketplace images correspond to what public non-marketplace images?
17:49:54 <davdunc> dustymabe: the submission is a manual process for now. It's a limitation of MP. We'll just schedule it at this point.
17:50:10 <maxamillion> davdunc++
17:50:28 <davdunc> there is a application security test that each submission goes through.
17:50:32 <dustymabe> davdunc: ok, i just worry since it's every two weeks
17:50:41 <dustymabe> davdunc: we'll keep a tight feedback loop
17:50:51 <davdunc> agreed
17:51:02 <jberkus> MP?
17:51:10 <dustymabe> marketplace
17:51:11 <maxamillion> Marketplace
17:51:14 <jberkus> ah
17:51:14 <davdunc> jberkus: I abbreviated.
17:51:22 <jberkus> we should announce when it's available
17:51:34 <davdunc> for sure. I'll put together a blog post.
17:52:23 <davdunc> and fyi, it's a personal contribution, not directly tied to the day job.
17:52:34 <dustymabe> davdunc: +1
17:52:35 <jberkus> #action davdunc to blog AWS MP availability of FAH/Cloud.
17:52:45 <jberkus> davdunc: let's put it on the atomic blog then
17:52:48 <jberkus> makes that clear
17:52:52 <dustymabe> should we try to put out that blog on one of our platforms?
17:53:11 <dustymabe> jberkus: maybe it should be a fedora publication (i assume this applies to the base cloud images as well??)
17:53:12 <davdunc> dustymabe: that's where it belongs. IMO.
17:53:14 <kushal> dustymabe, We should share the link to the blog.
17:53:28 <jberkus> dustymabe: yah, maybe
17:53:33 <jberkus> however I have one more thing
17:53:47 <dustymabe> davdunc: can you update the atomic-wg ticket about marketplace with this information?
17:53:53 <davdunc> I can.
17:54:02 <jberkus> New Item: The server blades originally intended for FOSP are finally ready
17:54:14 <jberkus> this is ~~ 9mo after we wanted them
17:54:19 <jberkus> FOSP is no longer a thing
17:54:24 <gholms> Heh
17:54:29 <jberkus> so infra wants to know: what do we want to do with them?
17:54:55 <jberkus> testing?  openshift hosting?  something else?
17:55:24 <jbrooks> FOSP is no longer a time?
17:55:26 <jbrooks> thing
17:55:44 <jbrooks> I thought we were just waiting for hw all this time
17:56:00 <dustymabe> jberkus: 1. i think we should 1st decide if we want to give the hardware away, 2. find an appropriate candidate for the donation.
17:56:28 <dustymabe> we should probably work with matt miller and paul frields once we get to #2
17:56:31 <kushal> Fedora infra team maybe :)
17:56:31 <dustymabe> if
17:56:34 <jberkus> dustymabe: not really an option, they're blades and the chassis doesn't belong to us
17:56:41 <jberkus> oh, that kind of give
17:57:06 <davdunc> brb.. bird in the house.
17:57:06 <jberkus> jbrooks: well, most of the folks who were working on FOSP have moved on
17:57:49 <jberkus> I think we should exhaust testing/hosting options first before we give them away
17:57:50 <jbrooks> jberkus, Hmm, ok, I didn't realize it went away
17:57:52 <maxamillion> which was basically the concern of FOSP in the first place ... if someone left, who'd be left to manage it?
17:58:05 <jbrooks> Who was leading it?
17:58:13 <dustymabe> i think jzb to begin with
17:58:14 <jberkus> for example, if we did have a FAO cluster rebuilding every week
17:58:30 <jberkus> it could be used to test FLIBS containers for OpenShift, for example
17:58:51 <jberkus> as well as testing that FAO works every week
17:59:09 <jberkus> as an example
17:59:20 <dustymabe> yeah - going to take a bit of thought
17:59:27 <dustymabe> jberkus: let's get together and brainstorm
17:59:32 <dustymabe> maybe next week
17:59:33 <jberkus> ok, I'm going to raise it on atomic-devel
17:59:40 <jberkus> please comment
17:59:55 <jberkus> out of time now
17:59:59 <jberkus> #endmeeting