17:00:17 <jkurik> #startmeeting F27 Server Beta Go/No-Go meeting
17:00:17 <zodbot> Meeting started Thu Oct 12 17:00:17 2017 UTC.  The chair is jkurik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:17 <zodbot> The meeting name has been set to 'f27_server_beta_go/no-go_meeting'
17:00:23 <jkurik> #meetingname F27-Server-Beta-Go-No-Go-meeting
17:00:23 <zodbot> The meeting name has been set to 'f27-server-beta-go-no-go-meeting'
17:00:25 <contyk> hey
17:00:31 <langdon> .hello2
17:00:31 <jkurik> #topic Roll Call
17:00:32 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
17:00:33 <contyk> .hello psabata
17:00:34 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
17:00:38 <jkurik> .hello jkurik
17:00:41 <zodbot> jkurik: jkurik 'Jan Kurik' <jkurik@redhat.com>
17:00:48 <jkurik> #chair dgilmore nirik adamw sgallagh mboddu langdon
17:00:48 <zodbot> Current chairs: adamw dgilmore jkurik langdon mboddu nirik sgallagh
17:00:55 <mboddu> .hello mohanboddu
17:00:56 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
17:01:04 <jkurik> hi contyk, langdon, mboddu
17:01:16 <sgallagh> .hello2
17:01:17 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:01:17 <nirik> morning
17:01:21 <contyk> this will be short :)
17:01:42 <langdon> we can make it long!
17:01:47 <jkurik> we need someone from QA
17:01:54 <jkurik> adamw, kparal ?
17:01:58 <dgilmore> hola
17:02:03 <langdon> jkurik: they are a no-go.. they have no rc to qa
17:02:08 <dgilmore> adamw sends hi appologies
17:02:32 <dgilmore> but without a RC we are stuck
17:02:57 <jkurik> I have not seen adamw's appologies
17:03:11 <jkurik> ok, so moving on without QA
17:03:20 <jkurik> #topic Purpose of this meeting
17:03:30 <jkurik> #info Purpose of this meeting is to check whether or not F27 Server Beta is ready for shipment, according to the release criteria.
17:03:33 <dgilmore> jkurik: he sent it to me via telegram
17:03:39 <jkurik> #info This is determined in a few ways:
17:03:42 <dgilmore> jkurik: I was giving it for him
17:03:52 <jkurik> dgilmore: ok, thanks for passing the info
17:04:00 <jkurik> #info * Release candidate compose is available
17:04:05 <jkurik> #info * No remaining blocker bugs
17:04:11 <jkurik> #info * Test matrices for Beta are fully completed
17:04:16 <jkurik> #topic Current status
17:04:22 <jkurik> As far as I am aware, the RC for F27 Server Beta is not yet ready.
17:04:26 <jkurik> As such, we do not have test matrices for the RC.
17:04:28 <langdon> jkurik: correct
17:04:33 <jkurik> The lastest F27 nightly compose is available at https://kojipkgs.fedoraproject.org/compose/Fedora-Modular-27-20171011.n.0/compose/Server/
17:04:38 <langdon> oops.. you were listing the pain points
17:04:48 <jkurik> Anyone wants to add/correct something ?
17:05:04 <jkurik> langdon: what do you mean ?
17:05:11 <dgilmore> jkurik: We have some pieces to get into place to make the f27 nightlies more correct
17:05:19 <contyk> there's still some work that needs to be done
17:05:26 <jkurik> ah, ok
17:05:48 <dgilmore> get them on the mirrors and updateable
17:05:54 <contyk> I can list what I'm aware of but not everything is currently tracked in tickets
17:06:01 <langdon> jkurik: i thought you were "asking" about the rc vs "stating the list of blockers"
17:06:06 <jkurik> #info The RC for F27 Server Beta is not yet ready.
17:06:44 <langdon> and.. im having some trouble with my reading abilities
17:07:13 <contyk> if (heh) we're no-go today, are we postponing this to next week?
17:07:27 <jkurik> ok, so I am not going to put the link into minutes
17:07:49 <jkurik> contyk: wait a while, there is an order :-)
17:07:52 <dgilmore> contyk: standard process is slip everything a week
17:08:09 * contyk should have gone somewhere warm ;)
17:08:23 <jkurik> #topic Mini-Blocker Review
17:08:39 <jkurik> I am proposing to skip this as there is no RC and no QA representative
17:08:48 <langdon> +1
17:08:55 <jkurik> anyone is oposed and would like to lead the review ?
17:09:12 <dgilmore> do we have blockers tracked in teh blocker bugs app?
17:09:22 <contyk> +1 to skipping this but I wouldn't mind an action (even for myself) tomake sure everything is tracked in a ticket
17:09:26 <langdon> dgilmore: app? i have some of them in bz
17:09:37 <jkurik> dgilmore: yes, we have, however I am not sure whether we have all of them there
17:09:44 <langdon> but they are more like the "big ones" not the details
17:09:54 <dgilmore> langdon: https://qa.fedoraproject.org/blockerbugs
17:09:58 <jkurik> langdon: https://qa.fedoraproject.org/blockerbugs/milestone/27/beta/buglist
17:10:08 <langdon> ohh right.. gotcha
17:10:14 <dgilmore> jkurik: it should be a seperate milestone
17:10:24 <dgilmore> we should not confuse modular and traditional
17:10:39 <dgilmore> they are two different things with different blockers and release criteria
17:10:51 <jkurik> dgilmore: I have seen an email from adamw, that the blocker app does not support it and he needs to work on it somehow
17:11:03 <langdon> jkurik: we also have additions to this in "proposed state" on the wiki.. but we haven't had a chance to get them reviewed..
17:11:19 <dgilmore> jkurik: :( okay
17:12:23 <jkurik> #info The Mini-blocker review is skipped
17:12:39 <jkurik> #topic Test Matrices coverage
17:12:40 <jkurik> #info As there is no RC yet, Test matrices are not ready as well
17:12:42 <jkurik> #info We are skipping the Test Matrices coverage check
17:12:53 <jkurik> #topic Go/No-Go decision
17:13:02 <jkurik> QA is No-Go
17:13:09 <jkurik> I am No-Go
17:13:14 <dgilmore> Relng is no go
17:13:19 <dgilmore> Releng is no go
17:13:34 <jkurik> sgallagh: you are typically representing FESCo
17:13:52 <sgallagh> No go
17:13:57 <dgilmore> jkurik: I can spak for FESCo
17:14:02 <dgilmore> or sgallagh
17:14:07 <jkurik> dgilmore: ah, yes - sorry
17:14:16 <sgallagh> s'all good
17:14:19 <langdon> well.. sgallagh spoke.. but you can keep spak'ing ;)
17:14:46 <dgilmore> langdon: apparently i can not type today
17:14:55 * langdon everyday
17:14:59 <dgilmore> I hope it makes people giggle
17:15:10 <langdon> i did
17:15:18 <dgilmore> :D
17:15:21 <jkurik> contyk, langdon: as you are here, may I check with you you are ok with the No-Go decision ?
17:15:39 <langdon> jkurik: 100% .. but "ok" is not the right word :/
17:15:42 <contyk> I would vote no-go myself
17:15:57 * nirik looked away for a minute and we are no go... sheesh. ;)
17:15:58 <jkurik> langdon: yeah
17:15:59 <contyk> I would also vote for a two week slip :P
17:16:03 <dgilmore> we will come back next week and do it again
17:16:20 <langdon> dgilmore, contyk come on.. we can have faith
17:16:21 <jkurik> proposed #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week however due to “Rain date” feature we are not going to slip the Final GA.
17:16:31 <jkurik> may I have your acks, please ?
17:16:38 <sgallagh> ack
17:16:45 <langdon> jkurik: who acks?
17:16:48 <contyk> langdon: I have faith :)
17:16:51 <langdon> just the chairs right?
17:16:56 <dgilmore> langdon: I have faith it is to say we are go
17:17:01 <langdon> :P
17:17:05 <sgallagh> langdon: This is just for phrasing
17:17:07 <sgallagh> So anyone
17:17:15 <dgilmore> ack
17:17:27 <langdon> ack
17:18:18 <jkurik> langdon: we typicaly need QA, RelEng, FESCo and me to ack, but if anyone on this meeting has a better statement, I am fine to rephrase
17:18:42 <jkurik> #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week however due to “Rain date” feature we are not going to slip the Final GA.
17:18:49 <jkurik> #action jkurik to publish the Go/No-Go result
17:18:50 <langdon> jkurik: nope.. the language is good.. i was reading as "ack the stmt" not "ack the wording"
17:18:53 <dgilmore> jkurik: re reading
17:19:04 <dgilmore> jkurik: I would maybe say we will be taking the rain date
17:19:13 <dgilmore> for GA
17:19:17 <jkurik> #undo
17:19:17 <zodbot> Removing item from minutes: ACTION by jkurik at 17:18:49 : jkurik to publish the Go/No-Go result
17:19:18 <langdon> do we have to yet?
17:19:21 <jkurik> #undo
17:19:25 <dgilmore> langdon: yep
17:19:36 <langdon> that is gonna have a lot of impact
17:20:24 <dgilmore> https://fedoraproject.org/wiki/User:Langdon/Proposed_Modular_Server_Release
17:20:25 <jkurik> proposed #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week. As we are taking the "Rain date" feature we are not going to slip the Final GA.
17:20:36 <jkurik> dgilmore: better ? ^^^
17:20:42 <dgilmore> jkurik: no
17:20:46 <jkurik> :-(
17:21:23 <jkurik> dgilmore: may I ask you to write your proposal then, please ?
17:21:38 <dgilmore> proposed #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week. With the rain date feature we will move to the "Rain Date" schedule
17:21:42 <dgilmore> however
17:21:56 <dgilmore> its all awkward
17:22:06 <dgilmore> I am not a fan of the whole rain date thing
17:22:12 <dgilmore> I think its confusing
17:22:25 <contyk> let's deliver on Christmas
17:22:43 <jkurik> contyk: Christmas present ?
17:22:51 <langdon> proposed #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week. As a result we move to the "Rain Date" schedule.
17:22:56 <langdon> or
17:22:58 <contyk> jkurik: indeed :)
17:23:08 <jkurik> dgilmore: I would state the rain date applies for Beta only
17:23:22 <dgilmore> jkurik: there is no rain date in the Beta
17:23:27 <langdon> jkurik: that is not what he is asking for..
17:23:35 <langdon> he wants the ga to move to the rain date
17:23:37 <dgilmore> https://fedoraproject.org/wiki/User:Langdon/Proposed_Modular_Server_Release
17:23:58 <langdon> proposed #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week. As a result we move to the "Rain Date" schedule which has a new GA date of X/Y/Z.
17:24:07 <langdon> proposed #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week. As a result, we move to the "Rain Date" schedule which has a new GA date of X/Y/Z.
17:24:09 <jkurik> ah, right, there is no rain for Beta
17:24:11 * langdon missed a comma
17:24:21 <jkurik> I am sorry, I was confused...
17:25:04 <jkurik> #agreed Due to missing RC for the F27 Server Beta release the decision is “No Go”. The F27 Server Beta release slips for one week. As a result, we move to the "Rain Date" schedule which has a new GA date of 2017-Dec-12
17:25:31 <jkurik> #action jkurik to organize second round of Go/No-Go meeting for F27 Server Beta on Thursday, October 19th at 17:00UTC
17:25:33 <dgilmore> so given we have 5 weeks between Beta Go/NoGo and Final Go/NoGo we mayeb do not need to adjust final
17:25:38 <langdon> woah
17:25:43 <langdon> can we vote on that?
17:25:46 <dgilmore> normally we have 4 weeks
17:26:03 <jkurik> langdon: on what ?
17:26:09 <langdon> slipping the ga
17:26:48 <dgilmore> langdon: we probably need to redo https://fedoraproject.org/wiki/User:Langdon/Proposed_Modular_Server_Release
17:26:56 <dgilmore> and put in freeze points
17:27:29 <jkurik> langdon: that is how we typicaly deal with slips. Changing the schedule needs FESCo approval
17:27:53 <dgilmore> langdon: I will reopen the schedule ticket
17:28:42 <langdon> jkurik: i am fairly sure the slipped beta date did not slip the proposed traditional release date during the first go/nogo
17:28:58 <jkurik> ok, so I will leave it as it is now, and we will let FESCo to adjust on the meeting tomorrow, if needed
17:29:19 <nirik> yeah, I thought we had a beta 'rain date' too.
17:29:28 <jkurik> langdon: because there was rain date for Beta
17:29:44 <jkurik> for modular server we do not have approved rain date
17:29:45 <langdon> me too.. i wonder if it got lost in all the rewriting i was doing live in the fesco meeting
17:29:46 <jkurik> for beta
17:30:40 <dgilmore> langdon: https://fedoraproject.org/wiki/Releases/27/Schedule final dates have all moved
17:31:12 <langdon> meh.. not how i remember it.. not worth arguing about..
17:31:13 <jkurik> langdon: I think you can ask FESCo to accept a rain date for the modular server beta, on the meeting tomorrow
17:31:48 <langdon> jkurik: understood
17:31:58 <nirik> dgilmore: we have slipped multiple times.
17:32:09 <nirik> if we only slipped one week at beta we could have used the beta rain date
17:32:19 <nirik> but we slipped 3? or 4?
17:32:25 <dgilmore> sure
17:33:09 * langdon is just worried about a hardware snafu in ~dec causing an impact on the rain date
17:33:26 <langdon> but.. like i said.. meh.. i bet if everything is working we can release early ;)
17:33:45 <jkurik> proposed #info langdon is going to ask FESCo to accept "Rain Date" for F27 Server Beta release to move the F27 Server GA back to 2017-Nov-28
17:33:56 <jkurik> langdon: may I put this into minutes ? ^^^
17:34:19 <langdon> jkurik: sure
17:34:27 <jkurik> #info langdon is going to ask FESCo to accept "Rain Date" for F27 Server Beta release to move the F27 Server GA back to 2017-Nov-28
17:34:34 <jkurik> #topic Open floor
17:34:44 <dgilmore> https://pagure.io/fesco/issue/1775#comment-472252
17:34:46 <jkurik> anything else for today's meeting ?
17:34:53 <dgilmore> taken the issue to FESCo
17:35:15 <jkurik> #undo
17:35:15 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x4b877110>
17:35:20 <jkurik> #link https://pagure.io/fesco/issue/1775#comment-472252
17:35:23 <jkurik> #topic Open floor
17:35:29 <jkurik> dgilmore: thanks
17:35:40 <dgilmore> Please be testing all
17:36:18 <langdon> i have nothing for open floor
17:36:30 * bowlofeggs decides to test dgilmore's patience…
17:36:33 <contyk> This is fine
17:36:50 <langdon> ohhh.. do we want to mention bodhi here?
17:36:55 <dgilmore> #info please be testing and find all the bugs so they get fixed sooner
17:36:59 <langdon> as one of the blockers for modular release?
17:37:07 <bowlofeggs> yeah bodhi still isn't quite ready
17:37:10 * dgilmore goes to find the bugs in bodhi to keep bowlofeggs busy :P
17:37:16 <bowlofeggs> i'm actually working on that patch right now, in fact
17:37:26 <bowlofeggs> https://github.com/fedora-infra/bodhi/pull/1697
17:37:31 <bowlofeggs> i think it's pretty close
17:37:37 <bowlofeggs> but there are still some loose ends to tie
17:37:42 <langdon> there is a bz blocking the change.. so it is tracked.. but we didn't mention it.. that's all
17:37:54 <bowlofeggs> it's reasonable to think we might could get this released early next week
17:38:04 <bowlofeggs> dgilmore: :)
17:38:52 <jkurik> #link https://github.com/fedora-infra/bodhi/pull/1697 - a Bodhi issue blocking the F27 Server Beta release
17:38:53 <langdon> i am actually having the team make sure there are bugs and how to fix them on everything we know about so we can better ask for help
17:39:09 <langdon> dgilmore: ^^
17:39:18 <bowlofeggs> i will help make sure there are bugs
17:39:29 * bowlofeggs goes to write True = False in bodhi's __init__.py…
17:39:29 <dgilmore> langdon: excellent
17:40:00 <langdon> always that chicken and egg problem of .. do you spend time fixing bugs or spend time making it so other people can fix bugs
17:40:16 <dgilmore> langdon: both :D
17:40:36 * langdon looks for dgilmore's time machine in scrollback
17:40:50 <jkurik> In case no one has anything else, I am going to close the meeting in one minute
17:40:57 <langdon> +1
17:41:18 <dgilmore> langdon: i borrowed it from hermione
17:41:27 <dgilmore> its small you will have to come here
17:42:02 <langdon> ha
17:42:04 <jkurik> #endmeeting