17:02:53 <jberkus> #startmeeting atomic_wg
17:02:53 <zodbot> Meeting started Wed Oct 25 17:02:53 2017 UTC.  The chair is jberkus. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:53 <zodbot> The meeting name has been set to 'atomic_wg'
17:03:04 <jberkus> #topic roll call
17:03:07 <dustymabe> .hello dustymabe
17:03:08 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:03:09 <jberkus> .hello jberkus
17:03:09 <davdunc> .hello davdunc
17:03:12 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:03:13 <strigazi> .hello strigazi
17:03:15 <zodbot> davdunc: davdunc 'David Duncan' <davdunc@amazon.com>
17:03:16 <ksinny> .hello sinnykumari
17:03:17 <zodbot> strigazi: strigazi 'Spyros Trigazis' <strigazi@gmail.com>
17:03:20 <zodbot> ksinny: sinnykumari 'Sinny Kumari' <ksinny@gmail.com>
17:03:20 <dustymabe> strigazi: \o/
17:03:25 <dustymabe> ksinny: \o/
17:03:33 <miabbott> .hello miabbott
17:03:35 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
17:03:36 <ksinny> dustymabe: Hey!
17:03:45 <jbrooks> .fas jasonbrooks
17:03:45 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:03:52 <ashcrow> .hello smilner
17:03:53 <zodbot> ashcrow: smilner 'None' <smilner@redhat.com>
17:04:08 <dustymabe> a good crowd here today
17:04:12 <maxamillion> .hello maxamillion
17:04:13 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:04:14 <dustymabe> no troublemakers so far
17:04:22 <maxamillion> UNTIL NOW
17:04:24 <dustymabe> ;-P
17:04:25 <maxamillion> >.>
17:04:27 <maxamillion> :)
17:05:16 <jberkus> #chair dustymabe jbrooks ashcrow ksinny miabbott strigazi davdunc
17:05:16 <zodbot> Current chairs: ashcrow davdunc dustymabe jberkus jbrooks ksinny miabbott strigazi
17:05:27 <jberkus> #chair jbrooks
17:05:27 <zodbot> Current chairs: ashcrow davdunc dustymabe jberkus jbrooks ksinny miabbott strigazi
17:05:45 <jberkus> #topic action items from last meeting
17:06:37 <jberkus> first ones are mine
17:06:48 <jberkus> jberkus to raise kube installation issues with openshift installer team
17:06:56 <jberkus> that's in progress with Jbrooks etc.
17:07:09 <jberkus> jberkus to follow up on images from Flock container workshop
17:07:24 <jberkus> I've been working on these, and a couple of procedural issues have come up
17:08:01 <jberkus> 1. it would be really nice if we had a fedora-owned place to upload files for the container image submissions, and
17:08:19 <jberkus> 2. it would be really nice if that place allowed minor edits by reviewers (ala Gist)
17:08:45 <jberkus> it seems really stupid for me to need to tell a submitter "hey, can you fix the smartquote characters in your dockerfile"?
17:09:41 <jbrooks> PRs to a repo in pagure?
17:09:49 <jberkus> that would work for me
17:09:59 <jberkus> it's also WAY easier for me to track pagure than bugzilla
17:10:51 <dustymabe> jberkus: can you put the new repo under the 'atomic' group like we did for kube?
17:11:00 <jberkus> sure
17:11:03 <jberkus> maxamillion: comment?
17:11:04 <dustymabe> https://pagure.io/atomic/kubernetes-sig
17:12:12 <jberkus> waiting for maxamillion to comment, and then I'll action myself
17:12:17 <jberkus> then 3.
17:12:32 <maxamillion> eh
17:12:42 <maxamillion> yeah, that's fine
17:13:04 <maxamillion> is there an open source solution that would be gist-esque and would fill that need? we could request the infra team to host it
17:13:22 <jberkus> I think we should add at least a *narrative* testing procedure to the submission requirements
17:13:38 <jberkus> like, dan walsh submitted a logorotate container, but I'm not clear on how to test it
17:14:03 <jberkus> scriptable tests would be even better, but that's a huge unresolved issue for this
17:14:04 <maxamillion> jberkus: also that
17:14:48 <jberkus> maxamillion: I don't know.  I agree that it would be better because asking submitters to create a PR in pagure and then an issue in bugzilla seems dumb
17:15:16 <jberkus> maxamillion: question: is there a fedora technical or policy reason we must use bugzilla?
17:15:52 <maxamillion> jberkus: I honestly don't know
17:16:11 <jberkus> because the easy-for-submitters route would be to move the whole thing to pagure
17:16:12 <davdunc> I would have thought it made the requests searchable for the people tracking next gen product management.
17:16:38 <jberkus> (well, the *really* easy would be to use github, but I know that's against policy)
17:17:34 <jberkus> davdunc: is that something you can verify?
17:18:02 <davdunc> jberkus: it is.
17:18:07 <jbrooks> I'm pretty much always happier not interacting w/ bugzilla ;)
17:18:21 <jberkus> #action jberkus to find place to host editable dockerfiles/readmes for container submissions
17:18:35 <jberkus> #action davdunc to verify whether we're required to use bugzilla
17:18:40 <maxamillion> jberkus: I agree it would be easier to do a PR of some sort
17:18:46 <jberkus> how do I remove an action?
17:18:59 <maxamillion> jberkus: I think some of it is tooling, there's a lot of tooling that would have to migrate out of BZ
17:19:00 <dustymabe> hashtag undo?
17:19:05 <jberkus> #undo
17:19:05 <zodbot> Removing item from minutes: ACTION by jberkus at 17:18:35 : davdunc to verify whether we're required to use bugzilla
17:19:12 <jberkus> #action davdunc to verify whether we're required to use bugzilla for container submissions
17:20:06 <jberkus> ok, moving on
17:20:25 <jberkus> dustymabe to update the rolling release plan with info about f27ah
17:20:54 <jberkus> dustymabe: ?
17:21:20 <dustymabe> jberkus: i just opened this ticket: Issue #365: Article for F27: Fedora 26->27 Atomic Host Upgrade Guide
17:21:32 <dustymabe> https://pagure.io/atomic-wg/issue/365
17:21:39 <dustymabe> the plan is to update people there
17:21:52 <jberkus> ok
17:22:08 <dustymabe> i'll assign myself that ticket
17:22:13 <strigazi> I can help test/review that
17:22:18 <jberkus> jbrooks to email fedora-devel with issue of needed deps for asciibinder container
17:22:19 <dustymabe> thanks strigazi
17:22:24 <jberkus> jbrooks: ?
17:22:28 <jbrooks> I did that
17:22:37 <jberkus> jbrooks: any response?
17:22:46 <jbrooks> #info jbrooks msg to fedora devel about asciibinder https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/4U3C4EMLFZIHK3Q5NT5PA2WPOXAMAUPD/
17:22:54 <jbrooks> Yeah, it was pretty fruitful
17:23:03 <maxamillion> strigazi++ dustymabe++
17:23:04 <zodbot> maxamillion: Karma for strigazi changed to 2 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:23:16 <jbrooks> Matthew Miller had put out a call on the ruby-sig
17:23:30 <jbrooks> Someone made a pkg, is asking for testing: https://lists.fedoraproject.org/archives/list/ruby-sig@lists.fedoraproject.org/message/HI5UZHSDQB5BRLKBXZWOC3YCND7BACGU/
17:23:43 <jbrooks> He cut out a bunch of the deps, so he's wondering if it'll still work
17:23:55 <jbrooks> So we could test that and get back to him
17:23:57 <jberkus> ok
17:24:30 <dustymabe> jbrooks++
17:24:35 <jbrooks> And for the issue of was it worth it, people were like: yay rpms!
17:24:36 <jbrooks> so
17:24:37 <jbrooks> :)
17:24:37 <dustymabe> i'm glad the email was fruitful
17:24:52 <jberkus> #action jbrooks jberkus to test asciibinder rpm
17:25:05 <jberkus> strigazi to do some testing around upgrades from f26 to f27 with kubernetes
17:25:07 <jberkus> strigazi: ?
17:26:03 * strigazi is writing..
17:27:03 <strigazi> I deployed kubernetes in single node - single master cluster with system container (based on kube 1.8.0) and
17:27:29 <strigazi> upgraded successfully from f26 to f27.
17:27:48 <strigazi> etcd and flannel where running from the host rpms
17:28:05 <strigazi> the kubernetes contairners where the same
17:28:20 <strigazi> rawhide-based
17:28:41 <strigazi> so, no problems, the upgrade for kube worked
17:28:43 <dustymabe> strigazi: i wonder if we do the same with our f26 based containers if we'll be good
17:28:49 <dustymabe> strigazi: that's aweseom news
17:28:55 <jberkus> yay!
17:29:12 <jberkus> strigazi: do you have a doc of the steps you took?
17:29:33 <strigazi> No, I can run something down tmr
17:29:48 <strigazi> I'll open an issue in kubernetes-sig
17:30:02 <jbrooks> strigazi, did you install flannel and etcd via layering?
17:30:19 <strigazi> yes
17:30:54 <strigazi> I can try again by running everything in system containers, makes more sense
17:30:58 * dustymabe notes we are 30 minutes in and still on previous meeting action items
17:31:20 <jberkus> there were alot of them
17:31:46 <jbrooks> I did that upgrade, there's a wrinkle in the etcd data dir that'll need documenting
17:31:58 <jberkus> ok, sounds good
17:32:20 <jberkus> #action strigazi jbrooks to document the steps they took for f27 kube upgrade
17:32:32 <jberkus> davdunc to blog AWS MP availability of FAH/Cloud.
17:32:34 <jberkus> davdunc: ?
17:33:16 <dustymabe> jberkus: sounds like we should add that as a "Article for F27:" ticket
17:33:24 <davdunc> still working on availability. We are in the final stages, but there were some issues related to using fedora project URLs and those not matching.
17:33:41 <jberkus> dustymabe: more, it should be part of this ticket: https://pagure.io/atomic-wg/issue/365
17:33:42 <davdunc> not matching my email domain account.
17:33:59 <jberkus> davdunc: ah.  anything anyone else can fix?
17:34:17 <dustymabe> jberkus: doesn't seem like that should be part of an 'upgrade' article
17:34:47 <davdunc> jberkus: I have it in hand. Matt and I anticipated some of these issues, so I have all the requirements for legal in the pipeline.
17:35:00 <jberkus> dustymabe: oh, wait, no, here: https://pagure.io/atomic-wg/issue/355
17:36:05 <jberkus> davdunc: thanks
17:36:31 <dustymabe> jberkus: i still don't see how aws marketplace has anything to do with migrating kube
17:36:32 <davdunc> I'll have a blog ready for Friday. I'll reach out for edits.
17:36:50 <jberkus> dustymabe: what?  no, that was for the prior item
17:37:01 <jberkus> davdunc: cool, thanks!
17:37:41 <jberkus> ok, before we get into tickets
17:37:46 <jberkus> #topic new meeting time
17:37:51 <jberkus> dustymabe: ?
17:38:15 <dustymabe> #info ok it looks like the time that was top voted (with 9 votes) was: 16:30 UTC (11:30 EST / 18:30 CEST / 22:00 IST)
17:38:31 <dustymabe> I was planning to do a 'runoff' doodle but then some more people voted and we had a majority
17:38:51 <dustymabe> I also talked with a few people who voted no and they said they should be able to make it work
17:39:05 <jberkus> great
17:39:12 <jberkus> what date is the first meeting at that time?
17:39:18 <ksinny> cool
17:39:21 <dustymabe> I said  November 8th in the ticket
17:39:33 <dustymabe> any opposition?
17:39:45 <ashcrow> none here +1
17:39:57 <jberkus> how about instead
17:40:00 <jberkus> all in favor?
17:40:03 <jberkus> +1
17:40:07 <ashcrow> +1
17:40:07 <dustymabe> +1
17:40:08 <miabbott> +1
17:40:09 <ksinny> +1
17:40:10 <davdunc> +1
17:40:16 <jbrooks> +1
17:40:53 <jberkus> ok, new meeting time approved
17:41:00 <jberkus> #action dustymabe to broadcast out new meeting time
17:41:27 <jberkus> #topic open tickets
17:41:47 <dustymabe> jberkus: let's cover the 'article' tickets real quick
17:41:52 <jberkus> first, there are a bunch of tickets open for articles/docs we want/need to have for f27
17:41:53 <jberkus> https://pagure.io/atomic-wg/issues?status=Open&tags=meeting&search_pattern=Article+for+F27
17:42:32 <dustymabe> can we get volunteers for ones that aren't assigned?
17:42:49 <maxamillion> +1
17:42:55 <dustymabe> ashcrow: miabbott strigazi maxamillion ?
17:42:56 <maxamillion> sorry, reading backlog ... multitasking badly
17:43:11 <maxamillion> dustymabe: I'll pick one up
17:43:13 <dustymabe> ksinny: it might be nice if we could have an article about mutli-arch enablement as well
17:43:14 * strigazi is looking
17:43:27 <ashcrow> I'll take the system containers one
17:43:40 <jberkus> ashcrow: please go ahead and assign the ticket to yourself
17:43:42 <dustymabe> *sold* to ashcrow
17:43:44 <ashcrow> will do
17:43:47 <ashcrow> \o/
17:43:54 <miabbott> i'll take the cockpit one
17:44:05 <dustymabe> woot!
17:44:10 <dustymabe> this is exciting
17:44:14 <strigazi> ashcrow: got first. dustymabe what is left? cockpit?
17:44:24 <davdunc> dustymabe I'll add a ticket for the AWS MP blog and tag it appropriately for tracking
17:44:30 <dustymabe> davdunc: thanks
17:44:31 <ksinny> dustymabe: yes, I will do one for multi-arch
17:44:38 <dustymabe> strigazi: jbrooks has two assigned to him for kube stuff
17:44:45 <dustymabe> do you mind helping him with those? or taking one from him
17:44:56 <jberkus> ksinny: can you create a ticket for that one?
17:45:08 <strigazi> ok, I'll talk with him about it
17:45:09 <ksinny> jberkus: yes, I will
17:45:15 <jberkus> ok, I'll work on editing all of these articles
17:45:25 <jberkus> in addition to the general "features" article
17:45:46 <ashcrow> jberkus / dustymabe: FYI I will need access to the space to be able to assign myself :-) https://pagure.io/atomic-wg
17:45:46 <jberkus> when anyone has a completed draft, please email it to me, unless it's going in pa.io blog, in which case just create a PR
17:45:55 <dustymabe> ashcrow: i'll fix that
17:46:04 <ashcrow> dustymabe: thanks!
17:46:25 <ksinny> #action Open a ticket to write a blogpost on mutli-arch enablement in F27 Atomic
17:46:29 <miabbott> ashcrow: i got you
17:47:06 <ashcrow> miabbott: thanks :-)
17:47:46 <jberkus> ok, more meeting tickets
17:47:54 <jberkus> I'm going to go from easy --> hard
17:47:58 <dustymabe> jberkus: one sec
17:48:16 <dustymabe> who all is chair? i.e. was ksinny's #action valid?
17:48:25 <jberkus> not sure
17:48:32 <jberkus> ksinny is on the list
17:48:32 <dustymabe> #chair jbrooks
17:48:32 <zodbot> Current chairs: ashcrow davdunc dustymabe jberkus jbrooks ksinny miabbott strigazi
17:48:39 <dustymabe> ok looks good
17:48:44 <ksinny> :)
17:49:02 <jberkus> remove & replace fedora images on docker hub: https://pagure.io/atomic-wg/issue/362
17:49:20 <jberkus> there's 100% agreement that we're going to wipe out the existing images there and start over
17:49:50 <jberkus> then start syncing flibs to there
17:50:04 <jberkus> so taking meeting tag off that one
17:50:34 <jberkus> overhaul members list, quorum rules: https://pagure.io/atomic-wg/issue/363
17:50:44 <jberkus> I'd like to table that issue until next meeting
17:50:49 <jberkus> as more people need to comment on it
17:50:56 <maxamillion> jberkus: +1
17:50:58 <jberkus> and update their own group membership
17:51:33 <jberkus> this issue remains unresolved: https://pagure.io/atomic-wg/issue/360
17:51:46 <jberkus> do we want to schedule a meeting specifically around it?
17:52:19 <jberkus> that's the "how do we include CRI-O etc. in Fedora Atomic"
17:52:30 <maxamillion> yeah, we might need to
17:52:38 <dustymabe> jberkus: yes. I had planned to try to set something up but I've effectively been 'out' the past 3 business days
17:52:44 <maxamillion> and likely schedule a VFAD later to get work done towards it
17:52:52 <jberkus> ok
17:53:08 <jberkus> #action dustymabe to schedule container-runtimes meeting
17:53:19 <jberkus> finally, one we can discuss here:
17:53:34 <jberkus> https://pagure.io/atomic-wg/issue/351
17:53:56 <dustymabe> atomic working group talks/sessions for devconf.cz
17:54:05 <dustymabe> maxamillion: ^^
17:54:09 <dustymabe> walters: ^^
17:54:17 <dustymabe> jbrooks, everyone else
17:54:22 <dustymabe> what are we planning to submit?
17:54:48 <maxamillion> dustymabe: I won't be at devconf.cz this year, I have a kid on the way that's due a week and a half after devconf ... too close for comfort
17:54:51 <jberkus> for this meeting, I'd like to discuss ... what do we *really really want* to be part of devconfcz?
17:55:08 <dustymabe> maxamillion: I see, congrats!
17:55:15 <maxamillion> dustymabe: thanks :)
17:55:41 <dustymabe> jberkus: what do you think should be the answer to that question?
17:55:57 <jberkus> well, I'd like your 101 workshop to be part of things
17:56:09 <dustymabe> ok, already planned to submit it
17:56:13 <jberkus> do we want to do another container-maintainer workshop?
17:56:27 <jberkus> with a fallback to a talk if the workshop doesn't get accepted?
17:56:59 <dustymabe> jberkus: seems reasonable
17:57:28 <dustymabe> strigazi: would you be able to come to devconf
17:57:41 <dustymabe> you and jbrooks could do a kubernetes/system containers on atomic host talk
17:57:41 <walters> i'm thinking of doing an rpm-ostree one
17:57:46 <dustymabe> walters++
17:57:47 <zodbot> dustymabe: Karma for walters changed to 2 (for the f26 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:57:50 <jberkus> what other technology do we want to spread around our dev communty?  system containers?  multiarch?
17:57:51 <strigazi> dustymabe I'll ask, chances might be slim
17:58:03 <jberkus> walters: with all the new commands?  would be good
17:58:14 <dustymabe> strigazi: it's in europe so maybe that helps
17:58:27 <jbrooks> I haven't yet planned to go to devconf -- I guess it would be worthwhile?
17:58:27 <strigazi> dustymabe depends on the budget of the deparment at that time
17:58:42 <davdunc> I'm available to help with slides, cloud demo, related content, etc. If anyone wants support.
17:58:42 <jberkus> unfortunately, it's at the end of the fiscal year so Atomic community money is running low
17:58:54 <dustymabe> davdunc: :)
17:58:55 <jberkus> but I can probably get one community member there, especially if they're giving a talk
17:59:12 <dustymabe> jberkus: fedora also has budget for speakers sometimes
17:59:12 <jberkus> davdunc: are you planning on going?
17:59:25 <davdunc> i'll be there.
17:59:34 <davdunc> I have some submissions for Openshift already.
17:59:37 * dustymabe likes having davdunc around
17:59:50 <dustymabe> davdunc: should we add those submissions to our list?
17:59:51 <maxamillion> I have to drop, I have another meeting
17:59:55 <jberkus> davdunc: ok.  would it be worthwhile to do some kind  of "FAO on AWS" thing?
18:00:12 <davdunc> :-) yes. I would be glad to do it.
18:00:17 <jberkus> sorry we're not making it to open floor, did anyone have something urgent?
18:00:24 * ksinny thinks that it is difficult to have a talk dedicated to multi-arch :/
18:00:38 <dustymabe> jberkus: i did have an FYI
18:00:39 <jberkus> davdunc: let's sync up, I can see submitting both a workshop and a talk
18:00:43 <jberkus> dustymabe: go ahead
18:00:51 <dustymabe> jberkus: is it worth trying to submit a "state of Fedora Atomic" talk?
18:00:54 <strigazi> jberkus If you were refering to me before, I'll try think of something
18:00:55 <davdunc> jberkus: sounds great.
18:01:12 <dustymabe> jberkus: my FYI is that we are now using pungi for bodhi updates within fedora
18:01:30 <jberkus> ksinny: mostly, I'd think you'd be talking about the status of the effort.  you could even co-present with CentOS multi-arch folks
18:01:30 <dustymabe> this means that we now can enable updating our multi-arch ostrees
18:01:36 <dustymabe> as well as atomic workstation ostrees
18:01:40 <jberkus> yay!
18:01:47 <dustymabe> as well as give us better ostree versioning
18:02:02 <jberkus> dustymabe: do we want to submit something on fedora releng for atomic?
18:02:02 <dustymabe> so wins all around
18:02:06 <davdunc> +1 for state of...
18:02:13 <dustymabe> to devconf?
18:02:29 <dustymabe> ehh, I think that would be more part of a larger talk if we did it
18:02:32 <jberkus> yah.  too fedora-specific?
18:03:18 <ksinny> Hmm, I will see what I can do here
18:03:28 <dustymabe> either we could add it to a fedora releng talk that was already being given
18:03:35 <dustymabe> or we could add it to the state of fedora atomic talk
18:04:45 <jberkus> I'm not sure how I feel about state of atomic talk
18:04:53 <jberkus> those tend to be kind of boring for attendees
18:05:21 <dustymabe> unless they're interesting in the improvements we've made over the past year
18:05:41 <dustymabe> i tend to like those better than some more detailed talks
18:06:09 <dustymabe> ok should we end this thing?
18:06:11 <dustymabe> over time
18:06:13 <jbrooks> What's the audience for devconf? Is it mostly RHers?
18:06:25 <jbrooks> That's my perception, but maybe I'm wrong
18:06:31 <jberkus> jbrooks: RHers, friends, European hackers
18:06:59 <jberkus> contributors to RH-sponsored projects
18:07:09 <jberkus> ok, let's take this back to #atomic
18:07:16 <jberkus> #endmeeting