21:01:01 <sgallagh> #startmeeting Fedora Server SIG Weekly Meeting (2017-11-07)
21:01:01 <sgallagh> #meetingname serversig
21:01:01 <sgallagh> #topic Roll Call
21:01:01 <zodbot> Meeting started Tue Nov  7 21:01:01 2017 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:01:01 <zodbot> The meeting name has been set to 'fedora_server_sig_weekly_meeting_(2017-11-07)'
21:01:01 <zodbot> The meeting name has been set to 'serversig'
21:01:05 <sgallagh> .hello2
21:01:06 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
21:01:44 <nirik> morning
21:01:53 <langdon> .hello2
21:01:54 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
21:02:17 <adamw> .hello adamwill
21:02:17 * langdon does wonder why ".hello w/o params" couldn't just be .hello2 ..
21:02:17 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
21:05:42 <sgallagh> smooge said he might be a few minutes late.
21:05:55 <sgallagh> I suppose we can get started; we have a lot to cover today.
21:06:01 <sgallagh> #topic Agenda
21:06:18 <sgallagh> I have four items for the agenda, in decreasing order of urgency:
21:06:22 <sgallagh> #info Agenda Item: What do we do for upgrades?
21:06:26 <sgallagh> #info Agenda Item: Name of the Edition
21:06:29 <sgallagh> #info Agenda Item: Final Release Criteria for modularity
21:06:34 <sgallagh> #info Agenda Item: Testing requested on Beta RC
21:06:40 <sgallagh> Oops, those last two should be reversed
21:07:40 <sgallagh> Actually, I also have a blocker candidate we can probably do a quick vote on so I can push the fix ASAP
21:07:54 <sgallagh> #info Agenda Item: Beta Blockers
21:08:01 <sgallagh> OK, let's get started.
21:08:05 <sgallagh> #topic What do we do for upgrades?
21:08:12 <sgallagh> Let me set the stage for you:
21:08:50 <sgallagh> Fedora 27 traditional looks likely to hit GA on Thursday.
21:09:15 <sgallagh> We have at least one bug in the queue that would have been a blocker for F27 Server upgrades if we were continuing with the traditional path.
21:09:39 <sgallagh> We have no planned (or realistic) upgrade path from F26 Server Edition to the F27 Modular Server
21:09:55 <langdon> sgallagh: that has always been the plan.. with a goal of upgrades by f28
21:10:00 <langdon> i think it is even in the change
21:10:03 <sgallagh> How should we treat things when users of F26 Server Edition type `dnf system-upgrade`?
21:10:14 <sgallagh> langdon: Yes, but we kind of handwaved the important details.
21:10:25 <langdon> i thought we expected them to upgrade to non-edition based on the everything repo
21:10:26 <sgallagh> Like: Are upgrade bugs along the traditional path still blocking?
21:10:44 <langdon> ahh .. that one.. hmm.. we did not cover that
21:10:45 <sgallagh> langdon: That's one way we can handle it
21:11:03 <adamw> langdon: all upgrades always use the 'everything' repo.
21:11:08 <adamw> that's what fedora.repo points to.
21:11:12 <langdon> right
21:11:21 <sgallagh> adamw: "non-edition" is the operative term there
21:11:41 <langdon> i guess we would need to do "something" to convert it to a non-edition..
21:11:44 <sgallagh> I think if we go that route, we *really* should convert the system back to non-edition Fedora rather than still keep claiming to be Fedora Server
21:11:56 <langdon> is mattdm around ? i am pretty sure he put the plan in a blog post :)
21:12:05 <adamw> yeah, i meant to ping him
21:12:25 <adamw> so the perspective i wanna keep in mind here is the person with a Fedora 26 Server system installed
21:12:29 <adamw> what is our message to that person?
21:12:37 <adamw> should they upgrade to 27? if so, when? what are the consequences of doing so?
21:12:53 <sgallagh> adamw: "Nice to see a fellow Red Hatter"?
21:12:58 <sgallagh> (sorry)
21:13:23 <langdon> https://fedoramagazine.org/where-is-fedora-server-27-beta/
21:13:41 <sgallagh> "When general F27 is released, do a normal dnf system-upgrade — this will get you a non-modular system updated with Fedora 27 packages."
21:13:44 <langdon> yeah.. he says right in there what the plan is :)
21:13:53 <adamw> but that's just presented as one of three options
21:13:54 <langdon> details details on making it true :)
21:13:57 <adamw> which, yes, those are your choices
21:14:02 <nirik> IMHO we need to be carefull here because I think lots of people think of "server" as just the install thing thats not workstation or cloud... they don't use rolekit or anything,
21:14:07 <adamw> but it kinda ducks out of saying which of those things we actually *suggest*
21:14:14 <adamw> and how much we are going to care about you if you *do* upgrade
21:14:26 <sgallagh> adamw: True, but it *does* say that if you upgrade, it should be expected to succeed and get F27 packages
21:14:34 <langdon> adamw: you care about everyone equally!
21:14:38 <sgallagh> It doesn't require us to still be Server Edition, but the upgrade should work
21:14:51 <nirik> if we are going to switch them from server to nonedition we have to have another rc for f27 traditional right?
21:14:56 <adamw> langdon: this clearly isn't true...for instance, i barely care about you at all! :P
21:15:06 <sgallagh> nirik: Not necessarily; it can be a 0day blocker
21:15:26 <sgallagh> As long as the necessary patch to fedora-release is stable before release day, it wouldn't require a respin
21:15:34 <adamw> we've fairly solidly established the precedent by now that we don't really block the media for upgrade issues
21:15:37 <langdon> adamw: i thought you were special. /me notes that the "you" was specifically about adamw, not a "directive you" .. sometimes langdon hates english
21:15:55 <adamw> since it's very difficult to do an upgrade using only the frozen release packages, and we really don't advise anyone to do it or document it anywhere
21:15:59 <sgallagh> I *think* we can do it with Obsoletes:, but I'm not tremendously confident in getting it right on short notice.
21:16:16 <adamw> (well, i guess not 'very difficult', it'd just be a --disablerepo=updates ... but we definitely don't advise it anywhere)
21:17:58 <adamw> what does implementing a transition to non-edition on upgrade actually get us, practically speaking, that's worth the effort of trying to rush it in late?
21:18:06 <sgallagh> The simplest option is just just declare that upgrade bugs don't block F27 traditional and not try to rush the Obsoletes: fix in time for release day.
21:18:21 <adamw> are we locking ourselves into any terrible commitment by just letting upgraded installs still call themselves Server? is anyone gonna care a lot?
21:18:31 <sgallagh> adamw: It's mostly just a user-confusion thing.
21:18:40 <adamw> sgallagh: that's simple for *us*, but it'll require messaging from others
21:18:49 <sgallagh> At this point I doubt it outweighs the costs and risks
21:19:13 <adamw> if one of the decisions we make is "we're not committing to upgrades from 26 Server to 27 working as we intend on 27 release day", that needs to be communicated properly
21:19:21 <sgallagh> Yes
21:19:50 <sgallagh> Another choice we *could* make is "Upgrades from F26 Server are not officially supported in any capacity, you get to keep the pieces, etc."
21:20:38 <nirik> which is the kind of thing that someone who installed f26 on their router will see and panic on... ;)
21:20:41 <sgallagh> This again requires messaging, of course
21:20:47 <adamw> yeah.
21:20:57 <adamw> it'd be nice to have input from outside our wg, here :/ shame mattdm isn't responding
21:22:01 <adamw> i'm not sure i have any terribly strong opinions, but i'll vote on proposals...i'd just like there to be a definite plan here i can understand and follow
21:22:09 <langdon> can i propose we move on? i don't think we can solve this here.. maybe mailing list?
21:22:56 <adamw> to bring in boring reality, as of right now we're two days away from 27 Final go/no-go, and we have a bug that's accepted as a blocker for Server upgrades. there is a plan to fix it, to some degree, but it's not done yet.
21:23:02 <smooge> here
21:23:05 <adamw> langdon: i'm worried about the time.
21:23:24 <nirik> adamw: is it likely to be done in time? and it needs to be a 0day?
21:23:31 <sgallagh> langdon: We don't have the choice to delay
21:23:34 <adamw> 27 final is quite likely to be signed off on thursday and released next tuesday. that doesn't give us a lot of time to figure this out if action is required for 27 final release.
21:23:44 <langdon> sorry which bug are you referencing?
21:23:54 <adamw> nirik: i think we could potentially make a cut at it, if we decided we really want to fix it for the 27 final date.
21:24:06 <adamw> langdon: https://bugzilla.redhat.com/show_bug.cgi?id=1503321
21:24:13 <sgallagh> langdon: Well, there's a FreeIPA one that's representative.
21:24:40 <adamw> nirik: the fix is basically 'twiddle things so the freeipa upgrade script runs when ipa.service starts'
21:25:15 <nirik> I'd prefer: fix bug, say upgrades are supported to f27, but note that it's end of line for non modular server items and after that people would move to non edition for f28 or need to install a fresh modular server
21:25:57 <sgallagh> OK, but what happens if we don't get that bug fixed in time? Is that blocking? Are we just making a best effort here?
21:26:31 <nirik> good question(s). ;)
21:26:35 <langdon> what happens if you f26-freeipa->f27-everything-repo-freeipa?
21:26:38 <nirik> I'd hate to block on it at this point...
21:26:56 <sgallagh> langdon: It breaks. See bug 1503321
21:27:22 <sgallagh> I would to, especially since we knew about it for a while and botched our handling of it.
21:27:46 <sgallagh> That last part being the "royal" we
21:28:09 <langdon> sgallagh: that doesn't answer my q does it? this is f26-freeipa->f27-modular-freeipa right?
21:28:19 <adamw> langdon: no. it's the scenario you asked about.
21:28:37 * langdon kicks himself again for the word "module"
21:28:39 <adamw> langdon: it's not really possible to go from f26 to f27-modular so far as i can tell.
21:28:55 <langdon> sorry i get it now
21:28:57 <sgallagh> adamw: Correct
21:29:35 <nirik> best effort to fix bug or document upgrade issues to f27, but note that it's end of line for non modular server items and after that people would move to non edition for f28 or need to install a fresh modular server
21:29:52 <sgallagh> nirik: Want to make that a proposal?
21:30:02 <nirik> sure.
21:30:06 <adamw> what the openqa test actually does, for the record, is boot an f26 disk image created by virt-install which is intended to match a default Server install as close as possible, deploy FreeIPA on that, then upgrade to F27 using dnf system-upgrade .
21:30:07 <nirik> proposal: best effort to fix bug or document upgrade issues to f27, but note that it's end of line for non modular server items and after that people would move to non edition for f28 or need to install a fresh modular server
21:30:29 <adamw> insufficiently precise, for me
21:30:36 <nirik> patch away. :)
21:30:45 <sgallagh> adamw: Please rephrase
21:31:01 <langdon> i think we don't need to add the bit about f28 .. we may be able to bring people back by then
21:31:33 <adamw> well
21:31:47 <adamw> does the proposal imply that there is *no* 'supported' upgrade path from f26 server?
21:31:53 <nirik> bring back you mean upgrade from non modular to modular?
21:32:02 <adamw> in the sense that the release criteria apply to it and we are committed to fix criteria-violating bugs?
21:32:09 <langdon> nirik: yeah
21:32:30 <sgallagh> adamw: I think at this point in the cycle, we are probably forced to say that, yeah.
21:32:31 <langdon> like this has nothiing, really, to do with modular server, right? this is just a bug in upgrade of freeipa.. which got lost in the shuffle because modular server has had some "challenges"
21:33:09 <nirik> I guess, since we said we were not blocking on traditional server...
21:33:10 <sgallagh> langdon: Right; we bundled all issues specific to Server along with the Modular Server and didn't think too hard about this one until it got late
21:33:14 <adamw> langdon: the specific bug has nothing to do with modularity, indeed. but it has to do with this decision to create a split release process, and the unclear upgrade path from f26 server.
21:33:40 <langdon> right.. ok.. im just making sure i am not being an idiot.. which there is prior evidence for
21:34:38 <sgallagh> Proposal: Upgrades from Fedora 26 Server Edition have no supported upgrade path to Fedora 27 packages.
21:34:45 <sgallagh> edit
21:35:08 <sgallagh> Proposal: Upgrade bugs from Fedora 26 Server Edition to Fedora 27 do not block the release of either F27 or F27 Modular.
21:35:46 <langdon> perhaps add "We hope to revisit upgrades from f26->f28 in the f27 cycle"
21:35:55 <langdon> s/hope/plan
21:36:38 <smooge> I am +1 to the proposal
21:37:21 <adamw> addition: We will address (attempt to fix, at least document) issues with dnf upgrade from Fedora 26 Server to Fedora 27 non-modular packages on a best-effort basis
21:37:43 <sgallagh> adamw: +1
21:37:58 <sgallagh> Proposal: Upgrade bugs from Fedora 26 Server Edition to Fedora 27 do not block the release of either F27 or F27 Modular. We will address (attempt to fix, at least document) issues with dnf upgrade from Fedora 26 Server to Fedora 27 non-modular packages on a best-effort basis
21:38:18 <langdon> no one likes my addition? :(
21:38:39 <nirik> langdon: that should be f28 cycle?
21:39:22 <langdon> nirik: yes.. i think so? i find that term confusing.. 28 cycle is when building 28? i often mix it with f27 is shipping cycle
21:39:37 <sgallagh> langdon: I'm not prognosticating for this
21:39:44 <adamw> maybe patch it to "We currently intend to provide a recommended upgrade path from Fedora 26 Server to Fedora 28 at the time of Fedora 28 release"
21:40:03 <adamw> (which is hedge-y enough to allow us to fail :>)
21:40:04 <sgallagh> -1 I don't want to make promises if we're not sure we will keep them
21:40:09 <adamw> it's not a promise, though!
21:40:10 <langdon> adamw: like it
21:40:19 <adamw> it's a classic political not-actually-a-promise...:P
21:40:23 <sgallagh> ... fine
21:40:31 <nirik> we might recommend... a fresh install. ;)
21:40:37 <sgallagh> Proposal: Upgrade bugs from Fedora 26 Server Edition to Fedora 27 do not block the release of either F27 or F27 Modular. We will address (attempt to fix, at least document) issues with dnf upgrade from Fedora 26 Server to Fedora 27 non-modular packages on a best-effort basis. We currently intend to provide a recommended upgrade path from Fedora 26 Server to Fedora 28 at the time of Fedora 28 release.
21:40:37 <adamw> sgallagh: jeez, you're just not slippery enough for this work
21:40:46 <langdon> sgallagh would like to patch it with s/We/Langdon :)
21:40:52 <adamw> =)
21:40:59 <adamw> +1.
21:41:02 <nirik> +1
21:41:03 * sgallagh starts laying about with his sword
21:41:17 <adamw> and we should action someone to co-ordinate this with the relevant teams to make sure release-day messaging actually lines up with this.
21:41:19 <langdon> +1 /me has no recollection if he has a vote
21:41:28 <adamw> release announcements, getfedora, etc.
21:41:40 <langdon> adamw: currently, that is on me..
21:41:48 <adamw> oh god, we're doomed
21:42:05 <langdon> adamw: i would like to point out the last few comments in #fedora-qa! :)
21:42:27 <sgallagh> #agreed Upgrade bugs from Fedora 26 Server Edition to Fedora 27 do not block the release of either F27 or F27 Modular. We will address (attempt to fix, at least document) issues with dnf upgrade from Fedora 26 Server to Fedora 27 non-modular packages on a best-effort basis. We currently intend to provide a recommended upgrade path from Fedora 26 Server to Fedora 28 at the time of Fedora 28 release.
21:42:38 <sgallagh> OK, we still have several other important topics.
21:42:42 <sgallagh> #topic Name of the Edition
21:42:51 <sgallagh> No bikeshedding. Simple proposal:
21:43:14 <sgallagh> Proposal: Call it "Fedora Modular Server" to avoid end-user confusion as requested by multiple parties.
21:43:23 <langdon> +1
21:43:29 <nirik> sure. that colour is fine.
21:43:35 <sgallagh> I personally don't care if we call it Grandma's Baked Cookies as long as we ship it.
21:43:51 <langdon> Fedora Bikeshed Server?!?! oh, wait, we have that already
21:44:05 <sgallagh> langdon: focus. I don't want this topic going on for 30 minutes
21:44:19 <langdon> i already +1'd it!
21:44:49 <sgallagh> Votes?
21:44:51 <smooge> my only questions is "How is it Server?"
21:45:17 <sgallagh> smooge: We're delivering server technologies, not desktop ones.
21:45:24 <sgallagh> (Right now)
21:45:47 <smooge> ok. the lack of things like shell utilities seemed ot point that htis was even more focused
21:46:10 <smooge> or was the dnf install screen not true
21:46:22 <langdon> smooge: as i said in my last email.. "screen" was actually an oversight.. many of the utils are there.. just not that one
21:46:47 * langdon needs to try to bring back system tools..
21:47:16 <adamw> +1 to either Fedora Modular Server or Grandma's Baked Cookies.
21:47:17 <adamw> i like both.
21:47:43 <sgallagh> smooge: We'll fix "screen" for GA
21:48:07 <langdon> tmux is there
21:48:09 <sgallagh> #agreed Call it "Fedora Modular Server" to avoid end-user confusion as requested by multiple parties.
21:48:18 <smooge> my main problem is that I don't think people will see the 'Modular' bit and assume it is a 1:1 with F26 Server
21:48:26 <sgallagh> #undo
21:48:26 <zodbot> Removing item from minutes: AGREED by sgallagh at 21:48:09 : Call it "Fedora Modular Server" to avoid end-user confusion as requested by multiple parties.
21:48:44 <sgallagh> smooge: And if we had a large userbase, I'd be more worried about that.
21:48:52 <langdon> smooge: well.. it won't be.. but i would say it will still be a "Server" .. but maybe not every bit in the Fedora Server
21:50:25 <langdon> but vi, tmux, emacs, less, lots and lots of stuff are all there
21:52:20 <smooge> OK I am going to say that i think that people are going to be confused by the fact that if something is in Everything but isn't part of a module they can't install it on their server.
21:52:50 <nirik> yep... but I think thats beyond our scope here. ;) Needs marketing/docs
21:53:00 <smooge> but I don't have any sort of magic name which will fix that perception so I am going to +0 and go ahead and agree
21:53:01 <langdon> yeah.. we need to get the messaging right.. and it is still gonna be a problem..
21:54:07 <langdon> so.. sgallagh we can be #agreed again i thnk
21:55:26 <smooge> #agreed Call it "Fedora Modular Server" to avoid end-user confusion as requested by multiple parties.
21:55:43 * smooge fails at irc also
21:56:20 <sgallagh> #agreed Call it "Fedora Modular Server" to avoid end-user confusion as requested by multiple parties.
21:56:20 <smooge> #agreed Call it "Fedora Modular Server" to avoid end-user confusion as requested by multiple parties.
21:56:31 <sgallagh> Sorry, putting out fires concurrently.
21:56:35 <langdon> well.. at least we really really agree!
21:56:44 <sgallagh> I forgot to chair anyone else.
21:56:44 <adamw> #agreed to disagree
21:56:52 <sgallagh> #char adamw langdon smooge
21:56:57 <sgallagh> #chair adamw langdon smooge
21:56:57 <zodbot> Current chairs: adamw langdon sgallagh smooge
21:57:05 <sgallagh> ... Freudian Slip
21:57:06 * nirik avoids the chair.
21:57:12 <sgallagh> #chair nirik
21:57:12 <zodbot> Current chairs: adamw langdon nirik sgallagh smooge
21:57:13 * adamw would prefer to be singed than charred
21:57:21 <nirik> curses. foiled.
21:57:30 <nirik> anyhow? next?
21:58:16 <sgallagh> #info Agenda Item: Testing requested on Beta RC
21:58:22 <sgallagh> #undo
21:58:22 <zodbot> Removing item from minutes: INFO by sgallagh at 21:58:16 : Agenda Item: Testing requested on Beta RC
21:58:29 <sgallagh> #topic Testing requested on Beta RC
21:58:38 <sgallagh> Please do as /topic asks
21:58:51 <sgallagh> We already have one potential blocker that we need to fix, but it's going to be quick.
21:59:02 <sgallagh> Mind if I ask folks to do a quick blocker review on that one?
21:59:12 <sgallagh> .bug 1510629
21:59:13 <zodbot> sgallagh: Bug 1510629 – Missing adcli on Modular compose - https://bugzilla.redhat.com/1510629
21:59:27 <sgallagh> Short version: missing package means domain-join fails
22:00:21 <nirik> seems reasonable...
22:00:21 <smooge> agreed
22:00:27 <nirik> want votes in bug? or ?
22:00:58 <sgallagh> Don't care as long as adamw is comfortable setting the AcceptedBlocker field so I can submit the fix.
22:01:33 <adamw> +1
22:02:02 <nirik> +1
22:02:07 <smooge> +1
22:02:28 <langdon> +1
22:04:12 <sgallagh> #agreed BZ 1510629 is a blocker for F27 Modular Server Beta
22:04:28 <sgallagh> OK, we are now over time.
22:04:48 <sgallagh> Motion to postpone the GA release criteria discussion?
22:04:55 <sgallagh> #topic Final Release Criteria for modularity
22:05:39 <nirik> sure.
22:07:01 <sgallagh> OK, I think that's for the best. I see that there's some feedback from the QA list that should be incorporated.
22:07:23 <sgallagh> #info We will postpone this discussion to next week after QA feedback is incorporated.
22:07:27 <sgallagh> #topic Open Floor
22:07:48 <smooge> I think we can close this.
22:07:54 <smooge> thanks for running sgallagh
22:08:06 <langdon> sgallagh++
22:08:18 <sgallagh> #info We have an RC!
22:08:28 <langdon> sgallagh: maybe a link too
22:08:29 <langdon> ?
22:08:38 <sgallagh> We will have to do at least one more, but we may in fact be able to get to Go this week, finally
22:08:56 <sgallagh> langdon: Well, it's still building. But https://kojipkgs.fedoraproject.org/compose/27/Fedora-Modular-27-20171107.1/compose/Server
22:09:18 <langdon> sgallagh: i meant so it would appear in the minutes
22:09:27 <sgallagh> #link https://kojipkgs.fedoraproject.org/compose/27/Fedora-Modular-27-20171107.1/compose/Server
22:09:40 <sgallagh> Fair point.
22:09:41 <langdon> cool
22:10:10 <sgallagh> OK, I'm going to fix up that blocker and one more FE tonight, then request another RC. PLEASE help QA test this in time for Go/No-Go on Thursday.
22:11:13 <langdon> +1
22:11:21 <sgallagh> Thanks for coming, folks
22:11:21 <smooge> sounds good
22:11:24 <sgallagh> #endmeeting