21:00:13 <sgallagh> #startmeeting Fedora Server SIG Weekly Meeting (2017-11-28)
21:00:13 <zodbot> Meeting started Tue Nov 28 21:00:13 2017 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:13 <zodbot> The meeting name has been set to 'fedora_server_sig_weekly_meeting_(2017-11-28)'
21:00:13 <sgallagh> #meetingname serversig
21:00:13 <zodbot> The meeting name has been set to 'serversig'
21:00:13 <sgallagh> #topic Roll Call
21:01:05 <sgallagh> .hello2
21:01:05 <asamalik> .hello2
21:01:06 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
21:01:09 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
21:01:25 <smooge> .ehlo
21:01:28 <smooge> .hello
21:01:28 <zodbot> smooge: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
21:01:33 <smooge> .hello2
21:01:34 <zodbot> smooge: smooge 'Stephen J Smoogen' <smooge@gmail.com>
21:01:42 <langdon> .hello2
21:01:43 <dperpeet> .hello2
21:01:43 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
21:01:46 <zodbot> dperpeet: dperpeet 'None' <dperpeet@redhat.com>
21:03:44 <sgallagh> #topic Agenda
21:03:44 <sgallagh> #info Agenda Item: To GA or not GA, that is the question.
21:03:53 <sgallagh> So, I anticipate this to be a quick meeting ;-)
21:04:21 <nirik> morning
21:04:22 <sgallagh> Any other agenda topics for today?
21:05:01 <sgallagh> I'll take that to be a "no"
21:05:07 <smooge> sorry slow typing
21:05:11 <sgallagh> #chair nirik dperpeet langdon smooge asamalik
21:05:12 <zodbot> Current chairs: asamalik dperpeet langdon nirik sgallagh smooge
21:05:29 <sgallagh> Is adamw around? I think we'll probably need him for this.
21:05:31 <smooge> when you say GA or not to GA do you mean GA for Modular or GA for original Server or GA for something else
21:05:41 <sgallagh> smooge: Yes
21:05:46 <adamw> ahoy
21:05:52 <sgallagh> #chair adamw
21:05:52 <zodbot> Current chairs: adamw asamalik dperpeet langdon nirik sgallagh smooge
21:06:05 <adamw> why does this meeting always show up when i'm trying to eat lunch...
21:06:11 <mjwolf> .hello2 mjwolf
21:06:12 <zodbot> mjwolf: mjwolf 'Michael Wolf' <mjw@linux.vnet.ibm.com>
21:06:21 <langdon> mmm lunch
21:06:30 <sgallagh> #chair mjwolf
21:06:30 <zodbot> Current chairs: adamw asamalik dperpeet langdon mjwolf nirik sgallagh smooge
21:06:36 <sgallagh> #topic To GA or not GA, that is the question.
21:07:05 <sgallagh> First off, if anyone has not seen it yet, there is a Council ticket related to this that has a fair amount of background:
21:07:17 <sgallagh> #link https://pagure.io/Fedora-Council/tickets/issue/149
21:07:31 * sgallagh wonders if there's a .council like there's a .fesco command
21:08:14 <sgallagh> I'd encourage you to read at least the description (which langdon put together with input from myself and geppetto)
21:08:16 <nirik> no but there could be. ;)
21:09:27 <nirik> .council 149
21:09:32 <zodbot> nirik: An error has occurred and has been logged. Check the logs for more information.
21:09:35 <nirik> ah well.
21:10:02 <sgallagh> So, the tl;dr version is that we've determined that the current approach we're taking (Everything must be a module to be included) is not going to work for both technical reasons and difficulty to packagers.
21:10:38 <sgallagh> So we're going to be taking a different approach in F28 that will involve modules being add-ons to the traditional Everything repo (capable of replacing content in it), rather than building everything from the ground up.
21:10:46 <adamw> to me, "Even the people who want to release it are unlikely to put it in production." rather gets to the heart of this
21:11:08 <langdon> :)
21:11:19 <sgallagh> So this leaves us in a bit of a quandary, because we're close to GA with something that will *probably* pass the letter of the law (release criteria), but probably won't meet all the actual needs of our users.
21:11:23 <sgallagh> And won't match our next release.
21:11:24 <adamw> if what we can ship for f27 is not something we really believe a sane person would want to deploy in the real world to do useful work, we should not ship it as Fedora 27 Server.
21:11:38 * nirik is with adamw
21:11:44 <smooge> +1 adamw
21:11:47 <sgallagh> adamw: That's pretty much my stance; langdon has a counter-argument that he'll present.
21:11:54 <adamw> as The Criteria Guy, let me say the criteria are not meant to be the Complete and Definitive Rules About When We Ship
21:12:19 <langdon> ha
21:12:24 <adamw> to put it another way, if it doesn't pass the criteria we definitely shouldn't ship it, but just because it does doesn't constitute a really strong indication that we *should* ship it.
21:12:30 <sgallagh> I'm very aware that my statements were biased towards my own position.
21:12:41 <sgallagh> adamw++
21:12:41 <zodbot> sgallagh: Karma for adamwill changed to 3 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
21:12:41 * adamw stops and waits for langdon
21:12:54 <dperpeet> adamw++
21:12:54 <zodbot> dperpeet: Karma for adamwill changed to 4 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
21:13:35 <langdon> i don't entirely disagree with the statment(s).. the pressure here is "fedora maturity" vs "fedora first" .. if the Server maturity is "too much" to always be first, then I am inclined to agree with the position.. im sad.. but understand :) ..
21:14:07 <langdon> however, the other concern is that getting it in the hands of users is important.. both to get feedback and to test "what happens when we want to ship chaneges"
21:15:38 <langdon> so.. i think my first point is "what does it mean to be 'first' " a bit and is "small" == "not useful" for this scenario
21:16:49 <adamw> sorry, "small" what?
21:16:58 <sgallagh> adamw: Small in terms of available content
21:17:03 <langdon> right
21:17:16 <sgallagh> Because in our current model, you can only install from our repos the set of stuff for which a module has been written.
21:17:23 <langdon> "why can't i install {wget, screen, locate}"
21:17:26 <sgallagh> Which is a sizeable drop in available content from F26
21:17:33 <adamw> okay, that context.
21:18:12 <nirik> I think it may well be good to publish it... but perhaps as a 'tech preview' or 'side content', not the main release.
21:18:37 <langdon> child of boltron: true unification!
21:18:48 <sgallagh> nirik: Well, if we publish it, we still need to expend the energy on polishing it for release
21:18:58 <sgallagh> Which includes time under the QA microscope.
21:19:06 <sgallagh> I'm not entirely convinced that this is time well-spent
21:19:17 <nirik> ok. I was thinking it was close to that... but if thats not the case... then yeah...
21:19:20 <langdon> sgallagh: well.. we could delay publish boltron-2 until we have rejiggered the architecture..
21:19:48 <sgallagh> langdon: How is that functionally different from F28 at that point?
21:19:54 <adamw> let me ask this: how useful would feedback about a 27 release actually be, given the apparent significance of the change in design that's planned for 28?
21:20:02 <smooge> OK so wild idea.. what if Boltron wasn't an edition of Server but a Spin for F27?
21:20:07 <sgallagh> adamw: Well, it's not entirely unusable feedback.
21:20:14 <adamw> that seems like a fairly weak answer
21:20:22 <sgallagh> The command interface for the end-user should be the same.
21:20:30 <sgallagh> They'll end up with a lot more CONTENT to process that way.
21:20:42 <langdon> adamw, sgallagh i don't entirely agree... the arch changes would have almost no visibility to users or packagers.. except to make things easier
21:20:49 <sgallagh> Of course, we also need to figure out how to present that content in a meaningful manner, but that's a technical issue
21:20:57 <smooge> but if most of the feedback is "where is <<fill in app we know we dont have a module for>>" how is it useful?
21:21:01 <nirik> FWIW, I am very happy we learned from this and have a new hopefully much better approach... better now than in a few more months.
21:21:02 <langdon> so i kinda agree with sgallagh :)
21:21:06 <sgallagh> langdon: I disagree on the "packager" side
21:21:32 <sgallagh> I think it's going to end up being much simpler in F28 than it is today.
21:21:35 <sgallagh> Which is a good thing!
21:21:40 <adamw> well, my thought is that even if it *appears* the same to the user, the implementation sounds like it's going to change quite a lot
21:21:48 <langdon> nirik: weirdly.. this was actually the original plan of the "everything else module".. however, we couldn't implement that .. so we took the f27 approach.. then we discovered a way to go back to the original "intent" if not quite the same implementation
21:21:52 <sgallagh> But asking people to learn The Hard Way now seems like a bad way to build goodwill
21:22:03 <adamw> so I guess feedback on whether they like the interface will still be broadly valid, but data on how well it *works*...seems like it may not be
21:22:22 <langdon> i do think we should note that in this approach we lose some modularity features.. specifically we go back to fuzzy build roots
21:22:41 <nirik> smooge: I bet most of the feedback is that. I saw some of that on #fedora the other night with the beta.
21:22:45 <sgallagh> langdon: We never actually had that feature, unfortunately
21:23:00 <sgallagh> It was aspirational, but we never got it to a state where it could work
21:23:23 <smooge> so what I am hearing is that we are going to deliver a car which has 4 wheels and maybe the engine they want if they wanted one particular engine.. but our main want for feedback is how the paint colour is?
21:23:28 <nirik> ie "I installed modular server beta and I can't find wget? where is it? let me look at it in the repos... can I just install it locally? why no wget"
21:24:47 <adamw> i think sgallagh kinda identified the trade-off: the value of whatever useful information you might get from people running a 27 release of this stuff, versus the time spent dealing with non-useful feedback, the time spent polishing and maintaining what is essentially a dead-end approach, and the reputational cost to fedora of the release not being as good as we'd like it to be, not being upgradable from f26, and potentially not being upgradable
21:24:47 <adamw> *to* f28(?)
21:24:59 <sgallagh> nirik: Right, and our plan for F28 is going to be that you should have access to Everything, which will alleviate that experience
21:25:08 <langdon> nirik: from above: ‎ "why can't i install {wget, screen, locate}" :) is what i have heard
21:25:12 * nirik nods.
21:25:36 * nirik admits to using wget, but I should retrain myself to use curl. ;)
21:25:52 <sgallagh> nirik: I've been in that same boat for years
21:25:59 * adamw swings both ways
21:26:03 <asamalik> and we already got a pretty good feedback on F26 Boltron https://docs.pagure.org/modularity/prototype/boltron/feedback.html
21:26:04 <smooge> nothing wrong with wget.. you don't need weird command line with wget
21:26:17 <asamalik> mainly about UX and we basically did everything users wanted
21:26:27 <asamalik> regarding the UX
21:26:32 * sgallagh nods
21:26:38 <nirik> yeah, so we already have a lot of that feedback
21:26:42 <sgallagh> asamalik: Yeah, I think we're in a pretty good place for the UX
21:26:50 <sgallagh> *UX feedback
21:27:03 <sgallagh> so that (to me) further reduces the value of shipping what we currently have.
21:27:13 <sgallagh> I think adamw summarized the trade-off pretty well above
21:27:31 <smooge> I think adamw summarized your summary of the trade-off pretty well above
21:27:49 <adamw> *ba-ding*
21:28:02 <adamw> oh, looks like I just got the 'summary summarizer' achievement
21:28:08 <sgallagh> adamw: Regarding upgrade TO F28... I think that's actually manageable, but if we don't have to do it, so much the better.
21:28:33 * sgallagh summarily executes adamw
21:28:46 <smooge> ooh another achievement
21:28:59 <langdon> Sorry.. Gnome-shell just crashed on me :/
21:29:15 <sgallagh> Achievements all around!
21:29:27 <sgallagh> Anyway.
21:29:41 <adamw> langdon: that's unpossible!
21:29:47 <langdon> Right?
21:30:16 <sgallagh> Is anyone in favor of shipping F27 Modular Server GA?
21:30:21 <adamw> (or alternatively it's probably https://bugzilla.redhat.com/show_bug.cgi?id=1469129 )
21:30:22 <langdon> I had a comment too.. But as I am on mobile.. Sgallagh do you want to bring up modules on wkstn? The convo with mattdm?
21:30:32 <sgallagh> (Note: a separate question will be asked about Boltron 2: Electric Boogaloo)
21:30:56 <sgallagh> langdon: As that's not something we can do in F27, I'd prefer to hold that conversation until later.
21:31:11 <sgallagh> The tl;dr version is that with the new approach, we can probably get that working at the same time.
21:31:24 <langdon> K
21:31:30 * adamw is still definitely not
21:31:40 <adamw> (based on information available)
21:32:06 <sgallagh> Yeah, I haven't heard anything that changes my opinion.
21:32:39 <sgallagh> #agreed Server SIG does not want to ship a formal GA of Fedora 27 Modular Server
21:32:40 <smooge> -1 to shipping
21:32:47 <nirik> ack
21:33:17 <sgallagh> OK, so the next question is whether we want to polish this <redacted> and release a "Boltron 2" sidecar-type release.
21:33:17 <mjwolf> I agree do not ship modular server
21:33:51 <adamw> sgallagh: personally i think you, langdon and the other folks actively working on the implementation are in the best position to determine that.
21:33:55 <sgallagh> I'm not as rigidly "no" on this, but I think realistically the resources would be better spent moving on to the next phase.
21:34:08 <adamw> if there is a clear consensus among you folks i will vote for whatever that consensus is.
21:34:20 <smooge> I am for better spending of resources
21:34:24 <asamalik> sgallagh: +1
21:34:33 <sgallagh> (Also freeing adamw and friends to do other work than the release validation treadmill)
21:34:59 <adamw> well, i mean, technically a boltron-type release wouldn't really require release validation. we didn't formally validate boltron.
21:35:07 <sgallagh> Oh, right.
21:35:57 <adamw> (also freeing me up would've meant a lot more two weeks ago, but never mind :>)
21:36:04 <sgallagh> adamw: Well, I think the implementers are a bit split on it, but I'm concerned that a portion of that is Sunk Cost Fallacy stepping in again.
21:36:28 * adamw opens box of popcorn, settles back
21:36:34 <sgallagh> adamw: Sorry, kind of a lot happened in a very short time period.
21:36:35 <smooge> do we do daily spins of Modular?
21:36:41 <adamw> smooge: yup.
21:36:41 <sgallagh> There was even Drama involved.
21:36:56 <adamw> smooge: they're in https://kojipkgs.fedoraproject.org/compose/ .
21:37:01 <sgallagh> smooge: Yes, although they're a little broken at the moment due to a screw-up with some of the Java modules.
21:37:05 <nirik> multiple times a day even
21:37:06 <adamw> https://kojipkgs.fedoraproject.org/compose/Fedora-Modular-27-20171128.n.1/ is the most recent for e.g.
21:37:18 <smooge> then we have a spin for people interested
21:37:26 <smooge> and we can move to the next item
21:37:33 <adamw> well...no, not really.
21:37:38 <sgallagh> But that should finally be fixed tonight. I expected it working yesterday, but two people made conflicting fixes without telling each other :-P
21:38:16 <adamw> nightly composes exist entirely for testing purposes.
21:38:31 <smooge> adamw, so the number of people interested in running modular are going to be a small segment of self-interested/motivated people wanting to test things
21:38:32 <sgallagh> Right, and they are reaped after 14 days
21:38:44 <adamw> yeah, that too.
21:38:50 <smooge> so this seems to be the place to send them to
21:39:19 <sgallagh> There's also the Beta; I suppose we could pack up shop by adding a Bodhi update for every remaining module so people could update from that.
21:39:19 <adamw> we mainly do nightly composes as part of the release production process.
21:39:40 <sgallagh> If we *really* care about that case.
21:40:18 <adamw> if we're not producing a release, the answer to "why do we have these nightly composes" gets a lot fuzzier. they aren't free, they eat a lot of resources to produce. so 'just keep making nightly composes of 27 modular' is, you know, a choice, but it's not a completely obvious one. how long do we keep making them? what if they're utterly broken? where do we tell people about them, if at all?
21:41:00 <sgallagh> Oh, absolutely not. If we abandon this, I'm asking rel-eng to turn those off immediately.
21:41:01 <smooge> adamw, well I was more thinking of modular f28
21:41:09 <adamw> we could do "one last nightly compose" and *not* garbage collect it, but that's about 50% of doing a Boltron 2 release *anyhow*.
21:41:32 <adamw> smooge: oh, kay. sure, there will continue to be 28/rawhide/bikeshed (graaaahhhh i hate that name) nightlies.
21:41:34 <smooge> ok so my idea was ill-advised. I retract it
21:41:58 <sgallagh> adamw: No, we'll be killing off bikeshed and getting things into the regular compose, I should think
21:42:08 <adamw> sure. i mentioned all three. :P
21:42:22 <adamw> (also please for the love of god do that)
21:43:07 <smooge> ok to go back to the point.. I don't think doing a Boltron II for Server 27 makes sense
21:43:16 <asamalik> so what would we actually get from releasing something we're going to work on vs. the Beta we already have? I mean as the Boltron 2
21:43:17 <nirik> less composes == less files == less bugs. ;)
21:43:30 <sgallagh> Straw Man Proposal: We abandon this path immediately and tell people if they really want to poke at it, the Beta exists.
21:43:50 * adamw has no objection to that.
21:44:00 <smooge> has no objection
21:44:06 <nirik> fine with me
21:44:11 <mjwolf> fine with me
21:44:16 <sgallagh> If langdon and his team REALLY want to dump some of the latest content in place, they can do it via a big Bodhi update
21:44:29 <smooge> I think we lost langdon
21:44:30 <asamalik> no objection
21:44:31 <sgallagh> Rather than spinning up a new install tree compose
21:45:09 <langdon> no im here
21:46:10 <langdon> i think server-wg has a slightly different agenda than modularity-wg.. so i understand the server-wg point.. and i think the council should ultimately decided on boltron-2 yea/nay .. this is just "the server-wg recommendation"
21:46:34 <langdon> and server-wg should decide on f27 server ga yea/nay
21:47:03 * langdon notices stack of hats on the floor.. should really throw some out
21:48:01 <adamw> replace them with bottles
21:48:14 <adamw> i'm fine with this being a server wg recommendation to council.
21:48:15 * langdon disconnected third monitor as apparently this is a known gnome issue
21:48:55 <sgallagh> That's fair. We've said our piece on the Fedora Server decision
21:49:58 <sgallagh> #agreed The Server WG recommendation is not to bother with a Boltron 2 release, but this is ultimately up to the Council and the Modularity WG to decide.
21:50:15 <sgallagh> OK, so there's one more hard question left:
21:50:17 <langdon> and.. to be clear.. mattdm explicitly asked for the server-wg reco on *all* these points..
21:51:01 <sgallagh> langdon: The Server WG has autonomy on what constitutes our deliverables, so if the Council wants to overrule us on that... it would get awkward.
21:51:21 <langdon> sgallagh: ohh.. yeah.. i think that came out wrong
21:51:35 <sgallagh> Remaining hard question: do we want to do something about a Fedora 27 Server Edition traditional release?
21:51:50 <langdon> i wanted to be sure y'all didn't think i didn't want you to provide on recommendation on boltron-2 .. and, in fact, mattdm even asked for it
21:52:03 <sgallagh> The proposal I suggested to the Council was to ask QA to run the Server tests against the ISOs that were built from the final RC of the regular release.
21:52:21 <mattdm> sgallagh: yeah it's more the opposite -- I don't want the council making up things for you to do with no one to do them
21:52:27 <sgallagh> If it passes, just ship it. If not: oh well, the upgrades have been working for everyone who's tried.
21:52:31 <adamw> sgallagh: i've just posted a comment to the ticket on that. we've actually already done all that validation, except possibly the AD tests if you didn't do those.
21:52:51 <sgallagh> adamw: I did those
21:52:51 <adamw> sgallagh: tl;dr version, i think it would be viable to just go ahead and 'release' the images from the GA compose.
21:52:59 <adamw> https://pagure.io/Fedora-Council/tickets/issue/149#comment-481872
21:53:12 <sgallagh> \o/
21:53:49 <nirik> 🤘
21:54:45 <smooge> ok are there any problems from the releng side for putting these out?
21:54:54 <adamw> i don't think releng needs to do anything
21:55:04 <adamw> the images are actually already on the mirrors, last i checked
21:55:15 <adamw> i think all we'd actually need to *do* in practical terms is update getfedora...
21:55:17 <nirik> well, there's no torrents (FWIW)
21:55:23 <smooge> hahahahaha
21:55:29 <adamw> oh, and make a torrent...yeah.
21:55:35 <nirik> but otherwise I think the images are in place.
21:56:44 <sgallagh> So that sounds like not too much trouble to me
21:56:50 <mattdm> also someone *cough* needs to write a "oh here it is after all" announcement
21:56:59 <mattdm> or else we just sweep it under the rug
21:57:14 <mattdm> (I'm coughing because it's me.)
21:57:18 <sgallagh> mattdm: Maybe we just roll it into the apology announcement about Modular
21:57:20 * langdon would enjoy writing that
21:57:34 * mattdm hands langdon a pen
21:57:39 <adamw> oh, sure, i was kinda assuming that
21:57:54 <adamw> i think it would actually work better to be super upfront about this than kinda downplay it
21:58:03 <mattdm> adamw yes me too
21:58:05 <adamw> just write a super honest "here's exactly what happened" post
21:58:21 <adamw> send it out via magazine, press release, whatever
21:58:32 <sgallagh> Yeah, I'll help with that
21:58:36 <langdon> yeah.. i think it would be useful too
21:58:56 <asamalik> I also offer my help with that
21:59:02 <nirik> one issue here is timing...
21:59:32 <sgallagh> Are we agreed to do this, before we go into the implementation details?
21:59:37 <sgallagh> Does anyone dislike this plan?
21:59:43 <nirik> I think it makes sense and is reasonable.
21:59:44 <langdon> o/ :)
21:59:52 <langdon> but im good
21:59:55 <sgallagh> (I mean, beyond the whole "we wanted something more out of this release" side of it)
22:00:02 * adamw is fine with the plan given where we're at
22:00:16 * mjwolf sounds fine to me
22:00:51 <sgallagh> #agreed Since the GA RC compose passed the Server tests, Server WG would like to just release the ISOs from that compose as Fedora 27 Server Edition
22:01:13 <dperpeet> I'm happy with that, /pass on more details :)
22:01:20 <nirik> isos and repos? release content? whatever, it's fine
22:02:02 <adamw> nirik: afaics the server tree and isos are alreadya t https://dl.fedoraproject.org/pub/fedora/linux/releases/27/ .
22:02:18 <sgallagh> #undo
22:02:18 <zodbot> Removing item from minutes: AGREED by sgallagh at 22:00:51 : Since the GA RC compose passed the Server tests, Server WG would like to just release the ISOs from that compose as Fedora 27 Server Edition
22:02:35 <sgallagh> #agreed Since the GA RC compose passed the Server tests, Server WG would like to just release the Server Edition content from that compose as the official Fedora 27 Server Edition
22:02:58 <nirik> adamw: yes, I was just nitpicking about "ISOS' in the statement...
22:03:02 <adamw> oh i see
22:03:02 <nirik> ack
22:03:04 <langdon> it is almost like this was planned for...
22:03:04 <adamw> ack
22:03:27 * adamw *certainly* wasn't testing non-modular server all along because he sorta expected this or anything like that.
22:03:34 <langdon> adamw: :P
22:05:22 <sgallagh> Alright, we're over time, but I think we're pretty much agreed.
22:05:28 <sgallagh> Thank you, adamw for your foresight :)
22:05:59 * adamw agrees that we are agreed
22:06:19 <langdon> agreed on the agreed upon summarization of the summary?
22:06:24 <smooge> would agree with the agreement but is a contrarian by nature
22:06:27 <adamw> DISAGREE
22:06:32 <sgallagh> Thanks everyone, on to the next adventure!
22:06:37 <smooge> thanks sgallagh
22:06:46 <adamw> the next princess module is in another castle?
22:06:59 <nirik> to ∞ and beyond!
22:07:03 <sgallagh> #endmeeting