18:04:03 <sgallagh> #startmeeting F27 Server Final Go/No-Go meeting
18:04:03 <zodbot> Meeting started Thu Nov 30 18:04:03 2017 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:04:03 <zodbot> The meeting name has been set to 'f27_server_final_go/no-go_meeting'
18:04:03 <sgallagh> #meetingname F27-server-final-Go-No-Go-meeting
18:04:03 <zodbot> The meeting name has been set to 'f27-server-final-go-no-go-meeting'
18:04:03 <sgallagh> #topic Roll Call
18:04:04 <sgallagh> #chair nirik adamw sgallagh mboddu
18:04:04 <zodbot> Current chairs: adamw mboddu nirik sgallagh
18:04:13 <mboddu_> .hello mohanboddu
18:04:14 <zodbot> mboddu_: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
18:04:15 <sgallagh> .hello2
18:04:16 <nirik> 
18:04:17 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
18:04:36 <sgallagh> #chair mboddu_
18:04:36 <zodbot> Current chairs: adamw mboddu mboddu_ nirik sgallagh
18:04:38 * mboddu_ is outside and cannot access his bouncer since he didn't setup soft token on his new phone :D
18:05:12 <langdon> .hello2
18:05:13 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
18:05:51 <smooge> .hello2
18:05:52 <zodbot> smooge: smooge 'Stephen J Smoogen' <smooge@gmail.com>
18:05:53 <sgallagh> adamw, kparal: Can one of you represent QA?
18:05:58 <smooge> running a meeting in another channel
18:06:11 <adamw> i'm here
18:06:14 <adamw> just having crashy issues
18:06:23 <sgallagh> ok, thanks
18:06:34 <sgallagh> #topic Purpose of this meeting
18:06:34 <sgallagh> #info Purpose of this meeting is to check whether or not F27 Server Final is ready for shipment, according to the release criteria.
18:06:34 <sgallagh> #info This is determined in a few ways:
18:06:34 <sgallagh> #info * Release candidate compose is available
18:06:34 <sgallagh> #info * No remaining blocker bugs
18:06:34 <sgallagh> #info * Test matrices are fully completed
18:06:52 <sgallagh> #topic Current status of F27 Server Final release
18:07:35 <sgallagh> #info We have a release candidate compose (RC 1.6)
18:07:59 <sgallagh> adamw: Can you provide a link to the test matrices?
18:08:03 <adamw> sure
18:08:08 <mboddu_> sgallagh: Is anyone tested how good is RC 1.6 in terms of Server variant?
18:08:24 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_27_RC_1.6_Server
18:08:32 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_27_RC_1.6_Base
18:08:50 <adamw> https://fedoraproject.org/wiki/Test_Results:Fedora_27_RC_1.6_Installation
18:09:18 * mattdm is here
18:09:22 * mattdm lost track of time
18:09:33 <adamw> so, missing things:
18:09:41 <adamw> we haven't tested physical media boot of the images
18:11:02 <sgallagh> adamw: Is that the only thing?
18:11:02 <adamw> the active directory results aren't filled in, though sgallagh says he ran the tests, i think
18:11:23 <sgallagh> adamw: I did, yes.
18:11:37 <sgallagh> (successfully)
18:11:41 <adamw> and the 'domain controller role' results are missing, because the openqa test for the compose happened to fail due to some kinda timeout or something...
18:11:49 <adamw> can you stick them in the table quickly then?
18:11:59 <adamw> let me see if i can re-run that test
18:12:47 <adamw> it may fail due to garbage collected assets, though.
18:13:22 <sgallagh> adamw: I would, but relval is throwing an error trying to log in with my FAS account
18:13:31 <adamw> sgallagh: oh, you need the latest wikitcms
18:13:35 <adamw> it's in updates-testing
18:13:44 <adamw> (or should be...)
18:13:45 * mboddu_ will be back in 10 min
18:13:55 <adamw> wiki auth changed with the upgrade
18:14:35 <adamw> yeah, i can't re-run just the openqa test we need, as it depends on an uploaded hard disk iamge that's been garbage collected. i'd have to re-run the whole set of server dvd tests.
18:14:37 <adamw> eh, i can do that.
18:14:40 <sgallagh> adamw: Broken dependencies; fedfind is missing
18:15:53 <sgallagh> OK, a point of order.
18:16:10 <sgallagh> We know that the Infra team has an outage next week and so releasing next week is not ideal.
18:16:47 <sgallagh> Should we just postpone this decision by a week, since we won't announce until at least the 11th anyway?
18:16:49 <sgallagh> mattdm: ^^
18:17:12 <adamw> sgallagh: should be in the same update
18:17:14 <adamw> but yeah, we could do that
18:17:15 <mattdm> sgallagh: this is fine with me.
18:17:28 <sgallagh> adamw: Ah, my favorite word... "should"
18:17:29 <adamw> we can dot some i's and cross some t's in the meantime
18:17:41 <mattdm> i can use this time to ask you some modularity questions instead :)
18:17:52 <adamw> well, we may want to decide what to do about the freeipa upgrade bug
18:18:14 <sgallagh> adamw: Shall we do the mini blocker review now then?
18:18:22 <adamw> very mini!
18:18:23 <adamw> sure
18:18:31 <sgallagh> Would you be so kind, adamw ?
18:18:40 <langdon> Anything to avoid mattdm's questions
18:18:42 <nirik> we could also just announce today/tomorrow...
18:18:46 <sgallagh> #topic Mini-Blocker Review
18:18:47 <nirik> but that needs ducks in row
18:18:56 <nirik> and friday is horrible for announcing things.
18:18:58 <sgallagh> nirik: Websites and stuff needs prepping.
18:19:04 <sgallagh> I'd prefer not to rush them
18:19:14 <mattdm> nirik: I have no ducks in a row at this point
18:19:19 <mattdm> all of my ducks are running in circles
18:19:24 <adamw> #info we have just one proposed blocker
18:19:32 <adamw> #topic (1503321) FreeIPA server upgraded from F26 to F27 fails to start with "ModuleNotFoundError: No module named 'ipapython.secrets'"
18:19:32 <adamw> #link https://bugzilla.redhat.com/show_bug.cgi?id=1503321
18:19:32 <adamw> #info Proposed Blocker, freeipa, NEW
18:19:34 <mattdm> there is a 3lb pomapoo puppy chasing them
18:19:36 <nirik> 🦆🦆🦆
18:19:41 <adamw> all my ducks ran away to join the yak farm
18:20:14 <adamw> so we still have this bug, which becomes more relevant if we're actually doing a 'traditional' server release: if you have a freeipa server and upgrade it to f27, the server will fail to start after the upgrade.
18:20:48 <adamw> the reason is that the freeipa upgrade script fails when run during the upgrade because the network isn't up, and there is a pretty simple workaround: run the upgrade script manually with the network up.
18:20:59 * sgallagh nods
18:21:34 <sgallagh> From conversations with the FreeIPA folks, a fix for this is non-trivial for $REASONS.
18:21:53 <mattdm> this is a TOTALLY different "module" than "modularity" right?
18:21:57 <adamw> iirc we have a couple of threads on fixing this, one involving making it possible for the rpm scriptlet to bring the network up during the upgrade process, one which is about changing the freeipa approach so that the script gets run during freeipa startup if it needs to be run
18:22:02 <mattdm> because _that's_ not confusing
18:22:11 <sgallagh> mattdm: Python module
18:22:26 <sgallagh> The latter one is probably the right one
18:22:27 <adamw> yeah. python definitely got there first, i'm afraid. :P
18:22:33 <mattdm> I figured. Which is... fine. It just makes it extra hard to document given the circumstances
18:22:47 <adamw> i know, let's call our modules 'flavors' instead!
18:22:50 <sgallagh> We REALLY don't want to have the network live during updates. That's... kind of the point of "offline updates".
18:22:51 * adamw runs away very fast
18:23:41 <sgallagh> but we don't need to solve ithere
18:24:00 <sgallagh> The crux of the situation is that we don't *strictly* have a blocker criterion for this case on upgrade.
18:24:07 <sgallagh> We only require that a fresh installation works.
18:24:15 <sgallagh> It *is* really ugly though.
18:25:23 <adamw> i think we decided before that upgrade criteria apply to release-blocking roles, no?
18:26:06 * adamw will have to check notes
18:26:15 <adamw> still, though, i think i'm OK with just documenting this, since it *is* a pretty easy workaround
18:26:31 <mattdm> +1 sad but documentable
18:26:33 <adamw> and since it's an upgrade issue, we can fix it with an update at any time
18:26:50 <sgallagh> adamw: I think we said we probably should propose it, but hadn't
18:27:05 <sgallagh> I feel conflicted.
18:27:10 <adamw> i thought we'd agreed that that's how it should be and we'd act on that basis, but we need to formalize it...
18:27:14 <adamw> i thought i'd written a proposal but can't find it now.
18:27:44 <sgallagh> I probably *would* have blocked on this if we were on the regular schedule. But it's fixable with an update and everything else about this process is out of whack, so...
18:27:47 <mattdm> I'd feel different if the IPA team had an idea for how to fix it
18:27:49 <sgallagh> I guess document it and move on
18:27:51 <adamw> well, we have an *idea*
18:27:57 <sgallagh> Several!
18:27:59 <adamw> it just seems to be a bit of work to implement
18:28:20 <mattdm> a non-trivial bit of work, from above
18:28:48 <mattdm> I guess the thing is: people can actually upgrade and get this error *today*
18:29:06 <mattdm> we just haven't documented that. it's probably *better* to document the problem
18:29:52 <adamw> proposed #agreed 1503321 - RejectedBlocker (Final) - while we do generally consider upgrade issues in release-blocking roles as potentially release-blocking, we feel this one is easy enough to work around, and it seems the FreeIPA team isn't sure the proper fix can be implemented super promptly. also, we note that there's nothing stopping Fedora Server users from upgrading at present anyhow, so 'blocking' on this is somewhat meaningless.
18:30:29 <mattdm> +1
18:31:11 <smooge> +1
18:31:14 <adamw> ack/nack/patch ?
18:31:19 <sgallagh> ack
18:31:23 <smooge> ack
18:31:24 <mattdm> ack
18:31:43 <adamw> #agreed 1503321 - RejectedBlocker (Final) - while we do generally consider upgrade issues in release-blocking roles as potentially release-blocking, we feel this one is easy enough to work around, and it seems the FreeIPA team isn't sure the proper fix can be implemented super promptly. also, we note that there's nothing stopping Fedora Server users from upgrading at present anyhow, so 'blocking' on this is somewhat meaningless.
18:32:19 <adamw> and that's all we had, unless someone wanted to add anything.
18:32:24 <adamw> no point doing FEs as we're not respinning.
18:32:31 <sgallagh> right
18:33:03 <sgallagh> #topic F27 Server Final Go/No-Go decision
18:33:33 <sgallagh> In light of having our ducks line up and be counted, I propose we defer the decision for a week
18:33:45 <sgallagh> That way we have time to get that extra round of automated results run
18:33:48 <mattdm> quack.
18:33:56 <mattdm> I mean, ack
18:33:57 * sgallagh groans
18:34:01 <mattdm> .fire mattdm
18:34:01 <zodbot> adamw fires mattdm
18:35:08 <sgallagh> proposed #agreed We defer the final Go/No-Go decision by a week to rerun the openqa tests, get websites in order, and avoid the Infrastructure outage.
18:35:23 <adamw> ackity ack
18:35:28 <sgallagh> Don't talk back
18:35:39 <langdon> Don't *quack* back
18:35:51 * mattdm is sorry he started t his
18:36:14 <adamw> NOT SORRY ENOUGH
18:36:19 <Kohane> Hello!
18:36:25 <Kohane> Sorry for been late
18:36:28 <adamw> hi kohane
18:36:34 <Kohane> .fas lailah
18:36:36 <zodbot> Kohane: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
18:36:37 <adamw> we're just deciding not to decide
18:36:42 <Kohane> hi adamw
18:36:48 <adamw> <sgallagh> proposed #agreed We defer the final Go/No-Go decision by a week to rerun the openqa tests, get websites in order, and avoid the Infrastructure outage.
18:36:49 <Kohane> LOL
18:37:17 <mboddu> ack
18:37:35 * mboddu is back
18:37:44 <smooge> and test if physical boot works?
18:38:03 <smooge> ack
18:39:14 * mboddu has a question to adamw and nirik which I will ask after we complete this topic
18:39:21 <sgallagh> #agreed We defer the final Go/No-Go decision by a week to rerun the openqa tests, get websites in order, and avoid the Infrastructure outage.
18:39:22 <adamw> smooge: yeah, we should probably do that too.
18:39:28 <sgallagh> #topic Open floor
18:39:31 <nirik> ack
18:39:35 <sgallagh> mboddu: Go for it
18:39:36 <adamw> mboddu: do you mean you're....b'ack ?
18:39:37 <mattdm> thanks everyone
18:39:54 <mboddu> adamw: nope
18:40:36 <mboddu> adamw, nirik : Lets say we find a blocker and that means we need a new respin of the RC compose for just server variant?
18:40:50 <sgallagh> mboddu: We aren't doing one. The end :)
18:40:53 <nirik> we don't do it.
18:40:59 <nirik> yeah, what sgallagh said.
18:41:05 <adamw> yup.
18:41:24 <adamw> i'd say we either release what we have or don't 'release' at all.
18:41:24 <Kohane> So what happens if someone finds a blocker?
18:41:25 <mboddu> sgallagh, nirik, adamw : Okay, that worried me a little bit
18:41:26 <sgallagh> If we discover a blocker we can't fudge, we just don't ship F27 Server
18:41:36 <adamw> Kohane: well, *first* we dig a shallow grave...
18:41:46 <mboddu> sgallagh: Okay, got it
18:41:53 <Kohane> Okay, got it  adamw
18:43:13 <mboddu> adamw: And the tombstone says "Hit by a blocker"
18:43:29 <adamw> no, it says RESOLVED WONTFIX
18:43:44 <mboddu> hahaha
18:43:47 <Kohane> LMAO
18:43:55 <Kellin> I don't know that it's all that funny but...
18:43:58 <sgallagh> I think NEEDSINFO would be the real salt in the wound
18:44:03 <adamw> ahahahaha
18:44:13 <smooge> WORKSFORME
18:44:23 <adamw> we're all terrible people.
18:44:37 <Kohane> Oh, yeah...
18:45:40 <sgallagh> Are we done here?
18:45:48 * mboddu has nothing
18:45:48 <sgallagh> Kellin: Did you have a question?
18:45:53 <Kohane> I suppose....
18:46:05 <Kellin> sgallagh: I have nothing constructive at this time.
18:46:16 <sgallagh> Fair enough
18:46:22 <sgallagh> #endmeeting