#fedora-meeting-1: Fedora Server SIG Weekly Meeting (2018-04-03)

Meeting started by sgallagh at 20:00:17 UTC (full logs).

Meeting summary

  1. Roll Call (sgallagh, 20:00:18)
  2. Agenda (sgallagh, 20:06:40)
    1. Agenda Item: Brainstorming (sgallagh, 20:06:46)

  3. Brainstorming (sgallagh, 20:07:36)
    1. Feedback: Fedora Server has too short a lifecycle (sgallagh, 20:08:35)
    2. Feedback: Fedora Server should be more minimalistic (sgallagh, 20:08:35)
    3. Feedback: SELinux needs better usability (sgallagh, 20:08:35)
    4. Feedback: Support OpenCL (sgallagh, 20:08:36)
    5. Feedback: Easy "home media server" would be nice (sgallagh, 20:08:36)
    6. Feedback: Cockpit should be able to control more of the system (sgallagh, 20:08:36)
    7. Feedback: Focus on simplifying common task execution (sgallagh, 20:08:36)
    8. Feedback: Support enterprise HBAs (sgallagh, 20:08:37)
    9. We will go through the list individually (sgallagh, 20:11:46)

  4. Fedora Server has too short a lifecycle (sgallagh, 20:12:01)
    1. The core problem that people want to solve generally is "I don't want my applications to break, because I rely on them" (sgallagh, 20:14:16)
    2. Rephrased: Core problem is "I want to be able to keep my system up-to-date wrt bug and security fixes without my applications breaking" (sgallagh, 20:16:35)
    3. Users automatically assume that the classic solution to this problem is the only one: longer compatibility lifecycle for the whole OS. (sgallagh, 20:17:34)
    4. Fedora Server attempts to solve the core problem with Modules and reliable OS release upgrades. (sgallagh, 20:18:25)
    5. Enhancement proposal: automatically upgrade when release is EOL (sgallagh, 20:22:03)
    6. Enhancement proposal supplement: Cockpit UI for scheduling the automatic update after EOL (sgallagh, 20:23:11)

  5. Fedora Server should be more minimalistic (sgallagh, 20:27:38)
    1. This topic is really easy to get rat-holed on. Will revisit later. (sgallagh, 20:40:44)

  6. SELinux needs better usability (sgallagh, 20:40:52)
    1. Cockpit SELinux Troubleshooter improvements would be ideal for this (sgallagh, 20:43:59)

  7. Support OpenCL (sgallagh, 20:46:42)
    1. This task would require specialized expertise that isn't readily available (sgallagh, 20:48:40)

  8. Easy "home media server" (sgallagh, 20:48:56)
  9. Server Focus (sgallagh, 20:55:07)
    1. Q: Is there a customer story similar to our previous OLPC effort that we could get behind? (sgallagh, 20:55:41)
    2. https://freedombox.org/ ? (nirik, 20:56:01)
    3. ACTION: Homework assignment: Think of an OLPC-style initiative that Server could back and present it next week. (sgallagh, 21:00:24)


Meeting ended at 21:04:33 UTC (full logs).

Action items

  1. Homework assignment: Think of an OLPC-style initiative that Server could back and present it next week.


People present (lines said)

  1. sgallagh (129)
  2. dperpeet (46)
  3. nirik (39)
  4. smooge (13)
  5. bowlofeggs (11)
  6. orc_fedo_ (8)
  7. zodbot (7)


Generated by MeetBot 0.1.4.