16:00:02 <geppetto> #startmeeting fpc
16:00:02 <zodbot> Meeting started Thu Apr 26 16:00:02 2018 UTC.  The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:02 <zodbot> The meeting name has been set to 'fpc'
16:00:02 <geppetto> #meetingname fpc
16:00:02 <geppetto> #topic Roll Call
16:00:02 <zodbot> The meeting name has been set to 'fpc'
16:00:06 <tibbs> Howdy.
16:00:09 <redi> 'sup
16:00:09 * limburgher here
16:00:11 <geppetto> #chair tibbs
16:00:11 <zodbot> Current chairs: geppetto tibbs
16:00:13 <geppetto> #chair limburgher
16:00:13 <zodbot> Current chairs: geppetto limburgher tibbs
16:00:14 <mbooth> How do
16:00:17 <geppetto> #chair redi
16:00:17 <zodbot> Current chairs: geppetto limburgher redi tibbs
16:00:21 <geppetto> #chair mbooth
16:00:21 <zodbot> Current chairs: geppetto limburgher mbooth redi tibbs
16:00:32 <geppetto> hey peeps
16:02:35 <geppetto> #chair decathorpe
16:02:35 <zodbot> Current chairs: decathorpe geppetto limburgher mbooth redi tibbs
16:02:36 <decathorpe> hi! sorry for being late
16:02:41 * Pharaoh_Atem waves
16:02:41 <geppetto> no problem
16:03:06 <geppetto> I give everyone until at least 5 past anyway :)
16:03:11 * decathorpe waves back
16:03:14 <decathorpe> oh good :)
16:05:15 <geppetto> Hmm, I assume igor would be here … oh well.
16:05:37 <geppetto> #topic Schedule
16:05:40 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/UATLIX2DFWOOQY2SDEAWENND3W6UGSLE/
16:05:54 <geppetto> #topic #761 Modernize R guidelines
16:05:58 <geppetto> .fpc 761
16:06:02 <zodbot> geppetto: Issue #761: Modernize R guidelines - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/761
16:07:02 <geppetto> Ahh, we have talked about this before … so it's a followup … but still
16:07:16 <decathorpe> did anybody find out why including a "%build" section is required?
16:07:17 <tibbs> Most of this is done; I just had the question about the empty %build section.
16:07:40 <tibbs> It's not required for anything as far as I can tell.  I do not know why that requirement was in there originally.
16:07:56 <tibbs> My only guess is that it was related to rpmlint complaining about it.
16:08:00 <decathorpe> in my experience it triggers -debuginfo subpackage generation
16:08:14 <tibbs> And as I wrote, I don't believe that's the case.
16:08:15 <tibbs> At all.
16:08:32 <tibbs> debuginfo subpackage generation is not hung off of anything related to %build.
16:08:50 <decathorpe> did you check?
16:09:13 <decathorpe> I encountered this exact behaviour not long ago.
16:09:16 <tibbs> I did some checks.  I don't know what specific case you encountered so of course I couldn't check that to understand what might have happened.
16:10:03 <tibbs> It's certainly possible I'm wrong, but I have been through the RPM source related to this as well as all of the macros and I don't see how it would matter.
16:10:13 <tibbs> But in any case, if I understand correctly, your case was the opposite.
16:10:25 <tibbs> You had to remove build in order to get rid of an unwanted debuginfo package.
16:10:36 <decathorpe> exactly
16:10:44 <tibbs> And we're talking about why %build might be required.
16:10:59 <tibbs> Note that arch-specific R packages just do the building in %install.
16:11:22 <tibbs> Which is how anything could get built when %build is empty.
16:11:46 <decathorpe> and do -debuginfo subpackages get generated without %build present?
16:12:03 <tibbs> My understanding is that they do.
16:12:31 <tibbs> Anyway, it's not a big deal.  I figure if any of us would have the inside scoop, it would be ignatenkobrain.
16:12:55 <geppetto> yeh
16:13:07 <Pharaoh_Atem> iirc, old versions of rpm hated having missing sections
16:13:25 <tibbs> I think here old means RHEL4 or so.
16:13:36 <redi> oooooooooold
16:13:40 <Pharaoh_Atem> yeah, we're talking < 4.4, I think?
16:13:42 <tibbs> I do not believe EL5 cares.
16:13:51 <Pharaoh_Atem> rpmlint still complains too :/
16:13:59 <tibbs> Yeah, I don't know why we don't turn that off.
16:14:11 <geppetto> I can see how things might trigger on stuff being in _builddir … but I doubt they'd care if that happened in %build or %install … ofc. I wouldn't be surprised at anything to do with rpm building :-o
16:14:52 <decathorpe> ok, so I'd approve removing that specific wording around an empty %build having to be present, pending verification that everything works as expected
16:14:53 <geppetto> So we have any actions or info for this ticket?
16:14:57 <tibbs> Note that there is a lot of env var setting that happens in %build (via %___build_pre, I think) but that is included again in %install.
16:15:12 <tibbs> geppetto: Nah, do more testing and report back.
16:15:18 <Pharaoh_Atem> the main difference at this point with %build and %install is creation of %buildroot automatically
16:15:28 <geppetto> tibbs: that would be an action ;)
16:15:58 <tibbs> It's a very interesting question and we should get an answer independent of what happens with the R stuff.
16:16:07 <geppetto> Pharaoh_Atem: yeh, and that might be the trigger that decathorpe saw
16:16:33 <Pharaoh_Atem> and that latter bit is actually in redhat-rpm-config ;)
16:16:52 <decathorpe> yeah, clarification in general would be nice
16:17:04 <tibbs> But __spec_install_pre explicitly creates the buildroot.
16:17:30 <tibbs> And it includes all of %___build_pre as well.
16:17:32 <geppetto> Hmm, ok, fair enough.
16:17:40 <geppetto> ¯\_(ツ)_/¯
16:17:53 <tibbs> Note that I'm looking at rawhide here, so something could have changed at some point.
16:18:21 <tibbs> Still, I'll do more investigation.  Just have to build 20 or so archful R packages with and without %build and rpmdiff the results.
16:18:37 <tibbs> Anyway, we should probably move on.
16:18:39 <decathorpe> sounds good!
16:18:58 <geppetto> #action tibbs vollunteers to build a bunch of R packages with and without %build to see if there's a difference.
16:19:12 <geppetto> #topic #754 Should py3-foo obsolete py2-foo (when py2-foo is removed)?
16:19:18 <geppetto> .fpc 754
16:19:20 <zodbot> geppetto: Issue #754: Should python3-foo obsolete python2-foo (when python2-foo is removed)? - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/754
16:19:24 <Pharaoh_Atem> oh boy
16:19:28 <Pharaoh_Atem> this one is a bit of a mess
16:19:45 <decathorpe> it is
16:19:48 * decathorpe frowns
16:20:00 <geppetto> Ahh, I thought there was an update … but just me being late with the summary
16:20:37 <geppetto> No proposals in the ticket yet … so we can move on.
16:21:05 <geppetto> #topic #743 Add link to C/C++ build flag docs. in redhat-rpm-config
16:21:07 <geppetto> .fpc 743
16:21:09 <zodbot> geppetto: Issue #743: Add link to C/C++ build flag documentation in redhat-rpm-config - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/743
16:21:47 <geppetto> Again, I think this was mbooth not mboddu
16:21:53 <tibbs> Yeah.
16:22:04 <geppetto> just mb<tab> doing the wrong thing
16:22:44 <mboddu> Haha, I think the people are used to tab completion right after two letters :)
16:22:57 <geppetto> So, I guess no real update here.
16:23:00 * Pharaoh_Atem shrugs
16:23:03 <Pharaoh_Atem> it's a nice document?
16:23:11 <geppetto> mboddu: Yeh, you even get hit for 3 which should be banned ;)
16:23:44 <mboddu> geppetto: Lol :)
16:23:45 <Pharaoh_Atem> if he was mohanboddu it'd work out better
16:23:48 <Pharaoh_Atem> but that's soooo long
16:23:55 <mbooth> mboddu: Sorry, I'm obviously too far down the alphabet
16:24:07 <mboddu> Anyway, I will let you guys carry on :)
16:25:11 <geppetto> #topic Open Floor
16:25:29 <geppetto> Ok, so that's it for tickets with updates … anyone else have anything else?
16:25:35 <mboddu> Pharaoh_Atem, mbooth : :)
16:25:55 <redi> I'm about to start on the action items assigned to me two weeks ago
16:26:04 <tibbs> Ruby?
16:26:07 <decathorpe> what was the action for the updated ruby guidelines?
16:26:22 <decathorpe> i tested them with 2-3 packages and found an issue
16:26:46 <decathorpe> (which should be fixed with an update to rubygems-devel)
16:26:46 <tibbs> I think ignatenkobrain did what he indicated he would do, and that ticket should have moved back to the meeting status.
16:26:55 <geppetto> Ahh
16:27:02 <tibbs> That was 710.
16:27:26 <tibbs> But I don't know what to make of the last couple days of discussion in that ticket.
16:28:21 <Pharaoh_Atem> O.o
16:28:53 <geppetto> #topic #710 Ruby packaging guidelines update
16:28:59 <geppetto> .fpc 710
16:29:01 <zodbot> geppetto: Issue #710: Ruby packaging guidelines update - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/710
16:29:22 <tibbs> Basically, for the issue that decathorpe found, was any change to the draft needed?
16:29:46 <tibbs> I don't have a problem with something breaking a small number of packages if the ruby maintainers are OK with it.
16:29:59 <decathorpe> just a change to macros.rubygems shipped with rubygems-devel is necessary
16:30:10 <decathorpe> and it affects only 2 packages according to vondruch
16:30:48 <geppetto> yeh, no update from churchyard … but I'm fine with it if decathorpe says it's good
16:31:15 <decathorpe> well, the changes look sane, and I created 2 packages with the new guidelines
16:31:25 <decathorpe> which worked well
16:32:20 <geppetto> tibbs: did ignatenkobrain post a summary in email or talk on IRC?
16:32:41 <geppetto> But again, I'm happy to +1 based on decathorpe's review.
16:33:09 <decathorpe> I didn't see anything from ignatenkobrain
16:34:06 <geppetto> Hmm, ok. Anyone else want to vote now?
16:35:29 <decathorpe> +1 from me, assuming the macros get updated
16:36:46 <ignatenkobrain> argh
16:36:47 <ignatenkobrain> I again forgot
16:36:47 <ignatenkobrain> .hello2
16:36:48 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <ignatenko@redhat.com>
16:36:56 <ignatenkobrain> those guidelines were looking good
16:37:02 <ignatenkobrain> apart from what decathorpe found
16:37:05 <ignatenkobrain> about macro in parent dir
16:37:24 <geppetto> #chair ignatenkobrain
16:37:24 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher mbooth redi tibbs
16:38:16 <ignatenkobrain_> something is wrong with my IRC client
16:40:57 <geppetto> ignatenkobrain: last thing I got was "about macro in parent dir"
16:41:31 <ignatenkobrain> hmm, okay
16:41:32 <ignatenkobrain> so it's +1 from me
16:41:34 <ignatenkobrain> just to be clear
16:42:34 <geppetto> Ok, that's 3 … tibbs mbooth redi … any of you want to vote?
16:43:03 <tibbs> Sorry, someone in my office.
16:43:10 <tibbs> Give me a couple to catch up.
16:43:31 <redi> not sure I understand the issues completely. not against the changes though
16:44:15 <redi> I know absolutely nothing about ruby, let alone ruby packaging
16:44:44 <decathorpe> summary of the issue I found: the location of the .gemspec file changed between old and new guidelines, and two macros in rubygems-devel have to be updated as well.
16:45:11 <decathorpe> *to account for that change
16:45:31 <redi> sounds good. +1 with that change, based on your review
16:45:53 <redi> but I'm still mostly ignorant :)
16:46:54 <tibbs> +1 this has sat around for too long anyway.
16:47:03 <mbooth> Sure, +1
16:47:09 <tibbs> If we have to tweak then we can do that next week.
16:48:19 <geppetto> #action VOTE: Ruby packaging guidelines update (+1:6, 0:0, -1:0)
16:48:24 <geppetto> ok
16:48:30 <geppetto> #topic Open Floor
16:49:12 <geppetto> Ok, only 10 minutes left … so anything quick?
16:49:22 <geppetto> ignatenkobrain: Anything you wanted to talk about this week?
16:49:56 <decathorpe> ignatenkobrain: any info why "%build" section could be magical?
16:50:12 <tibbs> I think I might have figured it out.
16:50:26 <ignatenkobrain> decathorpe: IIRC RPM adds debuginfo in there
16:50:27 <ignatenkobrain> sec
16:50:27 <ignatenkobrain> will find it
16:50:45 <tibbs> debuginfo generation is keyed off of whether %buildsubdir is defined.
16:50:54 <tibbs> And that happens internally to RPM, not in macros.
16:51:11 <Pharaoh_Atem> https://src.fedoraproject.org/rpms/redhat-rpm-config/blob/master/f/macros#_161
16:51:36 <ignatenkobrain> so it seems it's defined in %install
16:51:37 <Pharaoh_Atem> debuginfo construction occurs in the install phase
16:51:38 <ignatenkobrain> not in %build
16:51:50 <tibbs> Yes, it's all defined and inserted into the spec at %install time.
16:51:58 <tibbs> But it's keyed off of whether %buildsubdir is defined.
16:52:34 <tibbs> And that happens in build/parsePrep.c as far as I can tell, which confuses me even more.
16:52:55 <redi> but since the R packages do everything during %install, it will work fine
16:53:07 <tibbs> And... it doesn't.
16:53:38 <tibbs> decathorpe was entirely correct; if the empty %build is not present, %buildsubdir never gets defined internally by RPM and so debuginfo generation never happens.
16:53:46 <redi> oh
16:54:02 <tibbs> See how %install is defined:
16:54:07 <decathorpe> I was right? haha
16:54:08 <tibbs> install    %{?_enable_debug_packages:%{?buildsubdir:%{debug_package}}}
16:54:26 <redi> aha
16:54:40 <redi> well at least now you can add that to the guidelines as justifcation for requiring %build
16:54:58 <tibbs> Yes, it makes sense.
16:55:00 <decathorpe> yes, good idea to document that somewhere.
16:55:02 <Pharaoh_Atem> this is messed up
16:55:14 <Pharaoh_Atem> the mechanism to activate it is keyed on %install
16:55:21 <geppetto> #info tibbs confirms %build needed for debuginfo generation
16:55:34 <Pharaoh_Atem> but the actual build is required by %build :/
16:55:40 <tibbs> Well, the injection of it all happens in %install.
16:56:07 <tibbs> I just don't understand the mechanism behind how %buildsubdir gets defined.
16:56:32 <tibbs> I mean, I guess it's this in build/parsePrep.c: rpmPushMacro(spec->macros, "buildsubdir", NULL, spec->buildSubdir, RMIL_SPEC);
16:57:16 <tibbs> But but that's in the doSetupMacro function, so I still don't understand what %build has to do with it at all.
16:57:47 <ignatenkobrain_> let me ask different question, does removal of that section break anything?
16:58:06 <tibbs> You mean the empty %build section?
16:58:18 <tibbs> If so, yes, you don't get debuginfo packages if it's not there.
16:58:38 <tibbs> To recap: archful R packages do all of their building in %install and have an empty %build section.
16:58:53 <tibbs> If you remove the empty %build section, no debuginfo generation happens.
16:59:13 <tibbs> So the first question was whether the empty %build is required.  That's a big yes.
16:59:27 <tibbs> The followup question is "WTF?"
16:59:35 <decathorpe> haha yeah
16:59:49 <jkurik> info: we have anothere meeting here in 1 minute :-)
16:59:50 <tibbs> Anyway, we're at an hour and I learned something today.
16:59:55 <decathorpe> at least we know now that the empty %build is there on purpose
17:00:06 <tibbs> I'll summarize in the ticket and close it out.
17:00:16 <decathorpe> +1
17:01:59 * nirik looks for the F28 go/no-go meeting... if FPC is done?
17:02:01 * jkurik propose #endmeeting :-)
17:02:13 <geppetto> ok
17:02:18 <geppetto> #endmeeting