16:01:34 <mhroncok> #startmeeting fpc
16:01:34 <zodbot> Meeting started Thu Sep 13 16:01:34 2018 UTC.
16:01:34 <zodbot> This meeting is logged and archived in a public location.
16:01:34 <zodbot> The chair is mhroncok. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:34 <zodbot> The meeting name has been set to 'fpc'
16:02:02 <mhroncok> #meetingname fpc
16:02:02 <zodbot> The meeting name has been set to 'fpc'
16:02:05 <mhroncok> #topic Roll Call
16:02:33 <mhroncok> #chair decathorpe
16:02:33 <zodbot> Current chairs: decathorpe mhroncok
16:02:46 <geppetto> mhroncok: hey, thanks
16:03:00 <geppetto> I'm here, was just distracted
16:03:03 <mhroncok> #chair tibbs geppetto
16:03:03 <zodbot> Current chairs: decathorpe geppetto mhroncok tibbs
16:03:12 <decathorpe> hi everybody
16:03:19 <mhroncok> hi hi
16:03:33 * limburgher here
16:03:47 <mhroncok> #chair limburgher
16:03:47 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok tibbs
16:04:03 <mhroncok> ignatenkobrain: ping
16:04:03 <zodbot> mhroncok: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
16:04:19 <tibbs> Howdy.
16:06:20 <mhroncok> geppetto: feel free to continue from here :)
16:06:59 <geppetto> mhroncok: I can if you want, but I'm happy for you to run it.
16:08:27 <geppetto> #topic Schedule
16:08:40 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/3YK57SQSHAAZSLEV4LFPA77UULC4Q6TO/
16:08:51 <geppetto> #topic  #793 Python Guidelines: Move Python 2 to Appendix
16:08:55 <geppetto> .fpc 793
16:08:57 <zodbot> geppetto: Issue #793: Python Guidelines: Move Python 2 to Appendix - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/793
16:09:25 <mhroncok> (sorry, somebody knocked on the door)
16:09:49 <mhroncok> this change: the page changed in the meantime
16:09:59 <geppetto> No problem. This one is your ticket … want to say anything?
16:10:00 <mhroncok> and i cannot rebase it like in git, so the diffs are important
16:10:44 <mhroncok> basically we say: python2 is deprecated, do not package for it, and here are the guidelines for py3
16:10:48 <mhroncok> py2 is in appendix
16:11:00 <mhroncok> various details changed, like the naming rule of executables
16:11:19 <mhroncok> is now reversed, except for situations where it would break user expectations
16:11:26 <mhroncok> eof
16:12:47 * geppetto nods … is py2 deprecated for f30?
16:13:21 <mhroncok> yes
16:13:35 <mhroncok> not removed, but marked as deprecated
16:13:53 * geppetto nods … but you can't package new stuff without an exception for f30?
16:13:58 <mhroncok> right
16:14:04 * geppetto nods … I'm +1 then
16:14:47 <tibbs> +1
16:14:56 <mhroncok> +1 obviously
16:15:12 <decathorpe> looks good
16:15:14 <decathorpe> +1
16:15:52 <mhroncok> limburgher: ...
16:18:50 <mhroncok> orionp maybe?
16:20:10 <geppetto> #chair
16:20:10 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok tibbs
16:20:20 <limburgher> +1
16:20:27 <limburgher> Sorry, pulled 3 ways ATM. :)
16:20:39 <geppetto> #action Move Python 2 to Appendix (+1:5, 0:0, -1:0)
16:20:51 <mhroncok> \o/
16:21:07 <limburgher> :party_parrot:
16:21:09 <mhroncok> tibbs: would you liek to go trough it, or may i just apply the changes?
16:21:47 <tibbs> I do have time today, but if you want to do it now then feel free.
16:22:15 <geppetto> #topic Open Floor
16:22:36 <geppetto> So, no other tickets have changed in the last week … anything anybody wants to talk about?
16:22:41 <mhroncok> tibbs: I would do it today, but not now
16:22:46 <tibbs> One issue with doing writeups now is that I have no idea what state the conversion is in.
16:22:57 <mhroncok> no state
16:23:00 <tibbs> I did finish up all of the pending writeups before this one.
16:23:23 <mhroncok> if we have the conversion, it needs to be announced at least to us: do not touch the wiki form now
16:23:30 <mhroncok> or somehting liek that. that didn't happen yet
16:26:34 <mhroncok> tibbs: let's do it. I'll convert it to git to later if the ocnversion started
16:26:34 <mhroncok> *conversion
16:27:34 <tibbs> True, we can't just stall the whole process out.
16:27:53 <tibbs> I just thought it was supposed to happen over the weekend, so I made sure to get the writeups done.
16:28:16 <decathorpe> who's working on it?
16:28:22 <mhroncok> igor maybe
16:28:25 <mhroncok> but I'm not sure
16:29:02 <decathorpe> well, whoever it is, I have some free time I could throw their way to help
16:29:16 <tibbs> Sadly I've been out sick for several days
16:29:23 <mhroncok> https://pagure.io/packaging-committee/issue/727#comment-531198
16:29:34 <tibbs> At the last meeting Igor said he would do it over the weekend.
16:30:30 <tibbs> I just didn't want to interfere with that since I know it's a big job.
16:31:19 <mhroncok> I understand, but as said, I volunteer to apply this change on top of that conversion if it is needed
16:33:38 <mhroncok> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/JC6GEATSRPOQKIC4CC4OYYNLXA6RYUGP/
16:33:42 <mhroncok> juts got this
16:34:50 <geppetto> ok
16:35:59 <decathorpe> sounds interesting
16:36:51 <geppetto> Anything else to discuss?
16:37:01 <mhroncok> not really
16:37:08 <decathorpe> nope
16:37:39 <limburgher> Not here.
16:40:14 <geppetto> #endmeeting