16:01:34 <geppetto> #startmeeting fpc
16:01:34 <zodbot> Meeting started Thu Sep 20 16:01:34 2018 UTC.
16:01:34 <zodbot> This meeting is logged and archived in a public location.
16:01:34 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:34 <zodbot> The meeting name has been set to 'fpc'
16:01:42 <geppetto> #meetingname fpc
16:01:42 <zodbot> The meeting name has been set to 'fpc'
16:01:42 <geppetto> #topic Roll Call
16:01:49 <redi> hi
16:02:34 <geppetto> #chair redit
16:02:34 <zodbot> Current chairs: geppetto redit
16:02:34 <geppetto> #chair redi
16:02:34 <zodbot> Current chairs: geppetto redi redit
16:06:40 * limburgher is here
16:07:01 <geppetto> #chair limburgher
16:07:01 <zodbot> Current chairs: geppetto limburgher redi redit
16:07:06 <bexelbie> .hello bex
16:07:07 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bexelbie@redhat.com>
16:08:35 <geppetto> #unchair redit
16:08:35 <zodbot> Current chairs: geppetto limburgher redi
16:09:59 <tibbs> Hey, folks.
16:10:03 <tibbs> Busy day here in the office.
16:10:04 <geppetto> #chair tibbs
16:10:04 <zodbot> Current chairs: geppetto limburgher redi tibbs
16:10:15 <geppetto> tibbs: no problem … probably no meeting
16:10:21 <geppetto> no new tickets anyway
16:10:36 <geppetto> #topic Open Floor
16:11:03 <geppetto> Anything anyone wants to talk about?
16:11:33 <sdgathman> Yes, I wonder if there is a way to handle Fedora Java libraries bundled for EPEL in an official way.
16:11:37 <tibbs> I took care of all of the pending writeups and the announcement last week, so that's all done.
16:12:06 <tibbs> sdgathman: That would probably be more up to the EPEL folks.
16:12:13 * bexelbie understand that ignatenkobrain wants to talk about the git version of the packaging guidelines
16:12:23 <sdgathman> tibbs: thanks
16:12:58 <tibbs> I mean, I know that having prebuilt jars would still violate loads of requirements.
16:13:23 <tibbs> But bundling is just bundling and is already covered by existing guidelines.
16:13:44 <sdgathman> I'll just hope that EPEL8 has new enough libs to build without bundling.
16:13:56 <tibbs> So I'm assuming you're asking about some very java-specific thing and thus I don't know what we could tell you anyway.
16:14:05 <ignatenkobrain> .hello2
16:14:08 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
16:15:01 <x3mboy> .hello2
16:15:02 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
16:15:10 <x3mboy> Hi guys
16:15:12 <ignatenkobrain> I'm fully here
16:15:20 <ignatenkobrain> I would like to
16:15:40 <sdgathman> tibbs: I learned where to go to pursue it.  Thanks.
16:15:50 <geppetto> #chair ignatenkobrain
16:15:50 <zodbot> Current chairs: geppetto ignatenkobrain limburgher redi tibbs
16:16:09 <ignatenkobrain> .fpc 727
16:16:11 <zodbot> ignatenkobrain: Issue #727: convert guidelines to git and restructured text - packaging-committee - Pagure - https://pagure.io/packaging-committee/issue/727
16:16:17 <ignatenkobrain> I would like to talk about this one
16:18:27 <geppetto> Ok, I think we have 5 now
16:18:31 <redi> I worry about fancy new systems like antora
16:18:37 <redi> active development now, but what about in 2 years?
16:18:44 <redi> but in principle I'm all for the migration
16:19:30 <geppetto> #topic #727 convert guidelines to git and restructured text
16:20:08 <x3mboy> !
16:20:46 <ignatenkobrain> so we've made some progress with bexelbie  on it
16:20:48 <ignatenkobrain> but there are a lot of things to do
16:20:55 <ignatenkobrain> and zbyszek was not happy about antora due to some things
16:21:04 <ignatenkobrain> so I would like to discuss if we want to continue moving this way as we do now and what is critical for me to fix asap?
16:23:43 <ignatenkobrain__> wdyt?
16:24:16 <tibbs> I don't care about antora versus, well, anything else really.  I won't even complain about asciidoc or whatever it's called instead of RST.  I just want to know how I'll be editing things in the future.
16:24:41 <tibbs> I think fundamentally it would be dumb for us to try to break from whatever the rest of the documentation team is doing.
16:24:45 <redi> yeah, any of them is ok really. I like sphinx based on the tiny bit I've used it
16:24:49 <redi> if we're only 5 does that mean we lose quorum if I leave?  :-\
16:25:26 <tibbs> I don't think we have any real decision to make here.  We're just waiting on someone to tell us how this new system is going to work.[
16:25:30 <limburgher> Consistency is valuable.
16:25:31 <redi> hmm
16:26:05 <ignatenkobrain__> tibbs: ok, so next question is `where do we want to have guidelines to be stored?`
16:26:15 <ignatenkobrain__> which repo?
16:26:54 <tibbs> I'd assumed that would be dictated by the system, but if it can just live in pagure then why not the packaging-committee pagure instance we already have and use?
16:27:02 <limburgher> Seems rational.
16:27:26 <redi> makes sense to me too
16:27:43 <redi> gotta step away, sorry. back asap, but might not be before the end of the hour
16:28:46 <ignatenkobrain__> someone proposed to use packaging-guidelines repo... both have advantages and disadvantages
16:28:55 <tibbs> "someone"?
16:29:03 <ignatenkobrain__> zbyszek
16:29:18 <ignatenkobrain__> it is logical because people would search for guidelines in pagure...
16:29:20 <tibbs> Who... has no stake in this.
16:29:36 <ignatenkobrain__> but it's harder because we would have 2 repos
16:29:50 <tibbs> Well we're not going to maintain two ticketing instances.
16:30:02 <ignatenkobrain__> then let's put it into packaging-committee
16:30:04 <tibbs> That would just be dumb.
16:30:21 <ignatenkobrain__> history in git in my repo looks fine?
16:30:44 <ignatenkobrain__> https://pagure.io/fork/ignatenkobrain/packaging-committee/commits/guidelines
16:30:50 <bexelbie> it is possible to put the guidelines below the root dir of the repo if that would help with organization of files
16:30:51 <x3mboy> By using asciidoc with Antora, the Pagure instance can be used to store the docs and works like a standard git repo
16:31:21 <ignatenkobrain__> I realized that git-mediawiki didn't convert all revisions so I'm going to re-do this part. but just wanted to ensure that history looks good
16:31:52 <tibbs> Looks good except of course that it's missing two years of changes.
16:32:08 <ignatenkobrain__> tibbs: yes, I didn't spot this earlier. my fault
16:32:12 <ignatenkobrain__> I will redo it today
16:32:38 <tibbs> And sadly we have no access to the old moin history.
16:34:13 <ignatenkobrain__> bexelbie: I will ping you once I push to packaging-committee repo so that you change settings in your top-level project
16:34:33 <bexelbie> ignatenkobrain__, certainly - let me know if you need my help with putting the files belowt he root dir
16:34:42 <bexelbie> council-docs does it with several sets of things as a model
16:34:43 <tibbs> It would indeed be good to put the guidelines somewhere below the root if at all possible.
16:34:57 <ignatenkobrain__> bexelbie: if you could describe me this in tg, would be awesome
16:35:15 <bexelbie> mkdir foo; put all the stuff in foo :P
16:35:35 <bexelbie> build.sh, preview.sh, and site.yml should also be there
16:35:47 * ignatenkobrain__ shrugs
16:36:12 <ignatenkobrain__> bexelbie: I have better than those .sh, I have makefile which doesn't run `sudo docker` but rather just `podman` :P
16:36:15 <tibbs> And I'd like to know at some point how I can preview this stuff locally.
16:36:37 <bexelbie> tibbs, ./build.sh && ./preview.sh
16:36:48 <ignatenkobrain__> tibbs: basically run `make && make serve` and open localhost:8000
16:42:23 <geppetto> Ok, anything else?
16:42:35 <geppetto> We have a timeline for a finish line?
16:42:49 <ignatenkobrain__> just to recap: I'm going to push updated version with all updates from wiki tonight
16:42:57 <ignatenkobrain__> and then we will slowly fix all remaining issues
16:43:08 <ignatenkobrain__> so until monday docs.fp.o should be more or less usable
16:44:18 <tibbs> But the bottom line is that we should not be touching the wiki at this point.
16:44:57 <ignatenkobrain__> yes, let's do everything in git since tonight
16:45:02 <ignatenkobrain__> and make wiki read-only
16:45:16 <ignatenkobrain__> then once we are comfortable with docs, we will do redirects from wiki
16:46:25 <geppetto> #action Nobody should touch the wiki, at this point.
16:46:41 <geppetto> Ok
16:51:12 <geppetto> #endmeeting