16:00:02 <geppetto> #startmeeting fpc
16:00:02 <zodbot> Meeting started Thu Oct  4 16:00:02 2018 UTC.
16:00:02 <zodbot> This meeting is logged and archived in a public location.
16:00:02 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:02 <zodbot> The meeting name has been set to 'fpc'
16:00:02 <geppetto> #meetingname fpc
16:00:02 <zodbot> The meeting name has been set to 'fpc'
16:00:02 <geppetto> #topic Roll Call
16:00:09 <redi> yo dawgs
16:00:12 <geppetto> #chair redi
16:00:12 <zodbot> Current chairs: geppetto redi
16:00:15 <tibbs> Hello.
16:00:15 <geppetto> :)
16:00:19 <geppetto> #chair tibbs
16:00:19 <zodbot> Current chairs: geppetto redi tibbs
16:00:21 <ignatenkobrain> .hello2
16:00:22 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
16:00:26 <geppetto> #chair ignatenkobrain
16:00:26 <zodbot> Current chairs: geppetto ignatenkobrain redi tibbs
16:01:34 * limburgher here
16:01:43 <geppetto> #chair limburgher
16:01:43 <zodbot> Current chairs: geppetto ignatenkobrain limburgher redi tibbs
16:02:14 <geppetto> that's 5 … woo
16:02:19 <geppetto> mhroncok: you around?
16:02:46 <mhroncok> geppetto: yes, sorry
16:02:53 <geppetto> #chair mhroncok
16:02:53 <zodbot> Current chairs: geppetto ignatenkobrain limburgher mhroncok redi tibbs
16:02:56 <geppetto> #chair decathorpe
16:02:56 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher mhroncok redi tibbs
16:03:01 * decathorpe is here
16:03:15 <redi> I don't have to leave early today   \o/
16:03:28 <geppetto> cool
16:03:49 <geppetto> Although we might leave early anyway … as I'm not sure we have much to do.
16:04:10 <redi> aw man
16:04:11 <ignatenkobrain> just FYI
16:04:11 <redi> ;)
16:04:13 <ignatenkobrain> #info I have fixed markup on https://docs.fedoraproject.org/en-US/packaging-guidelines/Python/
16:04:33 <geppetto> ignatenkobrain: cool
16:04:35 <mhroncok> ignatenkobrain++
16:04:35 <zodbot> mhroncok: Karma for ignatenkobrain changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:04:38 <geppetto> #topic Schedule
16:04:42 <geppetto> https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/PCK2NLJADBXFXBR43BVQIYXGSLTKLMIR/
16:05:33 <geppetto> So … we have 4 tickets, nothing new … anyone want to talk about any of them?
16:05:44 <limburgher> Nothing here.
16:06:28 <mhroncok> .fpc 775
16:06:30 <zodbot> mhroncok: Issue #775: Allow to have %{?suse_version} condition in spec file - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/775
16:06:42 <decathorpe> ignatenkobrain++
16:06:43 <mhroncok> can we formally vote on their proposal so we can close it?
16:06:44 <zodbot> decathorpe: Karma for ignatenkobrain changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:06:47 <geppetto> tibbs: You dealt with the PR for 719?
16:07:06 <geppetto> #topic #775 Allow to have %{?suse_version} condition in spec file
16:07:52 <mhroncok> what we vote about: Allow to have %{?suse_version} condition in spec file of one particular package
16:08:07 <mhroncok> what we don't vote about: Allow it globally
16:08:15 <geppetto> it's kind of weird to vote on … because we can't disallow it
16:08:15 <tibbs> geppetto: Regarding 719 I've been talking with nim about it.  He says he's about done messing with it. I haven't had a chance to look in the past few days to see if he sent the combined PRs he was going to send.
16:08:31 <geppetto> tibbs: ok
16:08:42 <mhroncok> geppetto: IMHo we can formally say we (don't) agree
16:09:20 <redi> +1 to "we prefer that you not do this and aren't going to change existing guidelines to explicitly allow it, but we can't stop you"
16:09:33 <tibbs> About 775, if asked I'll always vote against that kind of thing, knowing I can't stop anyone but also knowing that if I have to touch a spec and that accidentally breaks it on suse somehow, I won't apologize.
16:09:34 <redi> is that what we're saying? :)
16:09:39 <geppetto> I'm a 0
16:09:44 <decathorpe> redi: I agree
16:09:55 <mhroncok> +1  for what redi said
16:09:58 <limburgher> I'm -1.
16:10:04 <redi> well that's just quoting tibbs from the ticket
16:11:05 <redi> tibbs: "if I have to touch a spec and that accidentally breaks it on suse somehow, I won't apologize" absolutely, provenpackagers should do what they need to for fedora, and if the maintainer wants to tweak that later for suse, that's their responsibility
16:12:11 <geppetto> decathorpe: is that a +1
16:12:32 <geppetto> ignatenkobrain: You have an opinion?
16:12:36 <decathorpe> +1 to: we can't stop you if you really want to do this
16:12:37 <mhroncok> limburgher: -1 to what redi ays or to what the ticket asks for?
16:13:25 <geppetto> yeh, the vote is on tibbs wording, which is the opposite of the ticket
16:13:32 <limburgher> mhroncok, to what the ticket asks for. Honestly I'm maybe -0.5 but we like integers.
16:13:39 <redi> :)
16:13:55 <geppetto> limburgher: Ok, that's a +1 then … or a +0.5 then ;)
16:14:11 <limburgher> I don't feel like these have any place in Fedora specs and if they break, the maintainer gets to keep both pieces.
16:14:53 <decathorpe> I agree
16:15:11 <limburgher> but if they are there and they work and don't break anything for Fedora.. . .:shrug:
16:15:29 <ignatenkobrain> I won't apologize if I break something related to suse when I touch that spec ;)
16:15:49 <ignatenkobrain> so +1
16:15:51 <ignatenkobrain> ;)
16:16:22 <geppetto> I mean I won't either … but part of me wouldn't mind if specs were more portable
16:16:24 <limburgher> Sort of like I won't apologize to my neighbor if changing my wifi password breaks his Netflix. ;)
16:16:32 <geppetto> #action FPC prefers you don't do it, but there's nothing stopping you. (+1:6, 0:1, -1:0)
16:16:37 <limburgher> geppetto, I agree, but it's not a high priority.
16:17:02 * geppetto nods
16:17:26 <geppetto> #topic #693 Wiki:Packaging:RPMMacros
16:17:54 <geppetto> tibbs: looks like you volunteered for something here
16:18:27 <limburgher> ---> Bus
16:18:28 <limburgher> ---> tibbs
16:18:29 <tibbs> A long time ago, yeah, but I indicated in a previous meeting that I don't really know what to do about it.
16:18:50 <limburgher> I don't think the guidelines need anything. Just close the ticket with above language.
16:18:56 <redi> yeah
16:19:06 <tibbs> I mean, there are some messy bits in the guidelines.
16:19:14 <tibbs> And some of this stuff just isn't documented anywhere.
16:19:29 <tibbs> But does it need to be in the guidelines? I don't know.
16:19:51 <geppetto> eh
16:19:59 <geppetto> if it's stuff that changes in rpm then probably not
16:20:13 <geppetto> So do we just want to close this as nothing to do now?
16:20:14 <limburgher> On the one hand, the manual to my fridge says "Use only Whirlpool Brand water filters." On the other. . .
16:20:30 <limburgher> I think so.
16:20:34 <geppetto> Or do we want tibbs to go through and delete stuff?
16:20:47 <tibbs> That's basically why it was kept open.
16:20:56 <tibbs> We have this page.  People expect it to be correct if it's there.
16:21:02 * geppetto nods
16:21:13 <tibbs> It's not unreasonable to think that there should be some information somewhere about that stuff.
16:21:19 <geppetto> That seems reasonable … so do we just delete the page?
16:21:35 <geppetto> eh, but we don't really need to be documenting bits of rpm
16:21:38 <tibbs> I just don't know where.  And I sot of had a draft somewhere, but that's not linked in the ticket somehow.
16:22:01 <tibbs> I know I said that I didn't intend to write one.
16:22:56 <tibbs> I'm fine with just removing the page.
16:22:58 <ignatenkobrain> probably just have table with main rpm macro, make sure it is updated and then say "look into /usr/lib/rpm/macros" ?
16:23:20 <tibbs> I don't think you could even define "main rpm macro".
16:23:26 <geppetto> yeh
16:23:55 <tibbs> The only conflict here I see is that the guidelines encourage the use of macros for directories.
16:24:38 <tibbs> %_bindir and the like.  Personally I don't really use any of them besides %_libdir (for obvious reasons) unless they actually save me typing.
16:24:55 <ignatenkobrain> well, it is useful for instance for flatpak efforts
16:25:06 <ignatenkobrain> where %_prefix is being redefined to /app
16:25:15 <tibbs> Hopefully I never have to interact with that mess.
16:25:41 <tibbs> But in any case, the problem is that we say "you should use this" and then don't say what "this" is.
16:26:12 <tibbs> Or rather, we sort of do now but wouldn't if we delete the page.
16:26:25 <tibbs> That's why the ticket is still open, and why it hasn't made any progress.
16:27:22 <geppetto> We can probably just say "use rpm macros where appropriate" and leave it at that?
16:27:32 <decathorpe> If nobody wants to volunteer, I can update and clean up the page :shrug:
16:27:49 <geppetto> We have a victi^W volunteer
16:28:03 <geppetto> #action decathorpe will clean up the page
16:28:33 <geppetto> #topic #784 forbid globs for shared libraries as it conceals sonames
16:28:45 <geppetto> decathorpe: did the PR happen?
16:28:49 <decathorpe> we merged it this week, yes
16:28:58 <decathorpe> we were all happy with the final version
16:29:04 <redi> yup
16:29:13 <geppetto> cool, so this ticket is done?
16:29:30 <decathorpe> from my point of view, yes
16:29:35 <geppetto> #info PR was merged this week
16:29:41 <ignatenkobrain> yep
16:29:42 <tibbs> I really wish pagure hadn't inherited the confusion between tickets and pull requests that github has.
16:29:44 <ignatenkobrain> let's close it
16:30:02 <tibbs> Don't you think it should be announced before it gets closed?
16:30:27 <geppetto> Yeh
16:30:29 <tibbs> The PR didn't get linked to the ticket as far as I can tell, so I'm not sure how to see what was actually merged.
16:30:57 <ignatenkobrain> it was supposed to be linked, but for some reason it didn't work
16:31:07 <ignatenkobrain> https://docs.fedoraproject.org/en-US/packaging-guidelines/#_listing_shared_library_files
16:31:19 <decathorpe> https://pagure.io/packaging-committee/c/2051d0c7dcd7f062e2c8571f19a8cf7eea8b0ce6?branch=master
16:31:29 <redi> can a PR include something like "Fixes #695" to auto-close a ticket?
16:31:36 <geppetto> redi: yeh
16:31:39 <tibbs> If it can, we shouldn't use it.
16:31:50 <geppetto> redi: but it closes the ticket, which isn't what we want … we want ot move it to announce
16:31:55 <redi> gotcha
16:31:56 <tibbs> We want to associate tickets with PRs, yes.
16:32:06 <mhroncok> we want to update https://fedoraproject.org/wiki/Packaging_Committee#Guideline_Change_Procedure I guess
16:32:20 <mhroncok> and say how PRs relate to tickets
16:32:25 * geppetto nods
16:32:41 <mhroncok> should I open a ticket for that so we can track it?
16:32:47 <geppetto> mhroncok: might as well
16:32:59 * mhroncok creates a ticket
16:33:23 <geppetto> we'll probably forget otherwise, until we hit something again and get reminded
16:33:27 <geppetto> Cool
16:33:31 <geppetto> #topic Open Floor
16:33:54 <geppetto> Ok, so that's all the tickets … anything else anybody wants to discuss?
16:34:22 <decathorpe> is there a plan (or progress) to package antora for fedora?
16:34:31 <tibbs> I sure hope so.
16:34:58 <tibbs> I did manage to get podman running but I think the whole thing is a mess and I really wish I had looked more closely into it before we jumped.
16:35:08 <limburgher> Any comments on the email to the packaging list about the new packager process?
16:35:08 <decathorpe> I agree
16:35:37 <tibbs> One thing we certainly shouldn't have done is sent an announcement.
16:35:37 <decathorpe> and I agree that finding a sponsor is a bottleneck, it was for me too
16:35:57 <tibbs> That's OT, but how is finding a sponsor a bottleneck?
16:36:33 <tibbs> It literally interrupts none of the review process and only holds up the import process as long as it takes to file a ticket and await a response.
16:37:03 <decathorpe> my first package was stuck in review / sponsor-finding for weeks~months
16:37:15 <mhroncok> mine as well
16:37:25 <tibbs> Stuck in review is true, but sponsor-finding isn't a part of that process at all.
16:37:45 <tibbs> Package is reviewed and approved.  If not sponsored yet, file a ticket in packager-sponsors.
16:37:46 <mhroncok> https://fedoraproject.org/wiki/How_to_get_sponsored_into_the_packager_group
16:37:52 <tibbs> Someone sponsors you.  Done.
16:38:10 <mhroncok> There are several ways to get sponsored into the packager group depending on your interest....
16:38:37 <tibbs> I assume you took the "submitting quality new packages" route.
16:38:44 <mhroncok> If you have accepted packages and still have not managed to find a sponsor, feel free to file a ticket in the sponsors ticketing system.
16:38:59 <mhroncok> that should do
16:39:18 <decathorpe> yeah
16:39:18 <mhroncok> I honeslt cannot remember if this was always written there
16:39:23 <limburgher> Reasonable. Just wanted to make sure we discussed it.
16:39:58 <tibbs> I did a lot of work and drafts and committee meetings a few years ago to eliminate the hard link between sponsorship and package reviews.
16:40:20 <tibbs> Since sponsorship is more about helping someone through the draconian process of geting things imported and pushed out.
16:40:34 <tibbs> And reviewing is more about helping someone through the draconian process of making an acceptable specfile.
16:40:39 <decathorpe> yeah
16:40:39 <tibbs> The two have little to do with each other.
16:41:09 <limburgher> Right. They used to coincide a lot, but they needn't.
16:41:24 <tibbs> And I think the current process is as good as we can get it without changing RPM or how our infrastructure flow works.
16:41:37 <tibbs> Or not using bugzilla for reviews.
16:41:54 <limburgher> Right.
16:42:08 <tibbs> The problem is that some people just remember it differently, and give bad advice like "first package?  The review must be done by a sponsor."
16:42:19 <tibbs> Which hasn't been true for years.
16:43:44 <decathorpe> @tibbs (before I have to go eat so I don't starve): concerning guidelines docs: I think announcing the "switch" was a bit early, but I guess we can say that 1) the wiki is now read-only, 2) the new docs are in "beta", 3) and we accept pull requests?
16:45:10 <redi> release early release often! :)
16:45:11 <tibbs> I think so.
16:45:28 <decathorpe> redi: move fast and break things? no thanks ;)
16:45:30 <tibbs> We should start marking wiki pages as being archived copies, at least for a bit.
16:45:35 <redi> :)
16:45:37 <redi> I do think the new docs look good, and formatting issues can be fixed
16:45:59 <tibbs> I can't find much in the new docs, but mostly they just need proper TOC entries.
16:46:05 <tibbs> Or however it works.
16:46:24 <ignatenkobrain> there's PR adding TOC
16:46:31 <tibbs> I am not enjoying asciidoc at all but on balance it isn't worse than the wiki.
16:46:31 <ignatenkobrain> so feel free to add your comment there
16:47:34 <ignatenkobrain> tibbs: any specific problems or just in general?
16:47:34 <tibbs> I just don't understand this mad rush to some software that isn't packaged.
16:47:51 <tibbs> Well it's more baroque than rst, that's for sure.
16:48:03 <tibbs> The `+ +` thing is terrible.
16:48:23 <tibbs> But as I wrote elsewhere, still better than <code></code>.
16:48:59 <ignatenkobrain> well, you can do things like
16:49:02 <tibbs> And fundamentally I think at least our main page just doesn't fit the organization.
16:49:29 <ignatenkobrain> https://paste.fedoraproject.org/paste/Af6Zb~cirGwiyAc6JaNIxA
16:49:48 <tibbs> But again, that wasn't really better in the wiki.  It has always been too long; the new system just exacerbates that.
16:49:55 <ignatenkobrain> so backticks just indicate monospace font
16:50:05 <ignatenkobrain> backticks and plus sign indicate monospace and literal text
16:50:11 <tibbs> My point is that's not ever what we actually want.
16:51:08 <tibbs> And the inability to preview these documents in pagure is... really bad.
16:51:29 <geppetto> So unless we have some proposals it's probably not worth keeping the meeting open just to air annoyances about the new system
16:51:47 <tibbs> Indeed, but we have to live with it now.
16:51:56 <geppetto> tibbs: You can't run something locally to see html?
16:52:12 <tibbs> I can now.  The instructions in the repository are incomplete.
16:52:20 <geppetto> Ahh
16:52:38 <tibbs> You have to enable subuids and subgids for your account before you can run podman.
16:52:53 <decathorpe> incomplete? they worked for me verbatim ...
16:52:58 <tibbs> Or you can run asciidoctor on a single file to get an HTML preview, which is good enough for most people.
16:53:37 <tibbs> decathorpe: Maybe you had already enabled subuids and subgids on your account.  All I know is that it didn't work for me until I did that.
16:54:04 <tibbs> And doing that was the only thing I needed to do in order to make it work.
16:54:22 * decathorpe shrugs. okay
16:54:45 <decathorpe> requiring python 3.7 for the html server command was the bigger hurdle for me ;)
16:55:11 <tibbs> You don't need that at all, though.  You can just run firefox index.html.
16:55:25 <decathorpe> yeah, I know that now
16:55:46 <tibbs> The only downside is that the document structure expects a directory reference to redirect to index.html, so sometimes you need an extra click.
16:55:54 <tibbs> It's not bad.
16:56:46 <tibbs> Sadly the docs.fp.org page suffers from excessive whitespace like the rest of the Fedora pages, but I've greasemonkeyed those out of existence.
16:56:56 <tibbs> https://www.math.uh.edu/~tibbs/greasemonkey/Widen_pagure.user.js
16:57:38 <decathorpe> \o/
16:58:09 <tibbs> I still have to zoom out a bit, even with my failing eyesight.
16:58:37 <ignatenkobrain> decathorpe: I already fixed it
16:59:19 <decathorpe> oh, thanks :)
16:59:23 <ignatenkobrain> tibbs: I think greasemonkey is proprietary thing, but there is stylus 😉 https://github.com/openstyles/stylus/wiki
16:59:33 <tibbs> Greasemonkey is not a proprietary thing.
16:59:41 <tibbs> Stylus is for stylesheets only.
17:00:09 <tibbs> https://github.com/greasemonkey/greasemonkey
17:00:11 <geppetto> Ok, on that note I'm going to close the meeting
17:00:20 <geppetto> #endmeeting