19:01:33 <bcotton> #startmeeting F29 Final Readiness Meeting
19:01:33 <zodbot> Meeting started Thu Oct 18 19:01:33 2018 UTC.
19:01:33 <zodbot> This meeting is logged and archived in a public location.
19:01:33 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:33 <zodbot> The meeting name has been set to 'f29_final_readiness_meeting'
19:01:35 <bcotton> #meetingname f29-Final-readiness-meeting
19:01:35 <zodbot> The meeting name has been set to 'f29-final-readiness-meeting'
19:01:40 <bcotton> #topic Roll Call
19:01:54 <contyk> .hello psabata
19:02:05 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
19:02:48 <nirik> morning
19:03:01 * stickster lurks, in another meeting
19:04:26 <bcotton> well the attendance here seems to roughly correspond to our readiness to release :-)
19:04:32 <frantisekz> .hello2
19:04:35 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
19:04:36 <frantisekz> :D
19:05:07 <Pharaoh_Atem> .hello ngompa
19:05:08 <zodbot> Pharaoh_Atem: ngompa 'Neal Gompa' <ngompa13@gmail.com>
19:05:21 <bcotton> okay, i'll get started and we'll see who else shows up
19:05:24 <bcotton> #info Before each public release all of the groups participating the development of Fedora's next release meet to make sure the release is well-coordinated.
19:05:26 <bcotton> #link https://fedoraproject.org/wiki/Release_Readiness_Meetings
19:05:32 <bcotton> #topic Current status
19:05:40 <bcotton> #info Fedora 29 Final is NO-GO
19:05:41 <bcotton> #info The next Go/No-Go meeting is planned on Thursday, 2018-10-25
19:05:43 <bcotton> #info The Final release moves from preferred target date to target date #1, which is 2018-10-30
19:05:54 <bcotton> any questions on F29 status?
19:06:29 <contyk> is it supergreen?
19:06:31 <bcotton> #info We will NOT repeat this meeting after next week's Go/No-Go meeting
19:06:58 <bcotton> it's super...something
19:07:13 <bcotton> okay, time to go around
19:07:18 <bcotton> #topic Ambassadors
19:08:34 <bcotton> any readiness update from the Ambassadors?
19:09:12 <bcotton> #topic Cloud WG
19:09:19 <bcotton> any readiness update from the Cloud WG?
19:10:33 <bcotton> #topic Design
19:10:41 <bcotton> any readiness update from Design?
19:11:25 <contyk> this is fun
19:11:32 <bcotton> i am having a blast :-)
19:11:33 <bcotton> #topic Desktop
19:11:44 <bcotton> any readiness update from Desktop WG?
19:12:23 <nirik> If they aren't here, they must be ready right? right?
19:12:29 <bcotton> exactly!
19:12:33 <bcotton> #topic Documentation
19:12:40 <bcotton> any readiness update from the Documentation team?
19:13:19 <pbokoc> we still need to write most of the release notes (contributions appreciated!) but we can make it for the release
19:13:37 <bcotton> #help Release Notes contributions needed
19:13:43 <bcotton> #info Docs is ready for the release
19:13:47 <bcotton> pbokoc++
19:13:47 <zodbot> bcotton: Karma for pbokoc changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:14:05 <bcotton> any questions or comments for docs team?
19:15:32 <bcotton> #topic Fedora Project Leader
19:15:39 <bcotton> any readiness update from mattdm?
19:16:21 <bcotton> #topic FESCo
19:16:30 <contyk> yay
19:16:36 <nirik> should be all ready for release as far as I know...
19:16:37 <contyk> .fesco 2001
19:16:39 <zodbot> contyk: Issue #2001: F29 Final: dnf rebase requested post-freeze - fesco - Pagure.io - https://pagure.io/fesco/issue/2001
19:16:42 <bcotton> #info yay
19:16:44 <contyk> there is this
19:16:46 <nirik> oh right that.
19:16:56 <nirik> I asked people to vote in ticket...
19:17:15 <contyk> I haven't yet but I'm going to be +1 to the rebase
19:17:34 <bcotton> #info FESCo is voting on whether to accept a dnf rebase
19:17:45 <bcotton> #link https://pagure.io/fesco/issue/2001
19:18:29 <bcotton> any questions or comments for FESCo?
19:19:00 <bcotton> i will say that we're trying to have some conversations about how to prevent last-minute major dnf changes in the future, so there's that
19:19:41 <mattdm> bcotton: mattdm not ready at all!
19:19:52 <Pharaoh_Atem> my understanding of the version bump to 4.0 is purely political
19:20:02 * mattdm promises to be ready next week for realz though
19:20:05 <bcotton> mattdm: well then good news. Fedora's not ready for you to be ready :-)
19:20:25 <mattdm> my finely-honed procrastination instincts were right on the money
19:20:41 <Pharaoh_Atem> and as the packager of the DNF stack in other distributions, I can pretty much confirm that the churn between 3.6 to 4.0 is no different than the various 3.x point releases have been thus far
19:20:59 <nirik> right. but thats still not ideal/what we want
19:21:14 <Pharaoh_Atem> I didn't say it's a *good* thing that it churns so much between point releases
19:21:26 <nirik> what we want is specific patches only for those issues we want patches for. Nothing else. But such is life sometimes.
19:21:42 <Pharaoh_Atem> so far, we've been accepting releases as such anyway, so *shrugs*
19:22:43 <bcotton> let's move on to infra
19:22:48 <bcotton> #topic Infrastructure
19:23:05 <nirik> Should be all ready once we have final bits to distribute.
19:23:20 <bcotton> #info Infra is ready once there are artifacts to deliver
19:23:32 <nirik> We also have a cloudfront mirror that should be ready for release time. :)
19:24:08 * stickster is now less lurking and will wait for after Marketing's turn to ask a question.
19:24:29 * cverna wait for Marketing's turn too :)
19:24:31 * bcotton thinks he knows what stickster is going to ask :-)
19:24:33 * mboddu is back now
19:24:39 <bcotton> anything else for the infra team?
19:25:35 <bcotton> #topic Marketing
19:26:00 <cverna> stickster: all yours
19:26:29 <bcotton> bt0 and x3mboy are both away
19:26:29 * stickster waits, since he doesn't represent the Marketing team -- anyone here from that team?
19:27:26 <bcotton> looks like no one's here from Marketing, but we can get your questions and comments on the record anyway
19:27:27 <stickster> Ah, OK. Well, I only wanted to ask about status of the official announcement. We have a placeholder post on the Fedora Magazine that awaits content. The authorship is assigned to mattdm, per usual, but that needn't block content from other folks.
19:27:51 <bcotton> stickster: afaik no progress has been made on the announcement content, but i'll check
19:28:00 <contyk> last time they were asking for talking points
19:28:09 <contyk> it didn't feel like they were getting [m]any
19:28:10 <bcotton> #action bcotton to follow up with Marketing team on Release Announcement content
19:28:20 <bcotton> contyk: that's a fair summary
19:28:34 <mattdm> stickster: I absolutely promise to not wait until last minute :)
19:28:35 <cverna> I would like to also point out that Fedora Core 1 was released November 6th 15 years ago. we could choose to have a preferred release date of November 6th for Fedora 29 that would be quite nice
19:28:47 <frantisekz> cverna++
19:28:47 <zodbot> frantisekz: Karma for cverna changed to 28 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:28:52 <mattdm> cverna++
19:28:52 <zodbot> mattdm: Karma for cverna changed to 29 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:28:59 <bcotton> cverna: it's not out of the question :-)
19:28:59 <stickster> There's quite a bit more in TPs now than Beta, which is nice.
19:29:00 <mattdm> that, um, may not be by choice :)
19:29:10 <stickster> lol
19:29:16 <Pharaoh_Atem> XD
19:29:17 <frantisekz> or we can slip even if we are ready... :D
19:29:33 <nirik> no redoing f18 please. ;)
19:29:37 <Pharaoh_Atem> we need swag for 15 years of Fedora :)
19:29:41 <mboddu> cverna: That might actually happen :)
19:30:00 <Conan_Kudo> cverna++
19:30:00 <zodbot> Conan_Kudo: Karma for cverna changed to 30 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:30:02 <cverna> marketing wise it is better to say that we choose it :)
19:30:10 <bcotton> cverna++
19:30:10 <zodbot> bcotton: Karma for cverna changed to 31 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:30:11 <mboddu> cverna: Haha :)
19:30:14 <mboddu> cverna++
19:30:25 <bcotton> cverna: that's why we have a preferred target date and target date #1 ;-)
19:30:51 <bcotton> okay, anything else marketing-related?
19:31:03 <Pharaoh_Atem> well, another interesting point
19:31:04 <mboddu> If we slip the rain date, we can give that reason (Its not a slip, we just decided to release on the same date as Fedora Core 1)
19:31:20 <Pharaoh_Atem> Oct 31, 1994 was the Red Hat Linux 0.9 beta release
19:31:31 <stickster> eof here, you're free to go ahead bcotton
19:31:56 <bcotton> #topic QA
19:32:34 <bcotton> any updates from QA?
19:33:06 <frantisekz> nothing serious... just saying something so it doesn't look like QA don't care about meetings... :D
19:33:21 <bcotton> #info QA is testing
19:33:26 <bcotton> frantisekz++
19:33:36 <bcotton> questions or comments for QA?
19:33:56 <contyk> looking forward to the RC?
19:34:53 <frantisekz> we're doing what we can to sort out all the blockers and to request RC :)
19:35:07 <bcotton> #topic Release Engineering
19:35:15 <mboddu> Releng is *almost* ready
19:35:22 <mboddu> We have pungi config PR waiting, we are testing some changes in Silverblue.
19:35:22 <mboddu> Based on that we will either update the PR or merge it as it is.
19:35:47 <bcotton> #info Releng is almost ready, except for pungi config PR (testing in progress)
19:36:03 <bcotton> questions or comments for releng?
19:36:20 <mboddu> Waiting for the RC request, thats it
19:36:49 <bcotton> #topic Server WG
19:37:42 <bcotton> any readiness updates from Server WG?
19:38:17 <nirik> Nothing blocking server that I am aware of... its a pretty quiet release for server
19:38:35 <bcotton> quiet is good :-)
19:39:04 <contyk> the best TP
19:39:38 <bcotton> any questions or comments for Server?
19:40:15 <bcotton> #topic Spins
19:40:27 <bcotton> any readiness updates from Spins WG?
19:40:56 * stickster notes, other than an update of Xfce version for that spin, no others have contributed any content to talking points.
19:41:16 <bcotton> #help Spins need to contribute to talking points
19:42:08 <bcotton> #topic Translations
19:42:16 <bcotton> any readiness updates from translators?
19:43:11 <contyk> nada
19:43:16 <bcotton> #topic Websites
19:43:25 <bcotton> any readiness updates from websites?
19:44:27 <bcotton> #topic Open floor
19:44:38 <bcotton> anyone I didn't call on or any general topics?
19:44:44 <bowlofeggs> such a big open floor
19:44:59 <stickster> bcotton: curiosity Q
19:45:04 * contyk waves the Modularity WG flag
19:45:10 <stickster> bcotton: Do you know the status of IoT content for the website?
19:45:16 <bcotton> contyk: d'oh, sorry. standby
19:45:33 <bcotton> stickster: i do not. i have an action item from yesterday's IoT meeting to follow up on that. thanks for the reminder
19:45:34 * stickster can hold question until Modularity is done
19:45:42 <stickster> bcotton: oh OK -- thanks.
19:45:57 <bcotton> #topic Modularity
19:46:15 <nirik> relrod was working on IoT content this morning
19:46:26 <contyk> so the modulemd dnf database isn't going to make it this release, whis still makes us sad
19:46:35 <contyk> but currently we're dealing with
19:46:38 <contyk> .bug 1632518
19:46:39 <zodbot> contyk: Bug 1632518 – PackageKit installs packages from default module streams, but does not enable the module stream - https://bugzilla.redhat.com/1632518
19:46:43 <bcotton> contyk: what's the impact of not having that db
19:46:54 <contyk> if this doesn't get resolved, we will have to drop the defaults in f29
19:47:32 <contyk> bcotton: not having the db means your system might get into inconsistent/broken state in some scenarios when the repodata for your installed packages are not available
19:47:53 <contyk> .bug 1616167
19:47:55 <zodbot> contyk: Bug 1616167 – dnf doesn't record modular metadata in a local database - https://bugzilla.redhat.com/1616167
19:47:59 <contyk> this is an example, a former blocker ^
19:48:09 <bcotton> eek. is that the one where it's not getting fixed until january?
19:48:15 <stickster> yes. :-(
19:48:43 <bcotton> #info modulemd dnf database will not make it into F29
19:49:52 <contyk> I don't have more details on the current status of the PackageKit issue but it's being worked on
19:50:02 <contyk> I think that's all from me
19:50:24 <bcotton> any other questions or comments for Modularity?
19:50:30 <nirik> blek
19:50:52 <bcotton> nirik: is that a question or a comment? :-)
19:51:09 * stickster commends Modularity WG for not trashing the hotel room
19:51:12 <nirik> that blocker. we need a PK fix asap or something...
19:51:27 * contyk agrees
19:52:15 <nirik> there's only 2 default streams in 29 right?
19:52:22 <contyk> yes
19:53:07 <nirik> and both of those were no longer traditional rpms?
19:53:34 <contyk> afaik, yes; so people who use these on f28 would need to manually enable those to upgrade
19:54:03 <nirik> right, but normal f29 wouldn't be too borken by them? it would install from them but not enable them?
19:54:20 <nirik> anyhow, I am sidetracking... go ahead with the rest of the meeting, we can discuss this in fesco or whatever
19:54:25 <contyk> you are ;)
19:54:36 <bcotton> anything else for Modularity?
19:54:44 <contyk> but yes, you could still install them, which is even worse
19:55:00 <contyk> you'd get modular content on your system without any tools knowing
19:55:47 <Pharaoh_Atem> I'm surprised we were doing *any* default module streams
19:55:55 <Pharaoh_Atem> I don't think anyone expected that for F29
19:56:36 <contyk> turns out the wording of the change wasn't clear to people who didn't know about it, which is bad
19:57:07 <contyk> but it was what was meant by it working transparently and such
19:57:14 <Pharaoh_Atem> and I'm a bit concerned that people seem to think retiring dist-git sources is okay for making modules, since you need both...
19:57:35 <contyk> hm?
19:57:56 <Pharaoh_Atem> there were a number of people suggesting that it's possible to maintain modules without package dist-git
19:58:06 <contyk> that doesn't sound right
19:58:10 <bcotton> in the interests of wrapping this up, i'm going to move on. let's pick up this conversation elsewhere
19:58:19 <contyk> +1
19:58:22 <bcotton> #topic Open floor
19:58:33 <bcotton> last call for other items
19:58:45 <x3mboy> Hi, sorry im late
19:59:05 <bcotton> welcome x3mboy. want to give a quick update on marketing's readiness?
19:59:30 <x3mboy> We are good to go, only issue: spins doesn't have TPs
19:59:57 <bcotton> awesome. stickster called that out earlier so hopefully people notice :-)
20:00:01 <x3mboy> #link https://fedoraproject.org/wiki/Fedora_29_talking_points
20:00:33 <x3mboy> This should be enough for mattdm to go with a good announcement
20:00:47 <bcotton> great
20:00:49 <x3mboy> But it will be nice if some teams add info about spins
20:01:35 <x3mboy> (and then complaint about spins not being promoted)
20:01:36 <x3mboy> Oooppps
20:01:50 <bcotton> :-D
20:02:13 <x3mboy> <eom>
20:02:25 <bcotton> thanks. any questions or comments for x3mboy?
20:03:35 <bcotton> going
20:03:41 <bcotton> going
20:03:44 <bcotton> gone
20:03:47 <bcotton> #endmeeting