15:00:57 <bcotton> #startmeeting Council (2018-11-07)
15:00:57 <zodbot> Meeting started Wed Nov  7 15:00:57 2018 UTC.
15:00:57 <zodbot> This meeting is logged and archived in a public location.
15:00:57 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:57 <zodbot> The meeting name has been set to 'council_(2018-11-07)'
15:01:02 <bcotton> #meetingname council
15:01:02 <zodbot> The meeting name has been set to 'council'
15:01:11 <bcotton> #chair jonatoni bex contyx dgilmore dperpeet langdon mattdm sumantrom tyll bcotton pbrobinson
15:01:11 <zodbot> Current chairs: bcotton bex contyx dgilmore dperpeet jonatoni langdon mattdm pbrobinson sumantrom tyll
15:01:19 <bcotton> #topic Introductions, Welcomes
15:01:43 <tyll> .hello till
15:01:44 <zodbot> tyll: till 'Till Maas' <opensource@till.name>
15:01:47 <mattdm> RIGHT ROOM
15:02:14 <mattdm> I'm here. Hi everyone!
15:02:21 <bcotton> hi, mattdm
15:02:43 <langdon> .hello2
15:02:43 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
15:02:48 <bcotton> mattdm: you can drive if you want, i just started in so that people weren't standing outside the door ;-)
15:03:19 <mattdm> bcotton: ok. I will. But I just rushed in the door and need to take off my coat and hat and etc. :)
15:03:33 <langdon> bcotton how many metaphors can u mix in to one stmt?
15:03:51 <mattdm> langdon: maybe car door?
15:03:52 <bcotton> langdon: MAXINT
15:04:07 <dgilmore> hi
15:04:13 <mattdm> okay that's five :)
15:04:20 * pbrobinson o/
15:04:27 <mattdm> perfect. let's get started.
15:04:28 <langdon> ha
15:04:32 <mattdm> #topic Today's Open Floor Agenda
15:04:51 <mattdm> Reminder of how this works, or for any observers...
15:04:57 <mattdm> You throw out topics. I arrange them into a list
15:05:08 <mattdm> We go through the list with about five minutes per topic.
15:05:12 <mattdm> What do we have for today?
15:05:50 <bcotton> a short meeting, i guess
15:05:57 <mattdm> (It'd be nice if jonatoni contyk and sumantrom[m] were here!)
15:06:02 <mattdm> yeah, I guess so
15:06:10 <langdon> contyk on vacation
15:06:18 <mattdm> ok.
15:06:30 <mattdm> bcotton: are there any tickets that are on fire?
15:07:07 <mattdm> stickster: are you around?
15:07:10 <bcotton> there are a couple of CoC tickets
15:07:29 <stickster> mattdm: I am now, although distracted
15:07:31 <mattdm> we should wait for bexelbie on those
15:07:49 <mattdm> stickster: should we talk about lifecycle stuff?
15:07:54 <stickster> Sure!
15:08:04 <bcotton> mattdm: i'll nudge bexelbie in the tickets. last we heard updates were due yesterday
15:08:09 <mattdm> #topic Lifecycle objective stuff!
15:08:12 <mattdm> bcotton++
15:08:16 <stickster> Where would you like to start? Or finish?
15:08:31 <mattdm> stickster: I'd like to finish with Fedora world dominance. How do we start?
15:08:43 * stickster notes the wiki page has been moved to the appropriate namespace now. And I have a change ready for the Council doc/web pages
15:09:08 * jonatoni is here now
15:09:18 <mattdm> jonatoni: welcome!
15:09:25 <mattdm> stickster: is that a PR?
15:09:45 * mattdm will go through council prs after this meeting
15:09:48 <stickster> mattdm: it will be -- I built locally but can't see the actual page to verify content.
15:09:57 <stickster> So I didn't file it yet. But that's a 10-sec operation
15:10:07 <mattdm> stickster: ok. hmmm. what happened to our theoretical CI pipeline for docs?
15:10:14 <mattdm> Is it still asamalik pushes manually?
15:10:25 <stickster> Maybe I'm missing something. But I can't seem to get to the page from the menu. Might just be missing the nav
15:10:27 <mattdm> #does-not-scale
15:10:38 <asamalik> mattdm: he does!
15:10:44 <stickster> mattdm: that's not a CI problem -- it's a "user doesn't know how to find this" problem.
15:11:19 <stickster> If someone here can lead me on the menu where I discover the list of objectives, that would be helpful. Then this issue is closed :-)
15:11:20 <mattdm> stickster: it's partly a CI problem, because you should be able to submit your PR and a site preview be automatically rendered
15:11:21 <asamalik> mattdm: I need to get in touch with bstinson again about that
15:11:46 <stickster> mattdm: we're talking about two different things here. Forget the CI for a moment. Show me where, on the Council docs menu, I find the page with objectives listed
15:11:57 <mattdm> stickster: https://docs.fedoraproject.org/en-US/project/objectives/
15:12:09 <mattdm> it's in the "Project" docs, not the council charter page
15:12:12 <asamalik> I've made a CI image for the docs PR preview at Flock (well actually updated the one that existed and even worked for the asciibinder tooling before)
15:12:14 <mattdm> Same repo, different result
15:12:39 <stickster> AH! There it is
15:12:41 <mattdm> these things *used* to have a shared, three-part left nav, but asamalik messed that up :) :)
15:12:43 <stickster> OK. Let's move on. PR forthcoming.
15:12:51 <mattdm> okay, yeah, so anyway.
15:12:59 <asamalik> mattdm: optimized!!!
15:13:05 <asamalik> mattdm: but seriously, what's broken?
15:13:14 <mattdm> asamalik: hard to find. need search. :)
15:13:26 <asamalik> yes :)
15:13:35 <mattdm> asamalik: it's not broken, just no way to get to "neighbors" from leaf nodes.
15:14:07 <stickster> One of the underlying premises of the Lifecycle objective is that our release process is not community friendly like so many other parts of Fedora. So one of the goals is to fix that, because unless we can make ways for the community to release things, having a split lifecycle isn't all that interesting
15:14:16 <mattdm> Here's the two big things about this objective, though. I'd like to use this to look at the possibility of *longer* fedora lifecycle
15:14:35 <mattdm> So, think (but do not say out loud), "Fedora LTS"
15:14:47 <mattdm> Second, I think we should consider making F30 a long cycle to enable this.
15:14:51 <mattdm> Like we did with F20.
15:15:09 <mattdm> #micdrop
15:15:28 <dgilmore> mattdm: I honestly think we are overdue a long schedule to allow us to work on and improve the pipeline fully
15:15:48 <mattdm> dgilmore: the last one was F20, right? So, yeah, five years!
15:15:57 <dgilmore> yep
15:16:35 <mattdm> So, I don't necessarily expect answers in this meeting, but stickster and i are gonna start a devel list thread about this soon.
15:16:35 * stickster is also +1 on the idea of a longer Fedora lifecycle. I personally think we should have a more constant release stream for our harder-core users, likely ostree-based, and something long term for those who are less OS-aware or -caring.
15:16:52 <bcotton> my only concern with that is that the f30 schedule is already set and out there and people are working on stuff with the idea of it landing in may. so i'd lean more toward making 31 the long cycle, but i do agree it woudl be good to have
15:17:21 <stickster> Also, +1 on taking some time to do this. Frankly, if it were up to me, whenever mattdm has his gumption worked up, I would say, we should say, "There will not be another Fedora release until we make the following things true: $THINGS"
15:17:40 <dgilmore> bcotton: pushing out may to October would be better
15:17:41 <mattdm> bcotton: yeah that's probably true. although it does make f30 a longer release by association
15:18:07 <mattdm> The DNF stuff in F29 is disheartening. I would like to put out one more solid on-schedule release.
15:18:13 <dgilmore> though it is 5 months vs 7
15:18:27 <langdon> hopefully, during that long cycle, we can get git branching sorted out so we don't need to do long release to do things that take more than one release
15:18:55 <mattdm> stickster: I don't think that's the right balance. Too much uncertainty.
15:19:10 <stickster> But a lot of incentive ;-)
15:19:15 <mattdm> It puts us at risk of never having a fedora release again, and there's enough fear going on already.
15:19:21 <langdon> dnf should be backward compatible.. it is fixes.. so why can't that go out as an update?
15:19:23 <mattdm> Having a timeframe is *also* an incentive.
15:19:40 <bcotton> so maybe the starting point is to figure out what the value of $THINGS is and then figure out when we do a long release and what "long" means in this context
15:19:43 <dgilmore> I do think there needs to be bounds on time
15:19:47 <mattdm> bcotton++
15:19:48 <stickster> bcotton: That's sensible.
15:19:58 <dgilmore> without it there will always be something that is not quite right
15:20:34 <bcotton> given that the council is meeting in a month, it might be good for us to put together a strawman of that and let the community beat it up (although waiting a month almost surely kills the idea of f30 being the long release, so maybe that's not great)
15:20:51 * langdon immenently entering mobile dead zone
15:20:57 <bcotton> revision: not "almost surely" but "dramatically increases the likelihood"
15:21:35 <mattdm> *nod*
15:21:41 <stickster> I think I can have details ready before that. Unfortunately I happen to be in the nadir (zenith?) of receiving short-deadline, important things to do. I hope to be out of that in the next week or so
15:21:59 <mattdm> stickster said he's too busy for long mailing list discussion this week so I intend to start thread next week
15:22:06 <mattdm> This discussion is a warning lol
15:22:13 <stickster> :-)
15:22:35 * mattdm likes that stickster still does noses on the smilies. so old school!
15:22:56 <mattdm> okay, so that's pretty much it for this.
15:23:11 <mattdm> Hey jonatoni! I don't think I ever gave you an official welcome to the council. Welcome!
15:23:12 <stickster> #action stickster send PR for the docs pages
15:23:23 <mattdm> #action mattdm to review all of the council docs prs
15:23:26 <jonatoni> thank you mattdm :)
15:23:37 <mattdm> jonatoni: anything you'd like to talk about today?
15:24:01 <stickster> Oops, no one chaired me ^^ bcotton, can you repeat that
15:24:02 <mattdm> any big diversity/inclusion plans for the next year? We should start thinking about spending.
15:24:07 <mattdm> #chair stickster
15:24:07 <zodbot> Current chairs: bcotton bex contyx dgilmore dperpeet jonatoni langdon mattdm pbrobinson stickster sumantrom tyll
15:24:11 <stickster> #action stickster send PR for the docs pages
15:24:17 <stickster> thx!
15:24:28 <mattdm> brb wife locked herself out :)
15:24:37 <jonatoni> mattdm: tbh I don't have something to add for today, but yeah we need to start planning for next year
15:24:55 <mattdm> *nod*
15:25:00 <mattdm> #topic Any other topics for today?
15:25:32 <mattdm> guess not :)
15:26:54 <stickster> I can't travel for the council event happening in December. But I can attend remotely as long as we make that possible
15:27:41 <dgilmore> I have plans on the 9th and may have to leave early
15:27:55 <mattdm> stickster: we'll try
15:28:02 <mattdm> dgilmore: noted. better than nothing :)
15:28:13 <mattdm> And with that let's wrap up early. Thanks everyone!
15:28:15 <mattdm> #endmeeting