16:30:42 <lorbus> #startmeeting fedora_coreos_meeting
16:30:42 <zodbot> Meeting started Wed Dec  5 16:30:42 2018 UTC.
16:30:42 <zodbot> This meeting is logged and archived in a public location.
16:30:42 <zodbot> The chair is lorbus. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:30:42 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:30:49 <lorbus> #topic roll call
16:30:57 <bgilbert> .hello2
16:30:58 <zodbot> bgilbert: bgilbert 'Benjamin Gilbert' <bgilbert@backtick.net>
16:30:59 <rfairley> .hello rfairleyredhat
16:31:01 <zodbot> rfairley: rfairleyredhat 'Robert Fairley' <rfairley@redhat.com>
16:31:04 <dustymabe> .hello2
16:31:05 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:31:09 <ajeddeloh> .hello2
16:31:10 <zodbot> ajeddeloh: ajeddeloh 'Andrew Jeddeloh' <andrew.jeddeloh@redhat.com>
16:31:14 <ksinny> .hello sinnykumari
16:31:15 <zodbot> ksinny: sinnykumari 'Sinny Kumari' <ksinny@gmail.com>
16:32:02 <kaeso> .hello lucab
16:32:03 <zodbot> kaeso: lucab 'Luca Bruno' <lucab@redhat.com>
16:32:10 <lorbus> #chair bgilbert rfairley dustymabe ajeddeloh ksinny kaeso
16:32:10 <zodbot> Current chairs: ajeddeloh bgilbert dustymabe kaeso ksinny lorbus rfairley
16:33:23 <lorbus> o/ sanja!
16:33:27 <sanja> .hello2
16:33:28 <zodbot> sanja: sanja 'Sanja Bonic' <sanja@redhat.com>
16:33:31 <jbrooks> .fas jasonbrooks
16:33:32 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <jbrooks@redhat.com>
16:33:38 <sanja> Hello! o/
16:33:39 <lorbus> #chair sanja jbrooks
16:33:39 <zodbot> Current chairs: ajeddeloh bgilbert dustymabe jbrooks kaeso ksinny lorbus rfairley sanja
16:33:51 <lorbus> ok let's start!
16:33:54 <lorbus> #topic Action items from last meeting
16:34:05 <lorbus> dustymabe to set up conversation with Patrick and Kevin about release signing
16:34:05 <lorbus> dustymabe to write up a ticket on release signing
16:34:05 <lorbus> jbrooks to create a ticket for deciding on the mechanism for shipping kube/okd pieces
16:34:05 <lorbus> jlebon to file a ticket to decide whether we need modularity support in rpm-ostree
16:34:26 <mnguyen_> .hello mnguyen
16:34:27 <zodbot> mnguyen_: mnguyen 'Michael Nguyen' <mnguyen@redhat.com>
16:34:35 <jbrooks> lorbus, I haven't filed that yet, I'll do it after the meeting, can we re-action it?
16:34:40 <lorbus> #chair mnguyen
16:34:40 <zodbot> Current chairs: ajeddeloh bgilbert dustymabe jbrooks kaeso ksinny lorbus mnguyen rfairley sanja
16:34:44 <dustymabe> #info dustymabe created ticket to investigate Fedora Infra signing https://github.com/coreos/fedora-coreos-tracker/issues/87
16:35:06 <lorbus> #action jbrooks to create a ticket for deciding on the mechanism for shipping kube/okd pieces
16:35:18 <dustymabe> #infor dustymabe, ksinny, ajeddeloh, bgilbert, puiterwijk, nirik had a meeting yesterday and learned a lot about Fedora infra signing - details here: https://github.com/coreos/fedora-coreos-tracker/issues/87#issuecomment-444268091
16:35:24 <dustymabe> #info dustymabe, ksinny, ajeddeloh, bgilbert, puiterwijk, nirik had a meeting yesterday and learned a lot about Fedora infra signing - details here: https://github.com/coreos/fedora-coreos-tracker/issues/87#issuecomment-444268091
16:35:51 <ksinny> dustymabe++
16:35:56 <lorbus> cool! thanks for the write-up dustymabe
16:36:17 <dustymabe> :)
16:36:23 <lorbus> I saw jlebon created an issue re Modularity in rpm-ostree as well, but he isnt here, is he?
16:37:14 <dustymabe> doesn't look like it
16:37:19 <dustymabe> one sec. i'll #info
16:37:20 <jlebon> .hello2
16:37:21 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:37:31 <lorbus> #chair jlebon
16:37:31 <zodbot> Current chairs: ajeddeloh bgilbert dustymabe jbrooks jlebon kaeso ksinny lorbus mnguyen rfairley sanja
16:37:38 <jlebon> sorry, was/am still in a mtg
16:37:46 <dustymabe> #info jlebon created ticket for modularity in FCOS https://github.com/coreos/fedora-coreos-tracker/issues/88
16:37:49 <walters> hey I have to head out in about 5 minutes but it'd be good if https://github.com/coreos/mantle/pull/954#issuecomment-444512623 could be discussed
16:38:11 <dustymabe> ack
16:38:39 <lorbus> #topic mantle: ore/upload: Add --size-gib and --size-inspect
16:38:52 <lorbus> #link https://github.com/coreos/mantle/pull/954#issuecomment-444512623
16:39:11 <lorbus> go ahead walters
16:39:17 <dustymabe> i'm trying to get background - does merging this PR conflict with supporting CL?
16:39:39 <dustymabe> or is the review just taking some time and need to be reviewed faster?
16:39:39 <walters> all of the patches so far I wrote have tried to do both
16:39:49 <walters> the previous attempt was reverted as it did end up breaking CL
16:40:26 <walters> https://github.com/coreos/mantle/pull/944#issuecomment-444553605
16:40:39 <dustymabe> so the question is.. is it worth the effor to try to support both at the same time, vs just branching (which itself is some work)
16:40:45 <walters> right
16:41:09 <dustymabe> bgilbert: ajeddeloh kaeso, thoughts ?
16:41:17 * dustymabe looks for slowrie, but I don't see him
16:41:21 <walters> this also came up a bit in https://github.com/coreos/mantle/pull/934
16:41:29 <kaeso> slowrie has some connectivity issues
16:42:15 <bgilbert> a lot of code review in mantle historically ends up blocked on me :-(
16:42:18 <bgilbert> that would be a good thing to fix
16:42:44 <kaeso> (we usually avoid progressing with parallel branches because that one is a maintenance hell too, but I don't know for this specific context)
16:43:00 <dustymabe> one question that comes to mind
16:43:04 <bgilbert> I don't think maintaining a fork/branch would be worth the cost though
16:43:10 <walters> another case is e.g. kola where if we forked the setup would be cleaner
16:43:11 <dustymabe> how much "development" work are we planning to do for CL?
16:43:20 <dustymabe> in mantle
16:43:44 <dustymabe> i.e. if it's only bugfix, then maybe fork isn't bad
16:43:47 <ajeddeloh> I think it is probably worth the effort to get it to work for both. In the case of some of the other changes (e.g. kola tests) it exposes differences to us that we normally wouldn't think about
16:44:01 <dustymabe> but if we want new features for both CL and FCOS then branching isn't as good an option
16:44:19 <bgilbert> in this particular case, the previous patch didn't break CL so much as it didn't consider all of the code paths
16:44:31 <bgilbert> i.e., the code that it broke was equally relevant for *COS
16:44:49 <walters> I don't forsee us using those paths for RHCOS at least
16:45:10 <bgilbert> the reason I don't think a fork/branch is a great model is that a lot of the dev work is in platform code, which applies equally everywhere
16:45:23 <bgilbert> for example, if we had already branched, the recent flight work would have had to be applied twice
16:45:36 <bgilbert> or would have been applied once, and then the divergence (which was substantial) would have affected all future maintenance
16:46:15 <walters> but i need to head out now...will read notes after
16:46:41 <jlebon> if we don't branch, would be a good idea to add some RHCOS and FCOS PR testing
16:46:58 <miabbott> .hello miabbott
16:46:59 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
16:47:01 <kaeso> it looks like the root issue is that we forked mantle in the past and we are now slow in merging back?
16:47:08 <lorbus> #chair miabbott
16:47:08 <zodbot> Current chairs: ajeddeloh bgilbert dustymabe jbrooks jlebon kaeso ksinny lorbus miabbott mnguyen rfairley sanja
16:47:08 <dustymabe> yeah. and the pending openstack PR probably too,
16:47:08 <dustymabe> then again cherry-picks might not be too bad if most of the code is the same
16:47:08 <dustymabe> ok. one other outstanding question.. how much work would it be to get the existing PR to work for both ?
16:47:20 <dustymabe> is it 1. not that hard, but it raises this philosophical question
16:47:35 <dustymabe> 2. really hard
16:48:19 <bgilbert> the --size-* PR is a compromise model
16:48:22 <dustymabe> oh looks like walters headed out
16:48:33 <dustymabe> anybody else able to answer the above questions ?
16:48:39 <bgilbert> it's not the cleanest fix but walters and I agreed on the approach.  I don't anticipate further philosophical problems there
16:48:52 <dustymabe> #chair dm0
16:48:52 <zodbot> Current chairs: ajeddeloh bgilbert dm0 dustymabe jbrooks jlebon kaeso ksinny lorbus miabbott mnguyen rfairley sanja
16:49:05 <dustymabe> welcome miabbott dm0 :)
16:49:25 <bgilbert> so in this case the problem is just mantle PRs getting blocked on me
16:49:40 <dustymabe> bgilbert: ahh. so that particular PR doesn't need to be changed
16:49:56 <bgilbert> I think there are a couple nits, but not design problems at this point
16:50:13 <dustymabe> ok. sounds good
16:50:18 <lorbus> so how would you like to proceed with this topic? anything we can info?
16:50:25 <lorbus> bgilbert^
16:50:26 <dustymabe> so let's prioritize getting that PR reviewed
16:50:42 <dustymabe> and also chip away at sharing the load for PR reviews for mantle
16:51:09 <dustymabe> does that work ^^ ?
16:51:19 <bgilbert> #action bgilbert to review https://github.com/coreos/mantle/pull/954
16:51:42 <bgilbert> #action discuss maintenance/review structure for mantle
16:51:43 <bgilbert> good?
16:51:54 <lorbus> sgtm
16:52:02 <dustymabe> yeah that 2nd one might need a name with it
16:52:07 <bgilbert> #undo
16:52:07 <zodbot> Removing item from minutes: ACTION by bgilbert at 16:51:42 : discuss maintenance/review structure for mantle
16:52:37 <bgilbert> #action bgilbert, dustymabe, ashcrow, walters, slowrie to discuss maintenance/review structure for mantle
16:52:40 <bgilbert> just to pick some people
16:52:45 <dustymabe> +1
16:53:20 <lorbus> alright, anything to add hee? otherwise let's move on to the tracker topics
16:53:42 <dustymabe> gogogogog
16:53:50 <lorbus> #topic Host Installer for Fedora CoreOS (bare metal)
16:53:57 <lorbus> #link https://github.com/coreos/fedora-coreos-tracker/issues/50
16:54:52 <dustymabe> so we've had some recommendations from neil hormon on how we can bring forward coreos_install to FCOS
16:55:15 <dustymabe> he developed a dracut module that will perform the install (triggered by kernel command line parameters)
16:55:40 <dustymabe> if we take this dracut module and embed it in our FCOS images, the kernel/initrd from FCOS can also be used to install FCOS
16:56:04 <dustymabe> so we wouldn't need to rely on anaconda, which is nice because we have one less thing we depend on
16:56:29 <lorbus> are there any downsides to this approach that we know of?
16:57:08 <dustymabe> slightly larger image size (though the dracut module is a bash script, so small)
16:57:26 <dustymabe> we maintain it, which adds to what we maintain
16:57:42 <ajeddeloh> I'm in favor of it in addition to shipping the script in the real root, just not in place of it
16:57:47 <dustymabe> bgilbert: ajeddeloh: any other downsides?
16:58:05 <kaeso> I've noted some here https://github.com/coreos/coreos-assembler/issues/240#issuecomment-444509739
16:58:12 <bgilbert> the dracut module is a bash script but it pulls in a bunch of additional commands from the host
16:58:24 <ajeddeloh> only downside I can think of is that debugging things that went wrong in the initramfs is a giant pain
16:58:34 <bgilbert> I'd still like to know the total size increase of the initramfs
16:58:46 <bgilbert> I don't anticipate major problems, but it'd be good to check
16:58:56 <dustymabe> bgilbert: yeah that should be pretty easy to check
16:59:58 <dustymabe> does anyone want to volunteer to take his POC and try to put it into FCOS and see if it works as we think it could/should ?
17:00:33 <dustymabe> and also debug/figure out the size increase
17:01:35 <dustymabe> ok we'll check for volunteers again soon
17:01:40 <bgilbert> dustymabe: how much do we expect to learn from moving the POC over?
17:01:52 <bgilbert> it might make more sense to just move forward with integration if that's what we want to do
17:01:52 <dustymabe> bgilbert: i.e. trying it out ?
17:02:00 <bgilbert> right
17:02:11 <dustymabe> i feel like POC is a step towards integration
17:02:18 <dustymabe> i.e. you can't do one without the other anyway
17:02:34 <bgilbert> okay, wfm
17:03:03 <lorbus> action you for it, bgilbert? or postpone to next mtg?
17:03:10 <dustymabe> once we decide for sure that is the path forward we want to take we should probably open a PR against the design doc to document it
17:03:15 <dustymabe> lorbus: postpone
17:03:39 <lorbus> ok we'll revisit next time, then
17:03:43 <lorbus> ready to move on?
17:03:46 <dustymabe> +1
17:03:47 <bgilbert> +1
17:03:48 <ajeddeloh> +1
17:04:03 <lorbus> #topic Hand over projectatomic/container-best-practices to Fedora Container SIG
17:04:04 <kaeso> I'm a bit wary of this POC, because I still don't understand how it will fit longer term with the live/diskless PXE artifact
17:04:20 <lorbus> #undo
17:04:20 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7fe4fdb33b10>
17:04:46 <lorbus> kaeso, let's take this to async discussion on GH?
17:05:00 <kaeso> ack
17:05:02 <lorbus> #topic Hand over projectatomic/container-best-practices to Fedora Container SIG
17:05:06 <lorbus> #link https://github.com/coreos/fedora-coreos-tracker/issues/85
17:05:48 <lorbus> Sooo. I tasked myself with cleaning up the projectatomic GH org. This is probably the first of many
17:06:14 <lorbus> #info The Container SIG has decided to request ownership of container-best-practices
17:06:24 <lorbus> #link https://meetbot-raw.fedoraproject.org/teams/container_sig/container_sig.2018-12-03-13.00.html
17:06:27 <dustymabe> nice!
17:07:05 <lorbus> is anyone fundamentally opposed to giving this to the Container SIG?
17:07:38 <lorbus> I've discussed this with the current maintainer eslobodo as well, and everybody seems to agree this is a sensible idea
17:07:51 <ksinny> +1 from my side
17:08:14 <dustymabe> +1
17:08:21 <lorbus> I"ve started converting the repo to the Antora docs formatting needed to add this to the official Fedora docs at docs.fp.o
17:08:34 <lorbus> sanja, you want to add anything here?
17:08:41 <ksinny> Nice work lorbus++
17:09:00 <lorbus> (btw awesome finally meeting you in person in Edinburgh last week!)
17:10:03 <lorbus> #info The container-best-practices will be handed off to the Fedora Container SIG, and integrated into the Fedora Docs
17:10:24 <rfairley> lorbus++
17:10:37 <lorbus> #action lorbus to convert and bring up to speed the container-best-practices
17:10:46 <lorbus> #undo
17:10:46 <zodbot> Removing item from minutes: ACTION by lorbus at 17:10:37 : lorbus to convert and bring up to speed the container-best-practices
17:10:50 <lorbus> #action lorbus to convert and bring up to speed the container-best-practices repo
17:11:00 <lorbus> ok cool.
17:12:03 <lorbus> dustymabe: we have some time left, should we move on to high-prio issues? I'd like to discuss the renaming considerations for rpm-ostree otherwise
17:12:04 <slowrie> .hello2
17:12:05 <zodbot> slowrie: slowrie 'Stephen Lowrie' <slowrie@redhat.com>
17:12:12 <lorbus> #chair slowrie
17:12:12 <zodbot> Current chairs: ajeddeloh bgilbert dm0 dustymabe jbrooks jlebon kaeso ksinny lorbus miabbott mnguyen rfairley sanja slowrie
17:12:15 <dustymabe> lorbus: that works
17:12:36 <lorbus> #topic Renaming considerations for rpm-ostree
17:12:43 <lorbus> #link https://github.com/projectatomic/rpm-ostree/issues/405
17:13:18 <dustymabe> i think jlebon has added some good comments to that topic recently
17:13:28 <lorbus> So I guess the current proposal is to add a symlinked name to rpm-ostree, to have a shorter CLI cmd
17:13:41 <lorbus> there are some ideas in the linked issue:
17:14:16 * jbrooks strokes his gray beard
17:14:17 <dustymabe> yep. I think we are mostly waiting on input from walters to see what he thinks
17:14:18 <lorbus> ros, rost, rpt
17:14:40 <lorbus> ok, probably best to discuss/vote on this when he's around
17:15:10 <dustymabe> right.. lorbus you could ask for him to add some input to the ticket
17:15:11 <lorbus> then there is also the question of under what GH org to move this repo
17:15:31 <dustymabe> yep that was a separate ticket, right?
17:15:49 <lorbus> hm not sure if there is a ticket for that honestly
17:16:01 <jlebon> they're entertwined, but yeah that ticket is on the tracker
17:16:12 <lorbus> ahh ok I missed that then
17:16:22 <jlebon> https://github.com/coreos/fedora-coreos-tracker/issues/19
17:16:45 <lorbus> ok I'll ask walters to add some info and add #19 to next mtgs agenda
17:16:57 <ajeddeloh> fwiw I'm partial to `rost`
17:17:20 * kaeso too
17:18:07 <lorbus> let's do the vote next time :)
17:18:10 <ajeddeloh> yum-image or rpm-image means you lose tab completition and the googleabilty is not great
17:18:23 <ajeddeloh> it's also not an image, its an os-tree
17:18:24 <jbrooks> I like rost too
17:18:27 <dustymabe> feel free to add comments to the ticket
17:18:33 <lorbus> anything with - in it sucks
17:18:37 <lorbus> (IMO)
17:18:43 <jbrooks> I like keeping rpm-ostree around as the project name as well
17:19:00 <lorbus> jbrooks, I think that is very sensible, too
17:19:10 <miabbott> lorbus: RIP coreos-assembler  lol
17:19:20 <ksinny> miabbott: good point :D
17:19:29 <dustymabe> miabbott: haha.. I alias it to `cass`
17:19:30 <jlebon> alias ca='coreos-assembler'
17:19:35 <jlebon> heh :)
17:19:49 <dustymabe> ca == cert authority in my mind
17:19:52 <miabbott> i'm partial to the symlink rost -> rpm-ostree approach
17:20:00 <lorbus> haha yeh...it's on different keys on US vs DE keyboards, so very error prone for my little head
17:20:27 * ajeddeloh still likes `cosa`
17:20:48 * lorbus agrees with ajeddeloh
17:21:29 <lorbus> #topic Container Linux migration tools and documentation
17:21:38 <lorbus> #link https://github.com/coreos/fedora-coreos-tracker/issues/48
17:21:58 <lorbus> dm0, I think that's you :)
17:21:58 <ajeddeloh> bgilbert and I chatted about this a little yesterday
17:23:47 <ajeddeloh> Once Ignition spec 3.0.0 hits and we fork it and such, we'll need to build fcos ct and a ignition 2.x > 3.0 "best effort" translator. Once fcos ct is done (or done enough) we'll need a CLCT->FCOSCT "best effort" translator
17:24:06 <ajeddeloh> I don't think a CLC -> Ignition 3.0.0 tool is a good idea
17:24:22 <dustymabe> ajeddeloh: any idea on how hard it will be to build those translators ?
17:25:47 <ajeddeloh> I think it's one of those things that its easy to make something that works 70% well but hard to make something that works 99% well
17:26:00 <ajeddeloh> Mechanical transtation is easy enough
17:26:06 <slowrie> ajeddeloh: do you see us renaming the clct repo to be more generic and maintaining branches for CL?
17:26:30 <ajeddeloh> detecting things like "fedora has this directory in a different place, you probably wanted that" is harder
17:26:42 <ajeddeloh> slowrie: I want to re-write ct
17:26:49 <slowrie> +1
17:26:50 <ajeddeloh> (for fcos)
17:27:35 <dustymabe> +1
17:28:06 <lorbus> ajeddeloh could you phrase an info item for this real quick?
17:28:17 <kaeso> it looks like there is agreement to fork (and rename) a ct specific for fcos
17:28:36 <lorbus> ack thanks kaeso
17:28:50 <slowrie> For the translation issues due to distro differences is it okay for us to just put docs saying that perfect translations won't always happen especially when system files are being touched and doing best effort translation?
17:29:03 <bgilbert> ajeddeloh: do we have time to rewrite ct before F30?
17:29:06 <ajeddeloh> #info there should be an fcos ct tool
17:29:09 <lorbus> #info agreement to fork (and rename) CL container tools for FCOS
17:29:25 <lorbus> ok great.
17:29:33 <ajeddeloh> lorbus: ct is config transpiler
17:29:35 <kaeso> #undo
17:29:35 <zodbot> Removing item from minutes: INFO by lorbus at 17:29:09 : agreement to fork (and rename) CL container tools for FCOS
17:29:44 <bgilbert> slowrie: I think that's what there is
17:29:50 <lorbus> ahh yea, sorry
17:29:52 <kaeso> #info agreement to fork (and rename) CL config-transpiler for FCOS
17:29:54 <ajeddeloh> again, I want to rewrite, not rok
17:29:57 <ajeddeloh> fork*
17:30:08 <jlebon> could we also just flat out error out if there are things that can't be safely translated?
17:30:15 <slowrie> bgilbert: not having a ct like tool for launch seems like not a great UX for new users
17:30:20 <lorbus> #undo
17:30:20 <zodbot> Removing item from minutes: INFO by kaeso at 17:29:52 : agreement to fork (and rename) CL config-transpiler for FCOS
17:30:28 * dustymabe notes time
17:30:28 <ajeddeloh> Probably use bits of old one, but a fresh start would be good
17:30:34 <lorbus> #info agreement to rewrite CL config-transpiler for FCOS
17:30:41 <ajeddeloh> +1
17:30:46 <lorbus> dustymabe: yup. no open floor this time
17:30:48 <slowrie> jlebon: we'd have to build in list of things like the folder location differences to detection logic which seems like it'd be a lot of extra work
17:31:03 <slowrie> and especially error prone
17:31:07 <lorbus> I'll end the mtg in 30sec
17:31:08 <bgilbert> slowrie: I meant as opposed to modifying now and rewriting later
17:31:12 <ajeddeloh> #info agreement to have a clc -> fcosc "best effort" translator
17:31:27 <jlebon> slowrie: i'd expect the error out method vs trying our best would be less work :)
17:31:36 <bgilbert> jlebon: right, we can't necessarily detect all the cases
17:31:57 <jlebon> gotcha
17:32:06 <lorbus> #endmeeting