13:00:26 <cverna> #startmeeting Container SIG
13:00:26 <zodbot> Meeting started Mon Dec 17 13:00:26 2018 UTC.
13:00:26 <zodbot> This meeting is logged and archived in a public location.
13:00:26 <zodbot> The chair is cverna. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:26 <zodbot> The meeting name has been set to 'container_sig'
13:00:53 <cverna> Hello anyone there for the Container SIG meeting ? :)
13:01:34 <cverna> I don't expect many people will show up and I have an hard stop in 20 minutes
13:02:38 <lorbus> .hello2
13:02:39 <zodbot> lorbus: lorbus 'Christian Glombek' <cglombek@redhat.com>
13:03:09 <cverna> o/ lorbus
13:03:14 <cverna> #chair lorbus
13:03:14 <zodbot> Current chairs: cverna lorbus
13:03:22 <lorbus> do we have an agenda? otherwise I'd just like to update the SIG on the docs status
13:03:29 <lorbus> o/ cverna
13:04:08 <lorbus> or rather discuss how to proceed
13:04:12 <cverna> No agenda so the update is more than welcome, just waiting another minute to see if we have others joining
13:04:56 <lorbus> kk
13:05:06 <bhavin192> .hello2
13:05:07 <zodbot> bhavin192: bhavin192 'Bhavin Gandhi' <bhavin7392@gmail.com>
13:05:22 <cverna> bhavin192: o/
13:05:27 <cverna> #chair bhavin192
13:05:27 <zodbot> Current chairs: bhavin192 cverna lorbus
13:05:58 <cverna> ok lorbus please go ahead
13:06:05 <lorbus> alright
13:06:18 <lorbus> so the plan is to deprecate container-best-practices altogether
13:06:40 <lorbus> as it contains a lot of references to the atomic cli, which won't be supported for long
13:06:48 <lorbus> and move everything to: https://pagure.io/fedora-docs/containers/
13:07:12 <cverna> that sounds good to me
13:07:22 <lorbus> I already created a skeleton, mostly copying stuff over. sanja merged it already, but it definitely needs some work still
13:07:48 <cverna> #chair cverna_
13:07:48 <zodbot> Current chairs: bhavin192 cverna cverna_ lorbus
13:07:59 <lorbus> which I'm happy to do, but I would appreciate a thorough review
13:08:26 <lorbus> also, I'd like to entirely deprecate the container-image-template repo in favour of:
13:08:30 <cverna_> Cool the docs repo is on pagure ?
13:08:44 <lorbus> https://pagure.io/fedora-docs/containers/blob/master/f/modules/ROOT/examples/Dockerfile.example
13:09:28 <lorbus> yes. There is an ongoing discussion on discourse to move the repo over to GH tho: https://discussion.fedoraproject.org/t/move-docs-sources-and-issues-to-github-redirect-subdomain-to-spins-website/799
13:10:24 <cverna_> Yes i saw that :)
13:10:45 <lorbus> cverna: if you could have a look at the Dockerfile.template at https://pagure.io/fedora-docs/containers/blob/master/f/modules/ROOT/examples/Dockerfile.example , that'd be great. I especially wasn't sure if we need the `--setopt=tsflags=nodocs` flag with dnf
13:11:04 <cverna_> I think it might be good to get ttomecek to have a quick review at the doca
13:11:12 <lorbus> I'd really like to get ttomecek's opinion on this too
13:11:16 <lorbus> ^ yep
13:11:44 <cverna_> Cool
13:12:28 <lorbus> #info Fedora Container Docs sources now live at https://pagure.io/fedora-docs/containers
13:12:30 <cverna_> About the docs flag i think it is de
13:12:55 <cverna_> Disabled in the base image
13:13:15 <cverna_> But i am not sure i need to double check
13:13:25 <lorbus> ahh ok. I just saw it on some image and wasn't sure.
13:13:32 <lorbus> #link https://docs.fedoraproject.org/en-US/containers/
13:14:00 <lorbus> (the docs are already online, but not in a usable state right now)
13:14:52 <cverna_> Nice lorbus++
13:15:24 <cverna_> Ok anything else on this ?
13:15:53 <lorbus> #action lorbus to open an issue discourse to discuss moving forward with the docs
13:15:59 <lorbus> #undo
13:15:59 <zodbot> Removing item from minutes: ACTION by lorbus at 13:15:53 : lorbus to open an issue discourse to discuss moving forward with the docs
13:16:18 <lorbus> #action lorbus to open an issue on discourse to discuss moving forward with the container docs
13:16:34 <lorbus> that's it from my side :)
13:16:55 <cverna_> Thanks for the update
13:17:07 <cverna_> On my side i am working on mob
13:17:29 <cverna_> Rhhh typing from the phone is hard :p
13:18:09 <cverna_> So working on OSBS aarch64 cluster deployment in production
13:18:17 <lorbus> nice
13:19:08 <cverna_> And I started to look at using OSBS to build the Fedora base image
13:19:58 <cverna_> That way the dockerfile will be stored in dist-git just like other containers
13:20:23 <cverna_> And we should be able to use bodhi for the updates
13:21:03 <lorbus> very cool!
13:21:06 <lorbus> cverna++
13:21:37 <cverna_> That's pretty much all on my side
13:21:42 <lorbus> I opened an RFE issue against atomic-reactor to support buildah as backend for builds: https://github.com/projectatomic/atomic-reactor/issues/1147
13:22:02 <cverna_> Ha nice :)
13:22:38 <lorbus> let's get rid of docker completely :P
13:22:47 <cverna_> I need to look at using imagebuilder in Fedora
13:22:55 <bhavin192> lorbus, Hehe
13:23:26 <lorbus> imagebuilder also uses Docker though. and they have no plans to add a buildah backend :(
13:23:44 <lorbus> but yea, conceptually it's nice
13:24:02 <cverna_> Does it ? I though it was based on the buildah stuff
13:24:11 <lorbus> cverna_ nope :(
13:24:21 <lorbus> https://github.com/openshift/imagebuilder/issues/33
13:24:27 <cverna_> Ha ok did not know that
13:25:13 <cverna_> Ok I have an hard stop now
13:25:34 <lorbus> ok. thanks for hosting cverna_!
13:25:45 <cverna_> #info next meeting 2018-12-31 is cancelled
13:25:59 <bhavin192> cverna_, lorbus thank you :)
13:26:13 <cverna_> See you all next year and have good holidays
13:26:14 <lorbus> thanks for joining bhavin192 :)
13:26:29 <lorbus> have great holidays!!
13:26:41 <cverna_> #endmeeting