15:00:06 <mattdm> #startmeeting Council (2019-01-02)
15:00:06 <zodbot> Meeting started Wed Jan  2 15:00:06 2019 UTC.
15:00:06 <zodbot> This meeting is logged and archived in a public location.
15:00:06 <zodbot> The chair is mattdm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:06 <zodbot> The meeting name has been set to 'council_(2019-01-02)'
15:00:07 <mattdm> #meetingname council
15:00:07 <zodbot> The meeting name has been set to 'council'
15:00:09 <mattdm> #chair jonatoni bex contyk dgilmore dperpeet langdon mattdm sumantrom tyll bcotton pbrobinson
15:00:09 <zodbot> Current chairs: bcotton bex contyk dgilmore dperpeet jonatoni langdon mattdm pbrobinson sumantrom tyll
15:00:11 <mattdm> #topic Introductions, Welcomes
15:00:15 <contyk> .hello psabata
15:00:16 <zodbot> contyk: psabata 'Petr Ĺ abata' <psabata@redhat.com>
15:00:17 <mattdm> Happy New Year, everyone!
15:00:19 <bcotton> .hello2
15:00:19 <dgilmore> hi all
15:00:19 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:00:26 <contyk> o/
15:00:46 <langdon> .hello2
15:00:47 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
15:00:55 <langdon> happy new year!
15:01:03 <langdon> it feels very Monday today
15:01:16 <mattdm> seriously. i bet tomorrow will also feel like monday.
15:01:26 <mattdm> it may be a whole week of mondays!
15:01:43 <mattdm> I know bexelbie is around here somewhere.
15:01:54 * langdon shakes fist and cries "Garfield!"
15:02:04 <dgilmore> mattdm: I am only working today and tomorrow
15:02:11 * langdon probably also dating himself
15:02:13 <mattdm> dgilmore: so just two mondays for you :)
15:02:15 <mattdm> langdon: :)
15:02:19 <dgilmore> mattdm: indeed
15:02:28 <contyk> Mondays are nice
15:02:43 <contyk> just four meetings
15:02:51 <langdon> just think.. there will be one for dgilmore just next week
15:03:10 <mattdm> okay, so I'm going to stop waiting on bex and start with the agenda
15:03:13 <mattdm> #topic Open Floor Agenda
15:03:21 <mattdm> this being an open floor meeting, we make up the agenda now
15:03:35 <mattdm> I have one thing, which is "What happened to that council update mattdm was going to write?"
15:03:49 <mattdm> also bexelbie wanted to talk about the proposed Badges FAD
15:03:53 <contyk> I was wondering if you all were looking for something specific when it comes to those engineering reports I will be doing
15:03:56 * bcotton notes jflory7 is asking for a resolution on the badges fad
15:04:02 <bcotton> d'oh. too slow
15:04:18 <mattdm> sure we can add that as a topic :)
15:04:25 <mattdm> anything else?
15:05:08 <mattdm> ok nothing else :)
15:05:17 <mattdm> 1. Update on council meeting readout
15:05:27 <mattdm> 2. Engineering/Mindshare report format
15:05:33 <mattdm> 3. Badges fad
15:05:46 <mattdm> I'm putting that last so bex can show up because he has thoughts
15:05:59 <langdon> DevConf council Meetup?
15:06:10 <mattdm> 4. DevConf Council meetup :)
15:06:16 <jonatoni> .hello2
15:06:17 <zodbot> jonatoni: jonatoni 'Jona Azizaj' <jonaazizaj@gmail.com>
15:06:23 <mattdm> #topic Update on Council Meeting Readout
15:06:34 <mattdm> This is quick, really
15:06:52 <mattdm> I wanted to word the part about "eh, github" more carefully so it doesn't overshadow everything else
15:06:56 <mattdm> and then it was the holidays
15:07:03 <mattdm> and I haven't looked at it since
15:07:14 <mattdm> so today after this meeting I will go back with fresh eyes
15:07:17 <mattdm> and plan to post tomorrow
15:07:23 <mattdm> that's all :)
15:07:35 <langdon> more likely to be read anyway
15:07:46 <langdon> do you want reviewers?
15:07:50 <mattdm> langdon: yeah. better now than sneaking it in right before the break
15:07:53 <mattdm> langdon: can't hurt!
15:08:15 <mattdm> then starting next week bcotton is gonna help me regularly post some faq-like followup posts
15:08:22 * jonatoni wishes Happy New Year to all :)
15:08:31 <bexelbie> .hello bex
15:08:32 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bexelbie@redhat.com>
15:08:34 <bexelbie> irc had disconnected ... related to my laptop gremlins
15:08:47 <langdon> mattdm: ill be available most of the day.. just ping me
15:08:49 <mattdm> thanks jonatoni!
15:08:52 <mattdm> langdon++
15:08:52 <zodbot> mattdm: Karma for langdon changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:09:07 <mattdm> #topic Engineering/Mindshare readouts
15:09:12 <tyll> .hello till
15:09:16 <zodbot> tyll: till 'Till Maas' <opensource@till.name>
15:09:19 <mattdm> contyk was asking for the format of this.
15:09:42 <mattdm> As I recall, the idea was for the to take over the "random guest" subproject reports
15:10:02 <mattdm> So, we'd probably keep as a video meeting with slides
15:10:13 <contyk> I didn't get any awesome ideas here; perhaps just an overview of what's going on on the list and in fesco/fpc
15:10:20 <contyk> oo, slides
15:10:37 <mattdm> slides help focus :)
15:10:39 <langdon> contyk: tie in to your love of meetings
15:10:45 <mattdm> exactly!
15:11:02 <contyk> so that's next week
15:11:11 <mattdm> I think maybe we want to keep some of the "subproject" aspect
15:11:14 <mattdm> So maybe:
15:11:16 <mattdm> 1. General overview
15:11:40 <mattdm> 2. Drill down on some particular subproject that is interesting or needs council attention or whatever
15:11:51 <mattdm> (like, five-ten minutes. not super deep)
15:12:11 <mattdm> 3. Note on anything else that needs council attention or resources
15:12:29 <mattdm> half the meeting that from Engineering, other half the same thing from Mindshare
15:12:39 <mattdm> how does that sound?
15:12:43 <mattdm> also sumantrom[m]?
15:12:49 <contyk> that might work
15:12:49 <bcotton> not quite
15:13:04 <bcotton> i think we settled on 1/3 FESco, 1/3 Mindshare, 1/3 D&I :-)
15:13:04 <contyk> bcotton has ideas!
15:13:13 <contyk> D&I?
15:13:16 <mattdm> bcotton: oh! yeah I was actually thinking about that too
15:13:21 <jonatoni> Diversity and Inclusion
15:13:24 <bcotton> but otherwise, i think the general format is right. at least to start
15:13:24 <contyk> ah
15:13:30 <mattdm> so that gives 20 minutes for each of those
15:13:32 <mattdm> and I like that.
15:14:04 <mattdm> one twenty minute report a month does not sound too much of a burden for the reps I hope :)
15:14:30 <mattdm> #action mattdm to update https://fedoraproject.org/wiki/Council_Meetings with this
15:14:40 <mattdm> jonatoni: sound good to you?
15:14:49 <jonatoni> mattdm: yep
15:15:30 <langdon> will there be a template?
15:15:42 <mattdm> maybe skip the "drill-down" section for d&i since that doesn't apply
15:15:51 <mattdm> langdon: ooh like a slide template?
15:16:12 <langdon> right
15:16:12 <contyk> templates are not good for diversity
15:16:16 <langdon> ha
15:16:25 <langdon> but .. good for inclusion!
15:16:53 <mattdm> does someone other than me want to volunteer to make a slide template? :)
15:17:03 <langdon> not it!
15:17:17 <mattdm> I think it's a fine idea, but I'm unlikely to actually do it
15:17:29 <bcotton> do we have a generic fedora slide template?
15:17:38 <contyk> a couple, I think
15:17:44 <mattdm> bcotton: yes but it's kind of out of date
15:17:50 <mattdm> needs refresh along with the new logo
15:17:51 <bexelbie> bcotton, we have a couple - there is an updated one that is super nice but we can't seem to get it approved
15:17:56 <bcotton> that's probably good enough for now, at least until we have a new logo
15:18:05 <mattdm> exactly.
15:18:24 <bcotton> i don't think we need a content template (but i'm also not the one presenting) since it's basically "here's what i want to tell you about my area this time"
15:18:30 <langdon> maybe the first run through.. we can keep 10m at the end and comment on the templates used .. then the template can be gen'd from the actual presos
15:18:41 <mattdm> langdon good idea
15:19:14 <mattdm> maybe have a google slides presentation that all three presenters work on their section of?
15:19:29 <mattdm> and then that could be copied to a new one and updated for the next month
15:19:49 <mattdm> or doesn't have to be google slides. that's just so good for collaboration
15:20:01 <contyk> wfm; anything would, though
15:20:23 <mattdm> ok so contyk and jonatoni and sumantrom[m] you can figure that out :)
15:20:57 <contyk> since you're suggesting google slides, do we have some Fedora gdrive space?
15:21:19 <mattdm> contyk: nope!
15:22:08 <contyk> I'll put something together then
15:22:11 <mattdm> thanks :)
15:22:15 <mattdm> next topic!
15:22:17 <contyk> and share it with jonatoni and sumantrom[m]
15:22:21 <mattdm> contyk++
15:22:27 <mattdm> #topic Badges FAD proposal
15:22:36 <jonatoni> thanks contyk :)
15:22:47 <mattdm> bexelbie: do you have ticket # handy?
15:23:15 <bexelbie> https://pagure.io/Fedora-Council/tickets/issue/239
15:24:29 <mattdm> soooo, I think that by our general consensus rules this is approved -- it has three +1s and no negatives
15:24:37 <mattdm> and it's been sitting that way for two weeks
15:24:45 <mattdm> however, bexelbie has Some Concerns
15:25:02 <mattdm> personally I love that there's a logic model :)
15:25:17 * mattdm throws bexelbie RIGHT UNDER THE BUS
15:25:27 <mattdm> but I share the concerns
15:25:36 <mattdm> which I was *getting around to saying*, bexelbie :)
15:25:51 <bexelbie> I have heard concerns from several folks (unnamed because I can't remember for sure who was in each conversation) that this doesn't seem to be setting us up for sustainability and doesn't seem to contain a lot that requires an in person meeting of 4 people from other continents in Brno
15:26:31 <bexelbie> in particular, I've noticed that there is no technical contribution commitment to badges and most of the blocked projects seem to be technical
15:26:34 <langdon> depends a bit on the definition of "sustainability"
15:26:46 <langdon> blocked "projects"?
15:26:50 <bexelbie> there is also little to no ongoing sysadmin contribution to unblock docs and ongoing posting
15:26:59 <bexelbie> art contribution seems to be present
15:27:01 <mattdm> The fundamental problem is that there's noone tasked to work on the badges _code_
15:27:10 <bexelbie> s/projects/issues/
15:27:20 <bexelbie> langdon, the common parlance
15:27:32 <langdon> i completely agree there is nothing here that seems to be technical ... but sustainability may mean of artists/ideas/etc .. vs badge infra?
15:27:33 <bexelbie> there is no set up for ongoing work to continue in badges post this fad
15:27:34 <mattdm> bexelbie: is sysadmin (os level) needed, or app maintenance / development
15:27:54 <bexelbie> the queue is backed up mostly due to a lack of technical and sysadmin contribution
15:27:56 <bexelbie> not art issues
15:28:01 <mattdm> bexelbie: there's the outreachy/gsoc proposal as part of the output
15:28:14 <tyll> the logic model shows three developers - are they not going to work on the technical issues?
15:28:14 <langdon> ahhh ok.. thats makes sense.. (your point I mean)
15:28:15 <bexelbie> arguably the art issues are undocumented which is a different challenge
15:28:39 <mattdm> So the basic concern is that this is going to be a frustration because the underlying blockers will get in the way of whatever this accomplishes
15:28:40 <bexelbie> mattdm, I don't see how we need to spend 7000 to write a proposal that we can't even get enough commitment on to agree to mentoring for
15:29:06 <bexelbie> that 7000 buys us an Outreach intern for a project that does have commitment
15:29:25 <bexelbie> I did some light badges sysadmin today - the tools are rough
15:29:30 <bexelbie> and the docs need help
15:29:43 <bexelbie> and it is blocked on no technical/admin contributors
15:30:25 <mattdm> Huh, apparently the badges app is called... Tahrir?
15:30:31 <bexelbie> yes
15:30:46 <mattdm> it definitely looks like a dead project https://github.com/fedora-infra/tahrir
15:31:16 <langdon> but .. one of the attendees is the last committer
15:31:34 <mattdm> langdon: yeah but that attendee is not working on badges as #dayjob
15:31:45 <mattdm> or at least more than 10% of day job
15:31:49 <langdon> gotcha
15:32:17 <bexelbie> as I understand it that person is not able to commit to contribution at any real level at this point
15:32:23 <mattdm> so, bexelbie, I'm going to turn the bus your way again... :)
15:32:31 <bexelbie> and we are blocked on merges in other parts of the code of lack of test environments, etc. again
15:32:38 <mattdm> what would have to be different in order to make this something you'd *want* to fund?
15:33:05 <bexelbie> badges is important in my opinion, I don't think this FAD fixes the real challenges we have and I don't think we can get them aligned for being fixed between now and the end of Jan ... this is my cocnern
15:33:42 <bexelbie> I'd want to see us jump starting new technical and admin contributors who have a demonstrated history of commitment to Fedora or whose number is such that we are likely tog et enough ongoing commitment
15:33:47 <bexelbie> that's my "pie in the sky"
15:34:02 <mattdm> bexelbie: does there exist a prioritized list of technical challenges?
15:34:14 <bexelbie> not as such, that I know of
15:34:20 <mattdm> because I think this group represents the "product owner" side pretty well
15:34:25 <langdon> if the fad purely focused on getting a deployable dev/test and production containers.. would that be enough? /me goes to look at open tickets
15:34:28 <bexelbie> I think one could be written, if we had a contributor who wanted to do it
15:34:42 <bexelbie> langdon, I don't know
15:34:45 <mattdm> so maybe coming out of this with a good such list would help set things up for future success?
15:34:55 <bexelbie> I don't think that list should require a FAD
15:35:06 <bexelbie> we don't accept that, aiui, from other groups
15:35:26 <bcotton> yeah, that seems like a very expensive way to get a list of what we need
15:36:00 <bexelbie> if we can't do this without in person meeting because we have no contributors, then we should do it at Flock, imho
15:36:14 <mattdm> It does, but I also want to extend some trust to the group. Getting together in person to work can be very productive.
15:36:18 <bexelbie> because we are only going to get the list/etc if we get it from existing contributors then
15:36:24 <mattdm> Flock isn't until August, though, right?
15:36:31 <bexelbie> that is the expected dates
15:38:17 <mattdm> So, here's another angle. Where do we think badges sits strategically?
15:38:28 <mattdm> I think it's a fairly important community building block.
15:38:35 <bexelbie> I agree
15:38:53 <bexelbie> I also think it could help us measure community health in a way that makes sense for Fedora
15:39:07 <langdon> soooo... i think bex has some good points.. however, i kinda think we should help them kickstart this... lets ask for a list of technical issues (and other issues) .. and look for a commitment that 1-2 of the top tech issues will also be resolved during the fad? not to mention some of the other things they want to do ?
15:39:42 <bexelbie> langdon, I think that is potentially a reasonable request, but not in line with the dates proposed
15:39:45 <mattdm> langdon: I'm +1 to that, with the addition that we'd be willing to also sponsor an additional technical contributor
15:39:52 <mattdm> bexelbie: because too soon?
15:39:56 <langdon> bexelbie: dates? why not?
15:39:56 <bexelbie> mattdm, yes
15:40:14 <langdon> what is blocking them from doing it "today"?
15:40:14 <bexelbie> in order to really commit - they need explore the feasability of those issues
15:40:16 <bexelbie> and scope them
15:40:19 <mattdm> bexelbie: otoh, don't we have budget surplus for this year as we stand right now?
15:40:27 <bexelbie> there are no active contributors now, so no one is doing that scoping
15:40:45 <mattdm> bexelbie: you mean no active code contributors?
15:40:50 <langdon> perhaps.. the commitment is they have the list before the fad?
15:41:01 <bexelbie> or sysadmin contributors (though there may be 1)
15:41:47 <bexelbie> langdon, and be able to really believe they can knock off the top 2 items, as I understood your proposal
15:41:53 <mattdm> maybe we can get some help to moving this to dev-controlled openshift, so sysadmin contributors are not so needed?
15:42:12 <bexelbie> mattdm, I am generally opposed to spending money just because it exists - I am sure we have other uses for the money, including refilling our swag needs
15:42:38 <bexelbie> mattdm, by sysadmin contributors I mean people to push badges, award them, fix them, etc
15:42:46 <bexelbie> not machine level sysadmin - but admin of the badges system itself
15:42:59 <bexelbie> today I awarded 9 badges manually
15:43:01 <langdon> i will say "Primary goals are our most urgent tasks that set the minimum bar for what we want to accomplish. " makes me have very little faith in the outcome
15:43:01 <bexelbie> for example
15:43:23 <langdon> i think bcotton has been loving doing the "i voted" badges
15:43:26 <bcotton> i wouldn't call this spending money because it exists. more like being less strict about the FAD requirements this time because we have plenty of funds available (which isn't to say we should defintely approve it)
15:43:50 <bexelbie> if we could get a FAD proposal that addresses these things, like I said, I'd be in favor of it - even if it cost more because we had to fly the people in Brno who would go to somewhere else
15:43:50 <mattdm> bexelbie: oh. that's not really "sysadmin"
15:43:51 <bcotton> langdon: it makes me very sad. hopefully the voting app will have support for giving people a link by the F30 elections
15:44:05 <bexelbie> badge System Administration :)
15:44:12 * langdon potentially, i misread in that the line ^^ is actually from the template
15:44:33 <mattdm> bexelbie, langdon, can you write that proposal into the ticket?
15:46:08 <langdon> mattdm: sure.. i can
15:46:14 * bexelbie will assist
15:46:19 <bexelbie> langdon, already PMed :P
15:46:42 <mattdm> awesome. thanks!
15:46:53 <mattdm> bexelbie: sorry for all the bus shoving :)
15:47:05 <mattdm> #topic Council at DevConf
15:47:07 * langdon notes mattdm may be lying
15:47:11 <mattdm> ha
15:47:46 <mattdm> we didn't put in for a panel or anything
15:48:06 <langdon> re: last topic, is this from "me" or from the "council"?
15:48:13 <mattdm> who all is going to be there?
15:48:20 * bexelbie will be there
15:48:23 * bcotton will be at DevConf
15:48:25 <langdon> mattdm: ohh i meant just dinner with the folks in town.. as we have done before
15:48:25 <tyll> o/
15:48:29 * jonatoni me too
15:48:36 <contyk> me too
15:48:41 <mattdm> langdon: yeah, getting to that :)
15:48:51 <mattdm> we should have a Team Dinner, basically
15:49:03 <bexelbie> how about we get all of our travel schedules together to find the dinner time?  mattdm can you take point on this since we all know where you are going to force us to eat :P
15:49:14 <mattdm> Annapurna FTW!
15:49:27 <mattdm> yes. I will make a ticket :)
15:49:37 <langdon> semi-related.. i think the BOFs still aren't sorted.. we might be able to do a BOF.. and if no one shows .... talk amongst ourselves
15:49:49 <langdon> mattdm: /me would prefer buddha.. just to be difficult
15:49:52 <bexelbie> BoFs are being sorted out - was one submitted?
15:50:00 <contyk> langdon: that reminds me of something from last year
15:50:06 <langdon> bexelbie: no.. but we *know people* ;)
15:50:13 <langdon> contyk: lol
15:50:19 <mattdm> langdon: bof would be good
15:50:24 <bexelbie> langdon, they said 'no' :P
15:50:35 * langdon kinda assumes most of the bofs will find a place..
15:50:46 <mattdm> n.b. I'm filing this as a private ticket so people can include travel plans
15:51:50 <langdon> however.... if some bofs won't be getting space.. we should definitely not get space.. we could just do it ad hoc
15:52:43 <mattdm> langdon: if it's just us talking to ourselves, we shouldn't take space
15:52:54 <mattdm> however if it's "come talk to the council" we could do it as a bof
15:53:03 <bexelbie> mattdm, perhaps we can talk to ourselves before the event then, if it isn't a public come talk to us
15:53:25 <langdon> mattdm: ha.. i meant "if all bofs get space and there is extra room" .. lets ask for one.. else.. lets not
15:53:56 <mattdm> do you know who is coordinating this? who do we ask?
15:54:12 <langdon> mattdm: i willl follow up
15:54:16 <mattdm> langdon++
15:54:20 <mattdm> awesome.
15:54:27 <mattdm> #topic Anything else?
15:54:32 <mattdm> we have five minutes :)
15:55:33 <mattdm> #crickets
15:55:42 <mattdm> okay, thanks everyone!
15:55:47 <mattdm> #endmeeting