17:00:10 <geppetto> #startmeeting fpc
17:00:10 <zodbot> Meeting started Thu Jan 17 17:00:10 2019 UTC.
17:00:10 <zodbot> This meeting is logged and archived in a public location.
17:00:10 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:10 <zodbot> The meeting name has been set to 'fpc'
17:00:10 <geppetto> #meetingname fpc
17:00:10 <geppetto> #topic Roll Call
17:00:10 <zodbot> The meeting name has been set to 'fpc'
17:00:16 <tibbs> Hey, folks.
17:00:34 <geppetto> #chair tibbs
17:00:34 <zodbot> Current chairs: geppetto tibbs
17:00:44 <mhroncok> hi
17:00:59 <geppetto> #chair mhroncok
17:00:59 <zodbot> Current chairs: geppetto mhroncok tibbs
17:01:03 <tibbs> I finally did get the announcement sent out, and closed a bunch of tickets.
17:01:03 * limburgher here
17:01:11 <limburgher> I saw that!
17:01:14 <limburgher> tibs++
17:01:18 <limburgher> tibbs++
17:01:18 <zodbot> limburgher: Karma for tibbs changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:01:40 <tibbs> The university decided to start the yearly inventory process on the first day of classes.
17:01:42 <mhroncok> tibbs: thank you
17:01:46 <tibbs> So it's been a double hit this week.
17:01:59 <limburgher> That seems. . .imprudent.
17:02:01 <tibbs> And my assistant had eye surgery and has been out.
17:02:02 <geppetto> #chair limburgher
17:02:02 <zodbot> Current chairs: geppetto limburgher mhroncok tibbs
17:02:12 <tibbs> So, yeah, it's just been a crazy week.
17:02:26 <tibbs> Just now starting to make progress on my todo list.
17:03:14 * geppetto nods … nothing has changed since last week, ticket wise.
17:03:27 <tibbs> Don't think so, really.
17:03:52 <decathorpe> .hello2
17:03:53 <zodbot> decathorpe: decathorpe 'None' <decathorpe@gmail.com>
17:03:57 <geppetto> #chair decathorpe
17:03:57 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok tibbs
17:04:00 <ignatenkobrain> .hello2
17:04:01 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
17:04:03 <geppetto> #chair ignatenkobrain
17:04:03 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher mhroncok tibbs
17:04:28 <tibbs> I did find out there is wiki magic to redirect from a wiki page to the docs site directly.
17:04:28 <ignatenkobrain> I'm a bit busy here, but will try to respond asap
17:04:43 <tibbs> We should decide if we want to use it.
17:05:18 <tibbs> Currently https://fedoraproject.org/wiki/Packaging:Guidelines has no content; just an admon with the new link and an explanation.
17:05:27 <mhroncok> tibbs: for the removed pages, I'd use it, if there is a way to access the wiki history even when it is enabled
17:05:41 <tibbs> There is, but it's nontrivial.
17:05:48 <tibbs> That's why there's a question about it.
17:06:02 <mhroncok> nontrivial as in you need to update the url mnaually?
17:06:22 <geppetto> #topic Schedule
17:06:25 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/WMI7BEXMJEAC77LYFT2P7LF4K2MME5EM/
17:06:38 <tibbs> Go to https://fedoraproject.org/wiki/Council
17:06:49 <tibbs> You'll get instantly redirected.
17:06:54 <geppetto> So do we have anything to talk about either of those tickets?
17:07:34 <mhroncok> tibbs: I see
17:07:48 <mhroncok> geppetto: I don't
17:08:10 <tibbs> If you want to see the history, you have to append ?action=history: https://fedoraproject.org/wiki/Council?action=history
17:08:24 <tibbs> Or action=edit if you need to change the redirect or whatnot.
17:09:02 <tibbs> For 841, I did file a ticket in the docs pagure, but I didn't get around to it until this morning.  So nothing to add there.
17:09:12 * geppetto nods
17:09:19 <geppetto> #topic Open Floor
17:09:41 <tibbs> For 719, I personally just have to put some time into reading through everything.
17:09:43 <Rombobeorn> Hello! May I direct your attention to issue 610 (source file verification) for a while?
17:09:43 <Rombobeorn> I got the impression that the proposal was waiting for programming to make signature verification easier, so I wrote a script that makes it as simple as possible, but no simpler:
17:09:43 <Rombobeorn> https://src.fedoraproject.org/rpms/redhat-rpm-config/pull-request/54#request_diff
17:09:43 <Rombobeorn> How do you guys like the script? How can the proposal be moved forward?
17:10:43 <tibbs> I thought ignatenkobrain was reviewing it.
17:11:26 <tibbs> But... whether that change is accepted or not isn't exactly up to this committee, though either ignatenkobrain or I could actually merge it.
17:12:00 <tibbs> Sadly the PR modifies the specfile, too, so it's always going to be hard to merge.
17:12:28 <tibbs> (and it modifies the specfile in the same commit that adds the file)
17:13:33 <Rombobeorn> I can update the pull request if I believe that it's going to get merged before it goes stale again. There's no point to me doing more work if you guys don't want the script.
17:13:49 <tibbs> Personally I don't know enough about pgp to feel like I can comment effectively on it.
17:14:41 <tibbs> I believe ignatenkobrain had asked why the cleanup at the end isn't done via a trap.  I don't know enough to understand the negative side effects of not cleaning up on error.
17:15:31 <ignatenkobrain> I wanted RPM maintainers to look at it too
17:15:44 <ignatenkobrain> but looks like they never got time to do so
17:16:24 <ignatenkobrain> PROPOSAL: #action ignatenkobrain to talk to RPM maintainers and try to merge PR#54
17:16:45 <Rombobeorn> I figure the negative side effects of not cleaning up are negligible, as /tmp will be cleaned up eventually anyway.
17:16:47 <geppetto> Yeh, I don't think we need to vote on that :)
17:16:56 <geppetto> #action ignatenkobrain to talk to RPM maintainers and try to merge PR#54
17:18:36 <geppetto> Anything else?
17:18:52 <Rombobeorn> As long as it moves forward somehow, that's all from me.
17:19:13 <geppetto> One thing from me: We'll probably skip next week's meeting due to devconf
17:20:04 <limburgher> Good to know.
17:20:06 <ignatenkobrain> I think so
17:20:22 <tibbs> I'll be around regardless.
17:20:30 <mhroncok> who is going to be onn devconf?
17:20:49 <tibbs> I need to try to go one year.
17:20:53 <geppetto> I won't, but I might be busy anyway
17:21:23 <geppetto> I figured ignatenkobrain and mhroncok would be.
17:21:30 <limburgher> Not I.
17:21:44 <mhroncok> I don't see why to cancel the meeting in that case
17:21:49 * ignatenkobrain will be on devconf
17:22:12 <ignatenkobrain> I even have Rust meetup on Sat, feel free to come ;)
17:24:41 <geppetto> Ok, well we'll see.
17:24:56 <geppetto> As for today that seems to be it so I'll close and give you time back
17:25:05 <mhroncok> geppetto: thanks
17:25:05 <geppetto> #endmeeting