17:00:24 <bcotton> #startmeeting F30 Final Go/No-Go meeting
17:00:24 <zodbot> Meeting started Fri Apr 26 17:00:24 2019 UTC.
17:00:24 <zodbot> This meeting is logged and archived in a public location.
17:00:24 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:24 <zodbot> The meeting name has been set to 'f30_final_go/no-go_meeting'
17:00:26 <bcotton> #meetingname F30-Final-Go_No_Go-meeting
17:00:26 <zodbot> The meeting name has been set to 'f30-final-go_no_go-meeting'
17:00:37 <bcotton> #topic Roll Call
17:00:44 <bcotton> here we go again!
17:00:47 * sgallagh rises from his grave to attend
17:01:00 <MarkOtaris> :D
17:01:03 <zbyszek> sgallagh: it's this time of the year
17:01:13 <bcotton> RIP sgallagh
17:02:16 <adamw> .hello adamwill
17:02:17 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
17:02:22 <adamw> un-RIP sgallagh?
17:03:02 * coremodule has docked in the Fedora pier, aboard the U.S.S. Ship-It!
17:03:08 <bcotton> paging mboddu
17:03:14 <sgallagh> (Sorry, just super under-the-weather today.)
17:03:20 * mboddu is here
17:03:29 <mboddu> .hello mohanboddu
17:03:30 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
17:03:30 <bcotton> okay, let's do this!
17:03:34 <bcotton> #topic Purpose of this meeting
17:03:36 <bcotton> #info Purpose of this meeting is to check whether or not F30 is ready for shipment, according to the release criteria.
17:03:37 <bcotton> #info This is determined in a few ways:
17:03:41 <bcotton> #info 1. No remaining blocker bugs
17:03:43 <bcotton> #info 2. Release candidate compose is available
17:03:44 <bcotton> #info 3. Test matrices are fully completed
17:03:51 <bcotton> (i took the "beta" out of #3 for today, mboddu)
17:04:08 <adamw> bcotton++
17:04:09 <zodbot> adamw: Karma for bcotton changed to 21 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:04:14 <mboddu> bcotton++
17:04:14 <zodbot> mboddu: Karma for bcotton changed to 22 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:04:21 <nirik> morning
17:04:23 <bcotton> i'm going to change the order up slightly so that thigns flow better
17:04:28 <bcotton> #topic Current status — release candidate
17:04:45 <bcotton> #info RC 2 is the current candidate
17:04:54 * mboddu will add something to the status at the end
17:05:25 <bcotton> anything not testing related to note about RC2 beyond the fact that it exists?
17:05:54 <adamw> i was a bit worried it might be missing images compared to RC1
17:05:55 <adamw> let's see...
17:05:58 <pwhalen> .hello pwhalen
17:05:59 <zodbot> pwhalen: pwhalen 'Paul Whalen' <pwhalen@redhat.com>
17:06:04 <bcotton> adamw: standing by
17:06:19 <mboddu> adamw: Yes, exactly
17:06:24 <adamw> https://fedoraproject.org/wiki/Template:Fedora_30_RC_1.1_Download vs. https://fedoraproject.org/wiki/Template:Fedora_30_RC_1.2_Download
17:06:27 <adamw> get to eyeballin'
17:06:32 <adamw> (i really need to write a silly script for this)
17:06:45 <adamw> scientific vagrant images are missing
17:07:00 * nirik is testing cloud in openstack
17:07:02 <adamw> LXDE live is missing
17:07:13 <mboddu> python classroom x86_64 iso is missing
17:07:19 <adamw> design suite too
17:07:40 <adamw> screw this i'm writing a script
17:07:41 <zbyszek> Neither RC_1.1 nor RC_1.2 is a superset of the other ;(
17:08:04 <adamw> oh hey i already have one sitting in my fedfind dir
17:08:05 <adamw> how bout that
17:08:13 <adamw> i did exactly this in...fedora 26
17:08:13 <adamw> heh
17:08:16 <bcotton> hooray for Past Adam
17:08:29 <coremodule> ++pastadam
17:08:39 <coremodule> dangit
17:09:01 <sgallagh> Googled "pasta dam". Was disappointed.
17:09:12 <adamw> =)
17:09:13 <coremodule> lol, i read the same thing too
17:09:23 <adamw> In RC1, not RC2:
17:09:23 <adamw> {('design_suite', 'live', 'x86_64'), ('scientific', 'vagrant-libvirt', 'x86_64'), ('lxqt', 'raw-xz', 'armhfp'), ('mate', 'raw-xz', 'armhfp'), ('container_base', 'docker', 's390x'), ('python_classroom', 'live', 'x86_64'), ('lxde', 'live', 'x86_64'), ('scientific', 'vagrant-virtualbox', 'x86_64')}
17:09:23 <adamw> In RC2, not RC1:
17:09:23 <adamw> {('container_minimal_base', 'docker', 's390x'), ('cinnamon', 'live', 'i386')}
17:09:47 <adamw> so, kinda sucks to lose those lives, i guess
17:09:49 <pwhalen> arm lost lxqt and mate
17:09:58 <nirik> :(
17:10:22 <sgallagh> Why is our compose process so unpredictable?
17:10:31 <adamw> how long do you got?
17:10:34 <bowlofeggs> .hello2
17:10:35 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <rbarlow@redhat.com>
17:10:44 <sgallagh> adamw: Doctor said six months, I think?
17:10:53 <sgallagh> But what do they know, really?
17:11:05 <bcotton> #info The following deliverables are not in RC2 (but were in RC1): design_suite-live-x86_64, scientific-vagrant-libvirt-x86_64, lxqt-raw-xz-armhpf, mate-raw-xz-armhfp, container_base-docker-s390x, python_classroom-live-x86_64, lxde-live-x86_64, scientific-vagrant-virtualbox-x86_64
17:11:21 <adamw> arm images are the "Cannot download, all mirrors were already tried without success." thing
17:11:24 * nirik could write a list
17:11:28 <adamw> https://koji.fedoraproject.org/koji/taskinfo?taskID=34454818 (LXQt)
17:11:33 <adamw> https://koji.fedoraproject.org/koji/taskinfo?taskID=34454781 (MATE)
17:11:59 <adamw> what we've done in the past in this kinda situation is stuff a link to a nightly image or similar into the website
17:12:02 <adamw> maybe we can do that again
17:12:14 <adamw> wait for nightlies of these images after we have done the final stable push, provide links to those
17:12:29 <nirik> yeah, we did those in another dir as 'unofficial' images
17:12:31 <adamw> i wouldn't want to use RC1 images especially for ARM as we fixed that initial-setup bug in RC2...
17:12:58 <mboddu> adamw: I was about to suggest that, we put them in unofficial images dir and link them
17:13:08 <mboddu> But that might be more work on websites
17:13:11 <adamw> yeah :/
17:13:27 <adamw> we can't realistically slip and respin though. especially since there's no reason to believe an RC3 would turn out better
17:13:32 <adamw> hey, it might turn out worse
17:13:45 <mboddu> Or we could vote on RC2 and we can RC3 without any changes
17:13:59 <adamw> LXDE live failed on a similar download error
17:14:00 <adamw> "Non interactive installation failed: Failed to download the following packages: Cannot download Packages/p/perl-PathTools-3.75-2.fc30.x86_64.rpm: All mirrors were tried."
17:14:03 <mboddu> Yeah, there is that
17:14:18 <adamw> as did python-classroom
17:14:19 <adamw> "DEBUG util.py:554:  BUILDSTDERR: 2019-04-26 02:06:39,374: Non interactive installation failed: Failed to download the following packages: Cannot download Packages/p/poppler-glib-0.73.0-8.fc30.x86_64.rpm: All mirrors were tried."
17:14:25 <adamw> we really need to figure out why this is happening
17:14:38 <adamw> (openqa tests run into this occasionally as of late as well)
17:14:40 <nirik> yes, that would sure be nice
17:14:41 <mboddu> I have checked python-classroom and couple other labs and they failed on the same error
17:15:12 <bcotton> #info several failed due to download failures during build
17:15:47 <mboddu> bcotton: I would say "non blocking artifacts" just so we are going to release rc2 itself
17:15:56 <mboddu> if we are*
17:16:05 <coremodule> I like mboddu’s idea, if we can do that. Vote RC2 through, then respin without any changes and if RC3 is better, go with that
17:16:24 * nirik doesn't like the idea of doing more composes... thats going to confuse people
17:16:30 <bcotton> #undo
17:16:30 <zodbot> Removing item from minutes: INFO by bcotton at 17:15:12 : several failed due to download failures during build
17:16:32 <bcotton> #undo
17:16:32 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f7e5fae0590>
17:16:32 <mboddu> coremodule: What if rc3 turns out to be worse than rc2
17:16:36 <coremodule> *all assuming we find RC2 “good enough” in case
17:16:45 <bcotton> #info The following non-blocking deliverables are not in RC2 (but were in RC1): design_suite-live-x86_64, scientific-vagrant-libvirt-x86_64, lxqt-raw-xz-armhpf, mate-raw-xz-armhfp, container_base-docker-s390x, python_classroom-live-x86_64, lxde-live-x86_64, scientific-vagrant-virtualbox-x86_64
17:16:48 <coremodule> mboddu ^^
17:16:48 <bcotton> #info several failed due to download failures during build
17:17:09 <adamw> yeah let's not do that
17:17:10 <bcotton> yeah, i'm concerned that RC3 would end up dropping more (or at least different) deliverables
17:17:21 <nirik> and it also means we have to wait for it.
17:17:25 <adamw> let's ship rc2 with whatever make-up images we can include
17:17:35 <nirik> if so, release tue seems poor waiting for another compose/
17:17:39 <sgallagh> adamw: +1
17:17:57 <Southern_Gentlem> (the Respins Sig will produce the lxde-live soon anyways)
17:18:31 * nirik wonders if anyone is driving lxde spin or if it should even exist.
17:18:47 <adamw> it's using full self-driving technology
17:18:58 <mboddu> We could let the f30 nightlies run without pushing stable updates over the weekend and push the images to "unofficial" dir
17:19:14 <adamw> right, that's basically what i'm suggesting
17:19:48 <nirik> well, let them run at least one more time after we have pushed things stable
17:19:56 <nirik> because we should also stage the 0 day updates
17:20:11 <mboddu> nirik: Okay
17:20:13 <nirik> and pushing all this out means releng gets to work the weekend. ;)
17:20:28 <mboddu> nirik: Yeah, I am prepared for it
17:20:49 <pwhalen> mboddu++
17:20:50 <nirik> great, but would be nice not to have to.
17:20:51 <zodbot> pwhalen: Karma for mohanboddu changed to 18 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:21:06 <mboddu> Luckily I made 2 plans for avengers endgame, so I will go to it on Tue :D
17:21:16 <bcotton> mboddu++
17:21:28 <nirik> ha
17:22:03 <bcotton> okay, so are we ready to move on to the rest of it?
17:22:16 <bcotton> rephrase: i'm moving on unless someone says not to
17:22:18 <nirik> cloud image looks ok (aside the random thing which is due to our openstack being a pile)
17:23:13 <bcotton> #topic Current status — blocker bugs
17:23:15 <bcotton> #link https://qa.fedoraproject.org/blockerbugs/milestone/30/final/buglist
17:23:31 <bcotton> so no new blockers have cropped up since yesterday :-)
17:23:56 <bcotton> #info (1670396) KSieve fails to start - fixed in RC2
17:24:06 <adamw> 1703152 is also fixed in RC2
17:24:12 <bcotton> #info (1703152) initial-setup fails with no network - AttributeError: 'NoneType' object has no attribute 'upper' - fixed in RC2
17:24:29 <bcotton> /me mutes coremodule so he can't propose any more blockers
17:24:44 <bcotton> i guess i didn't need to put a space before that /me but whatever
17:24:55 <bcotton> anything on blockers before we move on?
17:25:09 <bcotton> no? great!
17:25:12 <bcotton> #topic Current status — test matrices
17:25:13 <adamw> nope.
17:25:13 <bcotton> #link https://fedoraproject.org/wiki/Category:Fedora_30_Test_Results
17:25:18 <adamw> oh
17:25:19 <adamw> well
17:25:31 <adamw> we could note that we need to push the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1688462 stable for F29 before releasing
17:25:43 <bcotton> #undo
17:25:43 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f7e60ebff10>
17:25:45 <bcotton> #undo
17:25:45 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f7e60ebf650>
17:26:01 <adamw> i should also check if we need it for f28
17:26:15 <bcotton> adamw: i think we do
17:26:19 <adamw> k
17:26:24 <bcotton> but not 100% sure
17:26:26 <adamw> i'll try and get that sorted with dnf team
17:26:37 * nirik isn't sure either, since 28 didn't have modules like 29/30
17:26:50 <bcotton> #action adamw to verify if fix for BZ 1688462 is needed for F28
17:27:00 <bcotton> #action RelEng to push the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1688462 stable for F29 (and possibly F28) before releasing F30
17:27:03 <sgallagh> adamw: It's unlikely that 28 *can* be updated for this.
17:27:42 <adamw> well that means less work!
17:27:44 <sgallagh> But in F28, only Server Edition had module support and only had a very few modules
17:27:51 <adamw> nirik: F28 did have modules
17:27:52 <adamw> just not many...yeah
17:28:05 <nirik> yes, but not like the ones later... and only server, etc.
17:28:22 <nirik> anyhow, whatever is needed can be sorted.
17:28:27 * mboddu has to update one of his boxes to f29 asap
17:28:48 <sgallagh> IIRC, the F28 modules don't have the "Requires: platform(f28)" in their solvables either
17:28:58 <sgallagh> But I could be misremembering that
17:29:48 <bcotton> okay, let's move on to test coverage
17:29:51 <bcotton> #topic Current status — test matrices
17:29:53 <bcotton> #link https://fedoraproject.org/wiki/Category:Fedora_30_Test_Results
17:30:18 <adamw> so, coverage is almost complete now
17:30:27 <adamw> coremodule and I are just trying to get Xen run
17:30:34 <adamw> but frankly even if it fails we shouldn't block on it
17:30:51 * nirik nods
17:30:56 <adamw> because the whole deal with Xen is xen folks are supposed to help us test it, and they didn't. we had an ml debate about this in 2017 where they promised to do the testing, and they haven't.
17:31:12 <nirik> but we're not bitter
17:31:25 <coremodule> not bitter at all
17:31:45 * coremodule agrees with the above.
17:31:54 * bcotton too
17:31:57 <adamw> ok maybe a little bit bitter
17:32:08 <adamw> oh but hey it's working, so there's that.
17:32:15 <mboddu> adamw++
17:32:18 <mboddu> coremodule++
17:32:18 <zodbot> mboddu: Karma for coremodule changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:32:22 <adamw> there are some issues with dom0, but only domU is blocking, so.
17:32:53 <bcotton> #info Coverage is complete except for a few non-blocking Xen tests
17:33:30 <adamw> now our usual magic fingers have had 24 hours longer with the bits and haven't managed to break them in any really weird ways i feel a bit happier about saying these bits are OK
17:33:59 <nirik> and shockingly kparal hasn't found any new blockers. Is he feeling ok
17:34:00 <nirik> ?
17:34:03 <bcotton> any questions for QA?
17:34:12 <adamw> nirik: he's off his game, clearlyu
17:34:22 <sgallagh> Mostly a statement: Great work, QA!
17:34:24 * stickster extends thanks for big efforts here
17:34:39 <nirik> yeah, great work all around.
17:34:50 <mboddu> One more release on time
17:34:58 <mboddu> Hat-trick :D
17:35:02 <bcotton> alright, well i guess it's time for the Big Moment™
17:35:16 <bcotton> #topic Go/No-Go decision
17:35:17 * mboddu can sleep happily tonight
17:35:17 <bcotton> I will poll each team. Please reply “go” or “no-go”
17:35:26 <bcotton> FESCo?
17:35:28 <nirik> go
17:35:30 <sgallagh> GO
17:35:32 <bcotton> #info FESCo is GO
17:35:35 <bcotton> Releng?
17:35:38 <mboddu> Go
17:35:40 <bcotton> #info RelEng is GO
17:35:45 <bcotton> QA?
17:36:04 <adamw> per our rules: there are no outstanding unaddressed blockers and test coverage is complete, so GO
17:36:09 <bcotton> #info QA is GO
17:36:11 <sumantro> Go
17:36:17 <bcotton> adamw: your verbosity was killing me :p
17:36:18 <bowlofeggs> go
17:36:23 <bcotton> #agreed Fedora 30 is GO
17:36:24 <bowlofeggs> (from fesco)
17:36:26 <bowlofeggs> haha
17:36:26 <adamw> (my xen install is running so i'm gonna assume it's good :>)
17:36:29 <stickster> \o/
17:36:32 <bcotton> #info Fedora 30 will release on 2019-04-30
17:36:37 <bowlofeggs> woooo
17:36:39 <adamw> woo to the hoo
17:36:41 <adamw> nice job everyone
17:36:42 <stickster> 🍻
17:36:46 <bcotton> good work everybody!
17:36:49 <mboddu> Woot woot woot
17:36:52 <coremodule> yay! yay!
17:36:54 <bowlofeggs> now we are done making fedora - what will we do next
17:36:54 <adamw> thanks mboddu and nirik for the compose babying
17:36:55 <bcotton> #action bcotton to announce decision
17:37:00 <sumantro> yaayyyy!
17:37:01 <adamw> bowlofeggs: ...MOAR FEDORA
17:37:03 <bcotton> bowlofeggs: we're going to get rich
17:37:08 <bowlofeggs> hahah
17:37:10 <bcotton> #topic Open Floor
17:37:11 <bowlofeggs> yes and yes
17:37:18 <bcotton> Anything else we need to discuss before closing?
17:37:47 <mboddu> adamw: Can you request the final stable updates?
17:37:53 <adamw> maybe we should have a ticket or something for pulling in unofficial missing images so everyone can monitor that and make sure it happens?
17:37:59 <adamw> mboddu: will do in a sec, yep
17:38:01 <mboddu> So that the next nightly will have the same content as of RC 2
17:38:16 <bcotton> #action adamw to request the final stable updates
17:38:32 <bcotton> adamw: are you volunteering to create that unofficial missing images ticket?
17:38:47 <adamw> no
17:38:49 <adamw> ......fine yes
17:38:57 <bcotton> hooray!
17:39:14 <bcotton> #action adamw to file a ticket for pulling in unofficial missing images so everyone can monitor that and make sure it happens?
17:39:17 <bcotton> #undo
17:39:17 <zodbot> Removing item from minutes: ACTION by bcotton at 17:39:14 : adamw to file a ticket for pulling in unofficial missing images so everyone can monitor that and make sure it happens?
17:39:19 <mboddu> adamw: Probably create it at pagure.io/fedora-websites since they are one's who should know they are coming
17:39:20 <bcotton> #action adamw to file a ticket for pulling in unofficial missing images so everyone can monitor that and make sure it happens
17:39:43 <nirik> and... can we just fire the next nightly after the stable push?
17:39:55 <mboddu> nirik: Thats the plan
17:40:11 <sgallagh> 🍾
17:40:20 <mkolman> \o/
17:40:53 <bcotton> okay, last call before I #endmeeting
17:41:04 <mboddu> Although the stable push has to wait as there is a push going on right now
17:42:14 * bcotton bangs gavel
17:42:24 <bcotton> great work everyone, thanks for making this happen ON TIME!
17:42:30 <nirik> thanks bcotton
17:42:33 <bcotton> (and not even the fake on time!)
17:42:35 <mboddu> thanks bcotton
17:42:38 <bcotton> #endmeeting