14:00:12 <bcotton> #startmeeting Council (2019-07-10)
14:00:12 <zodbot> Meeting started Wed Jul 10 14:00:12 2019 UTC.
14:00:12 <zodbot> This meeting is logged and archived in a public location.
14:00:12 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:12 <zodbot> The meeting name has been set to 'council_(2019-07-10)'
14:00:13 <bcotton> #meetingname council
14:00:13 <zodbot> The meeting name has been set to 'council'
14:00:22 <bcotton> #chair jonatoni bexelbie contyk dgilmore dperpeet langdon mattdm sumantrom tyll bcotton pbrobinson asamalik
14:00:22 <zodbot> Current chairs: asamalik bcotton bexelbie contyk dgilmore dperpeet jonatoni langdon mattdm pbrobinson sumantrom tyll
14:00:24 <bcotton> #topic Introductions, Welcomes
14:00:32 <mattdm> good morning!
14:00:44 <mattdm> thank you for chairing the meeting bcotton :)
14:00:53 <contyk> .hello psabata
14:00:54 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
14:01:09 <bcotton> i live to serve, mattdm (please note the comma. it's very important)
14:02:10 <x3mboy> Tron!
14:02:23 <x3mboy> Sorry, funny comment, not meant to disturb the meeting
14:02:40 <bcotton> welcome, x3mboy :-)
14:02:54 <langdon> .hello2
14:02:55 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
14:03:27 <contyk> commas matter!
14:03:34 <mattdm> lol
14:05:24 <bcotton> well it seems like it's going to be a lightly attended meeting. more donuts for me!
14:05:35 <bcotton> #topic Today's agenda
14:05:36 <bcotton> 1. #254—Close out current modularity objective and consider next phase
14:05:38 <bcotton> 2. #251—Fedora Project & Nitrokey
14:05:45 <bcotton> 3. #255—Require Council candidates to only run for Council
14:05:46 <bcotton> 4. Council meeting changes
14:05:48 <bcotton> 5. IBM acquisition Q&A
14:05:49 <bcotton> 6. Open floor
14:05:54 <bcotton> #topic Close out current modularity objective and consider next phase
14:05:56 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/254
14:05:59 <bcotton> langdon: you're up
14:06:14 <mattdm> bcotton: I have something for open floor if we have time :)
14:06:19 <bcotton> mattdm: ack
14:06:23 <langdon> shhot .. can we skip me and come back
14:06:29 <bcotton> langdon: can do
14:06:31 <bcotton> #undo
14:06:31 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f6d2f730210>
14:06:33 <bcotton> #undo
14:06:33 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f6d2f66e950>
14:06:34 <mattdm> WATCH US DESTROY YOUR AGENDA
14:06:48 <bcotton> :-D
14:06:53 <bcotton> #topic Fedora Project & Nitrokey
14:06:55 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/251
14:06:59 <bcotton> #info tyll is to develop a proposal that includes 1. who will get the key and 2. how we will enforce it (including what infra work, if any, would be required)
14:07:10 <bcotton> tyll_: are you around?
14:08:45 * jwf waves
14:08:51 <bcotton> hi jwf!
14:09:00 <bcotton> okay, i don't see a tyll_, so we'll move on
14:09:07 <bcotton> #topic Require Council candidates to only run for Council
14:09:08 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/255
14:09:18 <bcotton> #info This vote is currently deadlocked
14:09:43 <bcotton> and the people who are -1 are not here, so we'll move on, again
14:09:57 <bcotton> #topic Council meeting changes
14:10:23 <bcotton> everyone should have seen mattdm's email about moving to bi-weekly ticket review/open floor meetings
14:10:39 <bcotton> and doing regular status reports via a pagure repo
14:10:49 <mattdm> yes. I saw it!
14:10:57 <bcotton> so since we're meeting today, i suggest that next week's meeting is the first we skip
14:11:00 <bcotton> mattdm++
14:11:51 <contyk> :)
14:12:55 <mattdm> +1 skip next week
14:13:02 <bcotton> that's enough for me :-)
14:13:07 <mattdm> bcotton: I seem to recall you volunteering to update the invites :)
14:13:18 <bcotton> #agreed We will skip next week's meeting and move to the bi-weekly meeting plan
14:13:31 <bcotton> mattdm: would i do that?
14:13:43 <mattdm> it does seem pretty on-brand
14:13:47 <bcotton> #action bcotton to update fedocal and any documentation
14:13:58 <bcotton> any questions about the meeting or the status updates?
14:14:01 <langdon> luckily the direction we are going means even if they aren't updated, I wont miss any
14:14:29 <langdon> sorry.. i had a drive by who was distracting me
14:15:22 <bcotton> langdon: ready for us to come back to you on the modularity objective?
14:15:33 <langdon> yeah.. was just going to look at the ticket
14:16:14 <bcotton> #topic Close out current modularity objective and consider next phase
14:16:16 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/254
14:16:20 <langdon> only update is there is no update since last time.. i have a new objective but I completely spaced on moving it to the docs site
14:16:37 <mattdm> oooh ooh do it right now :)
14:16:48 <langdon> might be what i am doing :)
14:17:12 <bcotton> #action langdon to move the new objective to the docs site
14:17:17 <bcotton> ;-)
14:18:04 <bcotton> i think that's all we can say on this topic right now
14:18:13 <bcotton> so let's move on
14:19:02 <bcotton> #topic IBM acquisition Q&A
14:19:16 <bcotton> #link https://fedoramagazine.org/red-hat-ibm-and-fedora/
14:19:58 <bcotton> so the answer to most questions is going to be "nothing is changing", but I think it's important to give the community an opportunity to ask questions
14:20:11 <bcotton> so if you have questions, please raise your hand and i will make mattdm answer them for you :-)
14:20:51 <langdon> did any come in on the ml thread? either public or private?
14:21:10 <bcotton> none that i saw
14:22:06 <contyk> so the Flock website lists RH as a platinum sponsor
14:22:12 <mattdm> we got one about power
14:22:12 <contyk> should we keep that or change it to IBM now?
14:22:17 <mattdm> we should keep it
14:22:25 <mattdm> Red Hat still exists
14:22:26 <bcotton> contyk: "Red Hat is still Red Hat"
14:22:48 <mattdm> It is no longer a publically traded company, but is a wholly-owned subsidiary of IBM
14:23:09 <bcotton> there are 15 comments on the magazine article. most are...cynical in nature. but no real questions, just a general sense of distrust, i'd say
14:23:10 <mattdm> I'd actually like to get IBM to _also_ sponsor, but that's a differnet issue :)
14:24:39 <bcotton> jwf, x3mboy, since you're here, do you have questions?
14:26:26 <bcotton> okay, seems like no
14:26:35 <jwf> I was here to observe. I don't have any questions specifically on this. The Magazine article was helpful
14:26:40 <jwf> Sorry, my connection dropped for a moment
14:26:53 <bcotton> jwf: great! i'm glad the article helped
14:26:54 <bcotton> #topic Open floor
14:26:59 <bcotton> mattdm: you have a thing
14:27:05 <mattdm> bcotton: I did!
14:27:19 <mattdm> We have a couple late funding requests for Flock travel
14:27:33 <mattdm> They came in from Red Hatters who had hoped to get internal funding but did not
14:27:47 <mattdm> We have allocated all of the flock travel budget already
14:28:17 <mattdm> the question is: should we allocate non-flock funds for this?
14:28:33 <mattdm> or otherwise ask bexelbie if he can dig in the proverbial couch cushions?
14:28:48 <bcotton> mattdm: how much are we talking?
14:28:54 <contyk> was just going to ask :)
14:28:58 <bexelbie> .hello bex
14:28:59 <zodbot> bexelbie: bex 'Brian (bex) Exelbierd' <bexelbie@redhat.com>
14:29:03 <langdon> 1 billion dollars!
14:29:06 <mattdm> oh good bexelbie is here!
14:29:24 <x3mboy> Sorry, I wasn't here, but i was
14:29:57 <mattdm> bexelbie, do you have "how much are we talking" offhand?
14:31:00 <bexelbie> So it is a bit complicated, but there are several answers
14:31:12 <mattdm> Let's hear all the answers!
14:31:20 <bexelbie> first, everyone selected by the funding committee has been funded.  Those not yet funded were lower than the funding cut off limit.
14:31:32 <bexelbie> Meaning that we didn't run out of money on those that were high priorities
14:31:50 <bexelbie> There are two requests that came in after the committee finished there work.  They have not been evaluated for ranking by the committee.
14:32:21 <bexelbie> We have about $21,000 in unfunded people who did not make the funding cut off.  I presume the other two requests total to about $3500 (I'll need to verify this)
14:33:05 <bexelbie> Both individuals submitting after the fudning committee finished there work said that they had not been paying attendiont to the process and missed the timings
14:33:23 <mattdm> Also, these are both people presenting talks that we have accepted or would accept. Not that it's all about talks of course.
14:33:58 <bexelbie> Both people also acknowledged knowing before the deadline they would not be receiving employer-based funding aiui
14:34:14 <mattdm> Right, so there's some degree of "please follow the procedures; we have them for a reason"
14:34:55 <mattdm> On the other hand, we don't want to be bound by bureaucracy
14:35:02 <bcotton> and the question of "would we be considering this if they weren't Red Hat employees?"
14:35:06 <bexelbie> My gut feeling is that Flock funding has been worked on as a process that is around getting the right people to Flock (speaker or not).  We have a process to try to make it as far as possible as this is a super contentious issue.
14:35:39 <mattdm> bcotton: I can answer that last one -- yes, definitely, I would at least
14:36:23 <bexelbie> Also, if it matters, we are projected to spend more this year on funding than we did last yera
14:36:28 <mattdm> Without going too far into twenty questions :) one person is a RHer but not working in an area where what they do in Fedora has anything to do with their day job
14:36:34 <bexelbie> final numbers won't be in until all bills are paid, of course
14:36:58 <mattdm> for the other person, it is their day job and their department is under-funding travel :(
14:37:56 <mattdm> My suggestion, if we want to approve travel, would be to consider this as coming from Council budget not already allocated to Flock
14:38:02 <bcotton> so if we have funds available, i don't want to say "no money for you" out of a spiteful adherence to The Process. on the other hand, i'm worried about the potential negative perception in the community
14:38:23 <bcotton> mattdm++
14:38:44 <mattdm> x3mboy jwf what do you think?
14:39:02 <bexelbie> I believe if we authorize additional funding we should both allocate additional funds from the council and reconsider all remaining applicants for that funding.
14:39:08 <bexelbie> not just the two new ones
14:39:23 <bexelbie> as we dont' know if the committee would rank them higher or lower than the others
14:39:36 <mattdm> bexelbie: that does seem fair
14:39:53 <bcotton> agreed. basically "we're going to fund two more people" and let the committee use their process to decide who they will be
14:40:00 <jwf> The messaging on my end from the last two years was like bexelbie said, on getting the right people in the room. I don't know who these people are or what they do in the Fedora community, but that is the criteria I would use for evaluating this request.
14:40:10 <bexelbie> bcotton, I encourage the funding to come as a dollar amount not a person count
14:40:35 <bcotton> bexelbie: sure, "two more people" is a proxy for whatever dollar amount that comes out to
14:40:49 <mattdm> bexelbie: that seems fair but I need you to tell us the dollar amount options we have
14:41:03 <jwf> To me personally, I am indifferent about whether they are RH employees, but worth noting that a lot of the work relevant to the goals of Fedora is often (not always, but often) done by people whose work is funded, one way or another, by Red Hat
14:41:18 <bcotton> as a point of order, i will point out that we have less than half of the council here and none of the elected reps, so the decision should go to a ticket vote
14:41:39 <bexelbie> at this point it is probably $1500/per person on average, maybe a bit more - airfare
14:41:42 <bexelbie> is a problem now
14:41:42 <jwf> +1 to bexelbie's suggestion fwiw
14:41:52 <mattdm> bcotton: yes that's a good point.
14:41:55 <bexelbie> also, we basically cannot offer funding to anyone who needs a visa
14:42:26 <bexelbie> There is pretty much not enough time left for processing
14:42:38 <bexelbie> from most countries (assume 2-4 weeks)
14:43:17 <mattdm> bexelbie: So, I'm going to propose ~ $4000 in additional funding
14:43:42 <mattdm> this would come from our potential budget for hackfests and stuff in the rest of the year
14:43:53 <mattdm> We haven't had a lot of such proposals
14:44:01 <mattdm> since langdon's got Shot Down :)
14:44:08 <langdon> :(
14:44:43 <bexelbie> yes
14:45:03 <bexelbie> also, we haven't passed a budget, but we have the same money as last year - I have been buried in Flock and a few other things so I haven't had chance to write a proposal
14:45:12 <bcotton> #action mattdm to create a Council ticket to propose allocating additional funding for flock travel
14:45:26 <bexelbie> other than flock, this should be right: https://budget.fedoraproject.org/budget/FY20/overall.html
14:45:43 <bexelbie> actually it looks wrong to me
14:45:48 <bexelbie> looks like it is missing projections
14:45:51 <bexelbie> I'll need to check
14:45:54 <bexelbie> but it is probably in the ball park
14:46:25 <mattdm> so, we are halfway through the year and have not spent very much at all
14:46:35 <mattdm> what's the projection for flock?
14:46:36 <bcotton> bexelbie: is it reasonable to have the budget ready for approval for our next meeting (24 July)? i know you have a lot going on right now
14:48:36 <bexelbie> bcotton, most likely - if you don't see a ticket by Monday please poke me with a blunt stick
14:48:48 <bexelbie> mattdm, we expect to spend the full ~100K
14:49:05 <bexelbie> I don't have final numbers from the venue on a few thigns so we may even overrun
14:49:06 <bcotton> bexelbie: sounds good
14:50:08 <mattdm> #link https://pagure.io/Fedora-Council/tickets/issue/264
14:50:14 <bcotton> mattdm++
14:50:23 <mattdm> thanks everyone
14:50:29 <bcotton> any other topics for open floor?
14:52:38 <bcotton> that's a "no"
14:52:48 <bcotton> thanks, everyone! see you in *two weeks*
14:52:52 <bcotton> #endmeeting