19:00:20 <bcotton> #startmeeting F31 Beta Readiness Meeting
19:00:20 <zodbot> Meeting started Thu Sep 12 19:00:20 2019 UTC.
19:00:20 <zodbot> This meeting is logged and archived in a public location.
19:00:20 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:20 <zodbot> The meeting name has been set to 'f31_beta_readiness_meeting'
19:00:21 <bcotton> #meetingname f31-beta-readiness-meeting
19:00:21 <zodbot> The meeting name has been set to 'f31-beta-readiness-meeting'
19:00:33 <bcotton> #topic Roll Call
19:00:52 <mkolman> (uses RPMs for apps, Wayland for graphics, systemd for init, DBUS for IPC, bas for shell, QML for apps, most apps in C++ or Python, etc.)
19:00:57 <mboddu> .hello mohanboddu
19:00:58 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
19:01:10 <mkolman> lruzicka: I call it "makes phone buying decisions easier"
19:01:54 <lruzicka> mkolman, :D
19:02:15 <mkolman> how are you supposed to choose otherwise with so many devices available ?
19:02:23 * mkolman is only half joking
19:03:07 <bcotton> #info Before each public release all of the groups participating the development of Fedora's next release meet to make sure the release is well-coordinated.
19:03:08 <bcotton> #link https://fedoraproject.org/wiki/Release_Readiness_Meetings
19:03:11 <austinp> .hello austinpowered
19:03:12 <zodbot> austinp: austinpowered 'None' <fedoraproject@wootenwilliams.com>
19:03:26 <adamw> .hello adamwill
19:03:27 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
19:03:47 <lruzicka> .hello2
19:03:48 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
19:04:03 <mhroncok> hi again
19:05:03 <bcotton> #topic Current status
19:05:04 <bcotton> #info Fedora 31 Beta is go and will release on 2019-09-17
19:05:26 <alciregi> .hello2
19:05:27 <zodbot> alciregi: alciregi 'Alessio Ciregia' <alciregi@gmail.com>
19:05:38 <bcotton> okay, let's run through the list
19:05:44 <bcotton> #topic Ambassadors & Advocates
19:06:34 <bcotton> anyone ambassadors or advocates around?
19:07:04 <bcotton> #topic Cloud WG
19:07:15 <bcotton> any cloud folks?
19:07:55 <bcotton> #topic Design
19:08:00 <bcotton> anyone from design?
19:08:49 <adamw> bueller
19:08:51 <adamw> bueller...
19:09:05 <bcotton> #topic Documentation
19:09:11 <bcotton> any docs-like persons?
19:09:38 <pbokoc> we're only starting to do stuff for the next release after beta so I'll just branch versioned repos and send out an instruction e-mail to our list to get people started
19:09:41 <bcotton> adamw: we may end up talking about voodoo economics
19:09:45 <bcotton> pbokoc++
19:09:46 <zodbot> bcotton: Karma for pbokoc changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
19:09:54 <adamw> it's just business
19:10:04 <pbokoc> I actually got some interest from people about writing relnotes so maybe this time we won't have to type everything up at the last minute :)
19:10:15 <bcotton> people ++
19:10:37 <bcotton> #info pbokoc is beginning the docs process for the F31 cycle
19:10:50 <mboddu> pbokoc: Thats great news
19:10:50 <bcotton> #info Contributors have expressed interest in writing release notes
19:10:50 <mhroncok> is https://fedoraproject.org/wiki/Common_F31_bugs considered documentation?
19:11:21 <bcotton> mhroncok: i would consider it documentation, but i think QA "owns" it
19:13:09 <bcotton> pbokoc, adamw, who should i #action to create the common bugs page?
19:13:19 <adamw> i usually do it
19:13:48 <adamw> it doesn't necessarily make a lot of sense that way, but hey it takes the heat off docs team and i have scripts :P
19:14:02 <bcotton> whatever works :-D
19:14:56 <bcotton> looks like that was "supposed" to happen on 2019-08-27, but it can happen now. i can add a reminder to remind you for future releases (or some other solution)
19:14:57 <bcotton> anyway
19:15:00 <lruzicka> if we want a common bugs page in the documentation space, I can do it
19:15:12 <bcotton> #action adamw to create common bugs page
19:15:42 <adamw> bcotton: in practice i usually do it shortly after go/no-go.
19:15:49 <adamw> dunno where the date in the schedule comes frm.
19:16:11 <bcotton> adamw: shrug.png. i'll update the schedule to match reality
19:16:14 <bcotton> anything else on docs?
19:16:24 <adamw> lruzicka: i don't see the problem with the wiki, really. we have templates and stuff for it too.
19:16:27 <pbokoc> Having common bugs on docs.fp.o instead of the wiki would be nice but I wouldn't treat it as a huge priority, right now we're linking there from the release notes table of contents
19:16:37 <pbokoc> ie https://docs.fedoraproject.org/en-US/fedora/f30/release-notes/
19:17:15 <lruzicka> adamw, pbokoc: yeah, as you wish :D
19:17:23 <adamw> pbokoc: well, please reinvent https://fedoraproject.org/wiki/Template:Common_bugs_update_testing and the other templates and https://pagure.io/fedora-qa/qa-misc/blob/master/f/commonbugs-update before you move it...:P
19:18:02 <pbokoc> jeez :)
19:18:41 * Southern_Gentlem Southern_Gentlem create updated commonbugs link for #fedora
19:20:03 <bcotton> #action Southern_Gentlemto create updated commonbugs link for #fedora IRC channel
19:20:08 <bcotton> #undo
19:20:08 <zodbot> Removing item from minutes: ACTION by bcotton at 19:20:03 : Southern_Gentlemto create updated commonbugs link for #fedora IRC channel
19:20:13 <bcotton> #action Southern_Gentlem to create updated commonbugs link for #fedora IRC channel
19:20:18 <bcotton> #topic Fedora Project Leader
19:20:27 <bcotton> is our beloved mattdm here?
19:21:16 <bcotton> well i can assure you all that he is totally ready
19:21:21 <bcotton> #topic FESCo
19:21:42 <mhroncok> I'm ready
19:22:05 <mboddu> I think mattdm is in a meeting, he is not at his desk
19:22:06 <mhroncok> also not aware of anything FESCo is supposed to do :D
19:22:31 <mhroncok> nirik: ?
19:22:44 <bcotton> .fesco 2125
19:22:46 <zodbot> bcotton: Issue #2125: F31 System-Wide Change: Set skip_if_unavailable default to false - fesco - Pagure.io - https://pagure.io/fesco/issue/2125
19:22:54 <bcotton> is that still under discussion?
19:23:28 <mhroncok> bcotton: it's 6 days and only +2
19:24:07 <mhroncok> if we get another +1, it shall be reverted, but considering the beta go, it wont be reverted for beta
19:24:49 <adamw> i think beta is ok with the new default
19:24:53 <adamw> but i do agree it should be reverted
19:25:24 <sgallagh> mhroncok: My reading of kalev ‘s reply is that he’s in favor of reverting too
19:25:35 <bcotton> #info FESCo ticket #2125 is still outstanding and may result in reverting the "Set skip_if_unavailable default to false" change
19:25:45 <bcotton> #link https://pagure.io/fesco/issue/2125
19:25:56 <bcotton> #undo
19:25:56 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7f938eaf31d0>
19:25:58 <bcotton> #undo
19:25:58 <zodbot> Removing item from minutes: INFO by bcotton at 19:25:35 : FESCo ticket #2125 is still outstanding and may result in reverting the "Set skip_if_unavailable default to false" change
19:26:00 <mhroncok> sgallagh: kalev votes?
19:26:04 <bcotton> #info FESCo ticket #2125 is still outstanding and may result in reverting the "Set skip_if_unavailable default to false" change for F31 final
19:26:08 <bcotton> #link https://pagure.io/fesco/issue/2125
19:26:18 <sgallagh> Oh, right. He’s not currently serving, is he?
19:26:25 <nirik> sorry, was sidetracked
19:26:26 <nirik> can read up
19:26:33 <mhroncok> sgallagh: he's not
19:26:45 <sgallagh> Oops
19:27:05 <nirik> yeah, I don't think we want to hold the beta for this...
19:27:11 <sgallagh> nirik: Mind voting to revert? QA is strongly in favor of doing so.
19:27:20 <sgallagh> But yeah, not worth blocking on.
19:27:35 <bcotton> okay, i'll leave this to fesco to sort out and we'll move on to...
19:27:46 <bcotton> #topic Infrastructure
19:28:11 <nirik> All ready to mirror and distribute bits. ;)
19:28:20 <nirik> no issues I am aware of
19:28:48 <bcotton> #info infra is ready for bits
19:29:00 <bcotton> any questions for infra?
19:29:46 <bcotton> #topic Marketing
19:30:06 <bcotton> i'm pretty sure there's going to be no updates here
19:30:24 <bcotton> #info We have not produced talking points for F31 Beta. Let's see if anyone notices
19:31:15 <bcotton> #topic Mindshare
19:31:25 <bcotton> anyone from mindshare?
19:31:33 <bcotton> mind...sharing an update?
19:31:36 * bcotton is very funny
19:32:08 <mhroncok> bcotton: how long have you had that prepared?
19:32:17 <mboddu> Haha :D
19:32:31 <bcotton> mhroncok: it just came to me, actually. i'm ashamed it took me this long to think of it
19:33:15 <bcotton> #topic QA
19:33:24 <adamw> ahoy
19:34:05 <adamw> we just need to write common bugs, nothing else really necessary.
19:34:25 <bcotton> bugs? what bugs?
19:35:26 <bcotton> anythign else for QA?
19:35:49 <bcotton> #topic Release Engineering
19:36:01 <mboddu> Hola
19:36:14 <mboddu> SHIPPPPPPPP ITTTTTTTTTT
19:36:31 <bcotton> mboddu++
19:36:58 <bcotton> mboddu: out of curiosity, how are we looking for non-blocking deliverables?
19:37:12 <mboddu> bcotton: There are some labs that failed
19:38:03 <mboddu> bcotton: https://pagure.io/releng/failed-composes/issue/149 lists the failed non-blocking artifacts
19:38:33 <bcotton> #info Some non-blocking artifacts failed in the RC1 compose
19:38:35 <bcotton> #link https://pagure.io/releng/failed-composes/issue/149
19:38:37 <bcotton> thanks, mboddu!
19:39:14 <bcotton> #topic Server WG
19:40:12 <bcotton> #topic Spins
19:40:19 <bcotton> i guess we kind of covered this in releng already
19:40:51 <bcotton> #topic Translations
19:41:21 <bcotton> the l10n is starting weekly meetings https://lists.fedoraproject.org/archives/list/trans@lists.fedoraproject.org/thread/2ND7WSRLKHJBT7DJQ3HO62YB7Z2IWMJB/
19:41:32 <bcotton> #info the l10n team is starting weekly meetings
19:41:34 <bcotton> #link https://lists.fedoraproject.org/archives/list/trans@lists.fedoraproject.org/thread/2ND7WSRLKHJBT7DJQ3HO62YB7Z2IWMJB/
19:41:38 <bcotton> i love repeating myself
19:41:51 <bcotton> #topic Websites
19:41:56 <bcotton> anything on websites?
19:42:44 <nirik> I think relrod was going to try and have beta ready...
19:42:49 <nirik> but I don't know the current status
19:43:33 <bcotton> i'll give relrod a moment to see if he notices us talking about him
19:43:43 <relrod> I'm here, but...
19:44:23 <relrod> nirik: I've been told my mgmt to hold for now on working on that, so not really sure what to say/update here
19:44:27 <relrod> s/my/by/
19:44:52 <bcotton> relrod: but the current website will work come tuesday morning?
19:45:00 <bcotton> relrod: this is the rework, yeah?
19:45:27 <relrod> bcotton: Let me send an email and figure some things out...
19:45:37 <bcotton> relrod: that's not encouraging :-D
19:47:39 <bcotton> okay, well i guess we'll find out
19:47:47 <bcotton> #topic Workstation
19:48:39 <bcotton> #info Workstation Live image is over the size limit. Workstation WG is going to determine if the limit is still appropriate
19:49:17 <bcotton> any other workstation-like comments?
19:50:10 <bcotton> Anyone else that I didn't have on my list that wants to give a readiness update?
19:50:38 <mhroncok> well, clearly nobody's ready
19:50:48 <mhroncok> so what happens now? :D
19:50:58 <bcotton> we ignore it and move on?
19:51:10 <bcotton> #topic Open floor
19:51:24 <bcotton> which leads me to my comment that I'm not sure this meeting provides much in the way of value
19:51:50 <nirik> yeah...
19:51:59 <bcotton> i've been thinking about a change that would potentially make this more useful
19:52:06 <nirik> but is it good to find out when things aren't ready in some areas...
19:52:17 <bcotton> where people would start reporting readiness sooner and asynchronously
19:52:20 <nirik> ie, websites. Good to scramble now rather than tuesday morning
19:52:28 <bcotton> i'd produce a dashboard like: https://bcotton.fedorapeople.org/release_readiness/report.html
19:52:38 <bcotton> then we could start fixing things more than 5 days in advance
19:52:53 <bcotton> and this meeting would become a shorter coordination if there are still big problems outstanding
19:52:56 <nirik> +100
19:53:36 <bcotton> we still might not get people to contribute updates, but it avoids the time waste of me copy/pasting 10 topics before we get to someone who has things to say
19:53:46 <bcotton> and people who are ready don't have to say anything at all
19:54:02 <alciregi> bcotton, the dashboard is a good idea
19:54:24 <bcotton> i meant to like have full ideas about this by now, but i got distracted. i'm going to try to write something up soon and maybe we can do this for f31 final. if not, then definitely for f32
19:55:04 <bcotton> but i'm open to suggestions on what a more useful release readiness meeting would look like. feel free to email me or stop by the fpgm office hours on wednesdays in this very channel
19:55:14 <bcotton> or use one of the other dozen ways to get in touch with me :-)
19:56:10 <bcotton> anything else before we close this out?
19:57:51 <bcotton> okay
19:58:02 <bcotton> thanks for coming, everyone! enjoy F31 Beta
19:58:09 <bcotton> #endmeeting