14:00:02 <bcotton> #startmeeting Council (2019-09-18)
14:00:02 <zodbot> Meeting started Wed Sep 18 14:00:02 2019 UTC.
14:00:02 <zodbot> This meeting is logged and archived in a public location.
14:00:02 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:02 <zodbot> The meeting name has been set to 'council_(2019-09-18)'
14:00:03 <bcotton> #meetingname council
14:00:03 <zodbot> The meeting name has been set to 'council'
14:00:08 <mattdm_> Good morning!
14:00:14 <bcotton> mattdm_: hellooo
14:00:21 <mattdm_> ugh why am i underscored?
14:00:23 <bcotton> #chair jonatoni bexelbie contyk dgilmore dperpeet langdon mattdm sumantrom tyll bcotton pbrobinson asamalik
14:00:23 <zodbot> Current chairs: asamalik bcotton bexelbie contyk dgilmore dperpeet jonatoni langdon mattdm pbrobinson sumantrom tyll
14:00:29 <bcotton> mattdm_: because you're so important
14:00:40 <dgilmore> hola
14:00:43 <bcotton> #chair mattdm_
14:00:43 <zodbot> Current chairs: asamalik bcotton bexelbie contyk dgilmore dperpeet jonatoni langdon mattdm mattdm_ pbrobinson sumantrom tyll
14:00:45 <mattdm_> "Cannot change nickname while banned/quieted on channel"
14:00:49 <bcotton> morning, dgilmore
14:00:51 <jonatoni> .hello2
14:00:52 <zodbot> jonatoni: jonatoni 'Jona Azizaj' <jonaazizaj@gmail.com>
14:01:00 <bcotton> hi jonatoni
14:01:39 <langdon> .hello2
14:01:40 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
14:01:43 <mattdm> fixed
14:01:47 <bcotton> hi, langdon
14:01:48 <mattdm> irc sucks, y'all
14:02:05 <langdon> could the real mattdm please stand up?
14:02:15 <bcotton> i guess not
14:02:22 <mattdm> yes. yes i can
14:02:22 * langdon updating PR
14:02:23 <bcotton> #topic Introductions, Welcomes
14:02:27 <contyk> .hello psabata
14:02:28 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
14:02:30 <bcotton> we've already started this, but
14:02:42 <bcotton> good afternoon contyk
14:02:52 <contyk> good morning
14:02:54 <langdon> contyk: are you napping again?
14:03:08 <contyk> not yet
14:03:37 <contyk> those three minutes between the meetings didn't give me enough time
14:03:50 <langdon> contyk: ha.. you should try harder
14:03:53 <bcotton> contyk: i believe in you
14:04:03 <langdon> i should really try to move from the cafe to my desk.. but also haven't had time
14:04:13 <langdon> and the snacks are tempting
14:04:30 <bcotton> is bexelbie around?
14:05:43 <mattdm> maybe on pto?
14:05:49 <bcotton> is that allowed?
14:06:07 <bcotton> #topic Planning Hackfest 2019
14:06:08 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/267
14:06:25 <bcotton> mattdm: i assume we're blocked on bex finalizing dates with a venue?
14:06:26 <mattdm> I think the status here is "Waiting for Bex to narrow down exact dates and venue"
14:06:29 <mattdm> Yes.
14:06:32 <mattdm> Yes, that.
14:06:32 <asamalik> .hello2
14:06:33 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
14:06:59 <mattdm> But everyone should plan to be in Prague around the week of November 18th
14:07:05 <bcotton> #info Blocked on bex finalizing exact dates and venue
14:07:11 <mattdm> Possibly the 11th if there's trouble with the location-finding
14:07:12 <contyk> absolutely everyone
14:07:28 <mattdm> Everyone on the council.
14:07:32 <mattdm> Not necessarily in the universe.
14:07:37 <langdon> mattdm: well.. the expensive, least flexible part, is the flights.. so i can "plan" all you want but what does that mean?
14:08:05 <bcotton> langdon: fly to prague for two weeks so you'll be ready whenever
14:08:14 <mattdm> don't, like, book other things?
14:08:19 <langdon> bcotton: hey.. if somoene else is paying.. im happy to :)
14:08:26 * dgilmore has been wondering what dates
14:08:37 <langdon> mattdm: ok.. if that's all.. i don't have anywhere else to go anyway :)
14:08:39 <bcotton> but in seriousness, oil prices are on an upward trend, so i'll lean on bex to get this set so we can let people start buying tickets
14:08:57 <mattdm> bcotton++
14:09:14 <bcotton> anything else we want to discuss here? i'm not sure there's much else to say at this point
14:09:18 <asamalik> we really need those electric planes
14:09:50 <langdon> i would prefer teleportation
14:10:25 <mattdm> yeah moving on :)
14:10:29 <asamalik> langdon: and maybe it would be even you on the other end :P
14:10:37 <contyk> hopefully not
14:10:38 <bcotton> #topic Close out current modularity objective. Consider and potentially approve next phase.
14:10:39 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/254
14:10:40 <bcotton> #link https://pagure.io/Fedora-Council/council-docs/pull-request/61
14:10:49 <bcotton> so langdon has updated the PR
14:11:11 <mattdm> as of ten minutes ago :)
14:11:20 <langdon> contyk: harsh
14:11:25 <bcotton> i wasn't going to throw him under the bus like that
14:11:31 <langdon> ha
14:11:46 <langdon> i had the content for like 2 weeks and just kept forgetting to put it in the PR..
14:11:58 <langdon> contyk: does that jive with what we talked about?
14:12:13 <mattdm> so, I haven't actually read it yet, and I'm going to blame it on that :)
14:12:19 <langdon> uh huh
14:12:35 <bcotton> speaking of two weeks, the next step is to give the community 2 weeks to discuss (assuming we treat it according to the policy change policy) and then vote on it
14:12:43 <mattdm> can you summarize what's new?
14:12:51 <bcotton> (see also: https://docs.fedoraproject.org/en-US/council/policy/policy-change-policy/)
14:13:33 <langdon> mattdm: whats new with what?
14:13:37 <mattdm> I think that's a good approach. Ben, maybe post to devel announce like a change, in this particular case?
14:13:45 <mattdm> langdon: what you updated in the PR?
14:13:55 <mattdm> I *did* read the previous version.
14:13:57 <dgilmore> langdon: what you plan to do new in the next 18 months
14:14:35 <langdon> ohh.. it is all the deliverables.. it *is* a summary so it would be me just retyping it here
14:15:29 <langdon> start at line 23: https://pagure.io/fork/langdon/Fedora-Council/council-docs/blob/2890194ffcdd790cc95ffc3716c882c5091ea76c/f/project/modules/ROOT/pages/objectives/objective-modularity-f30-f33.adoc
14:15:39 <langdon> to 48
14:15:57 <mattdm> ok :)
14:16:35 <mattdm> bcotton: want to post this to devel-announce, or should langdon do it?
14:16:46 <bcotton> langdon: one question i had in skimming this is do you have a plan for what will be accomplished at each of the hackfests (like a one-sentence version, not super detailed obviously) or are you just planning that you'll work on whatever's important at the time?
14:16:51 <bcotton> mattdm: i'll do it
14:17:15 <bcotton> i'm going to post it to commblog first, then share that to devel
14:17:33 <mattdm> bcotton++
14:18:18 <langdon> bcotton: it is more the latter.. and/or like planning for next phase.. so like at flock we worked out what we would do for f32/33 ..
14:18:32 <bcotton> okay, wfm
14:18:33 <langdon> actually .. now that you ask that.. i wonder if i could write in a general description
14:18:40 <langdon> and x-ref it
14:18:46 <langdon> let me try that
14:18:53 <bcotton> ok
14:18:57 * langdon couldn't think of a better way to handle it before
14:19:23 <mattdm> FWIW, I like the "let's finish this up and solve problems users are hitting" approach. It's good to focus on that some of the time and we don't do it enough.
14:19:33 <bcotton> #action bcotton to post proposal to CommBlog and devel list
14:19:57 <bcotton> are we #agreed that we'll start voting on 2 October?
14:20:10 <asamalik> yes this feels like it's going to solve all the major pain points people are complaining about
14:20:28 <bcotton> then we can find new things to complain about :-D
14:20:41 <asamalik> ursa prime being one of the biggest one for me
14:20:52 <asamalik> bcotton: that's called progress :D
14:21:04 <mattdm> yes. agreeed.
14:21:41 <bcotton> #agreed that we'll start voting on 2 October?
14:21:47 <contyk> +1
14:21:49 <bcotton> anything else on this topic?
14:22:53 <langdon> bcotton: does tihs do a good job of describing the hackfest? https://paste.fedoraproject.org/paste/81Cf34M~-Gw7hkLqFDnxfQ
14:22:58 <langdon> contyk: ^^
14:23:22 <contyk> wfm
14:23:24 <langdon> weird hard returns for the sake of adoc.. not lots of paragraphs
14:23:28 <bcotton> wfm
14:23:36 <bcotton> #topic EPEL module stream names policies
14:23:37 <bcotton> #link https://pagure.io/Fedora-Council/tickets/issue/272
14:24:00 <bcotton> so this was of questionable council relevance, but mattdm allegedly had opinions™ that he was trying to remember, so we punted it
14:24:54 <mattdm> Yeah, so, I talked to sgallagh
14:25:17 <mattdm> and I'm 95% sure that this request came in before we even had the idea that modules would have their own namespaces
14:25:46 <mattdm> My remaining concern is: remember, we'll be sharing dist-git with CentOS. So we need policy so that those things don't step on each other.
14:25:51 <mattdm> I don't care beyond that.
14:25:58 <mattdm> I can put this in the ticket :)
14:27:13 <mattdm> (did so. and closed.)
14:27:21 <bcotton> hooray!
14:27:38 <bcotton> #topic Open floor
14:27:51 <asamalik> I have something!
14:28:09 <mattdm> I have three things!
14:28:28 <mattdm> 1. Status dashboard -- getting people to do it
14:28:39 <mattdm> 2. Websites team, lack thereof
14:28:46 <asamalik> the Minimization Objective has been approved for the fist phase, ending at the end of September, so I believe I should somehow demonstrate progress, plan for the next phase, and get an approval for it?
14:29:03 <mattdm> 3. Consider acting replacement for Till
14:29:19 <mattdm> 0. Minimization Objective next steps :)
14:29:24 <asamalik> :)
14:29:51 <asamalik> not really what they are (at least not now), but rather when
14:29:51 <bcotton> wow, that's a lot of somethings
14:29:59 <bcotton> let's start with asamalik
14:30:06 <bcotton> #topic Minimization Objective next steps
14:32:17 <bcotton> so .... if i'm reading mattdm's mind correctly, we initially approved minimization on a short-term basis
14:32:23 <asamalik> I think I said all I needed to say myself
14:32:57 <bcotton> asamalik: ah yes, i lost it in mattdm's agenda dump :-)
14:33:00 <asamalik> so what about I have a proposal ready for the next meeting?
14:33:01 <mattdm> that seems to match my mind. because it was an exploratory thing. and that's not always been a successful approach :)
14:33:27 <bcotton> so yeah, i'd say what asamalik said is the right thing. basically as soon as it's ready i'll do the same thing i'm doing for modularity
14:33:31 <asamalik> mattdm: yep, it's been a mix of exploration, doing, and experimenting
14:33:43 <bcotton> (posting to places and then putting a vote on the calendar)
14:33:51 * langdon thinks he dropped a bunch of messages on the floor
14:34:10 <asamalik> bcotton: that makes sense
14:34:13 <bcotton> langdon: if you pick them up within 5 seconds they're still safe to read
14:34:20 <mattdm> The current objective says "Published blog posts (and maybe videos) about the process, about what is possible, and about our intentions. "
14:34:31 <bcotton> #info the Minimization Objective has been approved for the fist phase, ending at the end of September
14:34:54 <langdon> bcotton: i have kids.. 5 minutes
14:35:04 <bcotton> #action asamalik to draft an updated proposal that demonstrates progress and plans for the next phase
14:35:08 <asamalik> mattdm: yep, not many of those, but also things that have not been listed have been done
14:35:30 <asamalik> bcotton: +1 ack
14:35:30 <mattdm> So, maybe a blog post summarizing what did get achieved?
14:35:50 <mattdm> That would then also oroboros-style solve the problem of not having blog posts :)
14:36:06 <asamalik> yep, two or three are on the plan already :)
14:37:04 <asamalik> all right, I know what to do next and how we approach approving the next phase
14:37:14 <asamalik> that's basically what I wanted :)
14:37:17 <bcotton> awesome
14:37:36 <bcotton> okay next
14:37:47 <bcotton> #topic Status dashboard -- getting people to do it
14:37:48 <mattdm> Okay, so, yeah, 1) write the blog posts and 2) update future phases
14:37:58 <mattdm> bcotton, do you have a shame list?
14:38:11 * contyk is on it
14:38:12 <mattdm> #link https://docs.fedoraproject.org/en-US/project/dashboard/
14:38:27 <mattdm> "on it", like "i'm doing it now", or "on the shame list"?
14:38:34 <langdon> have there been any updates?
14:38:37 <bcotton> mattdm: not handy, but i can pull one together if you can stall for a moment
14:38:47 <contyk> on the shame list; I haven't updated it in two weeks as there wasn't much new
14:38:52 <mattdm> langdon: not from you! :)
14:39:11 <asamalik> I have stolen the Minimization part and I'm using it in our docs space: https://docs.fedoraproject.org/en-US/minimization/status/
14:39:17 <langdon> yeah.. i went and looked at it a couple weeks ago and couldn't find anyone else doing it for examples.. did it move?
14:39:23 <mattdm> asamalik: I have an anatora question. Do you know if there's some way to include a macro which expands to the commit date?
14:39:29 <asamalik> it's the same file
14:39:30 <mattdm> Or the build date? Or anything like that?
14:39:51 <bcotton> #info The following people have never updated: sumantrom (Mindshare), dperpeet (CI), pbrobinson (IoT)
14:39:54 <langdon> build date you definitely don't want
14:40:04 <mattdm> #link https://pagure.io/Fedora-Council/status_reports/blob/master/f/modules/dashboard/pages
14:40:04 <asamalik> mattdm: I don't think there is... but I see what you want here — an indicator of how outdated that info is, right?
14:40:11 <mattdm> asamalik: yes, exactly
14:40:31 <mattdm> Ideally with spiderwebs for very old information, but that's a nice to have. an automatic timestamp.
14:40:44 <mattdm> We can of course make that part of the manual template, but it's one of thoes things that's nice to have automatically
14:40:53 <mattdm> I can make an upstream request if nothing like that exists.
14:40:53 <bcotton> #info The following are more than a month old: Silverblue (tpopela)
14:41:06 <bcotton> the others are within the last month (although some just barely)
14:41:07 <asamalik> I was thinking about the very same thing... "write a date down and change it every time you update it" is probably not the ideal answer? (although it would work now!)
14:41:33 <mattdm> asamalik: are there general ways to include variables and high-level template information? Like, in the wiki, we have {{currentrelease} and that's used A LOT
14:41:34 <bcotton> asamalik: yeah, i added "update date: " to all the files yesterday to make mattdm happy, but a more automatic way would be nice
14:42:04 <asamalik> bcotton: oh you did! cool
14:42:23 <asamalik> mattdm: I believe so, yes, would have to check
14:42:25 <mattdm> None of the people who have never updated are here. except langdon :)
14:42:28 <bcotton> mattdm: did you want to discuss this beyond just #info ing a shame list?
14:42:29 <asamalik> mattdm: asking upstream would be ideal
14:42:46 <mattdm> bcotton: well, we need to figure out what to do if we can't get people to do the thing
14:42:54 <langdon> are there macros in general?
14:43:15 <mattdm> asamalik: let's take this somewhere else, but yeah, if there are general macros in some way can you point me to the docs for that? couldn't find it myself
14:43:16 <asamalik> langdon: the same answer, I believe so
14:43:19 <mattdm> (on antora site)
14:43:22 <bcotton> mattdm: better question: do you want to try to do that now or do you want to do it later and hit your other two agenda items?
14:43:41 <mattdm> bcotton: later i guess. but BE WARNED
14:44:29 <bcotton> mattdm: do you want to go to websites or till next?
14:44:32 <bcotton> i'm not sure we'll get to both
14:44:48 <asamalik> I'll explore that and ping mattdm
14:45:38 <mattdm> bcotton: I'll do websites in 1 minutes. Then the absent council member thing
14:45:42 <bcotton> ok
14:45:45 <bcotton> #topic Websites team (or lack thereof)
14:45:55 <dgilmore> :(
14:46:01 <dgilmore> makes me sad
14:46:14 <mattdm> Here's the short version: Since robyduck got a new job (good for robyduck!) there hasn't been much of a websites team.
14:46:27 <dgilmore> it is good for robyduck
14:46:31 <dgilmore> robyduck++
14:46:31 <zodbot> dgilmore: Karma for robyduck changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:46:47 <mattdm> CPE (Formerly Fedora Infrastructure) picked up the slack, but this timing has coincided with that team re-focusing their mission much more narrowly
14:46:52 <mattdm> and explicitly excluding websites
14:47:19 <mattdm> I understand the reasons for this but it's left us in a bad place.
14:47:35 <mattdm> For example, the spins and labs pages were not updated for the beta release
14:47:54 <mattdm> And the parts that were updated were done by stickster which is definitely not part of *his* job
14:48:21 <mattdm> So we need to figure out how to rebuild that team, and help to do so is not coming from Red Hat, at least in the near term.
14:48:39 <mattdm> Okay that's my minute. More happening on that outside the meeting.
14:49:05 <mattdm> #link https://docs.fedoraproject.org/en-US/websites/
14:49:07 <langdon> mattdm: like you have other avenues in pursuit? or things that others could participate in?
14:49:11 <mattdm> ^ docs for what's needed to get started
14:49:17 <asamalik> which reminds me that I promised to do search for the Docs and haven't got time to do so yet, which I'm sorry for... :(
14:49:28 <mattdm> langdon: I'm talking to OSPO
14:49:37 <langdon> gotcha..
14:49:44 <mattdm> If you have any university-connection ideas I'd love to hear them
14:49:58 <langdon> just a related q.. do we have enough time/help from the design team? or are we strapped there for websites too?
14:50:06 <langdon> mattdm: i may.. thats why im asking
14:50:19 <mattdm> _somewhat_ better
14:50:23 <mattdm> (design, I mean)
14:50:50 <langdon> ok... im more likely to find a html/js/css code slinger than a visual designer.. thats why i ask
14:51:18 <mattdm> Needs to work with the Flask framework, too.
14:51:43 <mattdm> Some design skills useful, but we basically need someone to be able to do basic updates to the structure and content as needed
14:51:48 <langdon> thats easy though
14:51:52 <mattdm> not generate content, but know how to put it in place
14:51:54 <langdon> flask i meant...
14:52:07 <mattdm> it is easy, but we don't have anyone who owns it
14:52:13 <mattdm> and there's of course potential to do more.
14:52:20 <asamalik> I think I saw an email about someone looking for student projects... let me dig it up, because that might be one way forward
14:52:30 <asamalik> I think it was docs-related, but maybe they can stretch it a bit
14:52:48 <mattdm> Concrete example: now we have an iot edition. The site needs to be updated to reflect that.
14:53:29 <asamalik> can we have easyfix issues on github and have people do that as part of the hacktoberfest?
14:53:50 <bcotton> asamalik: no because it's not on github :-)
14:54:05 <bcotton> also, i think it's more that we need a consistent owner rather than one-off tasks
14:54:07 <bcotton> but
14:54:12 <asamalik> can we move it/mirror it there?
14:54:14 <bcotton> what's the #action here?
14:54:40 <mattdm> none currently. wanted to escalate awareness.
14:54:46 <bcotton> ok
14:54:54 <asamalik> maybe someone falls in love with that :) but yeah I know what you mean, just trying to find ideas
14:54:58 <bcotton> in our last 5 minutes let's hit mattdm's last topic
14:55:08 <bcotton> #topic Consider acting replacement for absent Council member
14:55:39 <mattdm> So, Till has a medical situation which prevents him from really using computers.
14:55:51 <mattdm> It's been a long road to recovery. :(
14:56:10 <mattdm> So for one thing sending him good wishes for that would be nice.
14:56:20 <langdon> yeah.. no lie.. that sucks
14:56:36 <langdon> fedora should send a fruit basket
14:56:40 <asamalik> I'm really sorry to hear that
14:56:43 <mattdm> But also, since the council is intentionally small, having one of our community representatives not able to participate is not good
14:57:07 <mattdm> langdon: that's not a bad idea.
14:57:26 <mattdm> But we should consider a policy for appointing a temporary replacement.
14:57:53 <bcotton> so there were no other candidates when till was elected last time
14:57:54 <mattdm> Either open the seat in the next election or council tap someone
14:58:02 <contyk> I was just going to ask
14:58:17 <mattdm> Also, when we have so few candidates typically, picking the runner up isn't necessarily the right thing to do
14:58:20 <bcotton> i'd say the council should appoint someone, either on an interim basis or to fill his seat until the next cycle
14:58:44 <bcotton> i'd rather not wait until january to fill the seat
14:58:50 <langdon> should till be involved in who is "tapped"?
14:59:12 <mattdm> langdon: sure, that makes sense
14:59:19 <contyk> I think bookwar told me she was going to run next time
14:59:26 <contyk> so maybe it wouldn't hurt asking her
14:59:35 <mattdm> contyk: thanks!
14:59:47 <mattdm> #action mattdm to talk to till about this
14:59:56 <mattdm> also possibly bookwar
15:00:06 <mattdm> and now we're at time
15:00:32 <bcotton> don't need to answer now, but if we get bookwar to do it, would we ask her to give up her fesco seat? something to think about
15:00:51 <langdon> i would say "no" as it is appointed
15:00:51 <bcotton> anyway, yes, it is now the top of the hour
15:00:59 <langdon> if she ran in the next cycle, yes
15:01:02 <mattdm> yeah I gotta go. thanks everyone!
15:01:03 <bcotton> no it's not, it's the elected sit filled by appointment
15:01:11 <bcotton> #endmeeting