16:00:07 <mhroncok> #startmeeting fpc
16:00:07 <zodbot> Meeting started Thu Sep 26 16:00:07 2019 UTC.
16:00:07 <zodbot> This meeting is logged and archived in a public location.
16:00:07 <zodbot> The chair is mhroncok. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:07 <zodbot> The meeting name has been set to 'fpc'
16:00:07 <mhroncok> #meetingname fpc
16:00:07 <mhroncok> #topic Roll Call
16:00:07 <zodbot> The meeting name has been set to 'fpc'
16:00:07 <mhroncok> /msg limburgher FPC: /join #fedora-meeting-1
16:00:07 <mhroncok> /msg mbooth,orionp FPC: /join #fedora-meeting-1
16:00:08 <mhroncok> /msg SmootherFr0gZ,tibbs FPC: /join #fedora-meeting-1
16:00:08 <mhroncok> /msg decathorpe,mhroncok FPC: /join #fedora-meeting-1
16:00:09 <mhroncok> /msg ignatenkobrain,geppetto FPC: /join #fedora-meeting-1
16:00:39 <mhroncok> .hello churchyard
16:00:40 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
16:01:34 <decathorpe> .hello2
16:01:35 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
16:01:41 <decathorpe> I'm here!
16:01:42 <mhroncok> #chair decathorpe
16:01:42 <zodbot> Current chairs: decathorpe mhroncok
16:01:46 <mhroncok> decathorpe: hi
16:01:51 <ignatenkobrain> .hello2
16:01:52 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Gnatenko' <i.gnatenko.brain@gmail.com>
16:01:59 <mhroncok> #chair ignatenkobrain
16:01:59 <zodbot> Current chairs: decathorpe ignatenkobrain mhroncok
16:02:13 <mhroncok> ignatenkobrain: o/
16:03:12 <ignatenkobrain> mhroncok: \o/
16:03:21 <tibbs> Hey.
16:03:44 <mhroncok> #chair tibbs
16:03:44 <zodbot> Current chairs: decathorpe ignatenkobrain mhroncok tibbs
16:03:45 <mhroncok> hi
16:04:10 <ignatenkobrain> I might disappear at some point if my wife is going to go giving a birth 🙂
16:04:26 <mhroncok> ignatenkobrain: that's a big if
16:04:40 <decathorpe> oh wow. congratulations ;)
16:04:59 <jlebon> ignatenkobrain: woah, congrats! :)
16:05:38 <mhroncok> ignatenkobrain: I don't think we'll have quorum anyway
16:06:14 <mhroncok> should I go trough the topics anyway or jump to open floor?
16:06:30 <decathorpe> mhroncok: btw, your direct "FPC MEETING NOW" messages were malformed
16:06:37 <mhroncok> decathorpe: how?
16:06:54 <decathorpe> they didn't register as correct IRC commands I guess
16:07:08 <mhroncok> they were just posted here?
16:07:11 <decathorpe> "/msg SmootherFr0gZ,tibbs FPC: /join #fedora-meeting-1" I got this
16:07:24 <decathorpe> "/msg decathorpe,mhroncok FPC: /join #fedora-meeting-1" and this
16:08:06 <ignatenkobrain> I think I did not receive this one
16:08:18 <mhroncok> ok, will try differently next time
16:08:23 <mhroncok> anyway
16:08:28 * decathorpe shrugs
16:08:35 <mhroncok> #topic Open Floor
16:08:52 <mhroncok> there is no quorum. ignatenkobrain might run... let's call it a day
16:08:56 <mhroncok> one think
16:08:59 <mhroncok> *thing
16:09:30 <mhroncok> #info SELinux people approached me to ask what they can do to move https://pagure.io/packaging-committee/pull-request/814 forward
16:10:02 <mhroncok> if you are able to review the latest changes, please do (I wasn't yet)
16:10:11 <mhroncok> anyone has anything else to say?
16:10:41 <ignatenkobrain> I'll try to check it again. Last time I have checked, it was too much of useleess info there
16:11:16 <tibbs> Yes, that's always been the problem with that document.
16:11:22 <decathorpe> yeah I think there's a lot in there that has nothing to do with packaging ...
16:11:54 <tibbs> And unless they have figured out why that's bad, this simply isn't going to move forward unless we take the pieces we want and turn that into a guideline.
16:12:23 <decathorpe> ideally it should be split into two documents - one "how to package an selinux module" and "how to create a custom selinux module" (or something like that)
16:13:03 <tibbs> That's basically what I said when the document was first presented to us.
16:14:15 <mhroncok> OK, I'll try to communicate that to their request
16:14:21 <decathorpe> +1
16:15:49 <mhroncok> I'll end in 2
16:16:24 <limburgher> Geez, I got called away. Congrats ignatenkobrain!
16:17:08 <mhroncok> #chair limburgher
16:17:08 <zodbot> Current chairs: decathorpe ignatenkobrain limburgher mhroncok tibbs
16:17:37 <mhroncok> so... ignatenkobrain, are you still with us?
16:17:51 <ignatenkobrain> I am :)
16:18:02 <mhroncok> we have a quorum
16:18:11 <mhroncok> #topic Schedule
16:18:17 <mhroncok> #link https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/NFH4A6XZLFQCL7XGYJJSZF3HZ5TU4E42/
16:18:25 <mhroncok> #topic #902 Cleanup & enhance spec files
16:18:25 <mhroncok> .fpc 902
16:18:25 <mhroncok> https://pagure.io/packaging-committee/issue/902
16:18:26 <zodbot> mhroncok: Issue #902: Cleanup & ehnance spec files - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/902
16:18:49 <mhroncok> this is tagged with meeting
16:19:01 <mhroncok> but I'm not sure there's anything to discuss
16:19:14 <ignatenkobrain> I guess we should remove tag and do it :)
16:19:21 <mhroncok> 2 months ago: Propose guideline changes we can vote on...
16:19:43 <mhroncok> removing the meeting tag
16:19:58 <mhroncok> anybody has something for this ticket?
16:20:14 <decathorpe> yeah, I think we agreed that we need actual proposals for Guideline changes
16:20:33 <decathorpe> otherwise these are only stylistic preferences
16:20:38 <tibbs> I don't even agree with #3 in their list.
16:21:01 <tibbs> #2 is absolutely correct because the compression can change and I though this was already mentioned somewhere.
16:21:17 <tibbs> Haven't really tried to understand #1.
16:21:31 <decathorpe> it is: https://docs.fedoraproject.org/en-US/packaging-guidelines/#_manpages
16:22:30 <mhroncok> proposal: we close this, there has been no response in 2 months
16:22:44 <tibbs> The last sentence could use a tweak to use SHOULD/MUST language (as is the case with a bunch of stuff that existed from the old days) but otherwise, yes, they should feel free to go ahead with #2.
16:23:15 <decathorpe> +1, I'm on board with that
16:23:48 <decathorpe> (to clarify: say #2 is good, and close the ticket)
16:24:28 <tibbs> Doesn't hurt to keep it open to discuss the other stuff, I guess.
16:24:38 <mhroncok> there is no discussion
16:25:00 <ignatenkobrain> myself I like all 3 suggestions
16:25:08 <mhroncok> but I don't mind keeping it open
16:25:37 <tibbs> I strongly disagree with any prohibition on marking things as %doc just because there is RPM magic to mark them as %doc automatically.
16:26:14 <tibbs> I don't personally know the list of directories which get magically marked as %doc, and wouldn't expect most packagers to know, either.
16:26:48 <tibbs> But maybe I'm missing something.
16:27:55 <mhroncok> I slightly disagree with prohibition of being more explicit
16:28:31 <mhroncok> I wouldn't mind if the guidelines say that man pages are automatically maked as doc and the packagers don't need to mark them as such
16:28:48 <tibbs> Nor would I.
16:29:11 <tibbs> But this ticket was about bulk changing every package, and I just don't see the utility in doing that.
16:29:33 <decathorpe> mhroncok: yes, we should definitely document that somewhere
16:30:04 <mhroncok> #info We should document that man pages are automatically marked as %doc and the packagers don't need to mark them as such
16:30:36 <mhroncok> move to the next? I don't think it's worth staying on this...
16:31:24 <mhroncok> #topic #904 Caret versioning
16:31:25 <mhroncok> .fpc 904
16:31:25 <mhroncok> https://pagure.io/packaging-committee/issue/904
16:31:26 <zodbot> mhroncok: Issue #904: Caret versioning - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/904
16:31:40 <mhroncok> this waits for F31. anything to discuss?
16:31:44 <tibbs> I think this is back on me.
16:32:14 <tibbs> Kind of lost the will to work on it for a while after the pointless nitpicky arguments.  I should just ignore them, I guess.
16:34:46 <mhroncok> so I guess https://pagure.io/packaging-committee/pull-request/908 needs a rebase and review?
16:35:15 <tibbs> Yes, and further work by me.
16:35:50 <mhroncok> #topic #907 Which %__foo macros for executables are acceptable?
16:35:50 <mhroncok> .fpc 907
16:35:50 <mhroncok> https://pagure.io/packaging-committee/issue/907
16:35:51 <zodbot> mhroncok: Issue #907: Which %__foo macros for executables are acceptable? - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/907
16:36:29 <mhroncok> there is a PR in python-rpm-macros -> https://src.fedoraproject.org/rpms/python-rpm-macros/pull-request/27 with an open question
16:36:36 <tibbs> I think it useful to stop referring to %__* macros in the guidelines, at least.
16:36:47 <mhroncok> where it is possible
16:38:15 <mhroncok> #info we should revisit our use of %__* macros in the guidelines, at least (possibly removing it where appropriate)
16:38:35 <tibbs> I think it would still be good to see what Panu has to say about the python question, but he's busy and it's often tough to get his attention.
16:39:09 <mhroncok> OK, I'll try to get panu on borad
16:39:13 <tibbs> I thiink the open question is whether we want redefinition of, say, %python3 to change the definition of %__python3.
16:39:42 <mhroncok> that's it
16:39:43 <ignatenkobrain> I think %python3 should be %python3 %__python3
16:40:11 <tibbs> I agree.
16:40:22 <mhroncok> so the idea in the PR is that if people have old specfiles that redefine %__python3, it still works
16:40:51 <mhroncok> but if they opt-in for the new macros, %python3, they don't need to worry about %__python3 at all
16:41:51 <mhroncok> but I guess the question is, what will be used internally in %python3_version etc. %python3 or %__python3
16:42:22 <tibbs> Working on a PR to clarify the manpage language.
16:42:45 <mhroncok> I wonder whether it is possible to have maco aliases
16:42:50 <mhroncok> *macro
16:42:53 <mhroncok> I guess it is not
16:42:54 <tibbs> mhroncok: If they use the new, non "__" macros then they don't have to worry about the internal macros _unless_ they want to redefine something.
16:43:17 <tibbs> If they do, then they can change the internal macro and see a redefinition of all of the macros which derive from it.
16:43:31 <tibbs> That's kind of the point of the internal macros.
16:44:00 <mhroncok> it seems that really knows what is the point of the internal macros :D
16:44:22 <mhroncok> if the point is: redefine me to change everything else, they should not be marked as internal, as they are part of the API
16:44:57 <mhroncok> or the idea is: use %python3, %python3_version and %python3_sitearch to GET information, redefine %__pytohn3 to SET information?
16:45:17 <mhroncok> because that kinda makes sense (at least it is consistent)
16:45:24 <decathorpe> yeah that sounds good
16:45:40 <tibbs> Yes, I think that sums up Panu's comment on 907.
16:46:45 <mhroncok> Ok
16:47:36 <mhroncok> #action mhroncok to update the https://src.fedoraproject.org/rpms/python-rpm-macros/pull-request/27 in a line of what was said on this meeting (tl;dr use %python3, %python3_version, %python3_sitearch... to GET information, redefine %__python3 to SET information)
16:47:50 <mhroncok> #topic #909 Suggest that linting/measuring-coverage is not for %check
16:47:50 <mhroncok> .fpc 909
16:47:50 <mhroncok> https://pagure.io/packaging-committee/issue/909
16:47:51 <zodbot> mhroncok: Issue #909: Suggest that linting code and measuring coverage is not %check's business - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/909
16:48:39 <mhroncok> so we already tried to vote on something in there
16:48:59 <decathorpe> https://pagure.io/packaging-committee/issue/909#comment-584794
16:49:10 <mhroncok> thanks
16:49:10 <decathorpe> you can have my +1 for that as well
16:49:45 <ignatenkobrain> +1 from me
16:49:50 <limburgher> You already have mine.
16:49:59 <mhroncok> do I see +5?
16:50:18 <mhroncok> I do
16:50:36 <mhroncok> #agreed https://pagure.io/packaging-committee/issue/909#comment-584794 (+5,0,-0)
16:50:53 <mhroncok> #topic #914 Automatic R runtime dependencies
16:50:53 <mhroncok> .fpc 914
16:50:53 <mhroncok> https://pagure.io/packaging-committee/issue/914
16:50:54 <zodbot> mhroncok: Issue #914: F31 System-wide Change: Automatic R runtime dependencies - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/914
16:51:23 <ignatenkobrain> I am pretty sure we've talked about this not so long time ago
16:51:25 <tibbs> So the last comment there somewhat moots some of the questions.
16:51:43 <mhroncok> ignatenkobrain: we did
16:51:51 <ignatenkobrain> and IIRC we've agreed to wait for Legal and leave this to FESCo
16:52:05 <ignatenkobrain> but my memory might be wrong
16:52:05 <mhroncok> I recall the same thing
16:52:18 <limburgher> Same.
16:52:19 <tibbs> Yes, but the last comment....
16:52:44 <tibbs> Basically, filtering the extra Suggests is possible and easy, and sidesteps the legal issues.
16:52:52 <mhroncok> https://pagure.io/packaging-committee/issue/914#comment-588089
16:53:01 <tibbs> At least according to the comment; I don't know how easy it actually is.
16:53:21 <mhroncok> so to sum it up: https://pagure.io/packaging-committee/issue/914#comment-588089 till stands, but filtering the extra Suggests workarounds it
16:53:25 <tibbs> But if it doesn't result in Requires, Recommends or Suggests outside of the package set, then great, I'm all for it.
16:53:25 <limburgher> I'd like to see an example, that can be included in Guidelines. And the answer from legal.
16:53:26 <mhroncok> *still
16:53:58 <tibbs> I'd like to see the answer from FESCo/Legal as well, but if this ticket doesn't depend on it then great.
16:54:15 <tibbs> I think in general we're all for automatic generation of dependencies wherever possible.
16:55:57 <mhroncok> I guess qulogic would like to know, assuming legal and fesco would ack dangling suggests, whether the FPC would
16:57:04 <mhroncok> but I'd rather not waste our time on a hypothetical problem
16:57:24 <tibbs> I don't think there's even a question.  If FESCo says they're OK, then they're OK (and we make changes to the guidelines to indicate that).
16:58:07 <mhroncok> ack
16:58:09 <mhroncok> works for me
16:58:37 <mhroncok> #info We'd like to see an example about filtering the extra suggest, so we can document it
16:59:10 <mhroncok> #info FPC has no problem with dangling suggests as long as approved by legal and FESCo
16:59:12 <limburgher> I have to go, need anything from me in the next 60 seconds?
16:59:19 <mhroncok> limburgher: not really, about to end
16:59:32 <mhroncok> next item on scheule is the selinux PR and we've already covered that
16:59:41 <mhroncok> #topic Open Floor
16:59:54 <mhroncok> 15 seconds to 1 hour
17:00:01 <mhroncok> or 5
17:00:12 <decathorpe> I got nothing :) I'll look at the %ghost and %verify stuff though
17:00:14 <ignatenkobrain> nope
17:00:19 <tibbs> Nothing from me.
17:00:39 <mhroncok> ok, thanks everybody for being here
17:00:48 <mhroncok> ignatenkobrain: good luck with your offspring
17:00:59 <mhroncok> #endmeeting