16:06:24 <cipherboy> #startmeeting Stewardship SIG Meeting (2020-03-03)
16:06:24 <zodbot> Meeting started Tue Mar  3 16:06:24 2020 UTC.
16:06:24 <zodbot> This meeting is logged and archived in a public location.
16:06:24 <zodbot> The chair is cipherboy. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:24 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:06:24 <zodbot> The meeting name has been set to 'stewardship_sig_meeting_(2020-03-03)'
16:06:32 <cipherboy> #meetingname stewardship-sig
16:06:32 <zodbot> The meeting name has been set to 'stewardship-sig'
16:06:39 <decathorpe> hello!
16:06:43 <cipherboy> #chair decathorpe
16:06:43 <zodbot> Current chairs: cipherboy decathorpe
16:07:15 <cipherboy> decathorpe: sillebille_ is out this week, so it might just be the two of us unless someone else pops in.
16:07:44 <decathorpe> I think everybody else is busy
16:08:03 <cipherboy> Sounds good. Quick meeting so I learn the meeting ropes. :)
16:08:50 <decathorpe> you might want to post a link to the agenda ticket for the IRC log
16:10:49 <cipherboy> #link https://pagure.io/stewardship-sig/issue/77 Meeting agenda for 2020-03-03
16:11:02 <cipherboy> Okay, so first topic:
16:11:20 <cipherboy> #topic Review Open RHBZ Bugs
16:11:31 <cipherboy> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&email1=stewardship-sig%40lists.fedoraproject.org&emailassigned_to1=1&emailcc1=1&emailtype1=substring&list_id=10281127&product=Fedora&query_format=advanced BZ Query
16:11:58 <decathorpe> I've been doing some cleanups. closing old bugs that were actually already fixed etc.
16:12:09 <decathorpe> there's only 41 bugs left now
16:12:17 <cipherboy> And no open CVEs, which is always good.
16:12:29 <cipherboy> Which means... package updates \o/
16:12:36 <decathorpe> yeah ...
16:12:44 <decathorpe> I mean, yay \o/
16:12:46 <cipherboy> :-)
16:13:20 <decathorpe> but I actually spent some time on those this weekend
16:13:53 <cipherboy> I saw, thanks! I'll review these this week. We've just cycled over on our sprint, so I'll make sure to schedule some time for us :)
16:14:07 <decathorpe> great :)
16:14:26 <cipherboy> #action cipherboy Review all of decathorpe's open PRs
16:14:30 <decathorpe> I think all package updates should be straightforward, except maybe log4j where I needed to rebase the patch
16:14:46 <cipherboy> #topic Review Open Pull Requests
16:14:54 <cipherboy> #link https://fedora-stewardship.github.io/pr-report/
16:15:06 <decathorpe> we now have duplicate PRs for maven-plugin-tools 3.6.0 ...
16:15:23 <cipherboy> Lemme close the first one.
16:15:28 <decathorpe> which is one update that's actually breaking things >:-)
16:15:31 <decathorpe> yeah ...
16:15:55 <cipherboy> I believe he wasn't going to update his non-modular PRs any more, so that made that decision easy :)
16:16:02 <decathorpe> yes
16:16:14 <decathorpe> though I'm wondering about what'll happen to Java packages now
16:16:36 <decathorpe> with default streams being "banned" and such
16:16:50 <cipherboy> I'm not sure either. I've not heard anything useful on my end.
16:17:19 <cipherboy> But we also never had Ursa {Major,Prime,Star,Circle,...} so default module streams were only ever hurting us thus far, not helping.
16:17:33 <cipherboy> And we can continue to... borrow content from non-default stream.
16:18:04 <decathorpe> "borrow"
16:18:10 <decathorpe> but yes
16:18:15 <cipherboy> :-)
16:18:37 <cipherboy> From my POV that means we continue doing what we've been doing until Modularity gets in gear.
16:18:50 <decathorpe> either that, or until it dies
16:19:18 <cipherboy> As you saw, the modularity effort was given to the DNF team. They've been scheduling new meetings so I'll be sitting in on those for IdM, PKI, and represent the SIG as well.
16:19:33 <decathorpe> oh, nice. that's good to know
16:19:55 <decathorpe> still I don't see anything productive happen before f34 or so
16:20:02 <cipherboy> Heh we'll see :-)
16:20:10 <decathorpe> We'll see.
16:21:23 <cipherboy> #action cipherboy Create package review requests for JBoss resteasy deps
16:21:36 <cipherboy> Not strictly PRs but they'll eventually have more PRs open :)
16:21:45 <cipherboy> So... next topic?
16:22:25 <decathorpe> yeah yeah
16:22:36 <cipherboy> #topic Review (SIG) Leaf Package Cleanup 12
16:22:45 <cipherboy> #link https://pagure.io/stewardship-sig/issue/76
16:23:19 <decathorpe> PS: I've optimized the SIG leaf checking script. it now runs ~30 minutes, and doesn't require user input anymore
16:23:33 <cipherboy> \o/ Whee! I'll try that next time we want to do a leaf check to make sure I know how to run it.
16:23:59 <cipherboy> If randomizedtesting isn't required, we can drop all of that. I think dropping randomizedtesting allows us to drop a few more packages next round.
16:24:15 <decathorpe> yeah I think so
16:24:29 <cipherboy> (I thought RT was required for e* but if we're dropping auto, ~shrugs~) :-)
16:24:48 <decathorpe> yeah me *shrugs* as well
16:25:09 <decathorpe> but the SIG leaf list looks good otherwise?
16:25:15 <cipherboy> Then I'll ACK it
16:25:24 <decathorpe> thanks
16:25:47 <decathorpe> less packages is always good ...
16:25:52 <decathorpe> *fewer
16:25:56 <decathorpe> arghs stupid language
16:26:35 <cipherboy> Agreed, English can be a stupid language at times. :P
16:27:07 <cipherboy> #topic Open Floor
16:27:42 <decathorpe> do you have feedback for the new site?
16:27:48 <decathorpe> I think it works quite well
16:27:58 <cipherboy> "It looks great and its better than what I could've done" :P
16:28:04 <decathorpe> heh
16:28:05 <decathorpe> thanks.
16:28:07 <cipherboy> "I'll try not to break it" :D
16:28:39 <decathorpe> if you want to make changes to Jekyll stuff, you can always propose a PR and let me have a look at it.
16:29:39 <cipherboy> That sounds good.
16:30:22 <cipherboy> Thanks!!
16:30:33 <cipherboy> decathorpe++ for awesome web design
16:30:39 <decathorpe> sure, no problem. it was fun to do something different for once :-)
16:30:50 <cipherboy> Awww no cookies :/
16:30:53 <decathorpe> "web design" → default Jekyll theme
16:31:06 <decathorpe> probably diabetes protection
16:31:19 <cipherboy> :P
16:31:25 <decathorpe> only one cookie per (donor / acceptor) pair per release
16:31:34 <cipherboy> Ahh
16:31:50 <decathorpe> it's weird that you don't get an error message though.
16:31:56 <cipherboy> Yeah it'd be nice.
16:32:51 <cipherboy> Have anything else?
16:32:55 <decathorpe> errrr
16:33:00 <cipherboy> (Did I miss something?)
16:33:10 <decathorpe> I don't think you've missed anything, no
16:33:13 <cipherboy> PRs, Open BZs, raking...
16:33:33 <decathorpe> just wanted to mention: I have set up a cron job to autogenerate the reports for GH pages
16:33:39 <cipherboy> Ooohhh :)
16:33:48 <decathorpe> (local cron job)
16:34:03 <decathorpe> so as long as I use my PC every 1-2 days (likely ...) the reports should be always up to date
16:34:21 <cipherboy> :D
16:34:37 <cipherboy> Sounds great, thanks!
16:34:58 <decathorpe> yeah it's nice to have this almost working without my input ;-)
16:35:14 <decathorpe> I only look at the changes and do "git push"
16:37:39 <decathorpe> should I orphan the packages from the cleanup list, or do you want to go through the checklist? :-)
16:40:07 <cipherboy> Eh, I think it is fine.
16:40:37 <decathorpe> I'll deal with them after the meeting ;-)
16:41:25 <cipherboy> Thanks!
16:41:30 <cipherboy> Anything else?
16:41:46 <decathorpe> nope
16:42:06 <cipherboy> Sounds good. See you in two weeks!
16:42:20 <decathorpe> thanks!
16:42:23 <decathorpe> cipherboy++
16:42:37 <cipherboy> #endmeeting