16:02:14 <decathorpe> #startmeeting Stewardship SIG Meeting (2020-03-17)
16:02:14 <zodbot> Meeting started Tue Mar 17 16:02:14 2020 UTC.
16:02:14 <zodbot> This meeting is logged and archived in a public location.
16:02:14 <zodbot> The chair is decathorpe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:14 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:14 <zodbot> The meeting name has been set to 'stewardship_sig_meeting_(2020-03-17)'
16:02:19 <decathorpe> #meetingname stewardship-sig
16:02:19 <zodbot> The meeting name has been set to 'stewardship-sig'
16:02:25 <decathorpe> #topic Knock Knock
16:02:29 <mhroncok> hi 😷
16:02:33 <decathorpe> #chair mhroncok
16:02:33 <zodbot> Current chairs: decathorpe mhroncok
16:02:43 <decathorpe> hello! :)
16:02:54 <decathorpe> sillebille, cipherboy: meeting time!
16:03:08 <sillebille> hello \o
16:03:24 <sillebille> the meeting time changed?
16:03:26 <decathorpe> #chair sillebille
16:03:26 <zodbot> Current chairs: decathorpe mhroncok sillebille
16:03:42 <decathorpe> sillebille: no, the US has switched to DST before the EU did
16:04:02 <sillebille> decathorpe, ah ok. I hate time shifts :\
16:04:40 <decathorpe> yeah
16:05:05 <decathorpe> next meeting will be at the "usual" time
16:05:14 <decathorpe> since the EU switches to DST on March 29
16:06:05 <decathorpe> #link https://pagure.io/stewardship-sig/issue/80 Agenda
16:06:17 <decathorpe> any particular order in which you want to discuss things?
16:06:51 <mhroncok> Doom and Despair sounds interesting
16:07:17 <decathorpe> #topic java-1.8.0-openjdk crashes on fedora 32+
16:07:29 <decathorpe> #link https://bugzilla.redhat.com/show_bug.cgi?id=1813550
16:08:01 * cipherboy is here
16:08:11 <decathorpe> RaphGro and me spent a few hours trying to debug this, but we got nowhere - except that I think that GCC10 is to blame for crashes during GC / memory allocation in the JVM
16:08:15 <decathorpe> #chair cipherboy
16:08:15 <zodbot> Current chairs: cipherboy decathorpe mhroncok sillebille
16:08:25 <cipherboy> decathorpe: Do I need to poke the java team about it?
16:08:51 <decathorpe> I think they should be aware by now.
16:09:05 <decathorpe> there were some responses in the BZ and on the devel list
16:09:12 <mhroncok> propose as a prioritized bug?
16:09:23 <decathorpe> that's not a bad idea, yeah
16:09:25 <mhroncok> see if it breaks freeipa and report as finalblocker?
16:09:57 <cipherboy> mhroncok: It does break FreeIPA's weekly rawhide tests at least
16:10:33 <decathorpe> the f32 update is still in updates-testing and has some negative karma from me, so this should at least not impact fedora 32 (yet)
16:10:41 <mhroncok> https://fedoraproject.org/wiki/Basic_Release_Criteria#FreeIPA_server_requirements
16:10:53 <cipherboy> mhroncok: https://pagure.io/dogtagpki/issue/3130
16:11:07 <cipherboy> mhroncok: I don't know if we've been able to reproduce this with just a pkispawn.
16:11:11 <cipherboy> **ipa-server-isntall
16:11:43 <cipherboy> So far I don't think openqa has hit this, but we should make sure adamw is aware to look for it.
16:11:54 <adamw> hit wat
16:12:03 <mhroncok> adamw: hey \o/
16:12:12 <adamw> hum
16:12:14 <cipherboy> adamw: If you hit Java core dumping in any of the freeipa OpenQA tests, it is this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1813550
16:12:18 <adamw> roger, thanks
16:12:27 <cipherboy> F32+ due to GCC 10.0 / OpenJDK8 not playing nicely together.
16:12:47 <sillebille> we are able to see the issue in PKI's CI rawhide job. https://travis-ci.org/github/dogtagpki/pki/jobs/663345195
16:13:33 <decathorpe> https://bugzilla.redhat.com/show_bug.cgi?id=1813550#c13
16:13:47 <decathorpe> ^ proposed as prioritized bug.
16:14:13 <mhroncok> decathorpe: good. will see if this will ever hit fedora 32 and we shall propose it as a blocker if it indeed breaks freeipa
16:14:27 <decathorpe> mhroncok: +1
16:15:11 <decathorpe> anything else to say about this bug?
16:15:31 <mhroncok> ggggrrrhgg
16:15:36 <mhroncok> that's it
16:15:40 <cipherboy> argh
16:15:44 <cipherboy> :-) That's it here too
16:16:16 <decathorpe> there's light at the end of the tunnel!
16:16:27 <decathorpe> #topic OpenJDK 11 by default?
16:16:42 <decathorpe> #link https://fedoraproject.org/wiki/Changes/Java11 Change Proposal
16:16:48 <mhroncok> decathorpe: the change proposal seems very WIP
16:16:54 <decathorpe> this is still "Incomplete" yeah
16:17:01 <decathorpe> but it would be great if it could be done for fedora 33
16:17:02 <mhroncok> ChangeReadyForWrangler
16:17:15 <decathorpe> Oh it's set to Ready now. nice
16:17:47 <decathorpe> this would solve some problems, at least ...
16:17:58 <cipherboy> "nut not javac"
16:18:00 <mhroncok> FTBFS bugs connected with this proposal, maybe with jira ticket to allow discussion.
16:18:02 <mhroncok> what the
16:18:11 <cipherboy> Dogtag doesn't yet fully support JDK11+
16:18:34 <cipherboy> I think with JSS changes we have in the pipeline, we will be able to. JSSE wasn't working well on JDK11+ due to TLS1.3 introduction for some reason.
16:18:55 <decathorpe> yeah the change proposal has some interesting language ... e.g. "built in brew"
16:19:09 <mhroncok> Once the change is implemented properly, the update should be flawless and seamless :D
16:19:36 <cipherboy> ~cough~ bull ~cough~
16:19:42 <cipherboy> :-)
16:19:44 <decathorpe> :D
16:20:08 <cipherboy> I'm guessing we'll be one of the slower teams but hopefully we'll get time to do this.
16:20:12 <mhroncok> I'll definitively submit some initial feedback for this once it is proposed on devel
16:20:19 <decathorpe> I think openjdk 11 is already the default for some module streams, so the issues with tooling should have been resolved by now at least
16:20:20 <mhroncok> such as: who handles the rebuilds
16:20:39 <decathorpe> mhroncok: yeah that's an interesting question. Java SIG? lol
16:21:10 <mhroncok> should be the change owner but the change proposal suggests it is "other developers"
16:21:24 <mhroncok> which makes me thing: java 11 will be dumped on us and we will need to figure out the build order etc.
16:21:35 <mhroncok> *think
16:22:02 <decathorpe> I think in this case, backwards compatibility on bytecode level is actually great. build order shouldn't matter much
16:22:31 <cipherboy> Yeah if that works, it would be wonderful.
16:22:52 <decathorpe> "if that works" yeah
16:23:01 <mhroncok> decathorpe: an we test this in copr to see what blows up?
16:23:36 <decathorpe> mhroncok: I think so. some changes are needed to javapackages-tools, where the default java version is hard-coded, and xmvn should probably also be rebuilt.
16:23:51 <decathorpe> I can try to set that up later today
16:24:26 <mhroncok> that part is also not coverd by the change proposal :/
16:25:18 * decathorpe frowns
16:26:03 <mhroncok> let's wait for the change to be announced
16:26:15 <mhroncok> than we can send feedback on the mailing list ether individually or as a sig
16:26:20 <decathorpe> yeah
16:26:23 <mhroncok> individually will be easier to corodinate
16:29:01 <decathorpe> any other comments here?
16:29:07 <cipherboy> None from me.
16:29:22 <sillebille> none here
16:29:27 <mhroncok> goot go
16:29:46 <decathorpe> #topic Review Open RHBZs
16:29:51 <decathorpe> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&email1=stewardship-sig%40lists.fedoraproject.org&emailassigned_to1=1&emailcc1=1&emailtype1=substring&list_id=10281127&product=Fedora&query_format=advanced
16:30:09 <decathorpe> we almost managed to get things down to one page ;)
16:30:27 <decathorpe> does anybody see anything interesting?
16:30:42 <cipherboy> https://bugzilla.redhat.com/show_bug.cgi?id=1810950
16:30:45 <cipherboy> :P
16:31:02 <cipherboy> mhroncok started to triaged it I think, but not sure yet if its modular or non-modular maven.
16:31:20 <cipherboy> Not really sure why it matters tho.
16:31:49 <decathorpe> yeah ... and honestly, I don't want to start patching maven for that
16:32:45 <cipherboy> I added a comment to the bug, filed NEEDINFO on reporter. If no response in two weeks I'm inclined to say WONTFIX.
16:33:12 <decathorpe> good!
16:33:18 <decathorpe> moving on.
16:33:24 <cipherboy> We can probably use arguments similar to system-python.
16:33:32 <decathorpe> #topic Review Open Pull Requests
16:33:32 <cipherboy> I guess that's currently a RHEL8-ism but... meh
16:33:35 <decathorpe> #link https://fedora-stewardship.github.io/pr-report/
16:33:48 <cipherboy> Ugh, sorry. I've been busy and haven't had time to open these.
16:33:54 <cipherboy> *open new ones and review these
16:33:57 <cipherboy> I can english, I think.
16:35:07 <decathorpe> the three I opened (maven-doxia-sitetools, maven-parent, maven-source-plugin) should be good - simple small version bumps, with all rebuilds successful
16:35:15 <sillebille> i can review these later sometime today. Most of them are straightforward
16:35:25 <decathorpe> it's not like anybody's waiting for those updates ;D
16:35:31 <decathorpe> sillebille: that would be great, thanks.
16:35:34 <sillebille> junit kind of seemed like decathorpe already left some reviews
16:35:44 <decathorpe> I did :)
16:36:32 <decathorpe> any other comments for PRs?
16:36:37 <sillebille> i will try to rebase javaassist later this week or by next
16:36:46 <decathorpe> great!
16:38:01 <decathorpe> #topic Review SIG Leaf Packages
16:38:03 <decathorpe> #link https://pagure.io/stewardship-sig/issue/79
16:38:23 <decathorpe> #link https://fedora-stewardship.github.io/report/#total-leaves
16:38:57 <decathorpe> any objections to orphaning ant-antunit, jetty-toolchain, and simple-xml?
16:39:01 <cipherboy> simplexml I was fine orphaning unless it was needed for e* or loffice
16:39:15 <cipherboy> I thought it was required by e* for some reason, but... maybe not.
16:39:29 * decathorpe shrugs
16:39:47 <decathorpe> if it is needed, they can pick it up after mhroncok's report screams at them ;-)
16:39:49 <cipherboy> Fine dropping it then :)
16:41:20 <decathorpe> #action decathorpe will orphan SIG leaves after the meeting
16:41:27 <decathorpe> #topic Open Floor
16:44:10 <cipherboy> Nothing from me. I've been too busy to review resteasy upgrades for now.
16:44:44 <decathorpe> it's fine :)
16:45:05 <sillebille> I don't have anything too
16:45:15 <sillebille> i have been busy travelling for past 2 weeks
16:45:49 <decathorpe> alright, 15 more minutes of quarantine time for all. stay safe everybody
16:45:53 <decathorpe> #endmeeting