15:00:22 <contyk> #startmeeting FESCO (2020-04-06)
15:00:22 <zodbot> Meeting started Mon Apr  6 15:00:22 2020 UTC.
15:00:22 <zodbot> This meeting is logged and archived in a public location.
15:00:22 <zodbot> The chair is contyk. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:22 <zodbot> The meeting name has been set to 'fesco_(2020-04-06)'
15:00:24 <contyk> #meetingname fesco
15:00:24 <zodbot> The meeting name has been set to 'fesco'
15:00:26 <contyk> #chair nirik, ignatenkobrain, decathorpe, zbyszek, bookwar, sgallagh, contyk, mhroncok, dcantrell
15:00:26 <zodbot> Current chairs: bookwar contyk dcantrell decathorpe ignatenkobrain mhroncok nirik sgallagh zbyszek
15:00:28 <contyk> #topic init process
15:00:31 <contyk> .hello psabata
15:00:32 <zodbot> contyk: psabata 'Petr Šabata' <psabata@redhat.com>
15:00:34 <dcantrell> .hello2
15:00:35 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
15:00:38 <bookwar> .hello2
15:00:39 <decathorpe> .hello2
15:00:39 <zodbot> bookwar: bookwar 'Aleksandra Fedorova' <alpha@bookwar.info>
15:00:41 <sgallagh> .hello2
15:00:41 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
15:00:45 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
15:00:52 <frantisekz> .hello2
15:00:53 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
15:00:58 <nirik> morning
15:01:02 <zbyszek> .hello2
15:01:03 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
15:01:07 <mhroncok> hello
15:01:44 <contyk> Looks like we have a quorum.
15:02:24 <contyk> Let's start with Miro's topic.
15:02:40 <contyk> #topic #2369 Request: Postpone F32 Final Freeze by 3 ≤ N ≤ 7 days
15:02:45 <contyk> .fesco 2369
15:02:46 <zodbot> contyk: Issue #2369: Request: Postpone F32 Final Freeze by 3 ≤ N ≤ 7 days - fesco - Pagure.io - https://pagure.io/fesco/issue/2369
15:03:02 <mhroncok> this is from today, but in order to amek sens, would need to be approved today
15:03:09 <mhroncok> *to make sense
15:03:10 <nirik> I'm ok with this, but I will also note that the problems are not yet solved...
15:03:42 <mhroncok> nirik: the problmes not sovled is "OK" here. the added time is to workaround them for things that we planned to ship before the freeze
15:03:59 <mhroncok> (at least that's how I see it)
15:04:01 <decathorpe> nirik: sure, this would just be an additional buffer to get important things done.
15:04:15 <nirik> sure, just noting it for the record. :)
15:04:16 <dcantrell> I'm ok with some extra time for the delays.  I noticed bodhi has been really slow lately
15:04:35 <zbyszek> mhroncok: what is the outstanding stuff that is being worked on?
15:04:36 <mhroncok> I wonder if QA would be OK. we have frantisekz here
15:04:47 <bcotton> .hello2
15:04:48 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:04:53 <frantisekz> adamw? I think we're okay
15:04:54 <adamw> i'm here too
15:05:11 <contyk> +1
15:05:17 <adamw> for qa purposes delaying freeze is better than people trying to get big stuff in with FEs, i guess
15:05:27 <mhroncok> zbyszek: generally packagers who wanted to ship stuff prior to freeze but now they wouldn't make it
15:05:33 <adamw> nirik: does it increase the risk of us having to start moving infra before we're done with f32?
15:05:54 <adamw> hmm, wait
15:05:57 <nirik> if we delay a week it would be... not great
15:06:06 <adamw> if we accept this, do we slip the whole schedule? or only have a shorter freeze?
15:06:07 <nirik> if we just delay a few days thats probibly fine
15:06:15 <mhroncok> nirik: is it Ok not to have freeze on Tuesday?
15:06:29 <decathorpe> I can reduce my request to 1-2 additional days :)
15:06:45 <nirik> sure, just would mean less days in it if we still release on tuesday
15:07:26 <mhroncok> is Friday realistic? it's a holiday in CZ
15:07:44 <nirik> it's a holiday in the us too I think?
15:07:54 <mhroncok> I'd propose Friday if that's Ok to releng, Thursday otherwise
15:08:10 <dcantrell> Friday is a US RHT holiday
15:08:14 <ignatenkobrain> +1 to mhroncok
15:08:21 <nirik> I think thursday would be better... mboddu could chime in since he's doing the work probibly.
15:08:34 <mhroncok> ok, a proposal...
15:08:58 <nirik> although it's not too much, just updates pushing scheduled I guess
15:09:11 <mhroncok> Fedora 32 Final Freeze is posponed to Thursday 2020-04-09 14:00 UTC
15:09:30 <contyk> I'm fine with that.
15:09:36 <dcantrell> works for me
15:09:36 <nirik> +1
15:09:39 <sgallagh> +1
15:09:44 <mboddu> Well, Friday or Thursday doesn't matter in this time, I am okay with anything
15:09:51 <decathorpe> +1
15:09:52 <zbyszek> +1
15:09:58 <nirik> and to be clear, no slip in other milestones right?
15:10:03 * mboddu didn't even know Fri is a US holiday, thanks dcantrell :)
15:10:16 <dcantrell> mboddu: np, I tend to forget each year too
15:10:21 <mhroncok> mboddu: thursday it is... enjoy the holiday you didn't know about
15:10:30 <mhroncok> nirik: correct
15:10:37 <adamw> oh.
15:10:43 <adamw> well if someone answered that before people started voting i would have said:
15:10:54 <adamw> a shorter freeze is always going to come with a higher risk to the ultimate schedule, that's just...QA math
15:11:02 <nirik> yeah.
15:11:04 <adamw> we can work with it, but bear it in mind
15:11:25 <mhroncok> adamw: do you think the 2 days differ justifies to move everything?
15:11:40 <adamw> mhroncok: two days, probably not
15:11:42 <mhroncok> I trust adamw's decision on that
15:11:49 <adamw> just gives us a slightly higher risk of ultimately slipping
15:11:55 <mboddu> adamw: Right, but we still have rain date, if anything happens, hopefully we will be ready by rain date at the least
15:12:00 <adamw> sure
15:12:30 <contyk> So, with ignatenkobrain and dcantrell voting in the ticket for even a longer delay, I think we're +8.
15:12:33 <contyk> bookwar: ?
15:12:45 <bookwar> +1, to postponing for 2 days, no slipping for the rest of the schedule
15:13:12 <contyk> #agreed Fedora 32 Final Freeze is posponed to Thursday 2020-04-09 14:00 UTC (+9, 0, -0)
15:13:24 <bcotton> #action bcotton to update schedule
15:13:25 * mboddu sends an email to the lists
15:13:34 <sgallagh> bcotton++
15:13:35 <zodbot> sgallagh: Karma for bcotton changed to 19 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:13:36 <sgallagh> mboddu++
15:13:44 <decathorpe> thanks guys. I hope this makes today and tomorrow less stressful
15:13:46 <zbyszek> Quick action, nice.
15:13:46 <mhroncok> thanks
15:13:51 <contyk> Yay.
15:13:51 <bcotton> (not sure if #action can be done by non-chairs, but either way i'll have this done by the end of the meeting)
15:13:55 * nirik works more on the kojira issue
15:14:12 <contyk> Alright, next.
15:14:16 <contyk> #topic #2364 F33 System-Wide Change: Introduce module Obsoletes and EOL
15:14:24 <contyk> .fesco 2364
15:14:26 <zodbot> contyk: Issue #2364: F33 System-Wide Change: Introduce module Obsoletes and EOL - fesco - Pagure.io - https://pagure.io/fesco/issue/2364
15:14:46 <contyk> So we have -1 from ignatenkobrain in the ticket.
15:14:59 <contyk> But he's not around.
15:15:10 <ignatenkobrain> I am not sure if we should discuss this today...
15:15:14 <zbyszek> I think this needs more discussion on the mailing list.
15:15:15 <ignatenkobrain> because owners did not have chance to reply
15:15:22 <ignatenkobrain> yes, and that too.
15:15:31 <mhroncok> ignatenkobrain: bring your topics to the devel list?
15:15:36 <zbyszek> People were busy with other things, there's a few big threads happenning in parallel.
15:15:39 <ignatenkobrain> yes, I was planning to.
15:15:44 <contyk> Perhaps you're right. I personally have mixed feelings about this but I need to think more about it.
15:15:54 <mhroncok> I need more time as well
15:16:00 <contyk> It's not entirely new, the DNF team's been proposing it for a while.
15:16:08 <nirik> yeah, I think there's a lot of feedback that could be folded back into the change
15:16:44 <contyk> #info This topic needs more discussion and responses from the proposal owners. We'll discuss this next week.
15:16:57 <sgallagh> Note that next week is a holiday in many countrires
15:17:01 <sgallagh> (Though not the US)
15:17:14 <contyk> I'll try to be here but no promises.
15:17:39 <contyk> Chances are the discussion will still be ongoing by then anyway.
15:17:43 <contyk> #topic #2365 F33 System-Wide Change: ELN Buildroot and Compose
15:17:49 <contyk> .fesco 2365
15:17:50 <zodbot> contyk: Issue #2365: F33 System-Wide Change: ELN Buildroot and Compose - fesco - Pagure.io - https://pagure.io/fesco/issue/2365
15:18:02 <nirik> this will be a fun one. ;)
15:18:22 <nirik> so do we want to also wait for more discussion here? since it's still going on?
15:18:30 <zbyszek> yes please.
15:18:56 <nirik> FWIW, if anyone cares I am +1... have been meaning to reply into the thread, just haven't gotten time.
15:18:56 <sgallagh> I spoke with mhroncok about this at length about an hour ago
15:19:39 <sgallagh> He made some good points about lack of clarity in some places and I'm working to get those incorporated, but I didn't have time to finish ahead of this meeting.
15:20:05 <contyk> This might be a short meeting after all.
15:20:12 <sgallagh> I think it's probably sensible to postpone the formal vote, but I'm concerned about the possible lack of quorum next week
15:20:14 <bookwar> zbyszek: do you have anything in particular you want to have covered?
15:20:16 <dcantrell> sgallagh: so are you revising the proposal again?
15:20:36 <nirik> I wonder if it would help some folks concerns if we added some kind of sunset provision... like, "check in 6 months and consider if there's been bad or good impact and how much disruption"?
15:20:46 <zbyszek> bookwar: I certainly want to see the latest update that sgallagh mentioned.
15:20:50 <sgallagh> dcantrell: Yes, though as I said it should be a clarification rather than changing
15:21:02 <dcantrell> ok, sounds good
15:21:55 <decathorpe> if next week is going to have problems with quorum, we can always vote in the ticket on our own schedule
15:21:56 <sgallagh> I can enumerate the comments here if people want
15:22:12 <sgallagh> I'd like a commitment to that :)
15:22:13 <contyk> Please.
15:22:45 <mhroncok> FWIW it seemed to me that we were on the same page with sgallagh and if the things get clarified in the change I will vote +1, but I like to re-announce the thing for another week of discussion - but if there is no quorum next monday, it would be good if we commit to vote fast, in the ticket
15:23:14 <sgallagh> mhroncok: Thank you
15:23:39 <zbyszek> I'm fine with voting fast.
15:24:13 <sgallagh> OK, my plan is to get those changes written up and published by EOB today.
15:24:24 <sgallagh> I'll send another message to devel@ when it's ready
15:24:27 * nirik is happy when consensus can be reached
15:24:45 <sgallagh> Does anyone want me to summarize for this meeting or just await the write-up?
15:24:47 <contyk> #info sgallagh will address mhroncok's comments and clarify the proposal; we will vote next week; in case of no quorum, we commit to voting in the ticket async.
15:25:10 <contyk> If you could summarize here, that'd be great.
15:26:34 <sgallagh> Sure, just one second. SIGKIDS
15:26:55 <contyk> Make sure to kill all your children before you die.
15:27:45 <decathorpe> that's dark
15:28:09 <adamw> yikes
15:28:20 <dcantrell> damn dude
15:28:29 * contyk hides
15:29:13 <sgallagh> OK, I'm back
15:29:22 <sgallagh> Quarantine is FUN
15:29:32 <sgallagh> ok, let me summarize the main points.
15:29:46 <sgallagh> (mhroncok please feel free to let me know if I missed some points)
15:31:06 <sgallagh> * The Summary doesn't do a good job covering "Why" we are doing this. I'm going to explain about experimenting with things like AVX2 without disrupting Fedora and helping prep for future RHEL releases (including future-proofing conditinoals)
15:31:58 <sgallagh> * Describe the relationship to Rawhide better. The Rawhide build of any package not built for ELN will be present in the buildroot and compose.
15:32:19 <sgallagh> That's if it's not built intentionally or because it fails.
15:32:35 <sgallagh> There are more details around that, but I'll cover those in the Proposal
15:33:39 <sgallagh> * The time-limit on the PRs we send is a non-responsive check; it's not a hard limit. Once the maintainer responds, nothing happens without their agreement.
15:34:32 <sgallagh> * We will handle side-tags by waiting until they are tagged back into Rawhide, then we will rebuild in ELN. There are some additional details on tagging I will include in the proposal
15:34:44 <sgallagh> EOF
15:34:51 <contyk> Thank you.
15:34:52 <sgallagh> mhroncok: Did I miss anything obvious?
15:35:59 <mhroncok> the current proposal focuses on conditionals too much. the "what happens if the ELn build fails" will now first mention that the older or rawhide build will be used. conditionals are to be primarily fixed, not added
15:36:49 <nirik> I think thats probibly due to the list discussion focusing on them, but yeah...
15:37:03 <mhroncok> nirik: it was a spiral
15:37:08 <contyk> It always is.
15:37:11 <sgallagh> Heh
15:37:31 <contyk> Okay, let's move on.
15:37:36 <contyk> #topic Next week's chair
15:37:49 <contyk> Our favorite part.
15:38:07 <mhroncok> I'm nto sure i'll be here
15:38:10 <mhroncok> *not
15:38:16 <contyk> Same here.
15:38:23 <sgallagh> I'll take it for next week, but if we lack quorum I may not be around the week after
15:38:41 <sgallagh> That was poorly phrased
15:38:49 <mhroncok> I can take the 20th
15:38:52 <contyk> I can take the one two weeks fr--
15:38:54 <contyk> Or Miro.
15:39:19 <contyk> #action sgallagh will chair the next meeting.
15:39:29 <contyk> #action mhroncok will chair the meeting of 2020-04-20
15:39:38 <contyk> #topic Open Floor
15:40:18 <contyk> Closing in a minute if there's nothing.
15:41:08 <contyk> Okay. Thank you all for attending.
15:41:11 <contyk> #endmeeting