#fedora-meeting-1: fpc

Meeting started by geppetto at 16:00:18 UTC (full logs).

Meeting summary

  1. Roll Call (geppetto, 16:00:19)
  2. Schedule (geppetto, 16:06:07)
  3. #pr-#954 Prohibit use of `rpm` command from specfile. (geppetto, 16:07:43)
    1. ACTION: ignatenkobrain to open RFE for mock to populate lua table with package versions in chroot (ignatenkobrain, 16:16:08)
    2. https://src.fedoraproject.org/rpms/gdb-heap/blob/master/f/gdb-heap.spec#_30 (mhroncok, 16:18:13)
    3. https://src.fedoraproject.org/rpms/perl-Math-Calc-Units/blob/master/f/perl-Math-Calc-Units.spec#_2 I want a drink (mhroncok, 16:20:34)
    4. ACTION: Propose a standard alternative and ban querying rpm from inside .spec (+1:5, 0:0, -1:0) (geppetto, 16:32:55)

  4. #pr-#942 Recommend storing changelog entries in separate file. (geppetto, 16:33:19)
    1. https://pagure.io/packaging-committee/pull-request/942 (geppetto, 16:33:30)

  5. #pr-#947 Deprecate Old Style Dependency Generators (geppetto, 16:39:51)
    1. https://pagure.io/packaging-committee/pull-request/947 (geppetto, 16:39:55)
    2. https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/K3NLDLK4XVARTSROC6XVKNVW72BMMHYE/ (mhroncok, 16:48:11)
    3. ACTION: mhroncok to look at how python can get fixed for automatic lib provides (geppetto, 17:05:46)
    4. ACTION: decathorpe will help mhroncok (geppetto, 17:07:33)
    5. ACTION: tibbs agrees to fix everything else :) (geppetto, 17:14:27)
    6. ACTION: turn the %filter macros to error to avoid silent failures, we ban them (+1:5, 0:0, -1:0) (geppetto, 17:17:20)


Meeting ended at 17:21:28 UTC (full logs).

Action items

  1. ignatenkobrain to open RFE for mock to populate lua table with package versions in chroot
  2. Propose a standard alternative and ban querying rpm from inside .spec (+1:5, 0:0, -1:0)
  3. mhroncok to look at how python can get fixed for automatic lib provides
  4. decathorpe will help mhroncok
  5. tibbs agrees to fix everything else :)
  6. turn the %filter macros to error to avoid silent failures, we ban them (+1:5, 0:0, -1:0)


Action items, by person

  1. decathorpe
    1. decathorpe will help mhroncok
  2. ignatenkobrain
    1. ignatenkobrain to open RFE for mock to populate lua table with package versions in chroot
  3. mhroncok
    1. mhroncok to look at how python can get fixed for automatic lib provides
    2. decathorpe will help mhroncok
  4. tibbs
    1. tibbs agrees to fix everything else :)
  5. UNASSIGNED
    1. Propose a standard alternative and ban querying rpm from inside .spec (+1:5, 0:0, -1:0)
    2. turn the %filter macros to error to avoid silent failures, we ban them (+1:5, 0:0, -1:0)


People present (lines said)

  1. mhroncok (55)
  2. geppetto (52)
  3. tibbs (41)
  4. ignatenkobrain (37)
  5. decathorpe (33)
  6. zodbot (15)
  7. Defolos (10)
  8. nils (1)


Generated by MeetBot 0.1.4.