15:00:04 <siddharthvipul> #startmeeting Infrastructure (2020-05-14)
15:00:04 <zodbot> Meeting started Thu May 14 15:00:04 2020 UTC.
15:00:04 <zodbot> This meeting is logged and archived in a public location.
15:00:04 <zodbot> The chair is siddharthvipul. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:04 <zodbot> The meeting name has been set to 'infrastructure_(2020-05-14)'
15:00:05 <siddharthvipul> #meetingname infrastructure
15:00:05 <zodbot> The meeting name has been set to 'infrastructure'
15:00:05 <siddharthvipul> #chair nirik pingou smooge cverna mizdebsk mkonecny abompard siddharthvipul
15:00:05 <siddharthvipul> #info Agenda is at: https://board.net/p/fedora-infra
15:00:05 <siddharthvipul> #info About our team: https://docs.fedoraproject.org/en-US/cpe/
15:00:05 <zodbot> Current chairs: abompard cverna mizdebsk mkonecny nirik pingou siddharthvipul smooge
15:00:07 <siddharthvipul> #topic aloha
15:00:21 <mkonecny> .hello zlopez
15:00:22 <zodbot> mkonecny: zlopez 'Michal Konečný' <michal.konecny@packetseekers.eu>
15:00:43 <tflink> morning
15:00:50 <siddharthvipul> morning everyone :)
15:01:26 <mobrien[m]> .hello mobrien
15:01:27 <zodbot> mobrien[m]: mobrien 'Mark O'Brien' <markobri@redhat.com>
15:01:33 <nirik> morning
15:01:34 <smooge> hello
15:01:54 <siddharthvipul> #topic New folks introductions
15:01:54 <siddharthvipul> #info This is a place where people who are interested in Fedora Infrastructure can introduce themselves
15:01:54 <siddharthvipul> #info Getting Started Guide: https://fedoraproject.org/wiki/Infrastructure/GettingStarted
15:02:10 <astepano> hello
15:02:20 <amrmzaki> .hello
15:02:20 <zodbot> amrmzaki: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
15:02:38 <austinpowered> .hello austinpowered
15:02:38 <siddharthvipul> Do we have anyone new here? we are always looking for new folks
15:02:40 <zodbot> austinpowered: austinpowered 'T.C. Williams' <fedoraproject@wootenwilliams.com>
15:02:53 <amrmzaki> any easy tickets ?
15:03:19 <pingou> .hello2
15:03:20 <zodbot> pingou: pingou 'Pierre-YvesChibon' <pingou@pingoured.fr>
15:03:43 <amrmzaki> siddharthvipul i'm here
15:04:03 <siddharthvipul> amrmzaki: awesome, want to introduce yourself? :)
15:04:30 <mboddu> .hello mohanboddu
15:04:31 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
15:05:06 <amrmzaki> I'm Amr Zaki, devops Engineer , i worked a linux system admin for 3 years ago and still but with some of development tasks
15:05:13 <astepano> .hello astepano
15:05:14 <zodbot> astepano: astepano 'Andrei Stepanov' <astepano@redhat.com>
15:05:27 <nirik> welcome astepano!
15:05:43 <siddharthvipul> amrmzaki: about easy tickets, you can see easyfix labeled tickets on https://fedoraproject.org/easyfix/
15:05:58 <siddharthvipul> so if that's all, should we move to next topic?
15:06:09 <amrmzaki> siddharthvipul i think it's outdated
15:06:12 <nirik> but we haven't really added too many lately... so do ask about other tickets that interest you too.
15:06:23 <siddharthvipul> nirik++
15:06:23 <zodbot> siddharthvipul: Karma for kevin changed to 14 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:07:16 <siddharthvipul> #topic Next chair
15:07:17 <siddharthvipul> #info magic eight ball says:
15:07:17 <siddharthvipul> #info 2020-05-21 - mkonecny
15:07:17 <siddharthvipul> #info 2020-05-28 - ???
15:07:17 <siddharthvipul> #info 2020-04-04 - ??
15:07:26 <siddharthvipul> correction,
15:07:35 <siddharthvipul> #info 2020-06-04 - ???
15:08:04 <siddharthvipul> who wants to volunteer for chairing meeting on 28th? :)
15:08:58 <siddharthvipul> hmm, I can take (and learn more on the way)
15:09:12 <siddharthvipul> on 06-04?
15:09:29 <mkonecny> I can take it
15:10:02 <siddharthvipul> awesome
15:10:07 <nirik> I can start taking them again after the datacenter move is over... if I am still alive then. ;)
15:10:08 <siddharthvipul> #info 2020-05-21 - mkonecny
15:10:08 <siddharthvipul> #info 2020-05-28 - siddharthvipul
15:10:08 <siddharthvipul> #info 2020-06-04 - mkonecny
15:10:23 <siddharthvipul> nirik: haha, please focus there, we got this small one ;)
15:10:24 <mkonecny> I'm hijacking the meetings :-)
15:10:47 <siddharthvipul> mkonecny: no silos remember, I am with you :V
15:10:57 <siddharthvipul> #topic announcements and information
15:10:58 <siddharthvipul> #info CPE Sustaining EU-hours team has standups on Tuesday and Thursday at 1400 UTC in #fedora-admin - please join
15:10:58 <siddharthvipul> #info CPE Sustaining NA-hours team has a Monday through Friday 30 minute meeting going through tickets at 1800 UTC in #fedora-admin
15:10:58 <siddharthvipul> #info Fedora Infrastructure will be moving in 2020-06 from its Phoenix Az datacenter to one near Herndon Va. A lot of planning will be involved on this. Please watch out for announcements on changes.
15:10:59 <siddharthvipul> #info Fedora Communishift move has started but will take longer than expected. Current estimate for bringing back into production is TBD
15:11:02 <siddharthvipul> #info What's next in Fedora and CentOS infra https://communityblog.fedoraproject.org/whats-coming-up-next-in-fedora-and-centos-infrastructure/
15:11:19 <siddharthvipul> #topic Oncall
15:11:20 <siddharthvipul> #info https://fedoraproject.org/wiki/Infrastructure/Oncall
15:11:37 <siddharthvipul> #info  mboddu is oncall 2020-05-07 -> 2020-05-14
15:11:38 <siddharthvipul> #info cverna is oncall 2020-05-14 -> 2020-05-21
15:11:48 <siddharthvipul> mboddu: I think we missed you taking over the oncall
15:12:00 <siddharthvipul> so I was oncall for this week as well :P
15:12:17 <mboddu> siddharthvipul: Oh, thats why I never got pinged for .oncall thing
15:12:26 <mboddu> I thought no one needed any attention
15:12:35 <siddharthvipul> cverna: are you around? you can try `.oncalltakeeu`
15:12:41 <siddharthvipul> mboddu: that's automation :P
15:13:48 <siddharthvipul> question to nirik can 2 people take oncall thing in a week?
15:13:52 <siddharthvipul> like US and EU?
15:13:57 <siddharthvipul> for my personal info
15:14:08 <cverna> yeah
15:14:15 <cverna> .oncalltakeeu
15:14:15 <zodbot> cverna: Error: You don't have the alias.add capability. If you think that you should have this capability, be sure that you are identified before trying again. The 'whoami' command can tell you if you're identified.
15:14:29 <cverna> ah I need to login
15:14:54 <siddharthvipul> cverna: let's get back to it during the openfloor then :)
15:15:10 <siddharthvipul> #topic Monitoring discussion [nirik]
15:15:11 <siddharthvipul> #info https://nagios.fedoraproject.org/nagios
15:15:11 <siddharthvipul> #info Go over existing out items and fix
15:15:18 <siddharthvipul> nirik: you are up ^^
15:16:20 <nirik> sorry, got sidetracked. ;)
15:16:24 <nirik> so, lets see.
15:16:28 <smooge> https://nagios.fedoraproject.org/nagios/cgi-bin//status.cgi?host=all&servicestatustypes=28
15:16:49 <nirik> our typical planet and fas not sending fedmsgs.
15:17:12 <nirik> swap low on pagure01, notifs-backend01
15:17:24 <cverna> .oncalltakeeu
15:17:24 <zodbot> cverna: Kneel before zod!
15:17:32 <nirik> and a check raid on qa09... not sure what is going on with that
15:17:52 <nirik> I updated a bunch of buildvmhosts the other night to rhel 8.2 and rebooted them so they have all dropped off the low swap list
15:18:23 <nirik> I'm not sure why pagure01 takes up swap... we should perhaps schedule the rhel8 conversion on it sometime?
15:18:31 <nirik> I can restart notifs... it just leaks
15:18:59 <nirik> pingou: how is rhel8 on pagure-stg01? ready for prod?
15:19:29 <pingou> nirik: should be with pagure 5.10
15:19:55 <nirik> cool.
15:20:03 <nirik> ok, I think thats it on monitoring today
15:20:31 <siddharthvipul> awesome :)
15:20:34 <siddharthvipul> Thank you nirik
15:20:42 <siddharthvipul> #topic Data-Center Move update
15:21:26 <nirik> lets see...
15:22:08 <nirik> we have worked thru various issues this week. we are up to getting the last of the hardware (re)installed and then testing network rules...
15:22:36 <nirik> later today mobrien[m] and I will hopefully get a openshift cluster up and running in there.
15:22:59 <nirik> and rhen next week is stading up tons more application vm's and testing as much as we can.
15:23:20 <nirik> the week after will be standing up the build side of things... src, koji, builders, etc and testing that
15:23:36 <nirik> then we have a week of final testing and then on to the big move week. :)
15:23:46 <nirik> so, making progress, but still a lot to do.
15:24:08 <siddharthvipul> good luck :P
15:24:18 <nils> .hello nphilipp
15:24:19 <zodbot> nils: nphilipp 'Nils Philippsen' <nphilipp@redhat.com>
15:24:21 <siddharthvipul> you all seem busy enough
15:24:30 <siddharthvipul> are we okay to move to next topic?
15:25:05 <mboddu> Oh known_hosts file is going to see lot of changes :)
15:25:30 <nirik> yep. move along.
15:25:33 <siddharthvipul> no objections, I will take that as yes :)
15:25:35 <siddharthvipul> #topic  https://pagure.io/fedora-infrastructure/issue/8914 Please grant membership to Fedora DNS Sysadmin Group (sysadmin-dns)
15:25:44 <nirik> I may try and get help from folks next week and week after as we hit things.
15:25:47 <siddharthvipul> astepano: you entered it, want to share something?
15:26:17 <astepano> This is a part of fedora-ci initiative.
15:26:44 <astepano> To make easier deploy, and get freedom from specific cluster/datacenter.
15:27:08 <astepano> Example: https://jenkins-continuous-infra.apps.ci.centos.org/
15:27:55 <astepano> Idea to get access to some subdomain at xxx.fedoraproject.org
15:27:55 <siddharthvipul> pingou: mboddu you wanted to discuss this here?
15:28:08 <nirik> yeah, so I think this is fine... but we should use a subdomain, like ci.fedoraproject.org so your changes don't affect the main zones and someone will need to show you the process. ;)
15:28:20 <astepano> where changes can be applied on demand
15:28:24 <nirik> I think smooge added copr folks, so this is similar...
15:28:43 <astepano> nirik: that is exactly what I am asking for
15:29:07 <nirik> smooge: did you do anything special for the copr access? or just in the main group and set them up a zone?
15:30:43 <smooge> no just main group.. msuchy already had a lot of access and knowledge
15:31:18 <nirik> ok. any objections?
15:31:24 <smooge> so it was basically add them, tell them which files they should touch/not-touch/commands to run to safely update stuff... work through fires as time was available
15:31:28 <nirik> we do have a sop I think... but not sure how clear it is.
15:31:36 * nirik nods
15:31:38 <smooge> it was not clear
15:31:46 <smooge> and I didn't have time to fix it
15:33:22 <siddharthvipul> no objections so far.. do we have a clear idea of what to do here? with this I mean, should we move ahead?
15:33:58 <mboddu> Someone has to take action on this before moving on
15:34:02 <nirik> yeah, I guess it needs smooge or I to add them and show them the ropes. ;)
15:34:04 <nirik> we can move on
15:34:04 <siddharthvipul> right
15:34:20 <mboddu> But the problem is, the only people who know how to do this is smooge and nirik but they are busy with other things
15:34:46 <mboddu> astepano: When do you want this by? Is it okay if it is done when ^ they have free time?
15:34:52 <nirik> also nb knows... and I suppose the copr folks. ;)
15:35:33 <astepano> mboddu: absolutely, I will try to poke smooge / nirik / msuchy
15:35:52 <siddharthvipul> astepano: great.. seems it can go on the ticket
15:36:05 <siddharthvipul> #action astepano to ping more people to see who can help in time
15:36:14 <astepano> thank you!
15:36:15 <siddharthvipul> #topic Open Floor
15:36:16 <mobrien[m]> Would it be possible for another person to shadow when this is done to share the knowledge?
15:36:25 <nirik> yeah, I was just thinking that...
15:36:32 <mboddu> haha, I was about to ask that
15:36:33 <nirik> might be good to do a session with folks to go over it.
15:36:34 <smooge> it would be a great idea
15:36:42 * mboddu can shadow and update the docs
15:36:52 <mboddu> Please ping when it is being worked on
15:36:56 <mboddu> ping me*
15:36:59 <nirik> perhaps next week? is that soon enough astepano ?
15:37:09 <mobrien[m]> I can also shadow
15:37:29 <astepano> nirik: next week is fine. I will try to ask personally. Thank you!
15:37:35 <siddharthvipul> if it's not too restriction heavy, I can be there and try to learn. I have been thinking of getting more involved anyway
15:37:46 <nirik> yeah, lets pick a time...
15:37:53 * siddharthvipul doesn't want/have a lot of access yet for good reasons
15:38:19 <smooge> sysadmin-dns and sysadmin-noc used to be our entry point for new people
15:38:19 <nirik> how about 16utc tuesday?
15:38:37 <nirik> or 16:30
15:38:52 <astepano> is that question to me?
15:39:08 <nirik> astepano: yeah... not sure what your timezone is...
15:39:08 <mboddu> I prefer 16:30
15:39:43 * nirik finds if he schedules something it happens, if we just say 'sometime next week' everyone forgets or gets busy and it never happens.
15:39:43 <mboddu> (I think I need to update my timezone in fas as well)
15:39:44 <astepano> I am easy any time. (central EU zone) 16 UTC tuesday - is fine.
15:39:47 <mboddu> .time mohanboddu
15:39:47 <zodbot> mboddu: mohanboddu
15:40:17 <nirik> can everyone who cares make 16:30 -17:00 utc next tuesday the 19th? in #fedora-admin ?
15:40:30 <mboddu> +1 from me
15:40:38 <mobrien[m]> +1
15:40:39 <siddharthvipul> +1 for me  (I care) :)
15:40:44 <siddharthvipul> #action 16:30 UTC on 19|05|2020, nirik to work on #8914 and mboddu mobrien[m] siddharthvipul to shadow and learn
15:40:57 <nirik> great, can someone toss a calendar invite to all interested folks?
15:41:17 <nirik> (and anyone else is welcome to attend... )
15:41:46 <siddharthvipul> #action siddharthvipul to send invite to interested folks ( mboddu mobrien[m] astepano nirik) in working on #8914
15:41:53 <nirik> +1
15:42:00 <mboddu> Thanks siddharthvipul
15:42:02 * mkonecny will see
15:42:05 <astepano> thank you
15:42:17 <amrmzaki> nirik i'm interested
15:42:28 <siddharthvipul> awesome, so we have one entry for open topic by pingou
15:42:28 <amrmzaki> nirik +1
15:42:51 <siddharthvipul> amrmzaki: noted (if this is your fas, ignore, else please do send me your FAS id here or later so that I can send you an invite)
15:43:19 <siddharthvipul> open floor topic
15:43:21 <siddharthvipul> Could/Should we give misc `ticket` access to our issue tracker? (pingou)
15:43:22 <siddharthvipul> If we are going to collaborate more closely with misc and OSPO in general, it may be good for us to have them be able to self-assign and close tickets.
15:43:22 <siddharthvipul> `ticket` level access won't give them access to private tickets but will let them triage, assign, close tickets that are in their area of expertise.
15:43:42 <siddharthvipul> nirik: smooge cverna mboddu: thoughts?
15:44:29 <nirik> sure, seems perfectly fine to me.
15:44:40 <mboddu> Yeah, I am okay with it
15:44:46 <smooge> i am ok with it
15:44:52 <smooge> i thought he had it already
15:44:55 * nirik is somewhat surprised we didn't add him already in the past
15:44:56 <nirik> yeah
15:45:20 <siddharthvipul> awesome, we have agreement
15:45:36 <siddharthvipul> so who will be able to add him?
15:46:19 <nirik> done
15:46:29 * nirik just did it
15:46:39 <siddharthvipul> yayy
15:47:13 <siddharthvipul> right! so I don't have any entry on open floor in the etherpad, if anyone has any question, now is the time
15:47:19 <siddharthvipul> oh right! I have one
15:47:31 <pingou> thanks folks!
15:48:12 <amrmzaki> siddharthvipul my fas account is amrmostafazaki
15:48:14 <siddharthvipul> I can see create a group in my FAS account, but I recently say a ticket for i3-sig request that nb worked on.. the question is, which group has the access to create FAS groups?
15:48:30 <nirik> sysadmin I think it is.
15:48:54 <siddharthvipul> nirik: oh got it, and I understand there should be a procedure as well. Thank you nirik
15:48:57 <siddharthvipul> amrmzaki: ack
15:49:14 <siddharthvipul> will wait for a couple of minutes if anyone has to say anything.. else will close the meeting :)
15:51:03 <siddharthvipul> #endmeeting