15:59:06 <dustymabe> #startmeeting fedora_cloud_meeting
15:59:06 <zodbot> Meeting started Tue Jul 21 15:59:06 2020 UTC.
15:59:06 <zodbot> This meeting is logged and archived in a public location.
15:59:06 <zodbot> The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:59:06 <zodbot> The meeting name has been set to 'fedora_cloud_meeting'
15:59:29 <dustymabe> #topic roll call
15:59:35 <dustymabe> .hello2
15:59:36 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
15:59:52 <King_InuYasha> .hello ngompa
15:59:53 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:00:07 <michaelgugino> .hello2
16:00:08 <zodbot> michaelgugino: michaelgugino 'Michael Gugino' <gugino.michael@yahoo.com>
16:03:00 * dustymabe waves at King_InuYasha and michaelgugino :)
16:04:26 <dustymabe> #chair King_InuYasha michaelgugino
16:04:26 <zodbot> Current chairs: King_InuYasha dustymabe michaelgugino
16:04:39 <dustymabe> seems like we have a lot of people not around today
16:05:30 <King_InuYasha> yeah
16:05:36 <King_InuYasha> I'm at the moment splitting two meetings
16:05:40 <dustymabe> #topic Action items from last meeting
16:05:53 <michaelgugino> I forgot the time changed on this, luckily my calendar automatically updated.
16:06:07 <dustymabe> no action items from last meeting that I see
16:06:15 <King_InuYasha> yeah we don't have anything currently
16:06:25 <dustymabe> and we have no issues tagged with meeting
16:06:42 <dustymabe> maybe let's just do an open floor with a status update
16:06:45 <King_InuYasha> dustymabe: fwiw, I don't have the ability to tag anything
16:06:49 <dustymabe> #topic open floor
16:06:57 <dustymabe> King_InuYasha: i'll look into that right now
16:07:05 <dustymabe> michaelgugino: any updates on the work you were looking at?
16:09:39 <michaelgugino> dustymabe: no, sorry.  Friday is hack day again, so I'm planning on dedicating Friday to that.
16:09:46 <dustymabe> thanks michaelgugino
16:09:49 <King_InuYasha> the only thing I wanted to talk about this meeting was this: https://pagure.io/cloud-sig/issue/309
16:09:53 <dustymabe> i'll be around if you have questions
16:10:09 <dustymabe> King_InuYasha: i'll set the topic accordingly
16:10:12 <michaelgugino> great, I'm hoping to get something done, but if you're around to bother, I will :)
16:10:18 <dustymabe> #topic Cloud images should support UEFI
16:10:22 <dustymabe> #link https://pagure.io/cloud-sig/issue/309
16:10:30 <dustymabe> King_InuYasha: the floor is yours
16:10:50 <King_InuYasha> so we got a request last week for Fedora Cloud Base Edition images that would work in Azure Gen-2 hypervisors
16:11:23 <King_InuYasha> unfortunately, as it currently stands, none of our cloud images work in Azure (or local Hyper-V) with second generation platform, since it's UEFI-exclusive
16:12:19 <King_InuYasha> I did some digging and it seems to be caused by the fact we build our images with Anaconda through Image Factory and Oz
16:12:39 <King_InuYasha> and Anaconda doesn't have a way to be told to produce an install that boots in both BIOS and UEFI
16:13:15 <King_InuYasha> I filed a bug about it: https://bugzilla.redhat.com/show_bug.cgi?id=1858921
16:13:22 <dustymabe> right, that matches what I recall (though what I recall is not guranteed to be accurate)
16:13:26 <King_InuYasha> but I'm open to any suggestions from anyone on how to solve it
16:15:18 <dustymabe> King_InuYasha: in FCOS we run a script in a supermin VM that sets up the partitions
16:15:47 <King_InuYasha> could we do some adapting from FCOS to change our image build process to work properly?
16:15:48 <dustymabe> the problem is I don't know how to wire things up into koji to make it all happen
16:16:02 <King_InuYasha> maybe worth engaging with koji folks on the problem then?
16:16:34 <dustymabe> maybe - you might be able to do "various undefined things" like this in a runroot already and I just don't know how to make it all work
16:16:41 * King_InuYasha shrugs
16:16:43 <King_InuYasha> I have no clue either
16:17:01 <King_InuYasha> my personal experience with making hybrid disk images is with using the kiwi image builder tool to do it
16:17:13 <King_InuYasha> https://osinside.github.io/kiwi/
16:17:27 <dustymabe> King_InuYasha: you also linked to osbuilder (or whatever you call it) that supposedly might be able to do it
16:17:36 <dustymabe> we could look at maybe using that project for building the cloud images
16:17:50 <King_InuYasha> yeah, the osbuild tool that a team in RH is working on to replace lorax *seems* capable of it
16:17:54 <King_InuYasha> but I haven't verified it
16:18:15 <dustymabe> they might be willing to help us through it - I think mhayden works closely with that team
16:18:20 <King_InuYasha> yeah
16:18:23 <dustymabe> and he joins these meetings sometimes
16:18:34 <dustymabe> migth be worth posing the question to him in the ticket and linking him to it
16:18:35 <King_InuYasha> I'm okay with being a guinea pig here if it can help make these things less suck
16:18:46 <King_InuYasha> err suck less
16:19:46 <dustymabe> agree
16:19:54 <dustymabe> King_InuYasha: you mind taking an action item on that?
16:20:05 <King_InuYasha> sure
16:20:36 <dustymabe> #action King_InuYasha to engage mhayden to see if the cloud base images might be a good candidate for Image Builder
16:20:45 <King_InuYasha> sounds good
16:20:51 <dustymabe> he did a post about it recently: https://major.io/2020/06/19/build-aws-images-with-imagebuilder/
16:21:39 <King_InuYasha> who knows, maybe it'll be a good replacement for appliance-creator too
16:21:56 <King_InuYasha> then the arm images wouldn't be a devilishly hard platform to target :)
16:22:03 <dustymabe> King_InuYasha: another thing to consider here is that we might want to make an image per cloud, which is what we ended up doing for Fedora CoreOS. The primary reason was because each of them tend to have different ways to retrieve metadata.
16:22:13 <King_InuYasha> yup
16:22:25 <King_InuYasha> there's a whole bunch of things to consider, and cloud images are fugly as it is
16:22:31 <dustymabe> ok I'll move back to open floor again
16:22:36 <dustymabe> #topic open floor 2
16:22:41 <dustymabe> anything else for today?
16:22:54 <King_InuYasha> dustymabe: would you mind helping me package suse's image-mash tool?
16:23:03 <King_InuYasha> the uploader thing that supports going everywhere
16:23:33 <King_InuYasha> and the img-proof tool they use for testing cloud images
16:24:28 <dustymabe> I can certainly help review. Not sure how much extra ongoing commitment I can place on it. Are they python?
16:24:29 <King_InuYasha> I think both of those are going to be very helpful for us to support this stuff better going forward
16:24:31 <King_InuYasha> yes
16:24:39 <dustymabe> typically makes it easier
16:24:57 <King_InuYasha> img-proof: https://github.com/SUSE-Enceladus/img-proof
16:25:06 <King_InuYasha> image-mash: https://github.com/SUSE-Enceladus/mash
16:25:43 <dustymabe> yeah, is review enough of help ? sorry i'm already not putting enough effort into the cloud wg itself as it is
16:26:13 <King_InuYasha> perhaps, it depends on if I may need help with updating dependencies or packaging new deps
16:26:20 <King_InuYasha> haven't really dug into it yet -ETIME
16:26:34 <dustymabe> i'm mostly free for one off commitments that may take some time, the sustained commitment over time is the hard part
16:27:05 <King_InuYasha> well maybe other members of the cloud-wg/cloud-sig could help?
16:28:51 <King_InuYasha> anyway, that's all I got
16:29:44 <dustymabe> +1
16:29:50 <dustymabe> will close out the meeting here soon
16:33:44 <King_InuYasha> dustymabe: sounds good
16:34:03 <dustymabe> #endmeeting