16:01:18 <geppetto> #startmeeting fpc
16:01:18 <zodbot> Meeting started Thu Jul 23 16:01:18 2020 UTC.
16:01:18 <zodbot> This meeting is logged and archived in a public location.
16:01:18 <zodbot> The chair is geppetto. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:18 <zodbot> The meeting name has been set to 'fpc'
16:01:19 <geppetto> #meetingname fpc
16:01:19 <geppetto> #topic Roll Call
16:01:19 <zodbot> The meeting name has been set to 'fpc'
16:01:24 <mboddu> Thanks siddharthvipul
16:01:49 <tibbs> Hey.
16:01:52 <decathorpe> hello ö/
16:01:54 <mhroncok> hi
16:02:06 * limburgher here
16:02:10 <geppetto> #chair tibbs
16:02:10 <zodbot> Current chairs: geppetto tibbs
16:02:12 <geppetto> #chair mhroncok
16:02:12 <zodbot> Current chairs: geppetto mhroncok tibbs
16:02:15 <geppetto> #chair limburgher
16:02:15 <zodbot> Current chairs: geppetto limburgher mhroncok tibbs
16:02:26 <geppetto> #chair decathorpe
16:02:26 <zodbot> Current chairs: decathorpe geppetto limburgher mhroncok tibbs
16:03:04 <King_InuYasha> .hello ngompa
16:03:06 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:04:04 <decathorpe> hey Neal o/ have you officially joined us? ;)
16:05:03 * geppetto quickly assigns all the tickets to neal
16:06:26 <King_InuYasha> oh dear
16:06:34 <King_InuYasha> I dunno, but I figure I'd show up
16:06:57 * limburgher locks the door
16:07:23 <mhroncok> the meeting won't end until we solve all the tickets, right?
16:07:30 * King_InuYasha looks worried
16:07:30 <decathorpe> :D
16:07:46 <geppetto> hahaha
16:08:25 <geppetto> #topic Schedule
16:08:29 <geppetto> #link https://lists.fedoraproject.org/archives/list/packaging@lists.fedoraproject.org/message/47AODIXTYLCTQPUTH6IB6GWIPN3DLUNN/
16:08:42 <geppetto> #topic #1007 Golang pkg review exception to update a lot of packages
16:08:45 <geppetto> .fpc 1007
16:08:49 <zodbot> geppetto: Issue #1007: Golang package review exception to update a lot of packages - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/1007
16:09:26 <mhroncok> eclipseo: hey
16:09:41 <eclipseo> hi
16:09:54 <decathorpe> in principle, I'm fine with this. I know Go packaging is a bit of a mess and they make new dependencies like rabbits make little rabbits
16:10:22 <King_InuYasha> I'm okay with it too
16:10:30 <King_InuYasha> as a Go SIG member, I approve of this too
16:10:30 <decathorpe> though it would be nice to have a list of new packages (even a WIP list) that the exception applies to.
16:10:35 <King_InuYasha> yeah
16:11:00 * mhroncok would feel more comfortable having the bunch of spec files to inspect rather than giving a blanket exception
16:11:05 <geppetto> Yeh, I was +1 with it but then mhroncok was worrid enough to want a list
16:11:07 <eclipseo> I have posted 6 that are waiting on my last comment, they are the one I have for the 90 packages I have tested so far
16:11:09 <mhroncok> but I can acks this as well if that is unrealistic
16:11:22 <tibbs> The only issue with a blanket exception is the bit about licenses being autodetected.
16:12:02 <eclipseo> I use askalono-cli which is a tool dev by Amazon to detect license files
16:12:23 <geppetto> tibbs: this isn't like the old days though … now developer upload to github and github sees what the licesnes is, or bugs the developer about it until it finds out
16:12:36 <decathorpe> I mean, I don't have many things to do this week, I can be on standby to ACK package reviews and manually check licenses.
16:12:52 <tibbs> And does legal trust those processes and tools?
16:12:53 <eclipseo> ef there is no license files then I bother upstream of course
16:12:57 <geppetto> eclipseo: Does that check github, or just the data?
16:13:01 <mhroncok> decathorpe: I can imagine time better spent :)
16:13:11 <ignatenkobrain> .hello2
16:13:11 <zodbot> ignatenkobrain: ignatenkobrain 'Igor Raits' <igor.raits@gmail.com>
16:13:13 <eclipseo> that check all the files in the repo
16:13:16 <ignatenkobrain> sorry for being late
16:13:19 <decathorpe> mhroncok: sure ... I could fix more Java packages
16:13:23 <geppetto> #chair ignatenkobrain
16:13:23 <zodbot> Current chairs: decathorpe geppetto ignatenkobrain limburgher mhroncok tibbs
16:13:25 <mhroncok> decathorpe: exactly :D
16:13:44 <tibbs> Really, legal review is the sole reason package review is necessary in many cases where packaging is autogenerated.
16:14:21 <mhroncok> OTOH I bet many package reviews don't do better job than askalono
16:14:26 <tibbs> So if legal is OK with us bypassing things, then I would be happy to consider expedited process for whole classes of autogenerated packages.
16:14:52 <King_InuYasha> one of these days, I'll get cavil working...
16:15:04 <mhroncok> King_InuYasha: once everyhting else is done :D
16:15:08 <King_InuYasha> :D
16:15:22 <King_InuYasha> you know it!
16:16:00 <mhroncok> eclipseo: is it unreasonable to generate them all and past for sanity check? I don't know how you operate
16:17:31 <eclipseo> generate them all? I'm not sure I follow, I can't know what I will need right now
16:17:46 <limburgher> Oh, Go, never change.
16:18:11 * King_InuYasha sighs
16:18:11 <ignatenkobrain> basically the problem is that when you start packaging A, then you have to package B and C and thousands of deps for them :)
16:18:19 <eclipseo> There is very complex dependency graph, some app have chain of deps that goes to 800 packages
16:18:27 <tibbs> I'll fire off a message to fedora-legal and see if we can get an answer.
16:18:39 <ignatenkobrain> eclipseo: somebody said k8s?
16:18:50 <mhroncok> +1 to review exception assuming legal is OK with this
16:19:40 <eclipseo> k8s is tricky
16:19:40 <eclipseo> but less than docker
16:19:44 <eclipseo> docker use pinned repository and trivial forks
16:20:02 <decathorpe> +1 same as mhroncok (and otherwise I think I can spare a few minutes to check some packages manually every day)
16:20:17 <geppetto> #action tibbs to Make sure fedora-legal are ok with this
16:20:24 <limburgher> *cough*terraform*cough*
16:20:30 <geppetto> But, yeh, I'm fine with it all in theory
16:20:32 <King_InuYasha> uhh, does anyone one know *who* fe-legal is now?
16:20:49 <ignatenkobrain> spot & rfontana?
16:20:56 <tibbs> Still see messages from spot and Ruchard Fontana in the mailing list.
16:20:57 <geppetto> not spot
16:21:11 <tibbs> Though that list is pretty low traffic.
16:21:28 <ignatenkobrain> so still same black box :)
16:21:38 <tibbs> Pretty much.
16:22:15 <tibbs> I mean, a decision could just be made and then someone could come along and say it was a bad idea after the fact.
16:22:44 <eclipseo> should I ask myself to legal?
16:23:31 <tibbs> Well if you prefer; I was typing the message already but I can stop.
16:23:39 <eclipseo> no it's ok
16:24:01 <eclipseo> Just precise that I do check the license files manually too
16:26:11 <geppetto> #topic #pr-988 Don't obsolete debuginfo packages
16:26:11 <geppetto> https://pagure.io/packaging-committee/pull-request/988
16:26:37 <geppetto> Seems like a trivial +1
16:27:07 * mhroncok was +1 in the ticket
16:27:11 <limburgher> Agreed, +1
16:27:31 <ignatenkobrain> +1 from me too, ideally dnf would just automagically remove them, but oh well
16:27:55 <decathorpe> this is fine
16:28:03 <tibbs> To be clear: there's no automated process that adds these obsoletes, it's all done manually by a misguided maintainers?
16:28:14 <ignatenkobrain> tibbs: yes
16:28:41 <tibbs> I mean, dmlite still uses %defattrand has conditionsls for %fedora >= 17, so....
16:29:40 <tibbs> +1
16:30:05 <tibbs> Though to be nitpicky, the PR needs sembreaks and a lint for grammar.
16:30:54 <King_InuYasha> +1
16:32:05 <mhroncok> (my +1 is for the rule, not for merging immediatelly as is.)
16:32:29 <geppetto> #action Don't obsolete debuginfo packages (+1:5, 0:0, -1:0)
16:32:45 <geppetto> #topic #pr-1006 Update CMake guidelines
16:32:45 <geppetto> https://pagure.io/packaging-committee/pull-request/1006
16:33:06 * mhroncok hasn't read this yet
16:33:56 <decathorpe> this is fine (and already deployed in rawhide?)
16:34:08 <ignatenkobrain> yes, and backported to f31/f32
16:34:26 <ignatenkobrain> should have done it long ago, but did not have time :/
16:34:40 <decathorpe> diff is small and looks good, +1
16:34:47 <limburgher> Looks ok to me. Wish I'd seen it before one of my packages hit it but that's on me. :)
16:34:50 <limburgher> +1
16:34:59 <geppetto> yeh, adding a param. doesn't seem like a big deal :)
16:35:04 <geppetto> +1
16:35:46 <mhroncok> +1 in general, haven't checked the syntax etc.
16:36:11 <tibbs> So what happens if packages still use %make_build and %make_install instead of %cmake_*?
16:36:34 <geppetto> make != cmake … so they are fine?
16:36:42 <ignatenkobrain> tibbs: in f33, they have to add use `-C %{_vpath_builddir}` or `%global __cmake_in_source_build 1`
16:36:51 <ignatenkobrain> that is basically change: https://fedoraproject.org/wiki/Changes/CMake_to_do_out-of-source_builds
16:37:38 <tibbs> I wonder how many things that breaks.  Using %make_build with cmake has been the norm for basically forever.
16:37:49 <mhroncok> it breaks a lot fo packages
16:38:00 <mhroncok> but it already has
16:38:26 <ignatenkobrain> tibbs: we've already managed to fix around 1k packages out of 1.8k
16:38:29 <limburgher> Having this in the guidelines would help people fix it faster.
16:38:34 <mhroncok> yes
16:39:07 <tibbs> I don't disagree; just trying to understand the issue.  The decision to make the underlying change was already done (and I would argue is a mistake, but that's not up to us).
16:39:40 <tibbs> +1
16:39:59 <decathorpe> well, this PR for the Packaging Guidelines only aligns them with the new reality
16:40:09 <tibbs> Yes, of course.
16:40:48 <geppetto> #action Update CMake guidelines (+1:5, 0:0, -1:0)
16:41:23 <geppetto> #topic #pr-938 Add Package Review Process page.
16:41:23 <geppetto> https://pagure.io/packaging-committee/pull-request/938
16:41:43 <tibbs> I didn't think the guidelines were the place for this.
16:42:53 <mhroncok> I am fine either way
16:43:32 <decathorpe> well, we should verify that the content is actually still the same
16:43:54 <limburgher> If so, i'm on board.
16:44:30 <geppetto> tibbs: where did you want to put it?
16:44:49 <tibbs> The wiki seems a reasonable place for a community-maintained document.
16:44:55 <geppetto> tibbs: Just have it as a normal wiki page that anyone can change?
16:45:09 <geppetto> I guess I'm fine with that
16:45:09 <tibbs> Hasn't it always been that way?
16:45:16 * geppetto has no idea
16:45:57 <ignatenkobrain> I think it is not a bad idea to have such documents in one place, maintained by same people and with a same dialect of source code
16:46:23 <tibbs> Depends on what you mean by "such documents".
16:46:46 <decathorpe> It seems a bit weird to me that the actual Guidelines are all together but the document that outlines what to do with them doesnt
16:46:50 <tibbs> There is a rather big difference between something the community is welcome to edit and something that is protected by committee process.
16:47:45 <tibbs> I don't see this document as telling you how to apply the packaging guidelines at all.
16:48:49 <tibbs> This a about bugzilla states and blocker tickets.
16:49:26 <tibbs> The ReviewGuidelines page is more abuit applying the guidelines, and it is under the Packaging: hierarchy.  I don't know if it ever got moved or cleaned up in the new system.
16:52:30 * decathorpe shrugs
16:53:41 <geppetto> tibbs: You want to move it to the right place in the wiki?
16:53:59 <tibbs> What place would be better than where it is now?
16:54:40 <geppetto> I wasn't sure if it needed to be moved
16:55:01 <geppetto> So I guess we just close it and tell them to alter it directly?
16:55:37 <geppetto> I'm fine with that
16:56:10 <tibbs> Well, I mean, I'm just one person with an opinion.  If others feel confident moving the thing to be under the umbrella of the guidelines then that's fine.
16:56:22 <geppetto> #info No need for FPC to own this document, can leave it being commnuity maintained. Feel free to do any changes directly
16:56:27 <mhroncok> I feel like the wiki to docs transition is still a bit messy
16:56:41 <mhroncok> I would think this belong to docs, but I'm not arguing about it
16:56:43 <tibbs> That's an understatement.
16:57:02 <decathorpe> yeah :sad face:
16:57:06 <mhroncok> tibbs: I didn't want to sound harsh, it is a total mess :D
16:57:15 <mhroncok> I've heard King_InuYasha will fix it
16:57:21 <King_InuYasha> wait what?!
16:57:24 <mhroncok> :D
16:57:26 <geppetto> Sounds good
16:57:30 <King_InuYasha> oh no
16:57:33 * King_InuYasha dies
16:57:37 <tibbs> Well the automated conversion simply wasn't remotely as good as what was sold to us.
16:57:37 <geppetto> *action King_InuYasha will fix it
16:58:01 <King_InuYasha> oh no
16:58:05 <King_InuYasha> I can't fix this :(
16:58:16 <King_InuYasha> though it should really be in docs system instead of wiki
16:58:44 <geppetto> #topic Open Floor
16:58:53 <tibbs> But how do you have a community maintained document in the docs system?
16:58:59 <King_InuYasha> ... PRs?
16:59:17 <mhroncok> well, if somebody reviews thaem, maybe :P
16:59:22 <tibbs> That's kind of the opposite of community maintained.
16:59:33 <geppetto> I guess we didn't talk about 977 … I guess that's done now, unless King_InuYasha wants to volunteer after the fact
16:59:37 <King_InuYasha> someone is the steward of the package review process docs?
16:59:39 <geppetto> .fpc 977
16:59:40 <zodbot> geppetto: Issue #977: Get new members? - packaging-committee - Pagure.io - https://pagure.io/packaging-committee/issue/977
16:59:50 <King_InuYasha> I'm happy to join fpc if wanted
16:59:59 <King_InuYasha> I'd also volunteer carlwgeorge too :P
17:00:01 <tibbs> I would think the community would be the steward of things.
17:00:23 <geppetto> Would have been cool to apply in the tiny 2 month window ;)
17:00:33 <tibbs> Maybe that's comically utopian and wikis are just not the way things are done any more.
17:00:45 <decathorpe> 🔥
17:01:23 <King_InuYasha> geppetto: I didn't know :o
17:01:24 * bcotton peeks in the window
17:01:40 <mhroncok> oh no, it's 2020 out there
17:01:41 <decathorpe> geppetto: well, do we want to turn away volunteers when we're short-handed anyway?
17:01:46 <King_InuYasha> it only kinda showed up because mhroncok pointed it out to me :P
17:01:53 * decathorpe waves at bcotton
17:01:56 * limburgher pulls blinds
17:01:57 <mhroncok> me? no way
17:02:20 <geppetto> tibbs: The new new thing is git + hugo … so I assume we'll all be porting to that rsn.
17:02:39 <mhroncok> sustainability ftw!
17:03:08 <decathorpe> huh ... that's almost what I wanted them to do in the first place :O
17:03:32 <decathorpe> (though Jekyll actually has an official asciidoc plugin)
17:04:45 * bcotton glares in i-have-this-room-reserved-now :-)
17:04:59 <mhroncok> bcotton: deal with it, FPC is slow :D
17:05:09 <geppetto> bcotton: We also started late … so blame infra ;)
17:05:16 <mhroncok> bcotton: want to join? there was a window
17:05:16 <tibbs> I'm done.  Will finish up that message to legal and add my comments to 938.
17:05:37 <mhroncok> I'm done as well
17:05:39 <decathorpe> yeah, let's end
17:05:42 <mhroncok> bcotton: what is the meeting baout?
17:05:47 <mhroncok> *about
17:05:54 <bcotton> Council meeting
17:05:54 * dgilmore looks at bcotton
17:05:55 <geppetto> Anyway … we should be nice. I'll end it now.
17:06:02 <geppetto> #endmeeting