15:58:21 <dustymabe> #startmeeting fedora_cloud_meeting
15:58:21 <zodbot> Meeting started Tue Aug 18 15:58:21 2020 UTC.
15:58:21 <zodbot> This meeting is logged and archived in a public location.
15:58:21 <zodbot> The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:58:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:58:21 <zodbot> The meeting name has been set to 'fedora_cloud_meeting'
15:58:26 <dustymabe> #topic roll call
15:58:30 <dustymabe> .hello2
15:58:31 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
15:58:53 <jdoss> .hello2
15:58:54 <cyberpear> .hello2
15:58:54 <zodbot> jdoss: jdoss 'Joe Doss' <joe@solidadmin.com>
15:58:57 <zodbot> cyberpear: cyberpear 'James Cassell' <fedoraproject@cyberpear.com>
15:59:47 <dustymabe> \o/
15:59:49 <dustymabe> welcome all
16:00:52 <dustymabe> waiting for a few more to join if possible
16:01:38 <dustymabe> ok we'll get started
16:01:53 <dustymabe> #chair cyberpear jdoss
16:01:53 <zodbot> Current chairs: cyberpear dustymabe jdoss
16:01:59 <dustymabe> #topic Action items from last meeting
16:02:10 <dustymabe> #chair michaelgugino
16:02:10 <zodbot> Current chairs: cyberpear dustymabe jdoss michaelgugino
16:02:29 <dustymabe> * King_InuYasha to engage mhayden to see if the cloud base images might
16:02:31 <dustymabe> be a good candidate for Image Builder
16:02:47 <dustymabe> looks like Neal isn't around today
16:02:50 <michaelgugino> .hello2
16:02:51 <zodbot> michaelgugino: michaelgugino 'Michael Gugino' <gugino.michael@yahoo.com>
16:03:10 <King_InuYasha> .hello ngompa
16:03:13 <zodbot> King_InuYasha: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:03:15 <dustymabe> #chair King_InuYasha
16:03:15 <zodbot> Current chairs: King_InuYasha cyberpear dustymabe jdoss michaelgugino
16:03:18 <King_InuYasha> hey folks
16:03:27 <dustymabe> * King_InuYasha to engage mhayden to see if the cloud base images might
16:03:27 <jdoss> Hey Neal
16:03:29 <dustymabe> be a good candidate for Image Builder
16:04:27 <King_InuYasha> I hadn't emailed mhayden yet, but I did have a conversation during Nest that made me think that the solution might not be so simple
16:05:09 <dustymabe> ok any more you want to add or should we move on?
16:05:17 <King_InuYasha> nah, I'm good
16:05:21 <dustymabe> #action King_InuYasha to engage mhayden to see if the cloud base images might be a good candidate for Image Builder
16:05:22 <King_InuYasha> I'll email Major after this meeting
16:05:44 <King_InuYasha> this is probably going to prompt discussions of how to wire this up to Koji
16:06:00 <King_InuYasha> because right now, we have no way to use osbuild in our compose pipeline
16:06:48 <dustymabe> +1
16:06:52 <dustymabe> let me find a meeting ticket
16:07:47 <dustymabe> #topic publish a cloud image for GCP
16:07:51 <dustymabe> #link https://pagure.io/cloud-sig/issue/310
16:08:18 <dustymabe> #info The engineer from google has posted up a proposed kickstart for creating and image for GCP
16:08:40 <dustymabe> i need to look into it and see if we can get that into our build system for f33
16:09:21 <michaelgugino> last I tried cloud-init was broken on GCP, but I know dustymabe mentioned major had some steps to replace cloud-init with google's stuff.
16:09:22 <cyberpear> tie in with FCOS images? or is it purely a kickstart issue?
16:09:34 <michaelgugino> That was like a year ago at this point, so IDK.
16:09:42 <dustymabe> cyberpear: this is for fedora cloud base
16:09:55 <King_InuYasha> can we make sure GCP images are UEFI?
16:10:07 <jdoss> That Issue has a uefi script in it
16:10:52 <dustymabe> King_InuYasha: yeah I think that should be the default - just make it UEFI
16:11:06 <dustymabe> we'd have a specific image for GCP I think
16:11:15 <dustymabe> and not just make it part of a single cloud base image
16:11:16 <King_InuYasha> I think we already have to anyway
16:11:36 <King_InuYasha> we might want to reuse that pipeline for making an Azure image if the osbuild stuff doesn't work out
16:11:43 <King_InuYasha> and a Generic Cloud UEFI image
16:12:54 <dustymabe> yeah, though if we include the GCP tooling inside the image at some point
16:13:00 <dustymabe> we'll probably want individual images
16:13:55 <dustymabe> anything else to discuss this ticket?
16:15:12 <dustymabe> #topic regular releases: uploading to clouds
16:15:16 <dustymabe> #link https://pagure.io/cloud-sig/issue/301
16:15:24 <dustymabe> michaelgugino: I think has an update here
16:15:32 <michaelgugino> Yeah
16:16:27 <michaelgugino> I've put together a basic POC dockerfile for listening to the fedora-messaging bits: https://github.com/michaelgugino/fed-image-watcher
16:17:14 <michaelgugino> I haven't incorporated the bits to look up the image urls, but it's pretty straight forward looking at fedimg's stuff.
16:17:21 <dustymabe> #info POC for listening to fedora-messaging for doing cloud image uploads: https://github.com/michaelgugino/fed-image-watcher
16:17:52 <michaelgugino> I went down the dockerfile rabbit hole trying to figure out which is the most convenient base image to use.  I settled on the s2i python image, that makes it trivial to install python things, but I'm open to suggesting.
16:17:58 <cyberpear> #url https://github.com/michaelgugino/fed-image-watcher
16:18:21 <dustymabe> michaelgugino: i typically just use Fedora as a base and add whatever I need on top of that
16:18:35 <King_InuYasha> likewise
16:18:58 <King_InuYasha> also note that pingou and his team has the "toddlers" framework for being able to listen and kick off things in infra
16:19:06 <King_InuYasha> it might be worth talking to them about plugging into that framework
16:19:14 <dustymabe> yep. this is basically the same model
16:20:01 <dustymabe> thanks michaelgugino for working on this. i suppose you're just looking for feedback now?
16:20:42 <michaelgugino> One notable change in arch from fedimg, we can discuss the merits of here.  Previously fedimg would fetch multiple items from the messaging queue, and then use another thread to upload them with an internal queue.  I propose we don't do this.  We want to only fetch one item from the queue, and upload one at a time.  That way if the process fails, the queue items get nacked, and can get assigned to a different container.
16:22:17 <dustymabe> so do it serially?
16:22:20 <dustymabe> seems fine to me
16:22:55 <michaelgugino> Yeah, serially, but, in reality, we can spin up more than one container if we want to do more than one at once, just configure them both on the same queue.  That would also give us some HA in case one goes down for some reason.
16:23:24 <michaelgugino> The builds aren't all that frequent compared to some other topics on the exchange, so serially will mostly be just as fast.
16:23:25 <dustymabe> sounds like a good optimization to do later if we have problems
16:24:12 <michaelgugino> I think we should consume the fedora-messaging library as a binary using the CLI params vs using it python lib and building our own executable.  This is what's being done here: https://github.com/michaelgugino/fed-image-watcher/commit/a6ae76fff891a1920b2afdd2b49ed7e660576d22#diff-04c6e90faac2675aa89e2176d2eec7d8R12
16:24:33 <michaelgugino> Those are the highlights, really.
16:24:38 <King_InuYasha> serially in parallel :)
16:25:31 <michaelgugino> Running the fedora-messaging binary with the callback file as in my example repo, that gets you all the ack/nack stuff out of the box.  Not much code to maintain, which is always good.
16:26:08 <dustymabe> +1
16:26:26 <dustymabe> michaelgugino: that's what my examples that I linked you to do right? use the fedora-messaging binary with the callback file
16:27:04 <michaelgugino> Yeah, I can't remember who showed me what at this point, but yes, probably :)
16:28:02 <dustymabe> :)
16:28:10 <dustymabe> any more items to discuss here?
16:28:24 <michaelgugino> Did we decide on what to actually upload things with?  I think fedimg kicks off some kind of job or something so it's not actually pulling/uploading images directly.
16:28:39 <michaelgugino> I think King_InuYasha was looking at some tool the SuSe uses?
16:28:47 <King_InuYasha> yeah
16:29:02 <King_InuYasha> https://github.com/SUSE-Enceladus/mash
16:29:21 <King_InuYasha> I hadn't packaged it up for Fedora yet, but it seems like it'd do everything we need
16:29:41 <dustymabe> anybody want to volunteer to wire that up?
16:30:32 <King_InuYasha> it would go well with using https://github.com/SUSE-Enceladus/img-proof for testing cloud images
16:32:01 <King_InuYasha> already added support for Fedora into the tool: https://github.com/SUSE-Enceladus/img-proof/commit/b8a35010cd159c8c21b173594b145604aaac52ed
16:33:27 <dustymabe> ok. we can move on probably.
16:33:34 <michaelgugino> I can maybe look at getting the image uploading bits to work with mash, I have access to the big 3 clouds.
16:33:44 <King_InuYasha> that'd be awesome
16:34:07 <dustymabe> thanks michaelgugino
16:34:23 <dustymabe> King_InuYasha: can you work with michaelgugino to make sure he knows how to use mash ?
16:34:36 <King_InuYasha> sure
16:34:42 <cyberpear> King_InuYasha++ for cross distro work!
16:35:20 <dustymabe> #action King_InuYasha and michaelgugino to work together to see if mash is a viable avenue for uploading disk images to the clouds
16:35:54 <michaelgugino> sounds good to me.
16:36:01 <dustymabe> #topic open floor
16:36:08 <dustymabe> anybody have anything for open floor?
16:36:12 <dustymabe> jdoss: maybe?
16:36:39 <jdoss> I closed the initial change request for the cloud updates
16:36:50 <jdoss> because the can got kicked from F29ish to F33
16:37:13 <dustymabe> jdoss: got ya
16:37:17 <jdoss> and I am pretty sure bcotton was going to lart me
16:37:29 <jdoss> Other than that, I don't have anything else.
16:38:54 <dustymabe> cool
16:38:57 <dustymabe> anyone else?
16:40:23 <cyberpear> I had some old fixes for the ks files, might rebase and send...
16:41:07 <cyberpear> https://github.com/jamescassell/fedora-kickstarts/commits/cloud-cleanup
16:41:46 <cyberpear> nothing else from me
16:42:13 <michaelgugino> I got to drop.  Talk to you all soon.
16:44:11 <King_InuYasha> nothing else for me
16:44:22 <dustymabe> #endmeeting