16:39:38 <jlebon> #startmeeting fedora_coreos_meeting
16:39:38 <zodbot> Meeting started Wed Dec 16 16:39:38 2020 UTC.
16:39:38 <zodbot> This meeting is logged and archived in a public location.
16:39:38 <zodbot> The chair is jlebon. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:39:38 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:39:38 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:39:38 <jlebon> #topic roll call
16:39:38 <jlebon> .hello2
16:39:38 <jlebon> hmm, is the bot afk?
16:39:38 <dustymabe> zodbot ??
16:39:38 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:39:38 <jlebon> i guess we'll have to do this the old-fashioned way :)
16:39:38 <dustymabe> hey pingou do you know if zodbot is on holiday already ?
16:39:39 <dustymabe> jlebon: yeah it's not working in the other channel either
16:39:39 <dustymabe> I guess we go old fashioned
16:39:39 <dustymabe> just pretend like it was here I guess
16:39:39 <jlebon> hmm, doesn't look like we have a lot of people here
16:39:39 <dustymabe> .hello2
16:39:39 <dustymabe> hi my name is dusty mabe :)
16:39:39 <jlebon> hello Dusty, nice to meet you
16:39:39 <jlebon> here's a chair
16:39:39 <jlebon> #chair dustymabe
16:39:39 <zodbot> Current chairs: dustymabe jlebon
16:39:39 <dustymabe> :)
16:39:41 <dustymabe> jlebon: I guess we can just elect to send a few #info statements to the mailing list in lieu of a meeting
16:39:41 <zodbot> dustymabe: Error: Can't start another meeting, one is in progress.
16:39:41 <jlebon> i guess some folks are already on vacation?
16:39:41 <dustymabe> one of them is:
16:39:41 <jlebon> ack sure let's do that
16:39:41 <dustymabe> - We did an ad-hoc testing release yesterday (rolling out now) and should promote the content (Fedora 33 based) to stable this week.
16:39:44 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:39:48 <jbrooks> .hello jasonbrooks
16:39:49 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <jbrooks@redhat.com>
16:39:52 <cyberpear> .hello2
16:39:55 <zodbot> cyberpear: cyberpear 'James Cassell' <fedoraproject@cyberpear.com>
16:40:02 <skunkerk> .hello sohank2602
16:40:03 <zodbot> skunkerk: sohank2602 'Sohan Kunkerkar' <skunkerk@redhat.com>
16:40:06 <dustymabe> - We decided to effectively disable systemd-resolved until the Fedora 34 rebase because of issues with reverse DNS (insert link here)
16:40:10 <miabbott> .hello miabbott
16:40:11 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
16:40:44 <dustymabe> any other things?
16:40:45 <lorbus> .hello2
16:40:46 <zodbot> lorbus: lorbus 'Christian Glombek' <cglombek@redhat.com>
16:40:54 <dustymabe> should we cancel or try to have the meeting next week?
16:40:54 <jlebon> hmm couldn't that land in f33 timeline?
16:41:21 <dustymabe> jlebon: yeah I guess it could
16:41:22 <jlebon> is this not a bug in f34 already somehow? or are you banking on the eventual fix not getting backported to f33?
16:41:37 <dustymabe> i guess it depends on the fix
16:41:55 <jlebon> so maybe "We decided to effectively disable systemd-resolved for now because of issues with reverse DNS (insert link here)"
16:42:18 <dustymabe> more or less, we need some work in NM and I don't think that will land until f34 (https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/issues/601)
16:42:29 <dustymabe> jlebon: LGTM
16:42:41 <jlebon> ok cool
16:42:46 <jlebon> i guess we're done here then :)
16:43:01 <pingou> dustymabe: should be there (and I see it responded now :))
16:43:13 <dustymabe> 👋
16:43:15 <jlebon> wtf? zodbot is back now?
16:43:22 <jlebon> .hello2
16:43:25 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:43:32 <dustymabe> weird
16:43:46 <dustymabe> whoa
16:43:55 <jlebon> w... wow
16:44:06 <dustymabe> jlebon: I think you and I were on a network split
16:44:08 <jlebon> dustymabe: i think we might've been in a parallel universe
16:44:12 <jlebon> yup
16:44:14 <lucab> .hello2
16:44:15 <zodbot> lucab: lucab 'Luca Bruno' <lucab@redhat.com>
16:44:24 <dustymabe> hey all, jlebon and I were having our own meeting by ourselves :)
16:44:45 <jlebon> that's hilarious
16:44:53 <lucab> (I'm a around but my IRC connection doesn't seem to be doing too well)
16:45:25 <jlebon> #chair dustymabe jlebon lucab lorbus miabbott jbrooks
16:45:25 <zodbot> Current chairs: dustymabe jbrooks jlebon lorbus lucab miabbott
16:45:39 <pingou> dustymabe: how was it going?
16:45:49 <nasirhm> .hello2
16:45:50 <zodbot> nasirhm: nasirhm 'Nasir Hussain' <nasirhussainm14@gmail.com>
16:46:16 <dustymabe> #chair cyberpear nasirhm
16:46:16 <zodbot> Current chairs: cyberpear dustymabe jbrooks jlebon lorbus lucab miabbott nasirhm
16:46:20 <jlebon> let me try restarting my client
16:46:23 <dustymabe> #chair skunkerk
16:46:23 <zodbot> Current chairs: cyberpear dustymabe jbrooks jlebon lorbus lucab miabbott nasirhm skunkerk
16:47:09 <jlebon> .hello2
16:47:10 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:47:19 <jlebon> \o/
16:47:45 <jlebon> ok, let's try it out then
16:47:51 <jlebon> #topic Action items from last meeting
16:48:06 <dustymabe> welcome back :)
16:48:23 <jlebon> * red_beard to investigate forklifting FCOS artifacts into OVH to see if they work
16:48:26 <jlebon> * red_beard to open a ticket to strategize on FCOS RH summit presence
16:48:30 <jlebon> dustymabe: thanks :)
16:48:49 <jlebon> ahh red_beard didn't come back it seems
16:49:03 <jlebon> ok, in the interest of time, i'll just re-action this and move on
16:49:19 <jlebon> #action red_beard to investigate forklifting FCOS artifacts into OVH to see if they work
16:49:26 <jlebon> #action red_beard to open a ticket to strategize on FCOS RH summit presence
16:49:50 <jlebon> #topic  default hostname now is `fedora`, used to be `localhost
16:49:53 <jlebon> #link https://github.com/coreos/fedora-coreos-tracker/issues/649
16:50:05 <jlebon> dustymabe: did you want to (re)give a quick recap on this?
16:50:28 <dustymabe> yeah I can try to give a summary
16:51:32 <dustymabe> We realized kind of late that in our F33 rebase we lost setting hostname via reverse DNS lookups, partially because of the fallback hostname change and partially because of the move to systemd-resolved
16:52:12 <dustymabe> we tried to find a path forward, but in the end we ended up picking up a systemd rpm that no longer has the fallback hostname change AND also effectively not using systemd-resolved
16:52:51 <dustymabe> I use the work "effectively" there because we decied to leave the service enabled, but just configure it to not have a stub listener and also removed the entry from nsswitch.conf
16:53:41 <dustymabe> Disabling it by configuration was easier because we had already migrated `/etc/resolv.conf` to point to a symlink in `next` and `testing` and reverse engineering that change wasn't going to be easy
16:54:20 <dustymabe> There is a `testing` release rolling out now with all of this in it. We'll hopefully promote it to stable sometime tomorrow.
16:55:10 <dustymabe> questions?
16:55:44 <jlebon> worth noting we hit some selinux issues from disabling the stub resolver, which we're working around for now
16:56:17 <jlebon> (that makes the implementation for this yuckier than anticipated)
16:56:23 <dustymabe> yep. you remind me that every option we tried to pursue had roadblocks
16:57:28 <jlebon> looking forward: we need to work with the systemd and NM teams to have a proper fix for this, and then we can move back to resolved
16:58:00 <jlebon> ok cool, i think that's all on that subject unless anyone else has something
16:58:32 <jlebon> #topic RFE: provide a way to persist hostname via live ISO/`coreos-installer
16:58:37 <jlebon> #link https://github.com/coreos/fedora-coreos-tracker/issues/697
16:58:57 <jlebon> dustymabe: looks like that's you again :)
16:59:28 <dustymabe> Summary: should we provide an additional way for someone to configure a hostname via the live ISO installer?
16:59:31 <dustymabe> I'm torn
16:59:54 <dustymabe> adding to the confusion, `nmtui` has a "Set Hostname" option in the menu.
17:00:16 <dustymabe> I imagine bgilbert might have opinions if he was around
17:01:13 <lucab> Ignition can write the hostname in /etc/hostname, no?
17:01:40 <dustymabe> lucab: yes, it can
17:02:23 <jlebon> the hostname is not strictly required for breaking the network bootstrapping problem
17:02:31 <jlebon> which was the primary reason for the --copy-network workflow
17:02:52 <dustymabe> jlebon: yes, good point
17:03:12 <jlebon> for everything else, we should recommend the Ignition path
17:04:13 <miabbott> from a UX perspective, if we are telling the users they can use nmtui/nmcli to configure networking and they configure the hostname the same way, it is confusing when that is not persisted
17:04:32 <dustymabe> yeah I understand the reason for wanting it and I understand the reason why it's confusing (especially with nmtui showing "Set Hostname"), and I get why it's a good reason to say "No"
17:04:41 <miabbott> i agree that Ignition can do the trick here, but this may be a nice bit of polish for the end user
17:05:06 <jlebon> is there a slippery slope there? what else can people do in nmtui that they will expect carries forward?
17:05:14 <dustymabe> so I see everyone's point of view :)
17:05:24 <jlebon> (playing devil's advocate a bit on this :) )
17:06:57 <miabbott> i don't know the best answer here.  we don't want to make `--copy-network` a kitchen sink of functionality, clearly.  but this might be a corner case worth supporting.
17:07:15 <jlebon> if we go the strict "Ignition only" way, maybe --copy-network should be renamed to e.g. --copy-nm-connections or something
17:07:20 <dustymabe> yeah, I think I would propose we make it `--copy-hostname` or something.
17:07:33 <miabbott> i like the rename idea, jlebon
17:07:52 <miabbott> may be a good path even if we don't want to support the hostname
17:08:19 <dustymabe> ehh, i'm not a big fan of the rename
17:08:40 <dustymabe> unfortunately I don't think it's clear to the user where the hostname they set gets stored
17:08:53 <dustymabe> i.e. they could expect it got stored in the connection files and not in /etc/hostname or something
17:09:11 <dustymabe> in which case --copy-nm-connections would do us no good
17:09:58 <jlebon> does nmtui actually do that though? or does it write to /etc/hostname?
17:10:07 <dustymabe> it writes to /etc/hostname
17:10:15 <jlebon> i think the majority of people would expect it to write to /etc/hostname
17:10:45 <dustymabe> my two preferred outcomes:
17:10:51 <dustymabe> 1. instruct users to use ignition
17:11:06 <dustymabe> 2. support copying the hostname via a --copy-hostname option
17:11:51 <jlebon> maybe let's keep discussing in the ticket for now? interested in other people's opinion
17:11:59 <dustymabe> works for me
17:12:08 <lucab> but 2 can be wired back to an Ignition config, maybe?
17:12:13 <dustymabe> lucab: correct
17:12:26 <dustymabe> in the ticket I touch on "how" we could possibly implement it
17:13:03 <lucab> ah indeed, that's the last sentence there
17:13:24 <lucab> it wouldn't sound too bad
17:13:56 <jlebon> fwiw, i'd lean towards the "lump into --copy-network" option if we do want to do this
17:14:10 <lucab> a bit silly perhaps, changing the name host of your host for each machine you want to install
17:14:35 <miabbott> from the ticket:  merging with the ignition config seems sneaky...we'd have to yell at users that is happening
17:14:37 <dustymabe> to me it's a bit silly not to use PXE :)
17:16:43 <miabbott> let's defer any decision on this one...seems like we have some more thinking to do
17:16:50 <jlebon> +1 agreed
17:17:15 <jlebon> that said, this is the last ticket before open floor, so i guess we could keep discussing there if we want :)
17:17:21 <miabbott> :)
17:17:27 <jlebon> #topic Open Floor
17:17:42 <jlebon> anyone with anything they want to mention?
17:18:28 <dustymabe> are we close to ready to merge on this one: https://github.com/coreos/fedora-coreos-config/pull/768 ?
17:18:58 <jlebon> i think so. bumperboat is just debugging one last thing
17:19:06 * dustymabe is interested to see if that decreases the amount of ram we need for LIVE PXE/ISO
17:19:22 <jlebon> hmm, it shouldn't
17:19:29 <dustymabe> ahh, ok
17:19:30 <jlebon> this is for root reprovisioning only
17:19:44 <dustymabe> that's what I get for just reading the headlines :)
17:20:10 <cyberpear> What's the overlap with Fedora IoT and FCOS? IoT person thinks there's no overlap except rpm-ostree, with IoT focusing also on "Edge"; I think the projects could share build tooling and eventually merge one day (maybe)
17:20:54 <jlebon> cyberpear: they share a lot of the same technologies, but they have different focus
17:21:00 <dustymabe> cyberpear: to me it's mostly different focused use cases for now
17:21:23 <dustymabe> but agree, there's a lot of overlap when our use cases start to expand
17:21:26 <jlebon> as a result for example, you'll find different pkgsets
17:21:51 <cyberpear> at the least, it seems the build tooling could eventually merge?
17:21:54 <jlebon> doesn't mean there isn't a lot (more) we could share of course
17:22:00 <cyberpear> osbuild vs composer?
17:22:08 <cyberpear> * vs cosa
17:22:51 <dustymabe> right, we could do that eventually, but right now it would be a large effort and we haven't devoted large efforts to making it happen
17:23:09 <cyberpear> okay... I think I've gathered that merging the build tools is very low priority.
17:23:10 <dustymabe> i think in the long run it would make sense to share tooling in this space and there have been conversations around it
17:24:05 <dustymabe> cyberpear: more or less, yeah. We want to do it, but there's other things we need to take care of first.
17:24:06 <cyberpear> the fewer tools a contributor needs to learn, the better, IMO
17:24:25 <lucab> osbuild should be already able to build something like FCOS images, but cosa covers other aspects too
17:24:35 <jlebon> yeah, agreed it's confusing from a contributor's POV
17:24:49 <jlebon> maybe we need a FAQ entry in cosa or something to discuss the current state
17:25:56 <jlebon> anything else?
17:26:09 <cyberpear> right, like buildextend features...
17:26:22 <cyberpear> that's all from me
17:26:22 <dustymabe> oh yeah, I need to post a FAQ entry about the ssh key crypto stuff
17:27:02 * jlebon starts counting down from 60s
17:27:03 <lorbus> dustymabe++ for keeping track of that and the hostname issue
17:27:03 <zodbot> lorbus: Karma for dustymabe changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:28:01 <jlebon> #endmeeting